Jump to content

[1.3.1] Docking camera (KURS) (14.feb.18)


Recommended Posts

5 hours ago, DennyTX said:

why?  it should be under OLDD.  Did u remove  previous version?  on testing now.

I can only plead exhaustion after 6 hours of streaming. 

I had done the update, but it looks like CKAN used the cached copy, and installed the new one in the same directory as the old one, so actually it appears that both were there, but in the wrong spot

Sorry about that

1 hour ago, MikeO89 said:

DId you guys get around to reading a previous question I had asked about being to start the docking camera in clear view by default (instead of with noise on)?

@DennyTX is now controlling the mod.  This post will ping him about it.

Link to post
Share on other sites
1 hour ago, MikeO89 said:

DId you guys get around to reading a previous question I had asked about being to start the docking camera in clear view by default (instead of with noise on)?

noise in cfg is obsolete. use the radio button in the DockCam's drop-down menu. it should remember its state. Upcoming version will provide start without noise by default

Link to post
Share on other sites
  • 2 weeks later...

Hello @DennyTX

I was having problems with the function of "Extraplanetary Launchpads v5.9.0". I can't launch ships using the mod.  I've sent the developer my log files and he/she said that my described problem might be related to your mod.

Could you also be kind enough to take a peak at my logs, which can be found here; https://ufile.io/2z9xu

I really hope we can find the reason and a possible solution.

1 hour ago, taniwha said:

It looks like OLDD_camera is throwing a lot of  exceptions when parts are destroyed by the drag cube system. I suggest passing your log onto that dev.

Only problem is that the exceptions are in an event handler and KSP catches those to prevent their effects spreading.

 

Link to post
Share on other sites
On 2/23/2018 at 1:54 PM, linuxgurugamer said:

Strange, since I revived it last year at the beginning of October

Sorry, I took a break for a while and though I've been back... it fell off my radar.

Anyways, really just wanted to say thanks. That was all.

Edited by jayvaughan08
Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

I've PM'd @DennyTX about this.  I had revived the mod after decompiling the mod, since he hadn't updated Github with the latest sources.  He came back a couple of months ago, and I returned the mod to him, but he again seems to be neglecting the mod.

I may do a simple recompile of it and update Spacedock soon.  If he doesn't respond, I may just re-adopt the mod and do it as a full fork, to avoid any problems of the mod being neglected again.

Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...

whether this mod get re-adopted or continues here - I'd still like to ask a question :) 

Just wondering if it could be possible to be able to set the size of the camera window? I was hoping to use @linuxgurugamer AnyRes mod to span my IVA view across two screens and then enlarge the external camera window to take up the full second monitor view. I understand it would obscure some of the IVA, but it was all I can think of to get both fullscreen IVA and fullscreen external camera at the same time.

 

Edited by wile1411
Link to post
Share on other sites
On 5/8/2018 at 2:33 AM, wile1411 said:

whether this mod get re-adopted or continues here - I'd still like to ask a question :) 

Just wondering if it could be possible to be able to set the size of the camera window? I was hoping to use @linuxgurugamer AnyRes mod to span my IVA view across two screens and then enlarge the external camera window to take up the full second monitor view. I understand it would obscure some of the IVA, but it was all I can think of to get both fullscreen IVA and fullscreen external camera at the same time.

 

It should be possible, but I haven't yet officially readopted this mod.

Link to post
Share on other sites

Love this mod, I won't play without it. Question. Is there a way to have the camera background, when the camera is facing the moon, to not be whited out so much? When I'm docking a craft, I have the cameras on on both ends. When one craft is positioned facing the mun, the camera shows the craft against the mun background and I can't see the RCS thrusters fire because the mun background is too bright and drowns out the thrusters (both light and dark sides show the same color background). If there was some way to tone down the camera background against the mun just a bit, that would be way cool.

Edited by MikeO89
Link to post
Share on other sites
On ‎5‎/‎20‎/‎2018 at 12:39 PM, linuxgurugamer said:

It should be possible, but I haven't yet officially readopted this mod.

 

On ‎5‎/‎21‎/‎2018 at 8:24 PM, sibaar said:

I want you to know that you are loved.

By a LOT of people! :wub:

Link to post
Share on other sites
  • 4 weeks later...

Hello! I create my mod. I need to turn off the docking camera for my docking port in the config. What parameter should I write for this?

And is there a parameter for setting my camera point by coordinates or transform?

Thank you!

Link to post
Share on other sites
On 5/13/2018 at 10:52 PM, linuxgurugamer said:

For anyone interested, I have a working copy of this for KSP 1.4.* here:

https://github.com/linuxgurugamer/DockingCam/releases

Hello, I installed this into the GameData folder along with ModuleManager and it is not working. Nothing does anything. I place the camera on the craft and just nothing does anything. Version: 1.4.3.2152

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Within the KSP.log, I found 2 errors from the docking cam mod.

Quote

[ERR 12:30:57.480] AssemblyLoader: Exception loading 'DockingCamera': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

Additional information about this exception:

 System.TypeLoadException: Could not load type 'OLDD_camera.DockCamToolbarButton' from assembly 'DockingCamera, Version=1.1.6.6, Culture=neutral, PublicKeyToken=null'.

AND

Quote

[ERR 12:33:39.222] Cannot find a PartModule of typename 'DockingCameraModule'

 

Edited by fearcustard
Added error messages
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...