KasperVld

Welcome to the new forums!

Recommended Posts

19 minutes ago, KasperVld said:

...to fix the 502 errors we've had to remove the follows which is very unfortunate - but the forums are working like a dream now.

Does this not imply that as soon as people rebuild their follow/subscription lists, the problem will reoccur? (In my head it relates to the amount of database stuff that has to be trawled per user as they use the site.)

Removing subs was really not something to have done lightly, IMHO. Google searches no longer find the things on this forum that we used to follow. Forum searches don't always find the things we used to follow. Links from the forum posts we can find, do not work any more. I'm struggling to find the dev thread for a lot of mods I like to re-follow them :/

Edited by eddiew

Share this post


Link to post
Share on other sites
1 hour ago, Dodgey said:

Urgh, is it just me or does there seem to be a lot of wasted space with this design? I need to zoom out to 75% just to make it seem normal.

It's because it's designed with at least some thought towards touchscreen users. I frequent another forum where the design makes *no* concessions to touch and there's no different mobile version, and trying to use that on a phone is incredibly difficult and unpleasant. With the caveat that I haven't actually tried the new KSP forums on my phone yet, I think giving consideration to touchscreen users is the right thing to do, "wasted space" be darned.

Share this post


Link to post
Share on other sites

Is there any chance to tweak the colors? I know white is modern (iPhone and Stuff), but some contrast would be nice.

Share this post


Link to post
Share on other sites

*Shaking head* And why did we change forums again?  

Share this post


Link to post
Share on other sites
20 hours ago, KasperVld said:
  • [No Fix] Because thread and post IDs were reset, old links will not work.
  • Due to the fix for the 502 errors your followed content is no longer stored. Please re-follow the content you're interested in. Apologies for the inconvenience!

I was following well over 100 posts before the migration, and was assured before the migration that subscriptions would be retained, so I didn't do anything to preserve my subscription list. 

Was a map between old and new thread id's created at the time of migration?  Can we put a copy of the old forum back online in read-only mode to allow this to be reconstructed?

Is there any way to retrieve my old subscriptions in any form?

Share this post


Link to post
Share on other sites
35 minutes ago, Ted said:

Woohoo! I think we all owe Kasper a round of pats on the back for killing it this weekend upgrading it all. :)

It's definitely a stick in the mud, but Google should update its indexes soon enough and other sights will cache them soon enough.

Google will update, but other sites that link to the forums aren't going to change anything like as quickly. For a start you've immediately broken a whole bunch of links on another of Squad's "official" properties, Curse, including the first link in the description of the top mod. Then there's that Google considers the links pointing at a page in its rankings, so forum threads are almost certain to take a page ranking hit, meaning third-party sources are likely to show up above forum results in Google searches.

Share this post


Link to post
Share on other sites

Well, what can I say. It's very white and width spaced. It seems to go in line with the current tendency that all should comfortable be read on a mobile phone, leaving PC browser users in mostly empty space with big avatars and blobs of text here and there. ^_^

It'll probably grow on me, I hope, but I'm not very impressed. Maybe it's a theme thing, I haven't checked yet if I as a user can change that for the better. :D

 

Greets,

Jan

Share this post


Link to post
Share on other sites
14 minutes ago, cantab said:

It's because it's designed with at least some thought towards touchscreen users. I frequent another forum where the design makes *no* concessions to touch and there's no different mobile version, and trying to use that on a phone is incredibly difficult and unpleasant. With the caveat that I haven't actually tried the new KSP forums on my phone yet, I think giving consideration to touchscreen users is the right thing to do, "wasted space" be darned.

Sure, but why inflict this e x c e s s i v e  whitespace thing on those of us with mice?    On widescreen (16:9 and 16:10) displays, the excessive waste of vertical whitespace makes it seem like the forum can display less information per screen than could fit on my old Apple ][+ display..

 

Share this post


Link to post
Share on other sites

Hmmm, I didn't noticed the mess in the old thread formatting and text. All ' and " are replaced by garbage... Hopefully I only have 2 topics I show my stuff in, but I can't imagine what it'll be for many of forum users.

And those ridiculous interlines are a pain. I'm not a website designer but those CSS should be fixed.

Line 1

Line 2 with 2 wasted lines

Share this post


Link to post
Share on other sites

For reference, if you don't want the regular paragraph spacing you get when hitting enter
Hitting Shift+Enter will make a line break without starting a new paragraph and that gives a smaller space
(That works in MS Word too)

Share this post


Link to post
Share on other sites

Welp, here we are again. :D I'm seriously going to miss BBCode.

 

Always Remember

EDIT: Aww, it chomped the BBCode I put in that post. :(

 

Edited by Starwhip

Share this post


Link to post
Share on other sites
8 minutes ago, cantab said:

For reference, if you don't want the regular paragraph spacing you get when hitting enter
Hitting Shift+Enter will make a line break without starting a new paragraph and that gives a smaller space
(That works in MS Word too)

Even if you do that, there's still too much vertical space between lines.

Share this post


Link to post
Share on other sites
23 minutes ago, billkerbinsky said:

Sure, but why inflict this e x c e s s i v e  whitespace thing on those of us with mice?    On widescreen (16:9 and 16:10) displays, the excessive waste of vertical whitespace makes it seem like the forum can display less information per screen than could fit on my old Apple ][+ display..

 

But all that whitespace is modern so it must be good.

Share this post


Link to post
Share on other sites

The true question is why the old forum has been removed even I've never read any complaints about it. It was reasonably simple and tweakable.

 

The new forum is clearly less efficient than the old one and add nothing more.

Share this post


Link to post
Share on other sites
11 minutes ago, Warzouz said:

The true question is why the old forum has been removed even I've never read any complaints about it. It was reasonably simple and tweakable.

 

The new forum is clearly less efficient than the old one and add nothing more.

Mobile accessability. the only real reason I can see so far.

Share this post


Link to post
Share on other sites

I had to reset my password before I could log in. Was that just me or did I miss something?

Share this post


Link to post
Share on other sites

Maybe it'll grow on me, especially once the dev team have had time to address some of the outstanding issues, but first impressions are not good.

I didn't like the new look in the preview shots and I don't like it now. If anyone finds a way to apply a theme, please do tell.

Yes, this was flagged up in advance but I'm disappointed with the broken links. It's broken the contents page for my fanfic and it's completely broken my Fanworks index thread. That's going to take some time to fix.

Some punctuation marks haven't transferred across properly turning large sections of my long-running posts into gibberish. That's going to take even more time to fix.

I dislike the new rep system, although perhaps I'm just being old and grumpy. I don't like the 'likes', I don't like the way that the rep bar plus amusing title has been replaced by a single number shorn of any particular context and I miss the ability to send the thread author a comment when I give him/her rep.

Share this post


Link to post
Share on other sites

Hello hello, is this the place for new-forum-bug reports?

I just encountered an issue with notifications. Picture the following situation:

1.) Poster A starts thread
2.) Poster B replies
3.) I add a reply
4.) Poster A quotes me and likes my post

The forum, in turn, notified me that one of my posts had been quoted, and that one of my posts had been liked. So far, so good.

However, the notifications claimed that it was Poster B who performed both actions! :confused:

Share this post


Link to post
Share on other sites

Oh ummm I'm really not liking the style of the new forum. I can't put my finger on it though.

  • Maybe it's the broken BB code that makes all the forum pages look unprofessional.
  • Maybe it's the lack of color contrast, since everything seems to look like just a slightly different shade of white (see background vs. the background for quoted text). And it's hard to see borders between two posts.
  • Maybe it's the now much wider user profile area, which also lacks a border between the post to the right of it.
  • Are we also using a different default font?

Things just don't read well to me. I think it's mostly the lack of borders.

Also, how do we preview posts? Or is everything done through the toolbar up top, and not through BB code? Including Imgur pics AND albums?

P.S. Get rid of the non-KSP emoticons!!

Share this post


Link to post
Share on other sites

Nah, the new version is so eye-unfriendly. My eyes hurt after 5 minutes. Not sure if that's the contrast or font size but I find it extremely discomforting. 

 

Share this post


Link to post
Share on other sites

Well, all is well and good, who wants to help me retrieve my ~140 subscribed mod threads? Some of which were for mods that haven't been updated since 0.18, but I used their dl links and maintained the mods for myself.

If you ever do a transfer to a new platform(not even the choice of one - poor, imo), make sure all is working.

And what, only the mods and admins have access to a read-only copy of the forums? Noone from the community populating it? Not a good move. Give people an option to access the old forums and salvage what you could not do, Squad. Then at least people have a chance to do something on their own, since you didn't manage to do it.

Share this post


Link to post
Share on other sites

I'd just like to make everyone aware that the well over a 100 links in my Mod Dev sticky are gone with virtually no way of getting them back that I can see.

All the effort I put into that thread is basically ruined. This has to be someone's cruel joke. There's no polite way of conveying what I'm feeling right now. What the hell...

Share this post


Link to post
Share on other sites
21 hours ago, KasperVld said:

Due to the fix for the 502 errors your followed content is no longer stored. Please re-follow the content you're interested in. Apologies for the inconvenience!

And here a week ago I had complimented Squad for showing some signs of maturing software engineering processes by postponing the 1.1 update to allow for additional QA work.

Major changes *never* go smoothly.  You're always better doing a test run in a sandbox (say, grabbing a copy of the Announcements and running the update process on it), so you know exactly what the issues are in advance.  That way, you can inform the customers what steps they need to take to preserve data.  Yes, it's extra work, and it means you'll spend more time on it, but doing thorough tests before going live is a critical element of all software development and deployment processes.  Notifying customers ex-post-facto that they've lost data that they could have preserved is not ideal.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.