Jump to content
  • 0

KS-25 "Vector" can't handle re-entry


problemecium
 Share

Question

In developing my latest SSTO lift rocket, I've run into a problem with the KS-25 "Vector" engine, namely that it seems to be extremely prone to overheating during re-entry, far more so than other engines. Below I've posted an example craft file, which consists of a rocket that ascends to orbit and then re-enters and lands using parachutes. During the re-entry phase, while between 30 and 40km, the engines invariably explode unless all of the airbrakes are deployed and the ship is constantly rotated to distribute heat.

BSjWxyAm.png
SSL WIP.craft

At first I just assumed this was yet another obstacle built into the game, but after one attempted solution after another failed, I got suspicious and looked in the part's CFG file to see if there was something wrong with its thermal conductivity or emission parameters - and indeed, I found something!

liquidEngineLV-T45.cfg SSME.cfg

As visible in these two files (which are unmodified from the original installation of KSP 1.0.5), the LV-T45 "Swivel" includes a line setting a multiplier for its conduction of skin temperature to interior temperature, while the KS-25 "Vector" does not. Upon further investigation I found that during re-entry, the Swivel and other engines heat up both on the outside and inside, becoming quite warm but not dangerously so - but the Vector, on the other hand, remains relatively cool on the inside (often below 500K) while the outside rapidly heats up to over 2000K and causes the part to explode. Since radiators and thermal conduction between parts seem to only deal with interior temperatures, adding radiators and adjusting the way the engines are connected is ineffectual.

The fix is simple, of course: add the missing line about thermal conduction to the Vector's CFG file. But of course then my installation wouldn't technically have the "real" stock part ;P So I've decided this needs to be brought to SQUAD's attention and hopefully shoehorned in alongside all the other minor fixes in the queue. In the meantime, hopefully this thread will be useful to others sharing this problem.

Technical details:
KSP 1.0.5 Build 1028 (verified) with all stock physics
KSP does not crash due to this issue
Obviously there isn't an exception or anything in KSP.log so I left it out ;)

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

I'm SO glad this is a game thing and not a pilot error thing. I was slamming my oversized green head against the Vector engine trying to get it to come back down on an SSTO, but it kept blowing up before 30km. The decoupler at the top of the rocket handled re-entry better.

I put the fixed CFG file in a GameData subfolder, works wonders now, thanks much.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...