01010101lzy

[Plugin][See active fork] B9 Procedural Parts Modified

Recommended Posts

4 hours ago, theend3r said:

What is the end result going to be? I prefer B9PW over PW and would love to see it working in 1.2 if possible, no need for additional features.

Based on this, is there room for both mods?  More to the point, would be "ok" if I continued support of b9pw?

I do not want to duplicate effort, and I do not want to intrude on existing plans, but I'm willing to assist.

Share this post


Link to post
Share on other sites

The end result would be a single code base that supports both types of existing pwings parts and allows all possible common features to be shared (ie. original pwings with an editing UI, and when the edge angles from this get added it works for *every* Pwing part). Basically, while I'm converting to the U5 UI system, I also merged the two plugins so I don't have to keep doing the same work twice...

Development thread is here for a more detailed explanation

@Papa_Joe

Contributions are always welcome, whether to the seperate plugins, or the in development merger (it'll all get pasted around anyway until the merger supercedes the existing plugins...)

Edited by Crzyrndm

Share this post


Link to post
Share on other sites

I'm trying to make a copy of the procedural wing with most of the same settings from the config file. I'm trying to make a structural version of procedural wing that has no lift. However it doesn't seem to work, every time I remove the Surface Lift module the part work (the part would load but not cannot be edited). Is there any way to make a wing without lift?

Edited by Supergamervictor

Share this post


Link to post
Share on other sites

Since it is a wing, the plugin has an implicit dependency on there being a lifting module present. Removing it will cause problems

Share this post


Link to post
Share on other sites

WARNING! THIS IS A MAINTENANCE  DONE WITHOUT PRIOR KNOWLEDGE OF PROGRAMMING AND VERY LIMITED TESTING. USE AT YOUR OWN RISK!

With permission from @01010101lzy and  @Crzyrndm, I've managed to recompile this version of Procedural Wing to both 1.2 - 1.2.2 and 1.3 by referencing fixes done by Crzyrndm. Special thanks to @hypervelocity and @linuxgurugamer for helping me out. This is only a recompile, do not request for features or bug fixes that I cannot attend to as I lack the knowledge of programming. ModuleManager is not included and must be downloaded separately according to the KSP version.

1.2 Compatible : https://drive.google.com/file/d/1m8pCC5lC_zUtgbSAtyheIMjoVVaq_xVU/view

(Update 11/29/17 - Fixed Mirroring issues)

1.3 Compatible : https://drive.google.com/file/d/1YgFT-r-pCpkrViWtXP7rWdyZhcNfGlCk/view
Likely unstable, I wouldn't recommend using this version. It was haphazardly thrown together with some old code I was unable to update to.

If you encounter any issues, please PM me for them to be included in this post. I can't promise a fix if it's possible.

ALL TESTINGS WERE DONE ON KSPx64 v1.2.2 and 1.3.1 STOCK (English). MAY BE UNSTABLE AND GAME BREAKING; BACKUP YOUR SAVES BEFORE TRYING IT. 

Edited by Supergamervictor

Share this post


Link to post
Share on other sites

Victor, many many thanks for taking up on this endeavour! Your work is very much appreciated and it was a pleasure discussing with you!!!! :D:rep:

the inclusion of my name in the above post is a delightful courtesy of @Supergamervictor, as he has entirely conducted the research & actual re-compiling work, all credit to you mate!!!

cheers!

Share this post


Link to post
Share on other sites

I see that there have been weeks and months of silence between comments on this thread, alongside a recent community recompile with stability warnings for KSP v1.3.1.

Is this a dead / dying mod?

Share this post


Link to post
Share on other sites

How can I get this working in 1.4.3 its the only mod I'm needing to go from 1.3.1, this mod is great of large passenger and bomber aircraft that I make and would love to see this in the new ksp build.

if you aren't updating it please let me know what I need to do to get it working edit some configs maybe etc 

thanks

Share this post


Link to post
Share on other sites
20 hours ago, Gordon Dry said:

Unfortunately you didn't show it in service - will this be the next video?

My YouTube channel is currently under renewal. It will be reopen. - google translate

Share this post


Link to post
Share on other sites
On ‎5‎/‎15‎/‎2018 at 2:04 PM, jerry said:

 I usually play KSP 1.4.2 however this helicopter is built in KSP version 1.2.2

So it ( https://kerbalx.com/jerry/Sikorsky-S-64-Skycrane ) can bring at 1.3.1 version of ksp either. :D

sorry its google translate..

ah I cant get this mod to work in 1.4.2 or 1.4.3 are you using this mod only in 1.3.1?

Share this post


Link to post
Share on other sites

It's been a long time since I was last active in this forum. A lot of things has happened - including that I hadn't been playing KSP for quite a while. This mod has been abandoned since I dived into Gaokao preparation and hasn't been updated for about two years. I'm in university now, studying Software Engineering, and considering picking up KSP again. University is busy indeed, but I might start making new mods! Just don't expect anything soon.

 

Anyway, onto this mod:

@Me1_base has made a 1.5.1-compatible continuation of this mod (see here), and is being merged (some features has already been merged) into the currently active fork by @Jebman82. Please go to that thread for more information and downloads of the latest B9PW version. I will not update the mod under this thread any further.

 

Thank you all for supporting!

 

01010101lzy (Rynco Li)

Edited by 01010101lzy

Share this post


Link to post
Share on other sites
15 minutes ago, GuioVyond said:

update 1.6.1

Welcome to the forums!

It usually considered bad form to demand updates from mod makers.  The mod makers work on the mods in their own free time.  They are under no obligation to update, release, or abandon their work for anybody or any reason. 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.