Jump to content

Part Tools 0.23 Crashing With New Props, Help?


Recommended Posts

Hi all,

I noticed that with KSP 1.0.5, we have some new props and interiors available such as the mk1InlineInternal, Seat_Passenger, and CargoBagA. When I try to load these props or new spaces into Unity, Unity hangs and eventually crashes. Has anybody else experienced this? Is anybody able to successfully load the new spaces/props? If so, how?

Thanks for your help. :)

Edited by Angel-125
Link to post
Share on other sites

This is because the new models use .mu version 4 which introduces a new (replacement) material block format. If you are trying to study the new models, try using my blender .mu addon to import the models. There are many areas in which it is still lacking, but it's good for looking at the models, colliders, loc/rot/scale animations, and to a limited extent, even the materials (not all materials are set up correctly).

Link to post
Share on other sites
1 hour ago, taniwha said:

This is because the new models use .mu version 4 which introduces a new (replacement) material block format. If you are trying to study the new models, try using my blender .mu addon to import the models. There are many areas in which it is still lacking, but it's good for looking at the models, colliders, loc/rot/scale animations, and to a limited extent, even the materials (not all materials are set up correctly).

I just downloaded the latest version of your addon, thank you for maintaining that, it's really helpful. :) I think I'm doing something wrong though, with Blender 2.75 I'm unable to load the, say passenger seat .mu. Here's the error I get:

8UOB18Y.jpg

It looks like there's a shader script that's going south. I've installed all the scripts from your addon into a sub-folder in the addons folder in blender.

Thanks for your help. :)

Link to post
Share on other sites

Hrm, I'll look into that. passenger seat? external command seat?

[edit]Apparently not, though I had to fix a bug for it anyway (pushed). One of your models?

[edit 2]Just noticed it gave the shader it was looking for. I don't know that one, it must be new. I'll do up a fallback for unknown shaders.

[edit 3]Ok, I have pushed a change that makes the importer fail gracefully on unknown shaders: you get an empty material (ie, no nodes set up) and a message in the console.

Edited by taniwha
Link to post
Share on other sites
6 hours ago, taniwha said:

Hrm, I'll look into that. passenger seat? external command seat?

[edit]Apparently not, though I had to fix a bug for it anyway (pushed). One of your models?

[edit 2]Just noticed it gave the shader it was looking for. I don't know that one, it must be new. I'll do up a fallback for unknown shaders.

[edit 3]Ok, I have pushed a change that makes the importer fail gracefully on unknown shaders: you get an empty material (ie, no nodes set up) and a message in the console.

That did the trick, thank you. :) The stock passenger seat from PropsGeneric, which is in the new Mk1 inline crew cabin, loads into Blender now. Thanks again! :)

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...