Jump to content

[1.9.x] Editor Extensions Redux released (with SelectRoot merge. StripSymmetry & NoOffsetLimits)


Recommended Posts

Continue to enjoy this mod. The button to reset key binding is great! Have another suggestion, could we have an option in settings to make 'fine adjust' mode on all the time without needed the 'fine adjust' window open? yes, shift key is nice, but I just like using the fine adjust all the time. maybe a hotkey to toggle? In any case, have a successful day!

Link to post
Share on other sites
On 4/20/2019 at 9:40 PM, linuxgurugamer said:

Please provide a link to the complete log file. Snippits aren't useful in cases like this

Apologies, I figured there wasn't any point to the load up since I didn't see any errors occur there. It looks like the latest Click Through Blocker update has fixed the issue though.

Link to post
Share on other sites
1 hour ago, PhaserArray said:

Apologies, I figured there wasn't any point to the load up since I didn't see any errors occur there. It looks like the latest Click Through Blocker update has fixed the issue though.

Glad to hear it's working. Just an FYI, log files contain useful information beyond errors.  In this case, I would have been able to verify what versions of the mods you were using.

Link to post
Share on other sites

Hi, im not sure if this would be easy or not, or if youre even up for it for that matter...I know you maintain just about half of all mods on the forums. And perhaps this has been suggested before, Im not sure but Id like to suggest it anyways in case it hasnt. I love EER very much..however the vessel/resource overlay tabs are a tad bothersome to deal with or use(especally when many mod that include vab/sph icons are used) and in turn I tend to not use them at all or I use Quickhide and Adjustable Mod Panel rigorously. My suggestion would to change the overlay location to the right side of the screen and settings parameters have it slide up and down rather than side to side. that way when you click to show you are not clicking the icons directly behind them, also it would be easier to view the data they give and be kinda out of the way when you dont need it.

the toolbar mod button provides a very neat feature of locking/unlocking position with the ability to hide when put on the border when not hovered over. perhaps the EER info overlays could incorporate part of that functionality? such as hiding when not mouse hovering.

I suppose the more simple approach would be to add a button to the setting menu to hide those overlays, wheres the info provided is easily obtainable via different mods. EPL for example has a button in the editor for displaying some vessel info/resources as well as a few others mods. But I really like how EER shows it...I just really dislike its overlay position.

Thank you for your time and listening to(more like reading :)) my thoughts! 

 

Edit: Im also aware that this mod uses clickthroughblocker. but i suppose for whatever reason it ignores the overlays I speak of. Perhaps thats a different route that could be taken regarding my thoughts.

Edited by Jesusthebird
Link to post
Share on other sites
11 minutes ago, Jesusthebird said:

however the vessel/resource overlay tabs

Um...these?

evVLOi8.png

These panels are added by KER and not by EEX (and KER doesn't use ClickThroughBlocker ;) ). Well, if you don't like it, I would suggest to disable it in the KER settings, available in the editor. It's called "Build Engineer Overlay" and the "visible" state can be switchted ;)

Link to post
Share on other sites
On 5/4/2019 at 7:16 PM, 4x4cheesecake said:

Um...these?

evVLOi8.png

Lol woopsie...i had both threads open at the time..clearly i posted in the wrong spot. My bad:confused:. I should really pay attention when clicking ckan website links...can i blame the word redux in my search and lack of precise mouse clicking and spacing out?

 

Thanks tho..i didnt know that was an option..i just knew about the xaxis location option. I do like em...i just dont like its placment and that xaxis setting doesnt really help for me.

Dont mind me...carry on lol

Edited by Jesusthebird
Link to post
Share on other sites
  • 4 weeks later...
On 6/1/2019 at 6:41 PM, Majorjim! said:

It seems that the new DLC has broken no offset limits for struts and fuel lines.

No, it is working the same as before.  That never worked before, and it's going to stay the same

Link to post
Share on other sites
1 hour ago, linuxgurugamer said:

No, it is working the same as before.  That never worked before, and it's going to stay the same

By design on your part or its just not possible now?

 

Link to post
Share on other sites
9 minutes ago, Majorjim! said:

By design on your part or its just not possible now?

 

I think it's just a limitation of the engine, I wasn't able to get it working before, and I'm not going to spend any time on it now.  I have at least three mods which need updating for 1.7.1, plus some others that I'm working on

 

Link to post
Share on other sites
8 minutes ago, linuxgurugamer said:

I think it's just a limitation of the engine, I wasn't able to get it working before, and I'm not going to spend any time on it now.  I have at least three mods which need updating for 1.7.1, plus some others that I'm working on

 

Fair enough.

Link to post
Share on other sites
Just now, juanml82 said:

Is it just me (which means, some conflict with something) or are the symmetry and angle snap hotkeys not working with1.7.1 and Breaking Ground?

It's a know issue which happens sometimes: For some reason, the keybindings are set to "none" so two things you can do:

1) Go to the game settings and rebind the keys manually

2) open the EEX settings and you will find a button to restore the key bindings ;)

Link to post
Share on other sites
18 minutes ago, 4x4cheesecake said:

It's a know issue which happens sometimes: For some reason, the keybindings are set to "none" so two things you can do:

1) Go to the game settings and rebind the keys manually

2) open the EEX settings and you will find a button to restore the key bindings ;)

I think I’m going to move that down into the popup menu soo to make it easier to use

Link to post
Share on other sites
On 6/9/2019 at 11:09 PM, 4x4cheesecake said:

It's a know issue which happens sometimes: For some reason, the keybindings are set to "none" so two things you can do:

1) Go to the game settings and rebind the keys manually

2) open the EEX settings and you will find a button to restore the key bindings ;)

Just experienced the same issue. Had to exit to the game menu and reset the angle snap key. Was not able to do this in the EEX settings option inside the VAB.

Link to post
Share on other sites
21 minutes ago, 4x4cheesecake said:

For what reason? Did nothing happen when you clicked the button?

Might be me that are missing something, but I am using the keys "X" and "C" for number of symmetri (1,2,3,4R etc) and -angels (5*, 15*, 45* etc), respectively.

Neither of those options are in the EEX settings inside the VAB.

I did find the letter "C" missing in the vanilla settings for angle snap.

Link to post
Share on other sites
15 minutes ago, EasyAce said:

I am using the keys "X" and "C" for number of symmetri

Yep, me too, these are the default keys.

15 minutes ago, EasyAce said:

Neither of those options are in the EEX settings inside the VAB.

Well, it's supposed to be there:

Spoiler

MlAlHEO.png

and as far as I know, it works perfectly fine to restore the default keys. You probably just looked for a button like the others for surface attachment, vertical/horizontal snap, etc. and missed this one (happened to me as well when the button was introduced^^)

Link to post
Share on other sites
9 hours ago, 4x4cheesecake said:

Yep, me too, these are the default keys.

Well, it's supposed to be there:

  Reveal hidden contents

MlAlHEO.png

and as far as I know, it works perfectly fine to restore the default keys. You probably just looked for a button like the others for surface attachment, vertical/horizontal snap, etc. and missed this one (happened to me as well when the button was introduced^^)

Oh that one. Yes I might have looked for lines with the X and C's and missed that one.

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

Excuse me for being a total idiot :rolleyes: but I'm not sure if the mod has loaded correctly for me because I can't see the options in game but the log looks OK (from my brief search). 

Log is here. I hope that link works. 

Edited by madindehead
Link to post
Share on other sites
6 hours ago, madindehead said:

Excuse me for being a total idiot :rolleyes: but I'm not sure if the mod has loaded correctly for me because I can't see the options in game but the log looks OK (from my brief search). 

Log is here. I hope that link works. 

Something went wrong during the mod installation. There is a "EditorExtensionsRedux" folder in your GameData directory but it seem to be empty, neither the "EditorExtensionsRedux.dll", nor the bundled "MiniAVC.dll" or any of the textures are loaded into the game.

Just in case, download a fresh copy of the mod and reinstall it :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...