Jump to content

[1.10.0] Kerbal Krash System (0.5.1) 2020-08-05


Recommended Posts

It sounds like you might have an old version of the files, unless I fixed mine and don't remember :P For KerbalKrashSystem_Other.cfg it should have
@PART[*]:HAS[!MODULE[ModuleKerbalKrashSystem_Exclude],!MODULE[ModuleKerbalKrash*],!MODULE[ModuleWheel],~PhysicsSignificance[1]]:AFTER[KerbalKrashSystem]:NEEDS[KerbalKrashSystem_Other]

Can you confirm this matches what you have in that file?

Link to post
Share on other sites
On 1/17/2018 at 8:35 PM, JeffreyCor said:

It sounds like you might have an old version of the files, unless I fixed mine and don't remember :P For KerbalKrashSystem_Other.cfg it should have
@PART[*]:HAS[!MODULE[ModuleKerbalKrashSystem_Exclude],!MODULE[ModuleKerbalKrash*],!MODULE[ModuleWheel],~PhysicsSignificance[1]]:AFTER[KerbalKrashSystem]:NEEDS[KerbalKrashSystem_Other]

Can you confirm this matches what you have in that file?

I check that file and it has FOR in place of NEEDS, so that might be the issue.  However, haven't tested KKS in play with the fixes.  Also, the FOR to NEEDS syntax fix needs to be applied to all of the configs that show up in Module Manager errors.

Link to post
Share on other sites
1 hour ago, Nittany Tiger said:

I check that file and it has FOR in place of NEEDS, so that might be the issue.  However, haven't tested KKS in play with the fixes.  Also, the FOR to NEEDS syntax fix needs to be applied to all of the configs that show up in Module Manager errors.

That would be the problem. MM 3.0.1 throws an error for the incorrect syntax in the cfg. before it just ignored it internally without giving notice to users. That change in the files giving the error will have it all better and no errors on startup :)

Link to post
Share on other sites
21 minutes ago, Nittany Tiger said:

@JeffreyCor I figured there was a MM syntax error related to an updated version of MM, but one user I think reported KKS not working even after fixing the syntax issues.

I can give it a whirl myself in a clean install though I've never played with KKS before.

I haven't had any problems with it. apart from a few specific cases of deformation being strange it seems to be working fine here.

Link to post
Share on other sites

Great concept, tho i wonder if this mod is still active or was abandoned. If it was abandoned then its a shame cause in its current  version is unusable.

Parts, especially command pods, have to high crash tolerance. I tested this mod on stock unmoded game, with various planes/rockets and no matter the speed or angle of crash, no kerbal ever died. If anything command pods simply bounced of the ground in to the sky at speed above 80m/s, some even broke sound barrier.

After checking the damage value some pods sustained  0 damage and others went above 100%. I don't know if my logic is correct here, but if something sustained even just 1% more than 99% of damage then it should be completely destroyed.

If a big a** plane like the stock skyeye fall to the ground at the speed of 200 m/s at 70' angle, it shouldn't just scatter its parts around like Lego pieces, with almost no explosions and most of the parts being untouched.

Edited by Reizo
Link to post
Share on other sites

I can't call, a cases of command pods bouncing of the ground at a speed up to 300m/s after a crash,  a usable state.

And be it as it is with the max damage cap on parts, but a command pod that sustained 0 damage after being smashed against the ground at speed of 200 m/s and then being sandwiched between the ground and remaining parts of the rocket that also fly at the speed of 200m/s is a clear sign that the mods is not working as intended, at the very least its not consistent with what is supposed to do.

Not to mention that the visualization of the damage is also jumping between extremes, either no damage visible or parts is bend beyond recognition.

And Im still talking about stock game, no mod interference.

I would love to keep using this mod, but not when its up to random chance if the mod decide to work properly.

Link to post
Share on other sites

Considering that has happened to me exactly ZERO times and in fact every impact at that speed as resulted in the complete destruction of the pod it seems the problem is not indicative of the mod itself. You have certainly got something messed up going on with your install of it.

Even though I have found none of the problems you list has ever happened I too would very much like to see this picked up with a more active modder if the author does not have time to work on it himself.

Link to post
Share on other sites
  • 2 weeks later...
  • 4 weeks later...

 

On 2/7/2018 at 3:23 AM, b0ss said:

Heyo, I heard somewhere else on the forum that it was possible to get this to be compatible with BDA's damage system. Is that true and if so how can I manage it?

That may have been me and sorry but i dont think it is ive tried

Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...

Found out what the "blue flare" is coming from, the EZ_Particlez dll in KKS-Mod, Ive been looking over the code and configs to see if it can be fixed for 1.4.1. Right now you can just remove that directory from your install to not see it.

Link to post
Share on other sites
On 28.1.2018 at 3:07 AM, Reizo said:

I can't call, a cases of command pods bouncing of the ground at a speed up to 300m/s after a crash,  a usable state.

And be it as it is with the max damage cap on parts, but a command pod that sustained 0 damage after being smashed against the ground at speed of 200 m/s and then being sandwiched between the ground and remaining parts of the rocket that also fly at the speed of 200m/s is a clear sign that the mods is not working as intended, at the very least its not consistent with what is supposed to do.

Not to mention that the visualization of the damage is also jumping between extremes, either no damage visible or parts is bend beyond recognition.

And Im still talking about stock game, no mod interference.

I would love to keep using this mod, but not when its up to random chance if the mod decide to work properly.

 

Does your game run smooth, or do you (have) had lag during the testing?

Link to post
Share on other sites
  • 2 weeks later...
On 1/28/2018 at 3:07 AM, Reizo said:

Not to mention that the visualization of the damage is also jumping between extremes, either no damage visible or parts is bend beyond recognition.

I have encountered this issue in 1.3 (ksp ver) when i was still playing heavily, I had to tweak theconfigs for it to work and even then i couldn't find a way to make it so the part would either be deformed without sending verticies everywhere or be destroyed unless the deformation was basically off but then most parts wouldn't have a single scratch (or nothing visible rather, i also noticed shadows are a bit funky on deformed parts but that could be my graphic settings, the deformed faces kept the same shading as the original ones, no visible difference in shadows on the part) 

And i also had those issues with pods not really needing parachutes to survive a reentry although that was not always the case.

I'll do some indepth testing once back home

Sorry for the funky english

Link to post
Share on other sites

I would adore seeing this mod maintained/continued -- especially if integrated with Scrapyard, and DangIt! / Oh Scrap!

For the short-term, the DLLs can be recompiled against 1.4.2, but more *actual* development might need someone who knows what they're doing. :)

Link to post
Share on other sites

Ive taken a look at the code and done some testing, the issues that would need to be fixed are the particle system code (the particle system changed during the Unity version change of KSP), and possibly the code that makes leaks er,  leak, but IIRC thats fixable via the cfg files.  This mod is actually pretty well documented, and the code does have comments explaining functions throughout, but Ill admit I dont currently have the coding knowledge to fix the largest issues.

@EnzoMeertens has been away for awhile, real life has a way of taking precedence, so Id imagine someone with a bit more mod experience would have to pick up the torch.  Ive been looking at the code off and on in Visual Studio, but I wouldn't hold your breath on the strengths of my efforts! :)

Link to post
Share on other sites
  • 1 month later...
On 4/19/2018 at 4:35 PM, Beetlecat said:

I would adore seeing this mod maintained/continued -- especially if integrated with Scrapyard, and DangIt! / Oh Scrap!

For the short-term, the DLLs can be recompiled against 1.4.2, but more *actual* development might need someone who knows what they're doing. :)

I have to agree, but if it is integrated, I want there to be an option to not use "Scrapyard", "DangIt!" and "Oh Scrap!".

On 4/24/2018 at 5:04 AM, Jade_Falcon said:

Ive taken a look at the code and done some testing, the issues that would need to be fixed are the particle system code (the particle system changed during the Unity version change of KSP), and possibly the code that makes leaks er,  leak, but IIRC thats fixable via the cfg files.  This mod is actually pretty well documented, and the code does have comments explaining functions throughout, but Ill admit I dont currently have the coding knowledge to fix the largest issues.

@EnzoMeertens has been away for awhile, real life has a way of taking precedence, so Id imagine someone with a bit more mod experience would have to pick up the torch.  Ive been looking at the code off and on in Visual Studio, but I wouldn't hold your breath on the strengths of my efforts! :)

How's it going so far?

Link to post
Share on other sites
On 6/12/2018 at 7:50 PM, InfiniteAtom said:

I have to agree, but if it is integrated, I want there to be an option to not use "Scrapyard", "DangIt!" and "Oh Scrap!".

How's it going so far?

We definitely need someone with a bit more experience to take a look, havent made a whole lot of headway getting things (i.e. the particles) to work with the new versions of KSP.

Link to post
Share on other sites
16 hours ago, Jade_Falcon said:

We definitely need someone with a bit more experience to take a look, havent made a whole lot of headway getting things (i.e. the particles) to work with the new versions of KSP.

Maybe linuxgurugamer could help. He has updated old mods.

Link to post
Share on other sites
  • 2 months later...
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...