Jump to content

[1.11.x] Kerbal Atomics: fancy nuclear engines! (December 23, 2020)


Recommended Posts

CKAN won't install the mod for some reason, it gives me an error message and won't let me install Kerbal Atomics or any of the recommended ones. Or, when I manually install it to the GameData folder, the parts don't show up in-game.

Never mind the above, I did it wrong.

Something that is persisting though, with this mod and other Nertea mods, specifically engines. The engines themselves work, consume fuel, and produce thrust. But there seems to be some missing exhaust/flames projecting from the engine. The engine bell might glow, but there's no visible exit products.

Also apparently not working is parachutes. They don't even appear as a part of staging, and can't be activated manually by right clicking on them.

Edited by Dukemaster
Link to post
Share on other sites
Just now, Dukemaster said:

I'm bad at troubleshooting normally, please help.

You may need to download Waterfall to get engine FX. 
Parachutes are not affected in any way by this mod. 
Other troubleshooting tools might helpful. 
Modlist, KSP version, log, etc. 

Link to post
Share on other sites
1 hour ago, Dukemaster said:

KSP Version.

https://imgur.com/NsyGhoq

In-game image for the explanation.

https://imgur.com/3jqfA6q

Something is deleting the parachute module from the parachute. We need to know what other mods you have installed, Kerbal atomics shouldn't be touching the parachutes at all. A look at your player.log would be very helpful as well. See the instructions below.

 

Quote

KSP versions 1.8.0 and above:

  • Windows: C:\Users\<username>\AppData\LocalLow\Squad\Kerbal Space Program\Player.log
    - This folder is usually hidden so you should enable the view hidden folders option (more information).
  • Mac OSX: Open Console, on the left side of the window there is a menu that says 'files'. Scroll down the list and find the Unity drop down, under Unity there will be Player.log Aka Files>~/Library/Logs/Unity/Player.log
  • Linux: The log is written to ~/.config/unity3d/Squad/Kerbal Space Program/Player.log

You can upload these files to any file sharing site (such as Dropbox, Pastebin or File2web). These sites will give you a link you can include in your posts to share your files.

 

NOTE: These logs are not the same as KSP.log, which lacks valuable data. Do not upload KSP.log; do upload Player.log

 

Link to post
Share on other sites
34 minutes ago, Dukemaster said:

Well you have FAR installed, which isn't actually compatible with 1.11, but as far as I can tell, that incompatibility shouldn't be breaking the parachutes. But only that and Restock are playing with the parachutes, from what I see in the logs. You may need to downgrade KSP to 1.10.1, and pick versions of the mods built for that. You probably also should bring this issue up in the FAR thread, since it almost certainly isn't kerbal atomics. 

Link to post
Share on other sites
  • 2 weeks later...

I'm using the deliverance on several ships and noticed it has a ramp up to full thrust.  I'd like to break the balance of the engine the stop it from doing this to act more like other kerbal engines and provide full thrust instantly.  I can't figure out how to change the .cfg to do that though.  Can someone point me in the right direction to make this change?  I've tried searching the forums and web but not had any luck.

Link to post
Share on other sites
5 hours ago, Legendtheo said:

I'm using the deliverance on several ships and noticed it has a ramp up to full thrust.  I'd like to break the balance of the engine the stop it from doing this to act more like other kerbal engines and provide full thrust instantly.  I can't figure out how to change the .cfg to do that though.  Can someone point me in the right direction to make this change?  I've tried searching the forums and web but not had any luck.

This might work - I don't see these two properties in other engines, so assume they are responsible for ramp-up / ramp-down. No guarantees:

@PART[ntr-gc-25-3]
{
	@MODULE[ModuleEnginesFX]
	{
		!engineAccelerationSpeed = DELETE
		!engineDecelerationSpeed = DELETE
	}
}

 

Link to post
Share on other sites

I'll give deleting them a shot, I noticed that too and tried to change the values but it didn't seem to do anything.  Also those two values are present in the other nuke aerospike (who's name eludes me at the moment) and it does not have the same ramp.  The values on both engines were the same.  

Link to post
Share on other sites

Your mods are awesome by the way.  I have a ton of mods installed so that's very possible but I wasn't able to find a patch related to the engine. 

None the less I did fix it.  Turns out the Scylla was not exhibiting this behavior because it generates EC (not sure if that's a mod or not).  I do have System heat and NFE installed.  I was able to fix it by making the Deliverance generate EC.  The root of the problem was the reactor power would sit at a low level when enabled and no fuel flowing and would need to ramp up when fuel started to flow.  When it generates EC it ramps all the way up to full reactor power without fuel flow.  

So it seems like the collision of a bunch of mods.  My fix isn't the right way but it works and if anyone else runs into this it might work for them too.  

If you're bored I can send you my mod list, but since it's fixed no need to waste anymore of your time.  

Link to post
Share on other sites

which KA engines have a radioactive exhaust?

I guess Szylla, Emancipator and the other aerospike

I'm only aking it so that I could use non-radioactive exhaust ones with them as upper stages without having a bad feeling because I killed hundreds of kerbals, it's not gameplay, just ''roleplay''

 

Link to post
Share on other sites
9 hours ago, Starhelperdude said:

which KA engines have a radioactive exhaust?

I guess Szylla, Emancipator and the other aerospike

I think it's just the Emancipator, which is the only open-cycle engine in KA. (That's why it consumes Enriched Uranium as a secondary propellant.) All the others are probably dangerous to stand near, but shouldn't be dumping fallout into the atmosphere.

Link to post
Share on other sites

Emancipator is going to be bad. The badness of the others more or less depends on how much you believe nuclear rocket enthusiasts who say fuel erosion is 'solveable' or 'minimal' ;).

Edited by Nertea
Link to post
Share on other sites
  • 2 weeks later...

I can't find a way to cool down the reactor on the engine.

I have enough cooling power for the system heat flux, but no matter how many more radiators I add (as many as 20ish largest high temp radiators I think). The reactor just overheat in a blink of eye.

All I can do is lower the power setting to below 5%. And surprisingly this seems no affection on engine thrust or isp. Is it the correct way to use?

Link to post
Share on other sites
4 hours ago, cinemagic said:

I can't find a way to cool down the reactor on the engine.

I have enough cooling power for the system heat flux, but no matter how many more radiators I add (as many as 20ish largest high temp radiators I think). The reactor just overheat in a blink of eye.

All I can do is lower the power setting to below 5%. And surprisingly this seems no affection on engine thrust or isp. Is it the correct way to use?

That doesn't sound correct, let me look into that. Logs and modlist might help me. 

Link to post
Share on other sites
8 hours ago, Nertea said:

That doesn't sound correct, let me look into that. Logs and modlist might help me. 

I'm new to this game. I've only installed your mods, near future series, far future tech (with latest version of system heat), and some stocklike mk2&mk3 spaceplane expansions from other modders, and tools like kerbal engineer, mechjeb , then visual mods like stock visual enhance, real plume.

I find the nuke engine have two power settings, first one is under "fission reactor" sub section and only appears when you select enable manual control.

The "fission reactor" one can be toggled to 100% and engine works just fine. But the second one will causes overheat in seconds even with a load of radiator, it can only sit at 5% ish, but seem not affect engine thrust and isp.

 

yiaYxlk.png

B3cRNIT.png

Edited by cinemagic
Link to post
Share on other sites
2 hours ago, cinemagic said:

I'm new to this game. I've only installed your mods, near future series, far future tech (with latest version of system heat), and some stocklike mk2&mk3 spaceplane expansions from other modders, and tools like kerbal engineer, mechjeb , then visual mods like stock visual enhance, real plume.

I find the nuke engine have two power settings, first one is under "fission reactor" sub section and only appears when you select enable manual control.

The "fission reactor" one can be toggled to 100% and engine works just fine. But the second one will causes overheat in seconds even with a load of radiator, it can only sit at 5% ish, but seem not affect engine thrust and isp.

 

yiaYxlk.png

B3cRNIT.png

You have the NFElectrical Kerbal Atomics integration patch and the SystemHeat Fission Engines patch at the same time. That's going to cause a huge mess. 

There should be stuff in the SystemHeat patch to prevent this but maybe it's not correct. Anyways, remove one or the other. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...