Nertea

[1.6.x] Kerbal Atomics: fancy nuclear engines! (January 21)

Recommended Posts

9 hours ago, Nertea said:

What overheats - the core or the engine?

It's the reactor core that overheats. I got a little frustrated with this, and I've now about forgotten where I was up to, So here's the part config for the Pluto (pulled from MM cache, post-M2X bundled patch) before I messed with it:

Spoiler

	name = M2X_Pluto
	type = PART
	parentUrl = Mk2Expansion/Parts/Engines/Pluto/part
	url = Mk2Expansion/Parts/Engines/Pluto/part/M2X_Pluto
	PART
	{
		name = M2X_Pluto
		module = Part
		author = SuicidalInsanity
		mesh = PLUTO.mu
		scale = 1
		rescaleFactor = 1
		node_stack_top = 0.0, 1.636004, 0.0, 0.0, 1.0, 0.0
		node_stack_bottom = 0.0, -1.908448, 0.0, 0.0, -1.0, 0.0
		fx_exhaustFlame_blue = 0.0, 0.0, 0.0, 0.0, 1.0, 0.0, running
		fx_exhaustLight_blue = 0.0, 0.0, 0.0, 0.0, 0.0, 1.0, running
		fx_smokeTrail_light = 0.0, 0.0, 0.0, 0.0, 1.0, 0.0, running
		sound_vent_medium = engage
		sound_rocket_hard = running
		sound_vent_soft = disengage
		sound_explosion_low = flameout
		TechRequired = nuclearPropulsion
		entryCost = 72000
		cost = 17470
		category = Engine
		subcategory = 0
		title = AT-2 "Pluto" Atomic Rocket Motor
		manufacturer = Insanity Aerospace
		description = Following numerous complaints of long-term LV-N 'NERV' usage resulting in what the engineers phrased so calmly as 'Spontaneous sustained oxidation phenomenon' and everyone else as 'uncontrollably on fire', a new engine was designed featuring a pair of radiators, and was incorporated into a mk2 mount to accomodate the added bulk. Warranty void if radiator fins used as BBQ grills.
		attachRules = 1,0,1,0,0
		mass = 2.8
		heatConductivity = 0.06
		skinInternalConductionMult = 4.0
		emissiveConstant = 1.0
		tags = m2x m2x active atom efficient engine inter liquid nuclear nuke orbit propuls radio reactor vacuum
		dragModelType = default
		maximum_drag = 0.2
		minimum_drag = 0.2
		angularDrag = 2
		crashTolerance = 12
		maxTemp = 2500
		bulkheadProfiles = mk2
		radiatorMax = 0.35
		MODEL
		{
			model = Mk2Expansion/Parts/Engines/Pluto/Model
			texture = model003, Squad/Parts/Engine/liquidEngineLV-N/model003
			texture = PLUTO_E, Mk2Expansion/Parts/Engines/PLUTO/PLUTO_E
			texture = mk2FuselageShort, Squad/Parts/FuelTank/mk2FuselageShort/mk2FuselageShort
		}
		MODULE
		{
			name = ModuleEnginesFX
			thrustVectorTransformName = thrustTransform
			runningEffectName = running_closed
			exhaustDamage = True
			ignitionThreshold = 0.1
			minThrust = 0
			maxThrust = 80
			heatProduction = 33.2
			fxOffset = 0, 0, 0
			EngineType = Nuclear
			PROPELLANT
			{
				name = LiquidFuel
				ratio = 0.9
				DrawGauge = True
			}
			atmosphereCurve
			{
				key = 0 800
				key = 1 185
				key = 2 0.001
			}
		}
		MODULE
		{
			name = ModuleActiveRadiator
			maxEnergyTransfer = 5000
			overcoolFactor = 0.25
			isCoreRadiator = true
			parentCoolingOnly = true
			RESOURCE
			{
				name = ElectricCharge
				rate = 0.025
			}
		}
		EFFECTS
		{
			running_closed
			{
				AUDIO
				{
					channel = Ship
					clip = sound_rocket_hard
					volume = 0.0 0.0
					volume = 1.0 1.0
					pitch = 0.0 0.2
					pitch = 1.0 1.0
					loop = true
				}
				PREFAB_PARTICLE
				{
					prefabName = fx_smokeTrail_light
					transformName = thrustTransform
					emission = 0.0 0.0
					emission = 0.05 0.0
					emission = 0.075 0.25
					emission = 1.0 1.25
					speed = 0.0 0.25
					speed = 1.0 1.0
					localOffset = 0, 0, 1
					localRotation = 1, 0, 0, -90
				}
				MODEL_MULTI_PARTICLE
				{
					modelName = Mk2Expansion/FX/Pluto_Plume
					transformName = thrustTransform
					emission = 0.0 0.0
					emission = 0.05 0.0
					emission = 0.075 0.25
					emission = 1.0 1.25
					speed = 0.0 0.5
					speed = 0.2 0.8
				}
			}
			engage
			{
				AUDIO
				{
					channel = Ship
					clip = sound_vent_soft
					volume = 1.0
					pitch = 2.0
					loop = false
				}
			}
			flameout
			{
				PREFAB_PARTICLE
				{
					prefabName = fx_exhaustSparks_flameout_2
					transformName = thrustTransform
					oneShot = true
				}
				AUDIO
				{
					channel = Ship
					clip = sound_explosion_low
					volume = 1.0
					pitch = 2.0
					loop = false
				}
			}
		}
		MODULE
		{
			name = ModuleJettison
			jettisonName = fairingL
			bottomNodeName = bottom
			isFairing = False
			jettisonedObjectMass = 0.1
			jettisonForce = 1
			jettisonDirection = 1 0 0
		}
		MODULE
		{
			name = ModuleJettison
			jettisonName = fairingR
			bottomNodeName = bottom
			isFairing = False
			jettisonedObjectMass = 0.1
			jettisonForce = 1
			jettisonDirection = -1 0 0
		}
		MODULE
		{
			name = ModuleAnimateHeat
			ThermalAnim = ThermalAnim
		}
		MODULE
		{
			name = ModuleAlternator
			RESOURCE
			{
				name = ElectricCharge
				rate = 5.0
			}
		}
		RESOURCE
		{
			name = ElectricCharge
			amount = 0
			maxAmount = 0
			isTweakable = false
			hideFlow = true
		}
		MODULE
		{
			name = ModuleSurfaceFX
			thrustProviderModuleIndex = 0
			fxMax = 0.7
			maxDistance = 50
			falloff = 2.5
			thrustTransformName = thrustTransform
		}
		MODULE
		{
			name = TweakScale
			type = stack
			defaultScale = 1.25
		}
		MODULE
		{
			name = FissionReactor
			StartActionName = Start Reactor
			StopActionName = Deactivate Reactor
			UseStagingIcon = true
			UseForcedActivation = false
			UseSpecializationBonus = false
			AutoShutdown = true
			DefaultShutoffTemp = 0.90
			OverheatAnimation = ThermalAnim
			HeatGeneration = 65000
			NominalTemperature = 3200
			CriticalTemperature = 3600
			MaximumTemperature = 3800
			CoreDamageRate = 0.01
			FuelName = EnrichedUranium
			GeneratesHeat = false
			TemperatureModifier
			{
				key = 0 0
			}
			INPUT_RESOURCE
			{
				ResourceName = EnrichedUranium
				Ratio = 0.0002
				FlowMode = NO_FLOW
			}
			OUTPUT_RESOURCE
			{
				ResourceName = DepletedFuel
				Ratio = 0.0002
				DumpExcess = false
				FlowMode = NO_FLOW
			}
		}
		MODULE
		{
			name = ModuleCoreHeat
			CoreTempGoal = 3200
			CoreToPartRatio = 0.1
			CoreTempGoalAdjustment = 0
			CoreEnergyMultiplier = 0.1
			HeatRadiantMultiplier = 0.05
			CoolingRadiantMultiplier = 0
			HeatTransferMultiplier = 0
			CoolantTransferMultiplier = 0.01
			radiatorCoolingFactor = 1
			radiatorHeatingFactor = 0.01
			MaxCalculationWarp = 1000
			CoreShutdownTemp = 3800
			MaxCoolant = 1300
		}
		MODULE
		{
			name = FissionFlowRadiator
			passiveCooling = 65
			maxEnergyTransfer = 65000
			overcoolFactor = 0.20
			maxLinksAway = 1
			isCoreRadiator = true
		}
		MODULE
		{
			name = FissionEngine
			HeatUsed = 1300
			Priority = 2
			TempIspScale
			{
				key = 300 0
				key = 1000 0.2
				key = 3200 1.0
				key = 4000 1.3
			}
		}
		MODULE
		{
			name = FissionGenerator
			Priority = 1
			PowerGeneration = 20
			HeatUsed = 65
		}
		RESOURCE
		{
			name = EnrichedUranium
			amount = 55
			maxAmount = 55
		}
		RESOURCE
		{
			name = DepletedFuel
			amount = 0
			maxAmount = 55
		}
		MODULE
		{
			name = RadioactiveStorageContainer
			DangerousFuel = DepletedFuel
			SafeFuel = EnrichedUranium
			EngineerLevelForSafe = 1
			EngineerLevelForDangerous = 3
			MaxTempForTransfer = 400
			HeatFluxPerWasteUnit = 5
		}
	}
}

 

With this config, I get:
Embedding these is fubar for some reason: https://s23.postimg.org/d1fr21obv/screenshot11.png

I figured it needed exhaustCooling set in FissionFlowRadiator, so I patched it thusly:

Spoiler

@PART[M2X_Pluto]:NEEDS[NearFutureElectrical]:NEEDS[!KSPIntegration]:AFTER[Mk2Expansion]
{	
	@MODULE[FissionReactor]
	{
                %FollowThrottle = true
	}
	@MODULE[FissionFlowRadiator]
	{
		%exhaustCooling = 1300
	}
}

 

Now I get: https://s30.postimg.org/5g2cf9b8h/screenshot12.png

Edited by steve_v
Horrible, broken, POS fancy-pants editor. Ate my images. Again. Please kill IPS. Kill it with fire.

Share this post


Link to post
Share on other sites

For one thing, ditch your Alternator and ModuleActiveRadiator blocks. The first is harmless but you don't need it, the goal of FissionGenerator is to replace that. The additional ModuleActiveRadiator will make things problematic (use the PassiveCooling field of FissionFlowRadiator to simulate an integrated radiator). 

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, Nertea said:

The additional ModuleActiveRadiator will make things problematic (use the PassiveCooling field of FissionFlowRadiator to simulate an integrated radiator). 

Yup, that's it :D Much thanks.
Had a feeling this might be causing greif. I guess it was using ModuleActiveRadiator in preference to FissionFlowRadiator, so only getting 5000 energy transfer? In any case, good to know you can't have both on the same part.
The original config's not mine, I'm just trying to fix it. :wink:

Share this post


Link to post
Share on other sites
On 12/31/2016 at 6:46 PM, steve_v said:

Yup, that's it :D Much thanks.
Had a feeling this might be causing greif. I guess it was using ModuleActiveRadiator in preference to FissionFlowRadiator, so only getting 5000 energy transfer? In any case, good to know you can't have both on the same part.
The original config's not mine, I'm just trying to fix it. :wink:

Yeah, FissionFlowRadiator was derived from ModuleActiveRadiator, so they will conflict. I don't think this is a huge problem, can't think of cases where you want your dedicated reactor radiator to cool other parts of the ship. 

Share this post


Link to post
Share on other sites

I'm having an odd problem I can't seem to solve. For whatever reason, I can't get the Near Future Electrical patch reactors to generate any heat on the engines. I've had it working a few weeks ago, however now it doesn't seem to work at all. I've tried redownloading both NFE and KA, with no luck, as well as creating a stock copy of the game and installing only those two mods in a clean save. Still no luck. I'm wondering what else I haven't tried yet that I could be missing.

I should add that NFE reactors are working fine on their own, the problem seems to be with KA engines, and the stock Nerva engine

Edited by Matrix Aran

Share this post


Link to post
Share on other sites
12 hours ago, Matrix Aran said:

I'm having an odd problem I can't seem to solve. For whatever reason, I can't get the Near Future Electrical patch reactors to generate any heat on the engines.

I had this problem as well, but I'm not sure it's the problem you're having. You have to first activate the engine via staging; just using the tweakable menu doesn't work.

Share this post


Link to post
Share on other sites
5 hours ago, Rayder said:

I had this problem as well, but I'm not sure it's the problem you're having. You have to first activate the engine via staging; just using the tweakable menu doesn't work.

Would you believe... In all my testing... I never tried that. I figured it was something as simple and silly as that. Thank you.

Share this post


Link to post
Share on other sites
2 hours ago, Matrix Aran said:

Would you believe... In all my testing... I never tried that. I figured it was something as simple and silly as that. Thank you.

If you look back a few pages I actually posted here with the same problem. I thought the mod was broken or something. Eventually I found that out myself haha.

Share this post


Link to post
Share on other sites

I've run into a weird issue that i didn't see elsewhere reported in the thread--the sheath for the LV-100 Trimodal Nuclear engine is set by default to have your flag appear on either side. 

In my game, the flags show up fine in the VAB, but in the game they're just white rectangles. Other appearances of the flag on the ship are rendered correctly. 

Share this post


Link to post
Share on other sites

workijng on 1.2.2? if so, would be nice if you updated the github/whateveruploadyouuse... so that ckan recognizes it as up to date

Share this post


Link to post
Share on other sites
2 hours ago, Commissar said:

workijng on 1.2.2? if so, would be nice if you updated the github/whateveruploadyouuse... so that ckan recognizes it as up to date

If you're asking, the engines (or at least the LV-100) work with 1.2.2. There's a glitch with the sheath graphic though. 

Share this post


Link to post
Share on other sites

Hello.  I searched through several pages trying to find the answer to my question but may have missed it.

Regardless, I want to say that @Nertea I love your engines, the models and textures are 2nd to none.

While I totally respect the change in style of engine to include reactor (I am using most of your NF addons), I would prefer not to  use them with stock or even your engines at this time in my current save.  I have multiple active vessels with your engines and the NERV and would prefer not to break my save with any change.  I am just looking to go from the reactor/heatgen/ecgen to just LF consumption.

Thanks to anyone that helps and sorry if I missed a (probably obvious) answer somewhere else.

Share this post


Link to post
Share on other sites

Kerbal Atomics 0.3.4

  •  Marked for KSP 1.2.2
  •  Updated bundled MM to 2.7.5
  •  Updated bundled B9PartSwitch to 1.5.3
  •  Updated bundled CRP to 0.6.4
  •  Updated DeployableEngines to 2.1.0
  •  Fixed a typo in an NFE extras patch

Additionally, please note the license change for all mods going forward.

On 1/21/2017 at 9:47 AM, Cornholio said:

Hello.  I searched through several pages trying to find the answer to my question but may have missed it.

Regardless, I want to say that @Nertea I love your engines, the models and textures are 2nd to none.

While I totally respect the change in style of engine to include reactor (I am using most of your NF addons), I would prefer not to  use them with stock or even your engines at this time in my current save.  I have multiple active vessels with your engines and the NERV and would prefer not to break my save with any change.  I am just looking to go from the reactor/heatgen/ecgen to just LF consumption.

 

Install the NTRsUseLF extra. Do not install the NFE integration Extra. See readme for details. 

Edited by Nertea
  • Like 6

Share this post


Link to post
Share on other sites

I am sorry if this has been asked already in this thread, but can I trust kerbal engineer on these delta-v calculations? LoxAugmented gives me almost double the delta-v and double the TWR of pure H2. The TWR I expected, but not the delta-v, as it makes pure H2 kind of absolete, no?

Edit: Has been answered.

aMylnlq.png

 

Edited by SilentWindOfDoom

Share this post


Link to post
Share on other sites
2 hours ago, SilentWindOfDoom said:

I am sorry if this has been asked already in this thread, but can I trust kerbal engineer on these delta-v calculations? LoxAugmented gives me almost double the delta-v and double the TWR of pure H2. The TWR I expected, but not the delta-v, as it makes pure H2 kind of absolete, no?

~snip~

 

Yea, that's accurate. It has to do with the density of LH2. You have a much higher isp, but because LH2 is so light, you have much less reaction mass. Note that your pure LH2 craft is much lighter than your hydrolox craft. If you make your LH2 tank bigger so that the masses of both craft are equal you'll see that the pure H2 craft has much higher dV.

  • Like 2

Share this post


Link to post
Share on other sites
36 minutes ago, Ralathon said:

Yea, that's accurate. It has to do with the density of LH2. You have a much higher isp, but because LH2 is so light, you have much less reaction mass. Note that your pure LH2 craft is much lighter than your hydrolox craft. If you make your LH2 tank bigger so that the masses of both craft are equal you'll see that the pure H2 craft has much higher dV.

I didn't think about that. I mean I did notice the overall mass of the craft was much lower, I just didn't connect the dots.

It is a little bit unfortunate as far as game balance is concerned, seeing as putting mass into orbit is a lot easier than putting those massive (in terms of size) LH2 tanks up. At least for me. I suppose I can always just ignore the Lox mode, or only include a little bit of Oxidizer it for when i need a boost. Thanks for the reply.

Edited by SilentWindOfDoom

Share this post


Link to post
Share on other sites
1 minute ago, SilentWindOfDoom said:

I didn't think about that. 

It is a little bit unfortunate as far as game balance is concerned, seeing as putting mass into orbit is a lot easier than putting those massive (in terms of size) LH2 tanks up. At least for me. I suppose I can always just ignore the Lox mode, or only include a little bit of Oxidizer it for when i need a boost. Thanks for the reply.

Try scaling up the solar system so that getting into orbit becomes much harder. Mass will become a much bigger concern than size.

  • Like 2

Share this post


Link to post
Share on other sites

I have been having some trouble with boiloff.  I am using Kerbal Atomics, Cryogenic Engines, and Real Fuels.  For some reason, even when I have a ton of electric charge, I lose liquid hydrogen at a very fast rate from the cryogenic tanks.

Share this post


Link to post
Share on other sites
On 2/2/2017 at 3:17 AM, CheckYoStaging said:

I have been having some trouble with boiloff.  I am using Kerbal Atomics, Cryogenic Engines, and Real Fuels.  For some reason, even when I have a ton of electric charge, I lose liquid hydrogen at a very fast rate from the cryogenic tanks.

Are you using the latest version?  There was a bug that if you ever ran out of electricity, it would boil off forever, but that was fixed.

If you right-click on the tank, what does it say for status?  Does it say it's boiling off?

Share this post


Link to post
Share on other sites
On 2/1/2017 at 5:17 PM, CheckYoStaging said:

I have been having some trouble with boiloff.  I am using Kerbal Atomics, Cryogenic Engines, and Real Fuels.  For some reason, even when I have a ton of electric charge, I lose liquid hydrogen at a very fast rate from the cryogenic tanks.

If you have RF, boiloff is managed by RF, and there's not active cooling.

Share this post


Link to post
Share on other sites

Problem with Emancipator engine - it has two gimbal modules and two engine modules - one with LqdHydrogen and one with LqdHydrogen and EnrichedUranium. I have recent Near Future Technologies installed.

Here is a CFG of this engine - can someone help me delete additional gimbal modules and engine modules? Or maybe mod developer can look ino it :) Thanks.
https://www.dropbox.com/s/krhgpybgx76rvzx/ntr-gc-25-2.cfg?dl=0

Edited by GrzesiekB

Share this post


Link to post
Share on other sites
41 minutes ago, GrzesiekB said:

Problem with Emancipator engine - it has two gimbal modules and two engine modules - one with LqdHydrogen and one with LqdHydrogen and EnrichedUranium. I have recent Near Future Technologies installed.

Here is a CFG of this engine - can someone help me delete additional gimbal modules and engine modules? Or maybe mod developer can look ino it :) Thanks.
https://www.dropbox.com/s/krhgpybgx76rvzx/ntr-gc-25-2.cfg?dl=0

I think one is for the core engine, the other for the 2 gas outlets you use for roll control.

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, Temeter said:

I think one is for the core engine, the other for the 2 gas outlets you use for roll control.

So this is the only engine in the pack which uses enriched uranium?

Share this post


Link to post
Share on other sites
6 minutes ago, GrzesiekB said:

So this is the only engine in the pack which uses enriched uranium?

Technically all nuclear reactors, including those in the engines, run on limited enriched uranium. You can get that with the near future electrics patch.

As to why the core engine has limited uranium even at stock, no clue. Maybe it does actually shoot out a bunch of uranium?

Edited by Temeter
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now