Antipodes

[1.3] WalkAbout v1.7.1 (17-07-2017)

Recommended Posts

Version 1.7.1 is out.

Sorry about that folks. I tested against the wrong version KIS:rolleyes:

Share this post


Link to post
Share on other sites

Hey, two things. First, thank you for this excellent mod! It makes my initial science collections so much easier, since it takes a bit to get to rover tech. Second, i thought i might suggest adding a section on the main post about the CTD caused by being too close to running out of RAM, just in case more people have this problem on large modded installs. Keep up the good work mysir!

Share this post


Link to post
Share on other sites

I don't see a Github bug tracker or the like, so I thought I'd post a bug report here.

I'm on KSP 1.3.1, and WalkAbout 1.7.1.  While controlling a walking kerbal, this is spammed into the log, seemingly once per frame:

Quote

NullReferenceException: Object reference not set to an instance of an object
  at KspAccess.CommonKspAccess.IsKeyCombinationPressed (KspAccess.KeyCombination keys) [0x00000] in <filename unknown>:0 
  at KspWalkAbout.WalkAboutEva.AlterMotionAsPerUserKeystrokes (KspWalkAbout.Entities.MotionSettings motion, KspAccess.KeyCombination perpetualMotionKeys) [0x00000] in <filename unknown>:0 
  at KspWalkAbout.WalkAboutEva.FixedUpdate () [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)    

 

In addition, the Perpetual Motion key seems to do nothing.

Share this post


Link to post
Share on other sites

I absolutely love this mod, especially bow I've started using BARIS and KCT.

 

Slight issue though, whenever I place a kerbal it crashes the game. It create a a lot file I can edit in to this but is it a known conflict with one of those mods?

Share this post


Link to post
Share on other sites
17 hours ago, ThePhoenixSol said:

is there a plan to upgrade this to 1.4.x?

I have compiled and run the code under 1.4.1 and there is good news and bad news:

Good news: no more aborts or log spamming!

Bad news: no nothing. The mod does not do anything anymore. The GUI appears, but when you press the button to put a kerbal at a location, nothing happens.

I have traced the code and everything seems to be setting itself up internally just fine - KSP just ignores the changes the changes I have made to the game state.

Unfortunately, I do not foresee having the time to delve deep into the new KSP code to find out how to add objects to the game (I barely figured it out previously). If anyone would like to take a crack at it, I would be really grateful. I am not talking about having to take over the mod, but if anyone can point me in the right direction for how to get a kerbal's ProtoVessel added to the current game (or whatever the new equivalent may be), that would go a long way to getting me going again.

I don't want to abandon Walkabout - I had plans for it (getting kerbals to walk/run towards targets automatically with obstacle avoidance, cruise control for rovers, etc). But I just don't have the time to comb through all the documentation and figure this out all over again.

Edited by Antipodes

Share this post


Link to post
Share on other sites
1 hour ago, Antipodes said:

I have compiled and run the code under 1.4.1 and there is good news and bad news:

Good news: no more aborts or log spamming!

Bad news: no nothing. The mod does not do anything anymore. The GUI appears, but when you press the button to put a kerbal at a location, nothing happens.

I have traced the code and everything seems to be setting itself up internally just fine - KSP just ignores the changes the changes I have made to the game state.

Unfortunately, I do not foresee having the time to delve deep into the new KSP code to find out how to add objects to the game (I barely figured it out previously). If anyone would like to take a crack at it, I would be really grateful. I am not talking about having to take over the mod, but if anyone can point me in the right direction for how to get a kerbal's ProtoVessel added to the current game (or whatever the new equivalent may be), that would go a long way to getting me going again.

I don't want to abandon Walkabout - I had plans for it (getting kerbals to walk/run towards targets automatically with obstacle avoidance, cruise control for rovers, etc). But I just don't have the time to comb through all the documentation and figure this out all over again.

wow, did the change of unity version change that much? that sucks man... I wish you all the luck in finding the fix, and i wish the community luck in assisting you as im sure they will. 

Thanks for the reply as well! glad to know the state of the mod, its a mainstay for me when i play with KCT

Share this post


Link to post
Share on other sites
On 4/9/2018 at 10:27 PM, ThePhoenixSol said:

wow, did the change of unity version change that much? that sucks man... I wish you all the luck in finding the fix, and i wish the community luck in assisting you as im sure they will. 

Thanks for the reply as well! glad to know the state of the mod, its a mainstay for me when i play with KCT

I literally came here to find out the status of this mod, having remembered it during a session where I tried out KCT for the first time. Creating and parking vehicles for re-use, then spawning kerbals for missions/contracts is really where it's at! :D 

Hope this can get re-looked at someday!

Share this post


Link to post
Share on other sites

I figured I'd take a look at making this work again, but a recompile for 1.5.1 apparently just works as is if you still want to update this. I did want to replace the hotkeys with a toolbar button so I have that code if you want.

Share this post


Link to post
Share on other sites
On 11/10/2018 at 11:47 AM, xnowfall said:

I figured I'd take a look at making this work again, but a recompile for 1.5.1 apparently just works as is if you still want to update this. I did want to replace the hotkeys with a toolbar button so I have that code if you want.

Would it work on 1.4.5? got any download?

Share this post


Link to post
Share on other sites

Wow! I am thrilled that there is interest in reviving this mod. 

I am in the middle of changing residences and in putting on a theatre production, but once things settle down and I don't have to rely on my workplace WiFi for internet connectivity, I will be eagerly looking at what progress has been made. 

Thanks for the efforts, fellow Kerbalers 

Edited by Antipodes

Share this post


Link to post
Share on other sites

It works in 1.7.0 but Kerbal Inventory System support is broken: You can assign inventory part to a Kerbal but once you take control of it, inventory is empty...

Share this post


Link to post
Share on other sites
On 5/6/2019 at 3:24 PM, Galenmacil said:

It works in 1.7.0 but Kerbal Inventory System support is broken: You can assign inventory part to a Kerbal but once you take control of it, inventory is empty...

It probably needs to be recompiled for 1.7, I believe that the KIS API changed.

@Antipodes are you still around, and are you going to continue with this?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.