Nhawks17

[1.6.1] RealPlume - Stock [v1.3.1 - 1/14/19] - Better Late than Never Update

Recommended Posts

Hey there,
First let me thank you for a very cool mod.
I just have one issue; after installing Realplume and the configs, the basic jet engine's FX are rather bad looking IMO.
The jet is spewing orange "bubbles" and notning more - even when the engine is entirely shut off.

Im not using any other FX mods, so I really don't know where to look for the cause of this.
Anyone experiencing the same, or know of a solution/workaround?

Screenshot of the "bubbles"
https://imgur.com/a/44hIP

::Edit::
I should mention, that I'm running version 1.2.2 of KSP

Edited by Deviouz

Share this post


Link to post
Share on other sites
1 hour ago, Deviouz said:

Screenshot is the "bubbles"
https://imgur.com/a/44hIP

::Edit::
I should mention, that I'm running version 1.2.2 of KSP

I see the same issue on my rocket engines before launch. Is that supposed to be some sort of frozen fuel failing off or boil off effect?

Share this post


Link to post
Share on other sites

Increase the particle limit through SmokeScreen via the Toolbar menu or the settings file in the SmokeScreen folder that is created after running the game with it once.

Share this post


Link to post
Share on other sites

this happens with realfuel 12.0(SA 3.2.2) and RP 10.5.1(SC 0.11.2):

phantom plumes

Spoiler

UiSAPqf.jpg

on (clockwise) swivel, spark, Dawn, LVN trimodal, twitch, ant, skipper

Share this post


Link to post
Share on other sites
50 minutes ago, rgr said:

this happens with realfuel 12.0(SA 3.2.2) and RP 10.5.1(SC 0.11.2):

phantom plumes

  Reveal hidden contents

UiSAPqf.jpg

on (clockwise) swivel, spark, Dawn, LVN trimodal, twitch, ant, skipper

Are you referring to plumes showing up when the engines aren't on and throttled up? Can you give me a list of the engines doing this if that is the case. Real Fuels seems to cause this issue a lot recently. 

Share this post


Link to post
Share on other sites
4 hours ago, Nhawks17 said:

Increase the particle limit through SmokeScreen via the Toolbar menu or the settings file in the SmokeScreen folder that is created after running the game with it once.

Tried this, but with no change to the orange bubbles whatsoever.
I put in 2000 as maximum limit, but each engine seems to be hardcoded to 2*50 particles each. (see marking in pic)
The actice particles never rises above 200.

http://imgur.com/UFQpjCc

Share this post


Link to post
Share on other sites
17 minutes ago, Deviouz said:

Tried this, but with no change to the orange bubbles whatsoever.
I put in 2000 as maximum limit, but each engine seems to be hardcoded to 2*50 particles each. (see marking in pic)
The actice particles never rises above 200.

http://imgur.com/UFQpjCc

Alright, I'll have to take a look at it later. Not sure what's going on.

Share this post


Link to post
Share on other sites
22 hours ago, Nhawks17 said:

Alright, I'll have to take a look at it later. Not sure what's going on.

A small update: I removed the folder "MP_Nazari_FX" from within the "RealPlume" folder, and the orange bubble effect dissapeared all together from jet engines, preserving the plumes for the rocket engines.

Edited by Deviouz

Share this post


Link to post
Share on other sites

Hi, are there any plans on fixing the Plume-effect -always being on- with Ven's Revamped engines?

Share this post


Link to post
Share on other sites

I also have phantom plumes and some wrong plume placement with these parts / mods :

Squad:

24-77 "Twitch"
48-75 "Spark"
RE-Ii5 "Skipper"
KR-2L "Rhino"

RLA Continued Stockalike:

LV-0 "Aphid"
36-5D "Caravel"
 

KW Rocketry:

VR-9D "Vesta"
G8D "Griffon"
"Titan V"
"Maverick"
"Kw Rocketry Hypergolic Service Propulsion system"


Modular Rocket System:

All the engines.

Cryoengines:

All the engines.


SXT :

LV-NX3 "Phoebus"

Kerbal Atomics:

LV-N50 "Stubber"(Crooked plume)
LV-100 "Neptuna" (Crooked plume)
LV-N "Atomic Rocket motor trimodal" (Patched LV-N "Nerv" by squad)

Umbra Space Industries:

GNR-3750 (Smoke going 90degree sideway)
GNR-2500 (Misplaced plume and smoke)



 


 

Edited by flack

Share this post


Link to post
Share on other sites
On 1/15/2017 at 6:50 PM, flack said:

I also have phantom plumes and some wrong plume placement with these parts / mods :

Squad:

24-77 "Twitch"
48-75 "Spark"
RE-Ii5 "Skipper"
KR-2L "Rhino"

RLA Continued Stockalike:

LV-0 "Aphid"
36-5D "Caravel"
 

KW Rocketry:

VR-9D "Vesta"
G8D "Griffon"
"Titan V"
"Maverick"
"Kw Rocketry Hypergolic Service Propulsion system"


Modular Rocket System:

All the engines.

Cryoengines:

All the engines.


SXT :

LV-NX3 "Phoebus"

Kerbal Atomics:

LV-N50 "Stubber"(Crooked plume)
LV-100 "Neptuna" (Crooked plume)
LV-N "Atomic Rocket motor trimodal" (Patched LV-N "Nerv" by squad)

Umbra Space Industries:

GNR-3750 (Smoke going 90degree sideway)
GNR-2500 (Misplaced plume and smoke)



 


 

Thanks for this. When I get the free time I'll be sure to look into the issue.

Share this post


Link to post
Share on other sites

@Nhawks17 we had a question over at BDB. Is it possible to use have the plume change based on the part upgrade system added in 1.2? Size/shape/etc, but also one of the proposed upgrades converts the Redstone from LOX/Ethanol to LOX/Hydyne (aka Bagels and LOX), which is a storable propellant. If that is possibly it would be very cool. :)

Share this post


Link to post
Share on other sites

@flack @rgr Are either of you using Real Fuels with the Stockalike config set? I'd really discourage using RealPlume - Stock with Real Fuels and RF Stockalike, as it'll do odd things with the effects and/or engine modules. Especially so, since RF Stockalike comes with RealPlume configs for a good portion of the engines it alters.

Share this post


Link to post
Share on other sites

@Raptor831 I was having the same issues as @rgr and i had two sets of configs, messing things up. Removing the Real Fuels stock configs and keeping yours all is good. Thanks for keeping this great mod alive :)

Share this post


Link to post
Share on other sites
3 hours ago, Raptor831 said:

@flack @rgr Are either of you using Real Fuels with the Stockalike config set? I'd really discourage using RealPlume - Stock with Real Fuels and RF Stockalike, as it'll do odd things with the effects and/or engine modules. Especially so, since RF Stockalike comes with RealPlume configs for a good portion of the engines it alters.

 

4 hours ago, Nhawks17 said:

Thanks for this. When I get the free time I'll be sure to look into the issue.

Ahhh I removed RealPlume - Stock and it fixed a lot of the phantom plumes! Thank you!

But I still have some phantom plumes with :

-All the engines of Cryoengines
-MRS Liquid fuel engine "hound"
-LV-0 "ant"
-MRS "Flingatron"

Misplaced plumes are still there on previously mentioned engines.

Thanks a lot!
 

Share this post


Link to post
Share on other sites
5 hours ago, CobaltWolf said:

@Nhawks17 we had a question over at BDB. Is it possible to use have the plume change based on the part upgrade system added in 1.2? Size/shape/etc, but also one of the proposed upgrades converts the Redstone from LOX/Ethanol to LOX/Hydyne (aka Bagels and LOX), which is a storable propellant. If that is possibly it would be very cool. :)

I'm not familiar with the part upgrade system you're referring to but are you saying to change the plume if the engine size is changed? Like in Tweakscale? If so, no that limitation is with SmokeScreen and doesn't work. To the /ethanol to /hydyne upgrade, possibly, I'd have to look at a config file to see what parameters change with the engine when it is upgraded. If it's similar to the way @NecroBones does with the SpaceY togglable cluster engines (i.e. going from 9 "on" engines to 3/1 "on" engines) with the engineID names being different depending on what mode you're in (if I'm remembering correctly) then yes. If it is done another way I'd have to look into it.

32 minutes ago, flack said:

 

Ahhh I removed RealPlume - Stock and it fixed a lot of the phantom plumes! Thank you!

But I still have some phantom plumes with :

-All the engines of Cryoengines
-MRS Liquid fuel engine "hound"
-LV-0 "ant"
-MRS "Flingatron"

Misplaced plumes are still there on previously mentioned engines.

Thanks a lot!
 

Well if you remove the RealPlume-Stock folder that negates the purpose of this mod :P 

Share this post


Link to post
Share on other sites
2 hours ago, flack said:

 

Ahhh I removed RealPlume - Stock and it fixed a lot of the phantom plumes! Thank you!

But I still have some phantom plumes with :

-All the engines of Cryoengines
-MRS Liquid fuel engine "hound"
-LV-0 "ant"
-MRS "Flingatron"

Misplaced plumes are still there on previously mentioned engines.

Thanks a lot!
 

If you're having issues with those engines with RF Stockalike (and not Real Plume - Stock), hop on over to that thread and I can help troubleshoot those. I'm sure @Nhawks17 would appreciate me not fixing my stuff in this thread. :wink:

Share this post


Link to post
Share on other sites
38 minutes ago, Raptor831 said:

If you're having issues with those engines with RF Stockalike (and not Real Plume - Stock), hop on over to that thread and I can help troubleshoot those. I'm sure @Nhawks17 would appreciate me not fixing my stuff in this thread. :wink:

Of course!! For some reasons I thought RF Stockalike was dependent of Real Plume - Stock! Just wanted to be sure Nhawks17 wouldnt lose his time investigating because of my previous list of phantom plume!

Thanks!

Edited by flack

Share this post


Link to post
Share on other sites

@Raptor831 i have been using ckan versions of RF/RP and i tried fiddling with the configs on and off, also with the standalone pkgs, with mixed results. the dependency/install system of ckan does not like it and has a hard time getting its head around these two(four) packs living next to each other :)

with RF/SA + RP only, i was getting 3 phantoms, but after the RFSA 3.2.3 update, only the RT-5 Flea remains problematic in stock. good :D

 

Share this post


Link to post
Share on other sites

I'm having issues with plume effects always on on Cryo engines and I've narrowed down the culprit to Realplume mod. This happens. 2rqnlo8.png

Share this post


Link to post
Share on other sites
15 hours ago, Dermeister said:

Ill try it out. Naild it it was smoke screen!

Let me know if it fixes it. There have been other reports of the phantom plumes in other engines.

Share this post


Link to post
Share on other sites
3 hours ago, Nhawks17 said:

Let me know if it fixes it. There have been other reports of the phantom plumes in other engines.

IT did but now I don't know if it's related or not but procedural parts past a certain size behave weird. I don't want to do a details report on that because it might not even be related at all.

Other than that The ghost Plumes were fixed with the latest smokescreen!!! it worked like a charm!

Share this post


Link to post
Share on other sites
5 minutes ago, Dermeister said:

IT did but now I don't know if it's related or not but procedural parts past a certain size behave weird. I don't want to do a details report on that because it might not even be related at all.

Other than that The ghost Plumes were fixed with the latest smokescreen!!! it worked like a charm!

Good to know, thanks for reporting this :) 

Here's a quick update that includes the latest SmokeScreen version which hopefully fixes the phantom plumes (???????). I wasn't able to sit down and test it extensively so please tell me if this helps. If it doesn't, I'll have to sit down with it when I have a chance.

--------------------------------------------------------------------------------------------------------------

RealPlume-Stock v0.11.3

- Updated SmokeScreen to v2.7.1

--------------------------------------------------------------------------------------------------------------

Phantom plumes begone!?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.