AndrewDraws

[1.6.0] Extrasolar v1.8.0 [12/21/18]

Recommended Posts

13 hours ago, xXshadowXx said:

Okay, tested it with just Extrasolar and kopernicus (with some aesthetic mods, EVE etc.). Same behavior continues. The panels point towards Valentine even when Valentine is blocked by Kerbin and the Sun is in full view. Any suggestions?

Oh, also the current issue is with the stock 1x6 extendable solar panels, not sure about the others.

Sorry, I'm not getting the same problem. Is it possible that you oriented your solar panels strangely in the VAB? Send over a screenshot of your solar panels pointed in the wrong direction.

And you are sure that your haven't modified Extrasolar, or have any other mods installed?

Share this post


Link to post
Share on other sites
8 hours ago, AndrewDrawsPrettyPictures said:

Sorry, I'm not getting the same problem. Is it possible that you oriented your solar panels strangely in the VAB? Send over a screenshot of your solar panels pointed in the wrong direction.

And you are sure that your haven't modified Extrasolar, or have any other mods installed?

Okay, downloaded a fresh copy of Extrasolar. Here's my GameData folder:

dd7c9111ea.png

Valentine blocked by kerbin, sun in full view, panels are fine.

f5cfeeb3c0.jpg

Sun blocked by Kerbin, Valentine in view. Panels orient towards Valentine

a537f059ba.jpg

Valentine now blocked by Kerbin, Sun in full view. Panels stay oriented towards Valentine no matter how much time I give them to rotate. The only way to refresh it is to manually rotate the entire ship towards the sun, then they are mostly fine, though sometimes there's an odd panel that refuses to look away from Valentine (even if Kerbin is blocking it?). Until the Sun is blocked again.

e837305312.jpg

 

Edited by xXshadowXx

Share this post


Link to post
Share on other sites
1 hour ago, xXshadowXx said:

Okay, downloaded a fresh copy of Extrasolar. Here's my GameData folder:

dd7c9111ea.png

Valentine blocked by kerbin, sun in full view, panels are fine.

f5cfeeb3c0.jpg

Sun blocked by Kerbin, Valentine in view. Panels orient towards Valentine

a537f059ba.jpg

Valentine now blocked by Kerbin, Sun in full view. Panels stay oriented towards Valentine no matter how much time I give them to rotate. The only way to refresh it is to manually rotate the entire ship towards the sun, then they are mostly fine, though sometimes there's an odd panel that refuses to look away from Valentine (even if Kerbin is blocking it?). Until the Sun is blocked again.

e837305312.jpg

 

I'm going to release an update in a week or two and tell me after I do if you are still having problems.

Share this post


Link to post
Share on other sites

It may not be an issue with Extrasolar. I'm experiencing the same behavior without it installed; I'm instead using a procedural galaxy generated by To Boldly Go. My solar panels are quite insistent in pointing all kinds of wacky directions, many of them directly away from the nearby sun. They also report being in "direct sunlight," despite their energy flow being 0.000.

My guess? They don't have a good way to prioritize what light source will give them the best illumination.

Edited by Jim Starluck

Share this post


Link to post
Share on other sites
12 minutes ago, Jim Starluck said:

It may not be an issue with Extrasolar. I'm experiencing the same behavior without it installed; I'm instead using a procedural galaxy generated by To Boldly Go. My solar panels are quite insistent in pointing all kinds of wacky directions, many of them directly away from the nearby sun. They also report being in "direct sunlight," despite their energy flow being 0.000.

My guess? They don't have a good way to prioritize what light source will give them the best illumination.

Yeah It could possibly just be a problem will multi-stellar planet packs and out of my control for the most part. I can't think of anything else that could be causing this.

Share this post


Link to post
Share on other sites
Just now, AndrewDrawsPrettyPictures said:

Yeah It could possibly just be a problem will multi-stellar planet packs and out of my control for the most part. I can't think of anything else that could be causing this.

Yeah I've tested very briefly with other stellar planet packs, the same kinda thing happens, so it's probably not because of you haha. It's just really irritating when your sat network dies cos it wants to point at far off stars lmao

Share this post


Link to post
Share on other sites
3 hours ago, Jim Starluck said:

Think it's a bug with Kopernicus? Should it get reported on their end?

Could be a kopernicus issue, it is the only constant in the situation. Other than ksp itself

Share this post


Link to post
Share on other sites
4 hours ago, Jim Starluck said:

Think it's a bug with Kopernicus? Should it get reported on their end?

Probably a good idea.

Share this post


Link to post
Share on other sites

Working on an update for Extrasolar right now. In the next update, you will have to use a heatshield to protect your spacecraft from interstellar debri. So, if you are planning any interstellar missions in the near future, make sure to pack a heatshield!

Share this post


Link to post
Share on other sites

Was the distance form the star doubled recently? I remember it being around 5Pm, now it's 10Pm, but changelog says nothing about it.

Share this post


Link to post
Share on other sites
2 hours ago, Ununtri said:

Was the distance form the star doubled recently? I remember it being around 5Pm, now it's 10Pm, but changelog says nothing about it.

No, not that I'm aware of. I might have done it unintentionally. If you want to make it closer, I believe I put instructions for that a couple pages back.

Share this post


Link to post
Share on other sites

how can i get to valentine because manuvernodes dont work:/

Share this post


Link to post
Share on other sites
1 hour ago, KerbolExplorer said:

how can i get to valentine because manuvernodes dont work:/

Point, and go. :P

Share this post


Link to post
Share on other sites
1 minute ago, AndrewDrawsPrettyPictures said:

Point, and go. :P

ok thanks!

Share this post


Link to post
Share on other sites

So by reading the posts about solar panels issues, besides that; is this compatible to stock + OPM + SigBin + SigDim + RealisticRescale (Augustus) ?

Share this post


Link to post
Share on other sites
3 minutes ago, Gordon Dry said:

So by reading the posts about solar panels issues, besides that; is this compatible to stock + OPM + SigBin + SigDim + RealisticRescale (Augustus) ?

with opm yes but with the others i dont know

Share this post


Link to post
Share on other sites
2 hours ago, Gordon Dry said:

So by reading the posts about solar panels issues, besides that; is this compatible to stock + OPM + SigBin + SigDim + RealisticRescale (Augustus) ?

OPM works fine, Sigma Binary should be fine as well, though it won't actually change the Valentine system at all. Sigma Dimensions should also work fine as well as realistic rescale. Keep in mind, though, Realistic Rescale will probably cause Valentine to be EXTREMELY far away.

Share this post


Link to post
Share on other sites

Well, stars are usually extremely far away so this is okay :cool:

Share this post


Link to post
Share on other sites

@AndrewDrawsPrettyPictures I downloaded this pack and everything looks good, but I think the scatterer sun flare is offset from Valentine quite a bit. It looks fine from afar, but as you zoom into the star, the issue becomes apparent. I have only tested for a few minutes to ensure my Sigma configs were working, but this was immediately obvious to me.

Share this post


Link to post
Share on other sites
2 hours ago, Galileo said:

@AndrewDrawsPrettyPictures I downloaded this pack and everything looks good, but I think the scatterer sun flare is offset from Valentine quite a bit. It looks fine from afar, but as you zoom into the star, the issue becomes apparent. I have only tested for a few minutes to ensure my Sigma configs were working, but this was immediately obvious to me.

I know I have this problem with stars that are far away from the sun, where the sunflare jiggles around or is offset from the rest of the star. However, when you get close enough the star, the sunflare snaps back to where it is supposed to be. Can you test and see if the same thing happens when you are in the SOI of Valentine. Thanks for testing Extrasolar out for me. I haven't had the time recently to give as much love to my KSP mods because I've gotten slightly distracted making my first mod for Skyrim.

Share this post


Link to post
Share on other sites
1 hour ago, AndrewDrawsPrettyPictures said:

I know I have this problem with stars that are far away from the sun, where the sunflare jiggles around or is offset from the rest of the star. However, when you get close enough the star, the sunflare snaps back to where it is supposed to be. Can you test and see if the same thing happens when you are in the SOI of Valentine. Thanks for testing Extrasolar out for me. I haven't had the time recently to give as much love to my KSP mods because I've gotten slightly distracted making my first mod for Skyrim.

Weird. Getting closer doesn't snap it into place for me. I have messed with Kerbal StarSystem, which has many stars further out than yours, and they don't have that issue. I'll have a look at your sun flare stuff and see if I can make something work. :) 

Share this post


Link to post
Share on other sites
37 minutes ago, Galileo said:

Weird. Getting closer doesn't snap it into place for me. I have messed with Kerbal StarSystem, which has many stars further out than yours, and they don't have that issue. I'll have a look at your sun flare stuff and see if I can make something work. :) 

Oh. At least that's how it was for RSS Constellations. Is there an offset field for sunflares? I wasn't even aware of that. :P

Share this post


Link to post
Share on other sites
1 hour ago, AndrewDrawsPrettyPictures said:

Oh. At least that's how it was for RSS Constellations. Is there an offset field for sunflares? I wasn't even aware of that. :P

Yeah there is but I haven't looked at your cfg yet

Share this post


Link to post
Share on other sites
On 25/7/2017 at 4:59 AM, AndrewDrawsPrettyPictures said:

Working on an update for Extrasolar right now. In the next update, you will have to use a heatshield to protect your spacecraft from interstellar debri. So, if you are planning any interstellar missions in the near future, make sure to pack a heatshield!

you sould the same when you are pasing trought planetary rings

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.