AndrewDraws

[1.6.0] Extrasolar v1.8.0 [12/21/18]

Recommended Posts

That hotfix does not appear to address the same issue. It only includes Heba, and even the new version that you just released is showing this issue. In fact, the issue has returned because, after my post, I fixed it with the following addition to both Heba and Lominia:

Template
{
name = Laythe
removePQSMods = PQSLandControl, PQSMod_AltitudeAlpha, PQSMod_VertexHeightNoise, PQSMod_VertexSimplexHeightMap, PQSMod_VertexHeightMap
}

Once I added this, in the old version, it worked. So I added it in the new version as well on a test copy of KSP and.... it works as well.

I am not sure this is the right fix, but, it does work. Without it, if I go into the science archives (R&D Building), Wernher's face doesn't load and no children of Valentine can be seen in the list on the left, even after selecting Valentine.

Once I add the templates, it all works as expected. This is with no other mods installed except Kopernicus and its requirements.

Share this post


Link to post
Share on other sites
4 minutes ago, joolsjewls said:

That hotfix does not appear to address the same issue. It only includes Heba, and even the new version that you just released is showing this issue. In fact, the issue has returned because, after my post, I fixed it with the following addition to both Heba and Lominia:

Template
{
name = Laythe
removePQSMods = PQSLandControl, PQSMod_AltitudeAlpha, PQSMod_VertexHeightNoise, PQSMod_VertexSimplexHeightMap, PQSMod_VertexHeightMap
}

Once I added this, in the old version, it worked. So I added it in the new version as well on a test copy of KSP and.... it works as well.

I am not sure this is the right fix, but, it does work. Without it, if I go into the science archives (R&D Building), Wernher's face doesn't load and no children of Valentine can be seen in the list on the left, even after selecting Valentine.

Once I add the templates, it all works as expected. This is with no other mods installed except Kopernicus and its requirements.

Sorry, I saw you were having problems with Heba and I assumed it was something related to an earlier problem with Heba that was fixed with the hotfix. It must have something to do with both planets not having templates. I'll look into it, and see if I can fix it.

Share this post


Link to post
Share on other sites
Just now, joolsjewls said:

That hotfix does not appear to address the same issue. It only includes Heba, and even the new version that you just released is showing this issue. In fact, the issue has returned because, after my post, I fixed it with the following addition to both Heba and Lominia:

Template
{
name = Laythe
removePQSMods = PQSLandControl, PQSMod_AltitudeAlpha, PQSMod_VertexHeightNoise, PQSMod_VertexSimplexHeightMap, PQSMod_VertexHeightMap
}

Once I added this, in the old version, it worked. So I added it in the new version as well on a test copy of KSP and.... it works as well.

I am not sure this is the right fix, but, it does work. Without it, if I go into the science archives (R&D Building), Wernher's face doesn't load and no children of Valentine can be seen in the list on the left, even after selecting Valentine.

Once I add the templates, it all works as expected. This is with no other mods installed except Kopernicus and its requirements.

Okay I solved it. You can download the edited files off of GitHub (the only files I edited are Heba and Lomina's configs), or simply add this to their configs after the "name" value:

Template { name = Jool }

That should solve it.

 

Share this post


Link to post
Share on other sites

Thank you for all the work you've put into this! This is by far my favorite planet pack. I've been using it for a while now, and I just started a new save with aspirations of creating an extrasolar colony using MKS. I've been playing KSP since 2011 and it's modders like you that make it such an amazing and long-lasting game. Keep up the great work!!

Haha, all this time and this is the first time I've posted in these forums.

Share this post


Link to post
Share on other sites

I know that this has been touched before but does Valentine from 1.4 still light up Kerbin like the sun using Kopernicus 1.3.0-8? I really want some features added in Kopernicus 1.3.0-7 but that messes with the lighting.

Share this post


Link to post
Share on other sites
On 9/26/2017 at 10:18 PM, Orbnu said:

Thank you for all the work you've put into this! This is by far my favorite planet pack. I've been using it for a while now, and I just started a new save with aspirations of creating an extrasolar colony using MKS. I've been playing KSP since 2011 and it's modders like you that make it such an amazing and long-lasting game. Keep up the great work!!

Haha, all this time and this is the first time I've posted in these forums.

And it's people like you who keep me motivated to keep modding. Thank you!

 

15 hours ago, Funtime60 said:

I know that this has been touched before but does Valentine from 1.4 still light up Kerbin like the sun using Kopernicus 1.3.0-8? I really want some features added in Kopernicus 1.3.0-7 but that messes with the lighting.

No, this has been fixed in 1.4. Extrasolar should now work with the latest version of Kopernicus.

Share this post


Link to post
Share on other sites
5 hours ago, AndrewDrawsPrettyPictures said:

And it's people like you who keep me motivated to keep modding. Thank you!

Seconding the remark you replied to - Extrasolar is a great mod, and I've really enjoyed it. It's one of the better planet packs out there, and is definitely more accessible since it was moved closer in - though I think now it might be a little bit *too* close - it sits very near Neidon and Plock if one has OPM installed. In my save, I set it out 3x farther, which is still a lot more accessible than 9 trillion km. (I did like how the original was exactly 1 earth LY from Kerbin, although without warp it would take forever to get out there)

I might be a little... excessive, though, since I usually run Extrasolar with at least 2 other Planet Packs - depending on which instance of KSP I am playing, either OtherWorlds, Keridani, OPM, or GPP (with GPP_Secondary). At least 2 of those mods are the same distance from the Kerbal Sun, so I've gotten adept at editing config files to make things fit together aesthetically.

Thanks for all the work you put into this, it's giving me lots of hours of fun in KSP and new things to explore!

Share this post


Link to post
Share on other sites
29 minutes ago, panarchist said:

Seconding the remark you replied to - Extrasolar is a great mod, and I've really enjoyed it. It's one of the better planet packs out there, and is definitely more accessible since it was moved closer in - though I think now it might be a little bit *too* close - it sits very near Neidon and Plock if one has OPM installed. In my save, I set it out 3x farther, which is still a lot more accessible than 9 trillion km. (I did like how the original was exactly 1 earth LY from Kerbin, although without warp it would take forever to get out there)

I might be a little... excessive, though, since I usually run Extrasolar with at least 2 other Planet Packs - depending on which instance of KSP I am playing, either OtherWorlds, Keridani, OPM, or GPP (with GPP_Secondary). At least 2 of those mods are the same distance from the Kerbal Sun, so I've gotten adept at editing config files to make things fit together aesthetically.

Thanks for all the work you put into this, it's giving me lots of hours of fun in KSP and new things to explore!

Alright, I'll make sure to move Valentine a bit farther out. I've spent so much time on Extrasolar as well as Constellations, so it is definitely very rewarding to see that people are getting entertainment out of my mods. Currently, I'm working on making Extrasolar compatible with the Community Resource Pack, and I'm going to attempt to make Extrasolar compatible with RSS, perhaps integrating it with Constellations in some way.

For those who don't know how to change Valentine's distance to their liking, I posted a couple of pages back how to change how far Valentine is. It's not too complicated.

Share this post


Link to post
Share on other sites
1 minute ago, AndrewDrawsPrettyPictures said:

Alright, I'll make sure to move Valentine a bit farther out. I've spent so much time on Extrasolar as well as Constellations, so it is definitely very rewarding to see that people are getting entertainment out of my mods. Currently, I'm working on making Extrasolar compatible with the Community Resource Pack, and I'm going to attempt to make Extrasolar compatible with RSS, perhaps integrating it with Constellations in some way.

For those who don't know how to change Valentine's distance to their liking, I posted a couple of pages back how to change how far Valentine is. It's not too complicated.

Cool, thanks! - I wouldn't have brought it up if it wasn't OPM - and it's more a suggestion than a request.

Share this post


Link to post
Share on other sites

Hello guys!

 

I have a question, may be somebody can help me. I used previous version of this mod withi New Horizons mod. Everything was fine but after I had updated Exrsolar mod all my spacecrafts moved from orbit of one planet to another. May be somebody encountered such a problem and can help?

Edited by DuskFall

Share this post


Link to post
Share on other sites
5 hours ago, DuskFall said:

Hello guys!

 

I have a question, may be somebody can help me. I used previous version of this mod withi New Horizons mod. Everything was fine but after I had updated Exrsolar mod all my spacecrafts moved from orbit of one planet to another. May be somebody encountered such a problem and can help?

Did you make sure to install the "CareerSaver" as well?

Share this post


Link to post
Share on other sites
56 minutes ago, AndrewDrawsPrettyPictures said:

Did you make sure to install the "CareerSaver" as well?

May be I'm too stupid, but what is it "CareerSaver". Google didn't tell me anything. Is it config file?

Edited by DuskFall

Share this post


Link to post
Share on other sites
51 minutes ago, DuskFall said:

May be I'm too stupid, but what is it "CareerSaver". Google didn't tell me anything. Is it config file?

When you download Extrasolar, it should come with a config called "Extrasolar_CareerSaver." You can also get it off of the Extrasolar GitHub page linked in the OP.

 

46 minutes ago, abcofabc said:

Why can't I use this?

You are going to have to elaborate.

Share this post


Link to post
Share on other sites
8 minutes ago, AndrewDrawsPrettyPictures said:

When you download Extrasolar, it should come with a config called "Extrasolar_CareerSaver." You can also get it off of the Extrasolar GitHub page linked in the OP.

Unfortunately it didn't help. Anyway orbits changed. May be I did something wrong? But I did as instruction had said. Put careersaver anywhere in gamedata. More over I put config file everywhere in gamedata

Share this post


Link to post
Share on other sites

@AndrewDrawsPrettyPictures

I am planning to do a Modded KSP Graphic novel with this mod, the whole USI constellation, and a bunch of others. Basically, Creating KSC 2.0 on one of the habitable planets of the system. (After a catastrophe [Censored for spoilers] makes Kerbol not viable for living anymore). Dunno if I ever will get it done, but this planet pack is truly the best for this story. Thanks!

Edited by Starslinger999

Share this post


Link to post
Share on other sites
Just now, DuskFall said:

Unfortunately it didn't help. Anyway orbits changed. May be I did something wrong? But I did as instruction had said. Put careersaver anywhere in gamedata. More over I put config file everywhere in gamedata

Weird. Could you tell me what orbits changed? I moved Valentine closer to the Sun, perhaps I moved it so close that objects that were previously in orbit around a planet of Valentine got captured by a planet in New Horizons or vice versa. Show me a screenshot of the entire solar system from the map view or tracking station.

Share this post


Link to post
Share on other sites
54 minutes ago, AndrewDrawsPrettyPictures said:

Weird. Could you tell me what orbits changed? I moved Valentine closer to the Sun, perhaps I moved it so close that objects that were previously in orbit around a planet of Valentine got captured by a planet in New Horizons or vice versa. Show me a screenshot of the entire solar system from the map view or tracking station.

I've solved problem replaced only Valentine config into old version. Valentine came closer to Kerbol. Orbits didn't change, but I don't know how can it influence on spacecrafts and planets on Valentine orbit. The problem is, that Extrasolar thinks that New Horizons planets are it's own planets and move spacecrafts to planets on Valentine's orbit. May be there are equal planets whith identical charateristics. I'll check every planets from Extrasolar and can say, what's wrong

Edited by DuskFall

Share this post


Link to post
Share on other sites
13 hours ago, AndrewDrawsPrettyPictures said:

当你下载外,它应该有一个配置被称为“extrasolar_careersaver”。你也可以把它从太阳系以外的GitHub页面里操作

 

你要精心。

Well, I just copied the GameData folder to the root of the game. What's the problem, huh?
My game version is 1.3

I also found the Extrasolar_CareerSaver.cfg file. How should I use it?
I'm Chinese. My English is poor. Please forgive me if there is any grammar problem.

Edited by abcofabc

Share this post


Link to post
Share on other sites
2 hours ago, abcofabc said:

Well, I just copied the GameData folder to the root of the game. What's the problem, huh?
My game version is 1.3

I also found the Extrasolar_CareerSaver.cfg file. How should I use it?
I'm Chinese. My English is poor. Please forgive me if there is any grammar problem.

That's not a problem. My english is not better than yours :) So, regarding your issue. Try to install the latest Kopernicus. Anyway Ive cheked. I'd removed all mods, left only extrasolar and it also didn't work. After that I'd installed Kopernicus and it worked

Share this post


Link to post
Share on other sites

@DuskFall Here is another way you can solve it, from the Kerbal Star Systems thread:

Spoiler

As some of you may have noticed, while using Kerbol Starsystem, upon loading your game you will find most of your probes/projects currently in orbital flight are NOT where they are supposed to be. This can be game breaking for a lot of OCD players. Well now there is a fix for the problem that allows you to maintain your save file without problems. Now this process can seem a bit annoying, but after doing it a couple times it goes much faster. (Practice makes perfect) So now for a step by step guide to recover your orbits and flight paths.

Qualifying Factors:

  • you MUST start your game with KSS INSTALLED. (and properly)
  • you MUST ALREADY have a manually created save file to load WITH all your CORRECT orbit data.

Alright introductions aside, moving onto STEP 1 of this guide.

STEP 1:  After initial game boot, and profile load, ENTER the Tracking Station

PxFMdf4.png

Also note these are the correct target orbits im looking to achieve.

9y9R9NV.png

STEP 2:  While in the Tracking Station, take a look at your commnet visualizations and current orbit heights. You will notice both are in disarray.

43sjmaE.png

Now exit the Tracking Station.

STEP 3:  Re-enter the Tracking Station. Now you will notice one of the problems solved. COMMNET is back to normal. However orbits are still very incorrect.

VOGjz0R.png

 Now exit the tracking station once more and we move on to FIXING the orbits.

STEP 4:  Hit "ESC" key and select "Load Save".

vPB6M4B.png

STEP 5:  Now select your manually made save file and load it. NOT THE PERSISTENT.SFS FILE.

xi8bwna.png

STEP 6:  After the file re-loads you are DONE!! now were going to verify it worked!! Enter the Tracking station one last time for verification.

zq2XVgJ.png

EVERYTHING is perfect once again. theres the A-27 proper AP

EB60ub5.png

There is the correct PE. Now lets check a second satellite. Double checking doesnt hurt.

PDJM2Ss.png

Sure enough, AP is correct! One last photo.

Mptcpu9.png

And there ya go. PE is correct. FIX proven 100% WORKS!!!

Hope this helps all who need this knowledge.

 

Share this post


Link to post
Share on other sites
6 hours ago, AndrewDrawsPrettyPictures said:

@DuskFall Here is another way you can solve it, from the Kerbal Star Systems thread:

  Hide contents

As some of you may have noticed, while using Kerbol Starsystem, upon loading your game you will find most of your probes/projects currently in orbital flight are NOT where they are supposed to be. This can be game breaking for a lot of OCD players. Well now there is a fix for the problem that allows you to maintain your save file without problems. Now this process can seem a bit annoying, but after doing it a couple times it goes much faster. (Practice makes perfect) So now for a step by step guide to recover your orbits and flight paths.

Qualifying Factors:

  • you MUST start your game with KSS INSTALLED. (and properly)
  • you MUST ALREADY have a manually created save file to load WITH all your CORRECT orbit data.

Alright introductions aside, moving onto STEP 1 of this guide.

STEP 1:  After initial game boot, and profile load, ENTER the Tracking Station

PxFMdf4.png

Also note these are the correct target orbits im looking to achieve.

9y9R9NV.png

STEP 2:  While in the Tracking Station, take a look at your commnet visualizations and current orbit heights. You will notice both are in disarray.

43sjmaE.png

Now exit the Tracking Station.

STEP 3:  Re-enter the Tracking Station. Now you will notice one of the problems solved. COMMNET is back to normal. However orbits are still very incorrect.

VOGjz0R.png

 Now exit the tracking station once more and we move on to FIXING the orbits.

STEP 4:  Hit "ESC" key and select "Load Save".

vPB6M4B.png

STEP 5:  Now select your manually made save file and load it. NOT THE PERSISTENT.SFS FILE.

xi8bwna.png

STEP 6:  After the file re-loads you are DONE!! now were going to verify it worked!! Enter the Tracking station one last time for verification.

zq2XVgJ.png

EVERYTHING is perfect once again. theres the A-27 proper AP

EB60ub5.png

There is the correct PE. Now lets check a second satellite. Double checking doesnt hurt.

PDJM2Ss.png

Sure enough, AP is correct! One last photo.

Mptcpu9.png

And there ya go. PE is correct. FIX proven 100% WORKS!!!

Hope this helps all who need this knowledge.

 

I'll try. Hope that it's working not only for KSS

Share this post


Link to post
Share on other sites
8 minutes ago, The White Guardian said:

0_0 x 105

My goodness, this pack is a gem!

@AndrewDrawsPrettyPictures, I tip my hat to you.

Approval from the legendary White Guardian? At least that means I'm doing something right...

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.