AndrewDraws

[1.6.0] Extrasolar v1.8.0 [12/21/18]

Recommended Posts

1 hour ago, AndrewDrawsPrettyPictures said:

Approval from the legendary White Guardian? At least that means I'm doing something right...

You definitely are! :D

Share this post


Link to post
Share on other sites
On 05.10.2017 at 3:54 PM, AndrewDrawsPrettyPictures said:

@DuskFall Here is another way you can solve it, from the Kerbal Star Systems thread:

  Reveal hidden contents

As some of you may have noticed, while using Kerbol Starsystem, upon loading your game you will find most of your probes/projects currently in orbital flight are NOT where they are supposed to be. This can be game breaking for a lot of OCD players. Well now there is a fix for the problem that allows you to maintain your save file without problems. Now this process can seem a bit annoying, but after doing it a couple times it goes much faster. (Practice makes perfect) So now for a step by step guide to recover your orbits and flight paths.

Qualifying Factors:

  • you MUST start your game with KSS INSTALLED. (and properly)
  • you MUST ALREADY have a manually created save file to load WITH all your CORRECT orbit data.

Alright introductions aside, moving onto STEP 1 of this guide.

STEP 1:  After initial game boot, and profile load, ENTER the Tracking Station

PxFMdf4.png

Also note these are the correct target orbits im looking to achieve.

9y9R9NV.png

STEP 2:  While in the Tracking Station, take a look at your commnet visualizations and current orbit heights. You will notice both are in disarray.

43sjmaE.png

Now exit the Tracking Station.

STEP 3:  Re-enter the Tracking Station. Now you will notice one of the problems solved. COMMNET is back to normal. However orbits are still very incorrect.

VOGjz0R.png

 Now exit the tracking station once more and we move on to FIXING the orbits.

STEP 4:  Hit "ESC" key and select "Load Save".

vPB6M4B.png

STEP 5:  Now select your manually made save file and load it. NOT THE PERSISTENT.SFS FILE.

xi8bwna.png

STEP 6:  After the file re-loads you are DONE!! now were going to verify it worked!! Enter the Tracking station one last time for verification.

zq2XVgJ.png

EVERYTHING is perfect once again. theres the A-27 proper AP

EB60ub5.png

There is the correct PE. Now lets check a second satellite. Double checking doesnt hurt.

PDJM2Ss.png

Sure enough, AP is correct! One last photo.

Mptcpu9.png

And there ya go. PE is correct. FIX proven 100% WORKS!!!

Hope this helps all who need this knowledge.

 

So, I've found problem. Krankus mod was root cause. Kronkus has the same orbit as Sonnah from New Horizons. I'd removed Kronkus and after that orbits stayed where they were. I don't know exactly why it's happened, but anyway. May be you have an ideas? Of course if you have time to check it with this mods

Share this post


Link to post
Share on other sites
46 minutes ago, DuskFall said:

So, I've found problem. Krankus mod was root cause. Kronkus has the same orbit as Sonnah from New Horizons. I'd removed Kronkus and after that orbits stayed where they were. I don't know exactly why it's happened, but anyway. May be you have an ideas? Of course if you have time to check it with this mods

If Sonnah and Kronkus are in the same position, KSP would have some trouble determining what SOI your spacecraft is in, I think.

Share this post


Link to post
Share on other sites
32 minutes ago, AndrewDrawsPrettyPictures said:

If Sonnah and Kronkus are in the same position, KSP would have some trouble determining what SOI your spacecraft is in, I think.

Probably, but Kronkus is on the other side of the orbit. And also it doesn't explain why spacecrafts moved to the orbit of far planet.

Edited by DuskFall

Share this post


Link to post
Share on other sites
2 minutes ago, DuskFall said:

Probably, but Kronkus is on the other side of the orbit

Yeah I'm not 100% sure why that's happening to you. Glad you were able to find a solution.

Share this post


Link to post
Share on other sites
30 minutes ago, AndrewDrawsPrettyPictures said:

Yeah I'm not 100% sure why that's happening to you. Glad you were able to find a solution.

Anyway mod is great :)

38 minutes ago, AndrewDrawsPrettyPictures said:

Yeah I'm not 100% sure why that's happening to you. Glad you were able to find a solution.

By the way, have you ever tried this with Galileo? I tried, but can't make to work

Share this post


Link to post
Share on other sites
36 minutes ago, DuskFall said:

Anyway mod is great :)

By the way, have you ever tried this with Galileo? I tried, but can't make to work

I believe there is a separate config you can download for Galileo's planet pack that makes it work with other planet packs. I think it's called GPPSecondary or something like that. You can download it off of the GitHub page for Galileo's Planet Pack

Share this post


Link to post
Share on other sites
1 hour ago, AndrewDrawsPrettyPictures said:

I believe there is a separate config you can download for Galileo's planet pack that makes it work with other planet packs. I think it's called GPPSecondary or something like that. You can download it off of the GitHub page for Galileo's Planet Pack

Yeah, it works but with a little big problem for me. Without Extrasolar I have only Galileo planetary system. With extrasolar I have Kerbol plantary system and extrasolar and galileo systems far far from Kerbol. It seems to be a good one, but I never like to play constructor, I like career, and if I play career I'll never reach galileo system. That's why I think to play without extrasolar for now and use only galileo. But I try few career. 

Edited by DuskFall

Share this post


Link to post
Share on other sites
6 minutes ago, DuskFall said:

Yeah, it works but with a little big problem for me. Without Extrasolar I have only Galileo planetary system. With extrasolar I have Kerbol plantary system and extrasolar and galileo systems far far from Kerbol. It seems to be a good one, but I never like to play constructor, I like career, and if I play career I'll never reach galileo system. That's why I think to play without extrasolar for now and use only galileo. But I try few career. 

I'll test out how Galileo's planet pack works with Extrasolar and see if there are any holes I need to fill.

Share this post


Link to post
Share on other sites
6 minutes ago, AndrewDrawsPrettyPictures said:

I'll test out how Galileo's planet pack works with Extrasolar and see if there are any holes I need to fill.

You know, I've understand right now, that I like it. It's really close to real life. First of all I have to research home planetary system, after that reasearch extrasolar, and then reasearch galileo and otherworld systems. Oh yeah. It sounds really good. Elon Musk sucks :)

Share this post


Link to post
Share on other sites
16 minutes ago, DuskFall said:

For your understanding. How I see it

 

https://photos.app.goo.gl/dG8zyCXdM7IJx22F3

Ah interesting. So it puts Ciro in orbit around the Sun if you have GPPSecondary installed? Cool!

I think I still want to make Extrasolar compatible GPP for those who want to have their space program on Gael rather than Kerbin, if you get what I'm saying.

Share this post


Link to post
Share on other sites
19 hours ago, AndrewDrawsPrettyPictures said:

Ah interesting. So it puts Ciro in orbit around the Sun if you have GPPSecondary installed? Cool!

I think I still want to make Extrasolar compatible GPP for those who want to have their space program on Gael rather than Kerbin, if you get what I'm saying.

I have question not regarding your mod, but may be you know. I had mod that added 2 engins which are look like solar wind engins. It provided not much thrust but a lot of delta V. I don't remember which mod I used. May be you know which mod is it?

Share this post


Link to post
Share on other sites
1 hour ago, DuskFall said:

I have question not regarding your mod, but may be you know. I had mod that added 2 engins which are look like solar wind engins. It provided not much thrust but a lot of delta V. I don't remember which mod I used. May be you know which mod is it?

KSP Interstellar Extended has a solar sail mod, if that is what you are talking about.

Share this post


Link to post
Share on other sites
15 minutes ago, AndrewDrawsPrettyPictures said:

KSP Interstellar Extended has a solar sail mod, if that is what you are talking about.

Nope. Of course I have interstellar mod. There was another mod. It was real solar sail like engines 

Share this post


Link to post
Share on other sites
1 minute ago, DuskFall said:

Nope. Of course I have interstellar mod. There was another mod. It was real solar sail like engines 

Sorry I don't know what mod you are talking about. KSPIE is the only mod I can think of that has solar sails.

Share this post


Link to post
Share on other sites
1 hour ago, DuskFall said:

I have question not regarding your mod, but may be you know. I had mod that added 2 engins which are look like solar wind engins. It provided not much thrust but a lot of delta V. I don't remember which mod I used. May be you know which mod is it?

If you have the craft file and a KerbalX account, upload your file to KerbalX just long enough so you can read the part list and used mods list from there.

@AndrewDrawsPrettyPictures If your planet mod only adds Valentine and its worlds then no major effort on your part should be needed for GPP compatibility. Jet set Valentine to have perhaps 5 or 6 Tm for its SMA (or at least 4 Tm periapsis) for good clearance from Grannus, and invest in getting Extrasolar to load after GPP. Currently GPP purges any planet mod whose name starts alphabetically before itself.

Edited by JadeOfMaar

Share this post


Link to post
Share on other sites
21 minutes ago, JadeOfMaar said:

If you have the craft file and a KerbalX account, upload your file to KerbalX just long enough so you can read the part list and used mods list from there.

Unfortunately I haven't saved crafts with this engines. 

Edited by DuskFall

Share this post


Link to post
Share on other sites
2 minutes ago, JadeOfMaar said:

@DuskFall This?

 Nope. I've found it. Medusa nuclear engine from Project Orion

 

Edited by DuskFall

Share this post


Link to post
Share on other sites
1 hour ago, JadeOfMaar said:

 

@AndrewDrawsPrettyPictures If your planet mod only adds Valentine and its worlds then no major effort on your part should be needed for GPP compatibility. Jet set Valentine to have perhaps 5 or 6 Tm for its SMA (or at least 4 Tm periapsis) for good clearance from Grannus, and invest in getting Extrasolar to load after GPP. Currently GPP purges any planet mod whose name starts alphabetically before itself.

But it appears as though GPPSecondary puts Ciro in orbit around the Sun is that right? What if someone wanted Valentine in orbit around Ciro and have no stock solar system whatsoever? From what Galileo told me, GPPSecondary is required in order for an other planet pack to properly work with GPP, is that right?

Share this post


Link to post
Share on other sites

@AndrewDrawsPrettyPictures Yep. GPP_Secondary does that indeed. It makes GPP into an end-game destination instead of the home system, and the huge distance is to ensure hat it doesn't clash with any of the many small star system mods out there or any of the Kerbal Star Systems™. What Galileo said is also correct. GPP_Secondary does its job best in enabling GPP to coexist with planet and star mods that also replace Kerbin and the stock planets.

Share this post


Link to post
Share on other sites
On 8/16/2017 at 4:16 PM, joolsjewls said:

I have been chasing down a weird issue that seems to be with the Heba/Lomina configurations using Kerbal 1.3.0. When they are in the Exosolar folder, the science archives are broken and no previous experiments can be seen. This also breaks CactEye Community contracts as the contract fails to see the science be received. (that is where I started investigating.... Edit: turned out to be unrelated; but now I fixed that too)

Removing Heba/Lomina resolves the entire issue. When they are in, science archives are decidedly broken, even the graphics at the top do not load and Valentine is the only non-stock object that appears.

I do normally use CKAN, but, once I verified what fixed the issue, I copied my save into a pristine dir and installed both kopernicus and exosolar by hand. Same issue.

I wasn't sure if "use release 2" meant "do not use older than 2" or "do not update to 3 or beyond until further notice", so I tested with Kopernicus-1.3.0-2.zip AND 1.3.0-3.zip AND 1.3.0-4.zip; same issue on all three.

I took a look at the configurations but, I can't seem to find the documentation I need to make sense of Kopernicus configs to my liking. I noticed similar issues when I did a quick test with some of the Kopernicus example files as well. In fact, the only Kopernicus example I got to load without this error was the star "Nemesis".

Anyway, Dirty workaround: Delete Heba and Lomnia directories. I would be happy to take another crack at fixing the config myself but, nothing stands out to me other than they are the only two that are not declaring a template.

(edit: s/Lomia/Lomina/g)

ADD to the .cfg of both planets :

 

Quote

Template
        {
            name = Jool
            
        }

 

and it will resolve the issue .

Share this post


Link to post
Share on other sites
36 minutes ago, nismobg said:

ADD to the .cfg of both planets :

 

 

and it will resolve the issue .

That has been long resolved...

Share this post


Link to post
Share on other sites
2 hours ago, AndrewDrawsPrettyPictures said:

That has been long resolved...

Well I just noticed it so I was looking around and found that it's still missing in the 1.4-Core  of the mod.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.