Jump to content

[WIP] Coatl Aerospace ProbesPlus Dev Thread [Beta] 10/19/2020 (1.8-1.10)


akron
 Share

Recommended Posts

17 hours ago, wulf899 said:

I wish I could, however for some reason or other I can't find any - I checked all the spots where the websites say they should be, but they aren't there - probably because the 'missing' part doesn't actually cause KSP to poop itself. Is there a way to forcibly create a log?

You must have a newer version of KSP. The log has been moved. If you use a Windows OS, go here:

C:\Users\<username>\AppData\LocalLow\Squad\Kerbal Space Program\

P.S. AppData is a hidden system folder, you will have to unhide it if you want to navigate to it using Windows Explorer

Edited by akron
Link to comment
Share on other sites

2 hours ago, akron said:

P.S. AppData is a hidden system folder, you will have to unhide it if you want to navigate to it using Windows Explorer

Ah, so THAT'S why I couldn't find the Appdata folder haha, Thanks for that :)

 

I've booted up KSP and Shut it down just now, so that it may be easier for you to navigate (Does the log include what the user did in-game? I don't know, so I assume it does).

 

DropBox link to the file is here. Hope you find the issue! I'd love to send a few Draco probes to the Jool system.

Link to comment
Share on other sites

Tried installing this mod in 1.3.1, but ran into some problems. I finally found out that the problem was the wrong version in the plugin dependencies. 

SO OR EVERYONE THAT WANTS THIS MOD IN 1.3.1:

These are the download links for the working plugin versions:

-Replace the Firespitter folder with the "Plugins" folder of the following download: https://github.com/snjo/Firespitter/releases/tag/v7.6.0

-Replace the DMagicScienceAnimate folder with the following download: https://github.com/DMagic1/DMModuleScienceAnimateGeneric/releases/tag/v0.19

Hope this helps other people that had the same problems as me. 

Edited by LarsB
Link to comment
Share on other sites

Hello my friend!

And also THANX to YOU for these very nice probe cores, science parts and the whole stuff! I really enjoyed buiding Voyager and Juno and let them fly out in my 1.4.3 OPM!!! ;)

So, but now i want to go a step further and for this reason i installed me a 1.2.2 Version with RealSolSystem and RealismOverhaul. Next step ist the RP-0 so i can play an carrer ;)

For my RSS i really, really wanted your Probes so that they can fly in the right sytem... And the installation looks good. All seems to be fine. But what i really miss a few parts like these beutiful Juno-Solar-Panels with integrated Magnetometer...

Is there any chance for me, maybe to get only the parts from v.16 to the v.15 for KSP1.2.2??? I'm pretty sure you won't maintain for such an old Version..

I really appreciate your work! Thanks!

Interstate

 

Link to comment
Share on other sites

On 8/10/2018 at 6:26 AM, LarsB said:

Hope this helps other people that had the same problems as me. 

Thank you for  sharing this. Having the correct dependencies will fix the majority of compatibility problems in the mod since I do not use more complex settings or custom code -yet-.

3 hours ago, Interstate said:

Is there any chance for me, maybe to get only the parts from v.16 to the v.15 for KSP1.2.2??? I'm pretty sure you won't maintain for such an old Version..

I don't think you will have any issues is you want to add the solar panels to your 1.2.2 install as the solar panel config has not changed. The only major config change that I remember is for the RCS which, at one point, needed each part's node be re-oriented. If you move parts with RCS from a new install to an old one there *may* be some problems. This is not the case with those solar panels. Let me know if it works!

I think all you will needs is:

GameData\Coatl Aerospace\ProbesPlus\Parts\Electrical:

sp_juno.cfg, sp_juno_mag.cfg

GameData\Coatl Aerospace\ProbesPlus\Assets\Electrical:

sp_hera_panel.mu, sp_hera_mag.mu, electrical_a_D.dds, mat_fsilver_NA.dds

GameData\Coatl Aerospace\ProbesPlus\Compatibility:

DMagicContracts.cfg (If you use DMagic's mods)

It might get more complex if you use TexturesUnlimited

Link to comment
Share on other sites

  • 2 weeks later...

Hey there :)

I just tried it out yesterday evening (but only in launch pad cause my life wouldn't give me much time for this right now)

The solar panels from juno seem to work in RSS/RO 1.2.2. The EC output is right transfered to watts. Also the panels with included reaction weels work. (this I tried also in space for short)

But it labels me all the parts from probes+ as "non-ro" or ,non rp-0" but I think this will be ok, isn't it?

Thanks for your support and the nice parts! ;)

Link to comment
Share on other sites

8 hours ago, Interstate said:

Hey there :)

I just tried it out yesterday evening (but only in launch pad cause my life wouldn't give me much time for this right now)

The solar panels from juno seem to work in RSS/RO 1.2.2. The EC output is right transfered to watts. Also the panels with included reaction weels work. (this I tried also in space for short)

But it labels me all the parts from probes+ as "non-ro" or ,non rp-0" but I think this will be ok, isn't it?

Thanks for your support and the nice parts! ;)

Thank you for testing it out. I honestly do not know a whole lot about the RO mod and its configs. I do know that they maintain their own ModuleManager settings for my parts, but there's a chance that not all of them have received their own configs yet. This may be why they say "non ro" but I am not sure. An easy way, I think, is to look at the part manufacturer in the VAB. If it says the manufacturer is "Coatl Aerospace" then the RO configs are not loading correctly or are not done for that part yet 

Link to comment
Share on other sites

I'm not sure which science experiment is responsible, but something that I unlocked with Advanced Exploration broke KEI which is a mod that automatically collects all the science at the KSC for you and is maintained by Linuxgurugamer.

I'm not sure which experiment broke it. I tried deleting the DustX cfg and mu file but the KEI button was still broken.

When I uninstalled the entirety of Probes Plus the KEI toolbar button functioned again. It worked earlier in my career with your mod, and when i restored an old save game it worked with your mod, but after unlocking Advanced Exploration with your mod installed.... the KEI button stopped opening it's menu...

I thought it might be the second dust experiment because they run experiments with different names but they seem to both collect the same science...i.e. if you put both dust experiments on a vessel and collect science with one, and then run the other... the second one gives you no science....so they both collect the science from the same pool.

I suppose it could be one of your many science cameras or booms. Advanced Exploration unlocks quite a few things added with your mod....

Link to comment
Share on other sites

6 hours ago, JoE Smash said:

I'm not sure which science experiment is responsible, but something that I unlocked with Advanced Exploration broke KEI which is a mod that automatically collects all the science at the KSC for you and is maintained by Linuxgurugamer.

I'm not sure which experiment broke it. I tried deleting the DustX cfg and mu file but the KEI button was still broken.

When I uninstalled the entirety of Probes Plus the KEI toolbar button functioned again. It worked earlier in my career with your mod, and when i restored an old save game it worked with your mod, but after unlocking Advanced Exploration with your mod installed.... the KEI button stopped opening it's menu...

I thought it might be the second dust experiment because they run experiments with different names but they seem to both collect the same science...i.e. if you put both dust experiments on a vessel and collect science with one, and then run the other... the second one gives you no science....so they both collect the science from the same pool.

I suppose it could be one of your many science cameras or booms. Advanced Exploration unlocks quite a few things added with your mod....

DustC is a collector only for which you must return the samples to get any science. DustX can actually do science in-flight, but still not 100% return. They are the same experiment but with different in-flight science return levels. I would let LGG know about this on his thread.

I do have some development news! Argo Mk2 is mostly in-game! I tried to finish it enough to make it playable but ran into some weird issues plus I was a bit rusty on the configs. I should have a Github update out this weekend. Many thanks to @CobaltWolf for helping fix the normal map weirdness

c1Eq8KJ.png

tmhDRvU.png

Link to comment
Share on other sites

25 minutes ago, akron said:

DustC is a collector only for which you must return the samples to get any science. DustX can actually do science in-flight, but still not 100% return. They are the same experiment but with different in-flight science return levels. I would let LGG know about this on his thread.

I do have some development news! Argo Mk2 is mostly in-game! I tried to finish it enough to make it playable but ran into some weird issues plus I was a bit rusty on the configs. I should have a Github update out this weekend. Many thanks to @CobaltWolf for helping fix the normal map weirdness

c1Eq8KJ.png

tmhDRvU.png

Well I'm not positive the dust experiment broke KEI, but it was my guess....

It could have been any experiment I unlocked with Advanced Exploration from your mod....which includes several different parts...some science booms and cameras etc....

I was having a conversation with him at one point, but he hasn't replied to me in a couple days....

Anyhoo short term I uninstalled Probes Plus, collected what I could with KEI then installed your mod again...

 

Link to comment
Share on other sites

5 hours ago, akron said:

I do have some development news! Argo Mk2 is mostly in-game! I tried to finish it enough to make it playable but ran into some weird issues plus I was a bit rusty on the configs.

I'm not too sure this could ever be modeled in the game, but is the Argo satellite able to utilise solar/kerbolar winds as a slight method of propulsion/orientation? I heard recently that Mariner 4 used the foldable "paddles" at the ends of the solar panels to orient/slightly propel itself. If Argo Mk2 was able to do that, it'd be siiiiick.

Link to comment
Share on other sites

6 hours ago, wulf899 said:

I'm not too sure this could ever be modeled in the game, but is the Argo satellite able to utilise solar/kerbolar winds as a slight method of propulsion/orientation? I heard recently that Mariner 4 used the foldable "paddles" at the ends of the solar panels to orient/slightly propel itself. If Argo Mk2 was able to do that, it'd be siiiiick.

There is a solar sail mod from @FreeThinker not sure of its capabilities wth regard to this tho

Link to comment
Share on other sites

7 hours ago, wulf899 said:

I'm not too sure this could ever be modeled in the game, but is the Argo satellite able to utilise solar/kerbolar winds as a slight method of propulsion/orientation? I heard recently that Mariner 4 used the foldable "paddles" at the ends of the solar panels to orient/slightly propel itself. If Argo Mk2 was able to do that, it'd be siiiiick.

38 minutes ago, Drew Kerman said:

There is a solar sail mod from @FreeThinker not sure of its capabilities wth regard to this tho

As far as I know the solar vanes on Mariner were more for stability rather than actual attitude control, as it had RCS nozzles on the edge of each solar panel for that. What I did so far, was to give each solar panel a very weak reaction wheel with no EC use to simulate the "sails". I'll look into that mod, Drew, thank you for letting know. Might be able to eventually add support for it.

 

Link to comment
Share on other sites

First push of Mariner 4 parts should be up on Github now. This is very early BETA for those brave souls who don't mind some broken stuff. Also, here's an early look at Argo Mk3 parts for a Mariner 5 build:

QOpw9Us.png

ePm2Qcb.png

Edited by akron
Link to comment
Share on other sites

Ended up finding a lot of issues with Argo Mk2 and got them fixed. Some of them should have been pushed to Github, but I lost track of which. Argo Mk3 is in game and working alright. Still doing some balancing, but it should be up on Git sometime soon. One of the new experiments, the Geiger counter/radiation-ionization detector is partially done. I'm about 1/3 done with ScienceDefs. Still debating if I should add a stand-alone version of the experiment based on Mariner 5's payload. I still have plenty of room in the texture sheet but I kinda want to move on to the last Mariner parts to finish the lead up to Viking. The  other new experiment, a low-res camera still needs to be done. Any suggestions on the Mariner line are welcome. The current plan is to just do a Mariner 6-7 part set and then Mariner 8-9 parts. Mariner 10 can come in a later update

dEVw4FM.png

o3o7xWl.png

Link to comment
Share on other sites

I notice a small "problem" with Beta 0.16.1 in 1.3.1. If I install the latest version of this mod I can't seem to be able to swap the textures of the parts that allow it. Yet if I install Beta 0.15 I can swap the textures.

I have this problem whether or not I am using the dependencies that are compiled for 1.3.1 or their latests update.

Link to comment
Share on other sites

8 minutes ago, Pointblank66 said:

I notice a small "problem" with Beta 0.16.1 in 1.3.1. If I install the latest version of this mod I can't seem to be able to swap the textures of the parts that allow it. Yet if I install Beta 0.15 I can swap the textures.

I have this problem whether or not I am using the dependencies that are compiled for 1.3.1 or their latests update.

You definitely have to use the 1.3.1 dependencies and not the latest. Do you use Textures Unlimited? If so, that's the cause. TU changed it syntax, so my configs only work with newer versions

Link to comment
Share on other sites

2 minutes ago, Pointblank66 said:

Yes I am using TU in conjunction with SSTU, iirc it is one of the dependencies of SSTU.

Ok, TU takes over texture switching from Firespitter if installed. That's the cause, since the config syntax changed in TU at some point ago. I can only write configs for one version or the other, so I preferred to support the latest. I can provide you a test patch I have, or you can simply delete the TU configs which lets Firespitter take over again; but you'll lose the PBR shading on my parts.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...