akron

[WIP] Coatl Aerospace ProbesPlus Dev Thread [Beta] 3/17/2020 (1.8-1.9)

Recommended Posts

Yup, anything using Firespitter is broken until it gets resolved. Which is most of the mods I use...

 

Firespitter has updated, however the antenna parts don't seem to be working, or at least their info isn't showing up in the VAB Only thing that shows up is the additional modules like mesh switch or solar panels. 

 

https://imgur.com/undefinedvOSCVw6.png

Edited by oniontrain

Share this post


Link to post
Share on other sites

Update, this appears to be a problem with all modded antennas, not just the Coatl ones. I can't see anything that might be causing it either, as some of them work but most of them can't transmit data. model switch works, solar panels, and other modules work, but data transmitter seems to be broken.

 

EDIT: this has something to do with module manager replacing the ModuleDataTransmitter with ModuleRTAntenna

Edit edit: deleting the RT compatibility patch fixed the issue. Not sure what caused it in the first place though.

Modlist;

 

              "SCANsat"
              "surfacelights"
              "TarsierSpaceTechnologyWithGalaxies"
              "KAS"
              "ToolbarController"
              "DMagicScienceAnimate"
              "EVAEnhancementsContinued"
              "BluedogDB"
              "AviationLights"
              "ClickThroughBlocker"
              "ContractConfigurator"
              "Toolbar"
              "KIS"
              "DeployableEngines"
              "CryoTanks-Core"
              "CryoTanks"
              "NearFutureProps"
              "DynamicBatteryStorage"
              "CommunityResourcePack"
              "B9PartSwitch"
              "KerbalAtomics"
              "CryoEngines"
              "StationPartsExpansionRedux"
              "CommunityTechTree"
              "NearFutureSpacecraft"
              "NearFutureSolar-Core"
              "NearFutureSolar"
              "NearFuturePropulsion-XenonHETs"
              "NearFuturePropulsion"
              "NearFutureLaunchVehicles"
              "NearFutureElectrical-Core"
              "NearFutureElectrical"
              "NearFutureConstruction"
              "Scatterer-config"
              "Scatterer"
              "CustomBarnKit"
              "Scatterer-sunflare"
              "DMagicOrbitalScience"
              "ModuleManager"
              "TexturesUnlimited"
              "TextureReplacer"
              "PoodsCalmNebulaSkybox"
              "DistantObject-default"
              "DistantObject"
              "EnvironmentalVisualEnhancements-HR"
              "EnvironmentalVisualEnhancements"
              "ContractConfigurator-KerbinSpaceStation"
              "CommunityCategoryKit"
              "MechJeb2"
              "Konstruction"
              "MalemuteRover"
              "USI-ART"
              "USI-Core"
              "USI-EXP"
              "USI-FTT"
              "USI-LS"
              "USITools"
              "FirespitterCore"
              "ProbesPlus"
              "ResearchBodies"
              "REPOSoftTech-Agencies"
              "KerbalAlarmClock"
              "TriggerAu-Flags"

Edited by oniontrain

Share this post


Link to post
Share on other sites
On 10/31/2019 at 7:20 PM, oniontrain said:

EDIT: this has something to do with module manager replacing the ModuleDataTransmitter with ModuleRTAntenna

Edit edit: deleting the RT compatibility patch fixed the issue. Not sure what caused it in the first place though.

Maybe the RT compatibility patch uses :FOR instead of :NEEDS

Share this post


Link to post
Share on other sites
23 hours ago, Marcelo Silveira said:

Maybe the RT compatibility patch uses :FOR instead of :NEEDS

I haven't seen this as an issue before. Time to re-test everything again in 1.8

Share this post


Link to post
Share on other sites

Hello all.

Apologies for the lack of updates. I have unfortunately not been able to dedicate time to KSP in well over a month. My already limited time got further taken away now that I am a single parent, so I've pretty much had to put things on further hold. I am still working on trying to clear out some time weekly to get back to KSP work because it's one of my passions (and I miss it!)

In the meantime, do continue to post about any issues, suggestions, feedback, smart remarks, or kind words of encouragement. I will still try to be active in responding here, especially now that I can again reply while away from home.

Share this post


Link to post
Share on other sites

anyone has phantom force that you cannot recover spacecraft stationary on launchpad? I put the Quetzal(the first probe core u got in probeplus)  into service bay and it causes phantom force(you can recover if you remove the core). I have worldstablilizer installed too so dunno it's related

ksp 1.8.1

2019-11-19_21-25-43_Trim.gif

Edited by ssd21345

Share this post


Link to post
Share on other sites

Take a look at the config file to see if the part mass is zero.  That can cause odd issues.  Also, check the ModuleManager.ConfigCache file for the same part.  Always possible that an odd patch could do that

Share this post


Link to post
Share on other sites
16 minutes ago, linuxgurugamer said:

Take a look at the config file to see if the part mass is zero.  That can cause odd issues.  Also, check the ModuleManager.ConfigCache file for the same part.  Always possible that an odd patch could do that

uninstall worldstablilizer fixes it

still has phantom force but small enough to recover spacecraft

Edited by ssd21345

Share this post


Link to post
Share on other sites

That is odd. 

Are you on 1.8.1, and if so, is WorldStabilizer also updated  for 1.8.1?

Share this post


Link to post
Share on other sites
3 minutes ago, linuxgurugamer said:

That is odd. 

Are you on 1.8.1, and if so, is WorldStabilizer also updated  for 1.8.1?

last replies on the thread said it updated to 1.8

Edit:just checked decoupler, service bay and probe core. All has mass in the cache

Edited by ssd21345

Share this post


Link to post
Share on other sites

As I'm not a Blender user; can anybody tell me how to fix the

Cannot find fx group of that name for decoupler

log spamming and game lagging, which is induced by https://github.com/raveloda/Coatl-Aerospace/pull/81

and the fact that

explosiveNodeID = bottom

is not correct?

I need to know the name/ID of that attach node.

Share this post


Link to post
Share on other sites

@Gordon Dry Thank you for your testing and tweaks. I merged all pulls in Git except for the engine decoupler. Will look at having a separate decoupler part instead

Share this post


Link to post
Share on other sites

@akron I suggest you use the mesh that was the top node shroud of the retro engine. After removing the decoupler module from that engine this mesh is obsolete there.

Share this post


Link to post
Share on other sites

happy new year Akron. I hope things take their place for you.

Share this post


Link to post
Share on other sites
46 minutes ago, Vince_K said:

happy new year Akron. I hope things take their place for you.

Thank you! I sure hope so.

Happy new year to you as well

Share this post


Link to post
Share on other sites
Posted (edited)

Mod Update

Happy new year, folks!

If you have been keeping up with recent news, you have heard me report that I unfortunately am not able to work on the mod frequently. I am continuing to push towards getting the time and motivation, but so far I take whatever progress I can get.

At the suggestion of a couple of mod makers (mostly @CobaltWolf if I'm being honest) I have started to try and convert the art style of ProbesPlus! parts to something more neutral.

To practice I started working on a new Commsat bus based on the SSL-1300 and a few accompanying parts. I was able to finish the bus and got it in-game, which is now the first new part of the new year! 

The current plan is to finish the SSL-1300, or "Barça" as it is called in-game, while using the learned techniques from it for Viking. This could change, but after Viking, Barça, and a couple of rover parts I really want to make, the mod might be considered "Complete". I will still revamp old parts, but I don't think I can take on any new ones. With KSP2 on the horizon and no KSP1 Career/Science overhaul planned I am not sure it's a great idea to take on anything else. Again, this could change but it seems better to play it safe.

Anywho, this is now the largest bus in the mod, Barquetta's older sibling:

yVdRT8f.png Xf0jaWA.png SwxRM1l.png ZiXi53t.png

Some parts are from the amazing Restock and Near Future Solar mods

 

Coming to Github soon, I do have to tweak a fix some things to make sure that the mod works properly in 1.8.1

 

~Cheers

Edited by akron

Share this post


Link to post
Share on other sites
On 1/2/2020 at 8:45 PM, akron said:

Mod Update

Happy new year, folks!

If you have been keeping up with recent news, you have heard me report that I unfortunately am not able to work on the mod frequently. I am continuing to push towards getting the time and motivation, but so far I take whatever progress I can get.

At the suggestion of a couple of mod makers (mostly @CobaltWolf if I'm being honest) I have started to try and convert the art style of ProbesPlus! parts to something more neutral.

To practice I started working on a new Commsat bus based on the SSL-1300 and a few accompanying parts. I was able to finish the bus and got it in-game, which is now the first new part of the new year! 

The current plan is to finish the SSL-1300, or "Barça" as it is called in-game, while using the learned techniques from it for Viking. This could change, but after Viking, Barça, and a couple of rover parts I really want to make, the mod might be considered "Complete". I will still revamp old parts, but I don't think I can take on any new ones. With KSP2 on the horizon and no KSP1 Career/Science overhaul planned I am not sure it's a great idea to take on anything else. Again, this could change but it seems better to play it safe.

Anywho, this is now the largest bus in the mod, Barquetta's older sibling:

yVdRT8f.png Xf0jaWA.png SwxRM1l.png ZiXi53t.png

Some parts are from the amazing Restock and Near Future Solar mods

 

Coming to Github soon, I do have to tweak a fix some things to make sure that the mod works properly in 1.8.1

 

~Cheers

Looks good

Share this post


Link to post
Share on other sites
On 1/3/2020 at 3:45 PM, akron said:

Coming to Github soon, I do have to tweak a fix some things to make sure that the mod works properly in 1.8.1

Really glad to see this getting worked on still, one of the most missed mods in my fresh 1.8.1 install! :D

Share this post


Link to post
Share on other sites

Good to see this mod is still going! Any chance that the version(s) on CKAN can be updated as well when the new version comes out? CKAN currently lists 16.1 as compatible with KSP 1.4.3 when I've used it extensively in KSP 1.7.3 with no problems, and it forms an important part of a career game I have going.

That new probe core looks pretty big when compared to the other parts (antennas etc) in those images, and absolutely HUGE compared to Barquetta!

Just floating a suggestion- any chance you can make a really really small cube-sat type probe, roughly the size of the cubic octagonal strut? There don't seem to be very many cube-sats in KSP and they would be ideal for sticking onto larger vessels then detaching at a destination to use as extra relays.

Share this post


Link to post
Share on other sites
8 hours ago, jimmymcgoochie said:

Good to see this mod is still going! Any chance that the version(s) on CKAN can be updated as well when the new version comes out? CKAN currently lists 16.1 as compatible with KSP 1.4.3 when I've used it extensively in KSP 1.7.3 with no problems, and it forms an important part of a career game I have going.

That new probe core looks pretty big when compared to the other parts (antennas etc) in those images, and absolutely HUGE compared to Barquetta!

Just floating a suggestion- any chance you can make a really really small cube-sat type probe, roughly the size of the cubic octagonal strut? There don't seem to be very many cube-sats in KSP and they would be ideal for sticking onto larger vessels then detaching at a destination to use as extra relays.

Thank you. I do not actively update CKAN but whenever a full new release version of the mod is available, I am sure CKAN will update. For now I am just uploading changes to Github.

I have thought about cubesat-type probes but there's just no real purpose for them in KSP at the moment. Their small size also brings the challenge of perhaps not being able to attach surface-mounted parts to them. The compromise would be to unrealistically enlarge them a bit for gameplay reasons. If I ever do any, I would probably go that route so they are easier to deal with in the VAB. That being said, the lack of real functionality in-game as of right now means I am not likely to make any soon unless you guys want to make a case for them. I would like to make a version of the Mars MarCO probes but those were larger cubesats

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.