akron

[WIP] Coatl Aerospace ProbesPlus Dev Thread [v0.16.1 Beta] 6/27/2018 (1.4.4)

Recommended Posts

Question: everytime i load the game with this mod installs it crashes, i have both dependencies up to date and it still crashes, any help?

Share this post


Link to post
Share on other sites
13 hours ago, tmccreight651 said:

Question: everytime i load the game with this mod installs it crashes, i have both dependencies up to date and it still crashes, any help?

Can I get some more info? Are you using KSP 1.3? Did you by chance leave both versions of the dependencies installed? Maybe even the log file so we can see what KSP is trying to do

Share this post


Link to post
Share on other sites
8 hours ago, akron said:

Can I get some more info? Are you using KSP 1.3? Did you by chance leave both versions of the dependencies installed? Maybe even the log file so we can see what KSP is trying to do

Yes im using 1.3, i have both dependencies up to date and im going to sound like a total noob for saying this but i don't know how to post logs... 

Edit: It seems to crash when it loads the batteries

Edited by tmccreight651

Share this post


Link to post
Share on other sites

Are you using 64bit or 32bit I had crashing issues before i realised  I was using the 32bit executable a quick change and problem solved

Edited by Virtualgenius

Share this post


Link to post
Share on other sites
15 hours ago, akron said:

@tmccreight651 Sorry, I did not see your edit. Are you using 64 or 32 bit like @Virtualgenius mentioned?

i use steam and in my ksp folder there is an application called KSP_x64 so im pretty sure i use the 64bit version

Share this post


Link to post
Share on other sites
1 hour ago, tmccreight651 said:

i use steam and in my ksp folder there is an application called KSP_x64 so im pretty sure i use the 64bit version

Would you kindly run that EXE manually instead of going through Steam? I am not sure that Steam uses the 64-bit version by default. This is how I run my game and I do not have issues with 32-64 bit mismatch

Share this post


Link to post
Share on other sites
12 minutes ago, akron said:

Would you kindly run that EXE manually instead of going through Steam? I am not sure that Steam uses the 64-bit version by default. This is how I run my game and I do not have issues with 32-64 bit mismatch

Nope, still crashes when i run KSP_x64

Share this post


Link to post
Share on other sites

@akron I just encountered a bug with the site survey camera. When a scientist on EVA tries to restore the camera through its PAW, there's an error shown saying a scientist is needed to reset it.

Spoiler
Spoiler

 

 

After a bit of digging checking configs I eventually looked at the code for DMModuleScienceAnimateGeneric and the test for a scientist was inverted. I've put a pull request on @DMagic's GitHub that should fix it.

Share this post


Link to post
Share on other sites
30 minutes ago, Aelfhe1m said:

@akron I just encountered a bug with the site survey camera. When a scientist on EVA tries to restore the camera through its PAW, there's an error shown saying a scientist is needed to reset it.

  Reveal hidden contents
  Reveal hidden contents

 

 

After a bit of digging checking configs I eventually looked at the code for DMModuleScienceAnimateGeneric and the test for a scientist was inverted. I've put a pull request on @DMagic's GitHub that should fix it.

Fixed; on GitHub now.

Share this post


Link to post
Share on other sites

hey guys, so ive asked about my problems with this mod, those being that the game crashes when i try to load it with this mod installed, so i finally figured out how to share the game logs, so here are my logs. all help appreciated

Edited by tmccreight651

Share this post


Link to post
Share on other sites

Hmm I don't seem to be able to post a screenshot of the 1.3 Steam crash, but here are what seem to be the relevant logs.

All worked before copying in the Coatl Aerospace, DMagicScienceAnimate, and Firespitter folders.

Unity Player [version: Unity 5.4.0p4_b15b5ae035b7]

mono.dll caused an Access Violation (0xc0000005)
  in module mono.dll at 0033:a6320e18.

Error occurred at 2017-06-19_190906.
C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\KSP_x64.exe, run by vossie.
84% memory in use.
8066 MB physical memory [1270 MB free].
18273 MB paging file [2727 MB free].
134217728 MB user address space [134215434 MB free].
Read from location 00000000 caused an access violation.
************************************************************************

Environment Info
Win32NT 7FFFFFFFFFFFFFFF  Args: KSP_x64.exe 

Mod DLLs found:
Stock assembly: Assembly-CSharp v0.0.0.0
ModuleManager.2.7.5 v2.7.5.0
DMModuleScienceAnimateGeneric v0.16.0.0
Firespitter v7.3.6212.36331
KAS v0.6.3.0 / v0.6.3 for KSP 1.3
MiniAVC v1.0.3.1
KIS v1.5.0.0 / v1.5.0 for KSP 1.3
KSPDev_Utils.0.23.0 v0.23.0.0 / v0.23.0 for KSP v1.2
MiniAVC v1.0.3.0
PlanetarySurfaceStructures v1.4.4.0
Stock assembly: KSPSteamCtrlr v0.0.1.35
Stock assembly: Steamworks.NET v9.0.0.0 / v9.0.0
MiniAVC v1.0.3.2
MiniAVC v1.0.3.2

Folders and files in GameData:
Coatl Aerospace
CommunityResourcePack
DMagicScienceAnimate
Firespitter
FuelTanksPlus
KAS
KIS
OPT
PlanetaryBaseInc
Stock folder: Squad

StationPartsExpansion
UniversalStorage
ModuleManager Licence.txt
ModuleManager.2.7.5.dll
Universal Storage.pdf

************************************************************************
CodeAssetLoader: Compiling all code assets
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

GameDatabase: Assets loaded in 59.945s
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

PartLoader: Version strings do not match. Creating part database.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

PartLoader: Compiling Part 'Coatl Aerospace/GroundOps/Parts/Landvermesser/landv_battery/ca_landv_battery'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

EffectList: Created 14 effect types
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

PartLoader: Part 'Coatl Aerospace/GroundOps/Parts/Landvermesser/landv_battery/ca_landv_battery' has no database record. Creating.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

DragCubeSystem: Creating drag cubes for part 'ca.landv.battery'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

PartLoader: Compiling Part 'Coatl Aerospace/GroundOps/Parts/Landvermesser/landv_cam_s1/ca_landv_cam_s1'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Crash!!!
========== OUTPUTING STACK TRACE ==================

0x00007FFBA6320E18 (mono) mono_reflection_type_from_name
0x00007FFBA6321723 (mono) mono_custom_attrs_construct
0x00007FFBA632538A (mono) mono_reflection_get_custom_attrs_by_type
0x00007FFBA62D3ECA (mono) mono_domain_finalize
0x0000000004CF2EA1 (Mono JIT Code) (wrapper managed-to-native) System.MonoCustomAttrs:GetCustomAttributesInternal (System.Reflection.ICustomAttributeProvider,System.Type,bool)
0x0000000004CF2D51 (Mono JIT Code) System.MonoCustomAttrs:GetCustomAttributesBase (System.Reflection.ICustomAttributeProvider,System.Type)
0x0000000004CF2411 (Mono JIT Code) System.MonoCustomAttrs:GetCustomAttributes (System.Reflection.ICustomAttributeProvider,System.Type,bool)
0x000000002742D8BE (Mono JIT Code) System.Reflection.MonoMethod:GetCustomAttributes (System.Type,bool)
0x000000002742D63D (Mono JIT Code) BaseEventList/ReflectedData:.ctor (System.Type)
0x000000002742D453 (Mono JIT Code) BaseEventList:GetReflectedAttributes (System.Type)
0x000000002742D0EA (Mono JIT Code) BaseEventList:CreateDelegates (object)
0x000000002742CFCD (Mono JIT Code) BaseEventList:.ctor (Part,PartModule)
0x0000000000E495ED (Mono JIT Code) PartModule:ModularSetup ()
0x0000000000E49162 (Mono JIT Code) PartModule:Awake ()
0x0000000004C7725B (Mono JIT Code) (wrapper runtime-invoke) object:runtime_invoke_void__this__ (object,intptr,intptr,intptr)
0x00007FFBA63B4FFB (mono) mono_set_defaults
0x00007FFBA6308341 (mono) mono_runtime_invoke
0x00007FF675F6517D (KSP_x64) ScriptingArguments::AddString
0x00007FF675F65481 (KSP_x64) ScriptingArguments::AddString
0x00007FF675EB9AE1 (KSP_x64) IClusterRenderer::IClusterRenderer
0x00007FF675EBC7D8 (KSP_x64) IClusterRenderer::IClusterRenderer
0x00007FF675EBCB97 (KSP_x64) IClusterRenderer::IClusterRenderer
0x00007FF675F18CCB (KSP_x64) DestroyObjectHighLevel
0x00007FF675F18F15 (KSP_x64) DestroyObjectHighLevel
0x00007FF675E250CD (KSP_x64) CollisionMeshData::~CollisionMeshData
0x00007FF676045FAA (KSP_x64) Mesh::GetRuntimeMemorySize
0x0000000004CF1F6B (Mono JIT Code) (wrapper managed-to-native) UnityEngine.GameObject:Internal_AddComponentWithType (System.Type)
0x0000000004CF1EB5 (Mono JIT Code) UnityEngine.GameObject:AddComponent (System.Type)
0x0000000000E48B89 (Mono JIT Code) Part:AddModule (string,bool)
0x0000000000E48A36 (Mono JIT Code) Part:AddModule (ConfigNode,bool)
0x000000002742965B (Mono JIT Code) PartLoader:ParsePart (UrlDir/UrlConfig,ConfigNode)
0x0000000027426CEB (Mono JIT Code) PartLoader/<CompileParts>c__Iterator66:MoveNext ()
0x0000000004D2BC29 (Mono JIT Code) UnityEngine.SetupCoroutine:InvokeMoveNext (System.Collections.IEnumerator,intptr)
0x0000000004D2BD41 (Mono JIT Code) (wrapper runtime-invoke) <Module>:runtime_invoke_void_object_intptr (object,intptr,intptr,intptr)
0x00007FFBA63B4FFB (mono) mono_set_defaults
0x00007FFBA6308341 (mono) mono_runtime_invoke
0x00007FF675F6517D (KSP_x64) ScriptingArguments::AddString
0x00007FF675EB6FCA (KSP_x64) mono_array_length_safe_wrapper
0x00007FF675EB7258 (KSP_x64) mono_array_length_safe_wrapper
0x00007FF675EB72B5 (KSP_x64) mono_array_length_safe_wrapper
0x00007FF675EB72B5 (KSP_x64) mono_array_length_safe_wrapper
0x00007FF675EB72B5 (KSP_x64) mono_array_length_safe_wrapper
0x00007FF675D7F199 (KSP_x64) Behaviour::InitializeClass
0x00007FF675F3673B (KSP_x64) CallbackArray1<bool>::Invoke
0x00007FF675FF3050 (KSP_x64) Object::GetInstanceID
0x00007FF675FF384A (KSP_x64) PlayerMainWndProc
0x00007FF675FF6BEE (KSP_x64) PlayerWinMain
0x00007FF6764AC344 (KSP_x64) RectT<int>::GetYMax
0x00007FFBD60D2774 (KERNEL32) BaseThreadInitThunk

========== END OF STACKTRACE ===========

**** Crash! ****

 

Share this post


Link to post
Share on other sites

That is an older version of Module manager you are running there. for 1.3 you should be on version 2.8 I believe?

Also interesting to note that it's in your (x86) folder of windows, where the 32 bit stuff lives. Also it looks like it's trying to run KSP in 32bit compatibility mode:

Environment Info
Win32NT 7FFFFFFFFFFFFFFF  Args: KSP_x64.exe 

Try taking out the KSP folder from its current directory and placing it into the Program Files folder? Then run it from there?

Share this post


Link to post
Share on other sites
5 hours ago, Cheesecake said:

@vossiewulfIt Seems you are running out of memory. You have too many Mods installed.

Probably but not due to mods, I have two games running and I think I had Photoshop in the background also. I'll double check but unless you see me reply with more information, assume it works fine until I drop in those particular folders and then it falls down whether I'm running out of mem or not. Also two people from Steam seeing the exact same thing failing at the identical point suggests something besides running out of memory just at the time we're both loading this mod.
 

30 minutes ago, steedcrugeon said:

That is an older version of Module manager you are running there. for 1.3 you should be on version 2.8 I believe?

Also interesting to note that it's in your (x86) folder of windows, where the 32 bit stuff lives. Also it looks like it's trying to run KSP in 32bit compatibility mode:


Environment Info
Win32NT 7FFFFFFFFFFFFFFF  Args: KSP_x64.exe 

Try taking out the KSP folder from its current directory and placing it into the Program Files folder? Then run it from there?

If there's something broken about which executable it's running or where it's installed and launching from, then the Steam installation is broken as this is all default Steam- I let it do its normal install and just hit the Play button from my library.

One thing I just saw was that if I right click on the game listing in my Steam lib, there are two options: play KSP and launch KSP (64 bit). For this log you can see I manually ran the 64, not sure how Steam would be affecting how it executed. But I'll try the launch 64 option and see if it works.

Share this post


Link to post
Share on other sites
16 hours ago, tmccreight651 said:

hey guys, so ive asked about my problems with this mod, those being that the game crashes when i try to load it with this mod installed, so i finally figured out how to share the game logs, so here are my logs. all help appreciated

Hey, so I spot a number of things in your log that look fishy:

  1. You're running KSP.exe (32-bit) and not KSP_x64.exe (64-bit) thus limiting your available memory
  2. You're running Firespitter v7.3.6212.36331, the latest version seems to be v7.6 here
  3. You've got 2 versions of module manager running ModuleManager.2.7.1 and ModuleManager.2.8.0. Only use the latest, remove the old one

Thank you @Cheesecake and @steedcrugeon for stepping in to help. I'm still swamped at work, so my KSP time has been scarce

Share this post


Link to post
Share on other sites
9 hours ago, vossiewulf said:

If there's something broken about which executable it's running or where it's installed and launching from, then the Steam installation is broken as this is all default Steam- I let it do its normal install and just hit the Play button from my library.

As far as I know, unless you have explicitly configured it, Steam will launch 32-bit by default. It is not broken, just the default launch option.

Share this post


Link to post
Share on other sites

In the 1.2.2 version I used this mod to make all the probes I used and now when the game was updated for the 1.3.0 version I cannot use this mod without an updated version of this mod. What you suggest for me? Or can I use the current version of this mod in the 1.3.0 version of KSP?

Share this post


Link to post
Share on other sites
59 minutes ago, zeant93 said:

In the 1.2.2 version I used this mod to make all the probes I used and now when the game was updated for the 1.3.0 version I cannot use this mod without an updated version of this mod. What you suggest for me? Or can I use the current version of this mod in the 1.3.0 version of KSP?

For the time being, you will have to download ProbesPlus 0.15 and the install the latest Firespitter version. You will also need the latest Dmagic science animate plugin. Overwrite the versions included with my mod.

Is there any demand for to update just the dependencies and re-release? It doesn't feel right to do so without any significant updates to my mod as well, but it may help some people. Maybe I can finish one more part quickly to justify an update. Thoughts?

Share this post


Link to post
Share on other sites
2 hours ago, akron said:

For the time being, you will have to download ProbesPlus 0.15 and the install the latest Firespitter version. You will also need the latest Dmagic science animate plugin. Overwrite the versions included with my mod.

Is there any demand for to update just the dependencies and re-release? It doesn't feel right to do so without any significant updates to my mod as well, but it may help some people. Maybe I can finish one more part quickly to justify an update. Thoughts?

I use the latest Firespitter Core version. Will I have to use Firespitter or I can stay using the Firespitter Core version? I have the latest version of Dmagic Science Animate Plugin.

Share this post


Link to post
Share on other sites
41 minutes ago, zeant93 said:

I use the latest Firespitter Core version. Will I have to use Firespitter or I can stay using the Firespitter Core version? I have the latest version of Dmagic Science Animate Plugin.

Firespitter core is fine. I often forget that Firespitter is also a parts mod. Once you update those 2 modules, my mod should work fine

Share this post


Link to post
Share on other sites
5 hours ago, akron said:

Firespitter core is fine. I often forget that Firespitter is also a parts mod. Once you update those 2 modules, my mod should work fine

Before when I copy the mod folder to the GameData folder I overrite the files and then the crash but now I install only the Coatl Aerospace folder and then doesn't crash as he did before.

Share this post


Link to post
Share on other sites
15 hours ago, zeant93 said:

Before when I copy the mod folder to the GameData folder I overrite the files and then the crash but now I install only the Coatl Aerospace folder and then doesn't crash as he did before.

Yup, this is because the included modules are meant for KSP 1.2.2. Glad you got it working!

In other news, I've decided to push to get a few more parts done to justify releasing v15.1 with support with the new KSP. Still trying to find the time to work on the mod, but work continues to be very busy. It will not be Cassini because that would take far too long to complete. I'll post some progress once I have something, but the current low-hanging fruit is the rest of Surveyor. Landers FTW

Share this post


Link to post
Share on other sites

Hi, anyone know what mod is conflicting with Probesplus to prevent me from changing the textures on all the probe cores? I've tried seeing which of my mods is conflicting, but I couldn't find which one(s), and am hoping if someone knows of a list of incompatabilities with this mod.

DMagic, Kopernicus, Near Future Solar, Near Future Electrical (Plus decaying RTGs), General Nuclear Reprocessors, Orbital Decay, Station Parts Expansion and OPM. These can all be found at kerbal.curseforge.com .

Edited by sslaptnhablhat
Just clarifying a bit.

Share this post


Link to post
Share on other sites
24 minutes ago, sslaptnhablhat said:

Hi, anyone know what mod is conflicting with Probesplus to prevent me from changing the textures on all the probe cores? I've tried seeing which of my mods is conflicting, but I couldn't find which one(s), and am hoping if someone knows of a list of incompatabilities with this mod.

DMagic, Kopernicus, Near Future Solar, Near Future Electrical (Plus decaying RTGs), General Nuclear Reprocessors, Orbital Decay, Station Parts Expansion and OPM. These can all be found at kerbal.curseforge.com .

Try downloading Firespitter or updating it https://github.com/snjo/Firespitter/releases

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.