Jump to content

Recommended Posts

3 minutes ago, legoclone09 said:

Sorry for the off-topic post, but sweet Pelican!

Thanks! I rigged up a model someone ripped from Halo 3.

14 minutes ago, CliftonM said:

Are you using .max, or exporting it?  I know that .max files are kind of weird.

I have tried both.

Link to post
Share on other sites

Looks like either flipped uv faces, or flipped geometry ( all the hallmarks of a ripped model)and i'd like to bet the poly count i stupid high as well which will likely mean issues with colliders etc

ps if its  anew thing this ksp modding, try easy stuff first , unless you like being totally disheartened

 

Edited by SpannerMonkey(smce)
hmm
Link to post
Share on other sites
1 minute ago, SpannerMonkey(smce) said:

Looks like either flipped uv faces, or flipped geometry ( all the hallmarks of a ripped model)and i'd like to bet the poly count i stupid high as well which will likely mean issues with colliders etc

Poly count is OVER 9000!

(Literally!)

How do I fix those other two?

Edited by njmksr
Link to post
Share on other sites

I'll say now that those shapes and 9000 polys does mean you are going to have real trouble in unity , convex colliders can only have 250 something triangles. been there, paid the price, learned my lesson.

As a quicky maybe fix  select the whole model, find the utilities tab, looks like a little hammer, click it, scroll down find and click Reset XForm, if that doesnt work there are a million max tutorials on the web

 

Edited by SpannerMonkey(smce)
Link to post
Share on other sites
16 hours ago, SpannerMonkey(smce) said:

I'll say now that those shapes and 9000 polys does mean you are going to have real trouble in unity , convex colliders can only have 250 something triangles. been there, paid the price, learned my lesson.

As a quicky maybe fix  select the whole model, find the utilities tab, looks like a little hammer, click it, scroll down find and click Reset XForm, if that doesnt work there are a million max tutorials on the web

 

Thanks! Means a lot :)

Link to post
Share on other sites

Select everything, right click -> Object Properties -> Backface Cull (lower left side); if you see holes, you have flipped faces and you'll have to fix them. Playing with Select by Face by Angle could help speed up the selection process (works like the magic wand selection tool in image editor), either try selecting the flipped faces or regular faces, then inverting the selection (Ctrl-I)

Another way to check is Ctrl-A to select all faces in Poly subobject mode (4 key); faces pointing away from camera will appear dimmer. Be sure to turn on shaded selection (F2 key)

if there's no animation or skin modifier; export OBJ with Texture Coords; no need to create Material library, Unity don't need that MTL file. Otherwise export FBX, don't export cameras and lights (they should be deleted from the scene before export anyway).

Edited by nli2work
Link to post
Share on other sites

Unity can be mean lol.

I dont have enough info from looking at those two images to tell for sure what is wrong. I cannot see the body object in the unity list( but there are objects in that list that i cannot see as they are outside the view ).

To me it looks like the issue can atleast be narrowed down to the "body" object(s)(as they seem to be the only ones missing? inside unity)

So first make sure it doesnt have inverted faces in max (add a normals edit modifier and check that the arrows face out). If not then add an edit poly select all faces and flip normals. Collapse the stack. Also apply the reset xform utility. Export as fbx. 

Edited by landeTLS
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...