Jump to content

KSP 1.1 .NET Version?


almagnus1
 Share

Recommended Posts

1 hour ago, sal_vager said:

Here is the version of Mono that Unity3D uses.

Ok, assuming that I'm following the docs right, and http://www.mono-project.com/docs/about-mono/compatibility/ is valid documentation for the GitHub repo, then the answer is .NET 4.5 (mostly), correct?

Edited by almagnus1
Link to comment
Share on other sites

17 minutes ago, sal_vager said:

I'm not the best to answer that, I just know it uses that version of Mono, have you tried compiling anything with .NET 4.5 to see if it works ?

Unfortunately I have not.

That's something I'm going to look into next week, as I'll have ample free time to dedicate towards things like CKAN and other KSP related projects (among other things).

Link to comment
Share on other sites

16 minutes ago, sal_vager said:

I just asked around, and the version that you should compile plugins against is actually 3.5

Hope this helps.

IIRC KSP 1.1 is coming with a Unity upgrade, right?

Assuming that's the case, that version might be changing as 3.5 is what we're using right now.

The game changer is .NET 4.5, and what can be done with plugins (as we can potentially leverage everything in the System.IO.Compression assembly as seen https://msdn.microsoft.com/en-us/library/system.io.compression(v=vs.110).aspx ).  Many of the classes (and methods in existing classes) are .NET 4.5 ONLY.

In a more practical sense, it means that .NET gives us a better ability to work with zip files without having to use 3rd party DLLs (like the ones for 7zip for example), potentially allowing for mod files to be read from a zip file without need for extraction, which can greatly simplify mod management as you'd need to extract the mod loader mod, then just drop zip files into a directory.  That is, assuming that a stream created from the zip file for an entry can be hooked into KSP.  There's still a lot of unanswered questions there, but it is something that merits further investigation.

Most of this is theorycrafting, so some (possibly most or all) of the above may not be possible.

Link to comment
Share on other sites

8 hours ago, almagnus1 said:

IIRC KSP 1.1 is coming with a Unity upgrade, right?

Assuming that's the case, that version might be changing as 3.5 is what we're using right now.

The game changer is .NET 4.5, and what can be done with plugins (as we can potentially leverage everything in the System.IO.Compression assembly as seen https://msdn.microsoft.com/en-us/library/system.io.compression(v=vs.110).aspx ).  Many of the classes (and methods in existing classes) are .NET 4.5 ONLY.

In a more practical sense, it means that .NET gives us a better ability to work with zip files without having to use 3rd party DLLs (like the ones for 7zip for example), potentially allowing for mod files to be read from a zip file without need for extraction, which can greatly simplify mod management as you'd need to extract the mod loader mod, then just drop zip files into a directory.  That is, assuming that a stream created from the zip file for an entry can be hooked into KSP.  There's still a lot of unanswered questions there, but it is something that merits further investigation.

Most of this is theorycrafting, so some (possibly most or all) of the above may not be possible.

1.1 adds Unity asset bundle loading. That will do the same and will is supported natively by Unity.

4.5 would be nice but the main benefits would not be in the new class but in the global improvement of the code (a lot of the old mono has dreadfully inefficient code in some class)

Link to comment
Share on other sites

Mods compiled for 4.5 crash unexpectedly when reaching branch that uses OPCode that Uniy mono does not know. So yes, don't use 4.5. Anyway the point is moot, unity runs on the old for the time being.

Link to comment
Share on other sites

  • 1 year later...
49 minutes ago, marce said:

Sorry for necroing this thread, but I remember reading Unity to be on a 4.6+ Mono by now.

Is that relevant for KSP or are mods still stuck on a .NET 3.5 target?

Stuck at 3.5.  KSP isn't running the latest version of Unity.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...