Jump to content

How do I get shadows to appear while Zoomed out


Recommended Posts

Hey there, @RYU AZUKU99 um, im just gonna go ahead here and say it. You are actively zooming out. By definition this means your craft is getting smaller by comparison, which means so is its shadow. 

Look at it like this: you are on a flight from nyc to Lax in cali. You are at say 45,000 feet. The aircraft is positioned in a manner that has the sun on the left side and you are on the right side at the window. You look down below to the ground some 8 MILES or so +\- below. Do you see your aircrafts shadow? Nope. Its way way too small to be seen so far away. 

Same deal with zooming out in ksp. Hope that helped

Edited by AlamoVampire
Link to post
Share on other sites
On 2/23/2016 at 10:49 PM, AlamoVampire said:

Hey there, @RYU AZUKU99 um, im just gonna go ahead here and say it. You are actively zooming out. By definition this means your craft is getting smaller by comparison, which means so is its shadow. 

Look at it like this: you are on a flight from nyc to Lax in cali. You are at say 45,000 feet. The aircraft is positioned in a manner that has the sun on the left side and you are on the right side at the window. You look down below to the ground some 8 MILES or so +\- below. Do you see your aircrafts shadow? Nope. Its way way too small to be seen so far away. 

Same deal with zooming out in ksp. Hope that helped

But even if i zoom out just a tad little bit the shadow will just vanish.

Link to post
Share on other sites

@RYU AZUKU99 Not sure how far a little is, but, I know from my experience you should still be able to see it for a bit, especially if you are on the ground and have the camera looking down at say a 45 degree angle. But it's like I said, it will ultimately vanish on you at a certain distance, but that's a variable based on things like graphics card, graphics settings etc.

Link to post
Share on other sites

I know what you're talking about and it's definitely graphics settings.

KSP will only show shadows that are within a certain radius of the camera. The "render quality" setting determines this radius. On the lowest option that allows shadows the render distance is WAY too short, like 15 meters or something. 

Try bumping the render quality (main menu > settings > graphics) up a few notches assuming your PC can handle it.

Edited by KerbonautInTraining
Link to post
Share on other sites
5 hours ago, KerbonautInTraining said:

I know what you're talking about and it's definitely graphics settings.

KSP will only show shadows that are within a certain radius of the camera. The "render quality" setting determines this radius. On the lowest option that allows shadows the render distance is WAY too short, like 15 meters or something. 

Try bumping the render quality (main menu > settings > graphics) up a few notches assuming your PC can handle it.

Yes! Thanks for the help!

Link to post
Share on other sites
6 hours ago, KerbonautInTraining said:

I know what you're talking about and it's definitely graphics settings.

KSP will only show shadows that are within a certain radius of the camera. The "render quality" setting determines this radius. On the lowest option that allows shadows the render distance is WAY too short, like 15 meters or something. 

Try bumping the render quality (main menu > settings > graphics) up a few notches assuming your PC can handle it.

To add to this, there's been a bit of glitchiness that HarvesteR has been working on trying to fix.  Sometimes they won't appear correctly because of the different cameras.  It's very technical, but I don't think you'll get any issues that far out.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...