Nazari1382

[1.1.3] KSO (Kerbin Shuttle Orbiter) Legacy Packs & Development Updates

Recommended Posts

8 minutes ago, Avalon304 said:

Based on what he posted, this is what I would assume he means:

 

And unfortunately, this is just because of the stock gimbal module I think.

Where is the really wiggly part?

Share this post


Link to post
Share on other sites

At booster sep? You have a ton of drag acting on the craft, and the massive loss of thrust causes that jolt. Maybe try getting to orbit with thrust lowered a little, so drag is lower, flying at an angle that is not as steep. Do you and @Vardicd both have the gimbal angle on? Do  you have 0 payload?

 

Share this post


Link to post
Share on other sites
Just now, Nazari1382 said:

At booster sep? You have a ton of drag acting on the craft, and the massive loss of thrust causes that jolt. Maybe try getting to orbit with thrust lowered a little, so drag is lower, flying at an angle that is not as steep. Do you and @Vardicd both have the gimbal angle on? Do  you have 0 payload?

 

When testing, I saw this same behavior regardless of ascent profile or cargo. Yes the gimbals were angled prior to lift off, and if vardicd is using the 4.4 craft files, then they are angled by default.  The stock gimbal module is just bad at dealing with stability assist. It always has been.

Share this post


Link to post
Share on other sites
4 minutes ago, Avalon304 said:

When testing, I saw this same behavior regardless of ascent profile or cargo. Yes the gimbals were angled prior to lift off, and if vardicd is using the 4.4 craft files, then they are angled by default.  The stock gimbal module is just bad at dealing with stability assist. It always has been.

Then the right method might not be stability assist. I just launched using SAS on prograde and it flew like an arrow through booster sep. Might not be good to have it on the entire time, but it is worth you all trying. The other thing that can be modified is gimbal response speed but I don't like it looking (more) silly visually.

 

Share this post


Link to post
Share on other sites
Just now, Nazari1382 said:

Then the right method might not be stability assist. I just launched using SAS on prograde and it flew like an arrow through booster sep. Might not be good to have it on the entire time, but it is worth you all trying. The other thing that can be modified is gimbal response speed but I don't like it looking (more) silly visually.

 

It does fly better with the prograde vector toggled on in SAS and I actually show that in my vid. Really I think upping the gimbal response speed would just make the oscillations more violent rather than fixing it.

Share this post


Link to post
Share on other sites
1 minute ago, Avalon304 said:

It does fly better with the prograde vector toggled on in SAS and I actually show that in my vid. Really I think upping the gimbal response speed would just make the oscillations more violent rather than fixing it.

i thought that too, i disabled gimbal on the SRBs.

Share this post


Link to post
Share on other sites
2 minutes ago, Avalon304 said:

It does fly better with the prograde vector toggled on in SAS and I actually show that in my vid. Really I think upping the gimbal response speed would just make the oscillations more violent rather than fixing it.

But you clicked prograde well after 1:40, what I'm seeing is giving the shuttle some tilt when you first launch and letting it do a gravity turn with prograde, it practically flies itself into orbit. I'm not seeing a playability issue.

Share this post


Link to post
Share on other sites
1 minute ago, Nazari1382 said:

But you clicked prograde well after 1:40, what I'm seeing is giving the shuttle some tilt when you first launch and letting it do a gravity turn with prograde, it practically flies itself into orbit. I'm not seeing a playability issue.

Oh Im not either. Even with the wobble after SRB sep I didnt, it just requires more hands on at that point is all. Its still really easy to get to orbit and to get back.

Share this post


Link to post
Share on other sites
6 hours ago, Nazari1382 said:

Can you post a complete shuttle launch video?

 

5 hours ago, Avalon304 said:

Based on what he posted, this is what I would assume he means:

 

And unfortunately, this is just because of the stock gimbal module I think.

This video is pretty much what I'm seeing, the wiggling back and forth. it's definitely possible to get to orbit, just difficult. Though in my launches the orbiter starts to pick up a roll as well after the boosters detach.

Share this post


Link to post
Share on other sites
8 minutes ago, vardicd said:

 

This video is pretty much what I'm seeing, the wiggling back and forth. it's definitely possible to get to orbit, just difficult. Though in my launches the orbiter starts to pick up a roll as well after the boosters detach.

Are you using the newest craft files? If you arent, and youre using previous ones, go into the VAB and hit 'Show Actuation Toggles' on the main engines and toggle Roll to off.

Share this post


Link to post
Share on other sites
Just now, Avalon304 said:

Are you using the newest craft files? If you arent, and youre using previous ones, go into the VAB and hit 'Show Actuation Toggles' on the main engines and toggle Roll to off.

I do have those, and yaw turned off on the engines also, with yaw turned on, controlling the shuttle is even more difficult for me.

Share this post


Link to post
Share on other sites
7 minutes ago, vardicd said:

I do have those, and yaw turned off on the engines also, with yaw turned on, controlling the shuttle is even more difficult for me.

 

Hmmm, thats odd, it shouldnt be that difficult. How do you normally launch your shuttle?

Share this post


Link to post
Share on other sites

well I've tried with mech jeb, but it has trouble controlling it, I've also tried manually, but I can't compensate fast enough to keep it really stable. about to film a video of a launch now.

Share this post


Link to post
Share on other sites

I have a video made, will upload as soon as my roommate finishes his multi-player game, so I can steal the internet without killing his game.

side note, any idea why the bus shakes, but none of the other cars or trucks do?

Share this post


Link to post
Share on other sites
4 minutes ago, vardicd said:

I have a video made, will upload as soon as my roommate finishes his multi-player game, so I can steal the internet without killing his game.

side note, any idea why the bus shakes, but none of the other cars or trucks do?

The new wheel modules are just buggy.

Share this post


Link to post
Share on other sites
1 minute ago, Avalon304 said:

The new wheel modules are just buggy.

Yeah, I am unsatisfied with the way KSP changed the wheels with this newest update, was just wondering if there was something specific to the bus that made it shake, when I hadn't seen that from the other vehicles in the mod, but have seen it in some stock wheels and other mod's wheels. thanks

 

Share this post


Link to post
Share on other sites
Just now, vardicd said:

Yeah, I am unsatisfied with the way KSP changed the wheels with this newest update, was just wondering if there was something specific to the bus that made it shake, when I hadn't seen that from the other vehicles in the mod, but have seen it in some stock wheels and other mod's wheels. thanks

 

Im pretty sure if you launch the firetruck or the lorry they'll shake too, the bus uses the same wheels.

Share this post


Link to post
Share on other sites

Can't remember if I used the firetruck or not, but I did use the lorry for a bit, and I don't recall it shaking.

 

Share this post


Link to post
Share on other sites
23 minutes ago, Avalon304 said:

That yaw is odd... I cant reproduce it...

he used mechjeb smart A.S.S thingy

also the KSO Super 25 seems to be more stable

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.