Nazari1382

[1.1.3] KSO (Kerbin Shuttle Orbiter) Legacy Packs & Development Updates

Recommended Posts

23 minutes ago, Bomoo said:

Sorry if you've already clarified this, but are you launching with or without mechjerb flying the craft?

I've done it both ways. with and without mechjeb the craft kicks into a hard yaw.

Share this post


Link to post
Share on other sites

Woah! The thread just exploded overnight!

Yesterday I checked and it was on like page 10 or 11, and now it's on page 15!

I've seen talk about it doing a hard yaw to the right on launch using mechjeb. What's that all about?

Oh yeah, and I hate that the day that the new KSO comes out, KSP 1.1.3 comes out and breaks EVERYTHING.

Even when I put it at the last version, it still says a crap-ton of stuff is incompatible!

 

Ohhhh.... SONS OF-

 

Yeah, I'm pretty ticked off.

Share this post


Link to post
Share on other sites
1 minute ago, Raptor22 said:

Woah! The thread just exploded overnight!

Yesterday I checked and it was on like page 10 or 11, and now it's on page 15!

I've seen talk about it doing a hard yaw to the right on launch using mechjeb. What's that all about?

On my install, for some reason, I have a mod, and I don't know which one, that's applying shadow forces to the launch clamps and large vessels when they release. for the KSO, this causes it to yaw hard to one side. it is not a mechjeb issue. I was just commenting that I had found a way to use mechjeb to compensate.

Share this post


Link to post
Share on other sites

Is it just because 1.1.3 has f***ed everything up?

Share this post


Link to post
Share on other sites
2 minutes ago, Raptor22 said:

Is it just because 1.1.3 has f***ed everything up?

No was happening in my install before the 1.1.3 update.

Share this post


Link to post
Share on other sites

Oh, alright.

 

Now that I think about it, perhaps it's just Mini AVC, since an update can come along and it will be just fine, yet miniAVC says it's outdated

 

*EDIT*:

Nope. All of my saves are outdated.

...

 

F***ING PERFECT!

 

*EDIT THE SECOND*:

I was building in the spaceplane hangar and I realized that it used the old mirror symmetry symbol. The rover wheels didn't have all of the options. I'm guessing it went all the way back to 1.0.5 or something.

Going to present version to see if it will work.

 

*EDIT THE THIRD*:

So, I will need to update JSI transparent pods. Kopernicus and Tweakscale are completely broken (according to the thing on the loading screen), and if it pops up there it's probably bugged to non-functionality in the game. I guess I'll go and let those guys know "HEY! YOUR MOD'S BROKEN! FIX IT!"

*STAY TUNED FOR FURTHER UPDATES*

 

 

Edited by Raptor22
Welp. Launched KSP and found I was wrong, again.

Share this post


Link to post
Share on other sites

So, this is off-topic from what I was talking about earlier, but whoever made those two patches for phase one and phase two should also make some for phase three, four, and five (the new EX, once some textured pictures come out to give you an idea of what it looks like in-game). 

Also, either Nazari or Helldiver, could you post updated versions of the extra cockpits (the configs will need to be the current one.), and the patch creation kits so that other people can make those patches if the original person doesn't feel up to it?

 

(by the way, I can't draw to save my life.)

Share this post


Link to post
Share on other sites
6 minutes ago, Raptor22 said:

So, this is off-topic from what I was talking about earlier, but whoever made those two patches for phase one and phase two 

 

What? And what is a patch creation kit?

Share this post


Link to post
Share on other sites

Well, I found another bug. In the original KSO cockpit, the navballs on both sides are missing, and you can't switch the display from the modern hud-type to the navball.

I'm not sure if it's because of the KSO props or because of RPM.

I haven't tested it out in the Super 25's cockpit, but I assume it's the same there.

My next mission will use it, so I'll let you know then.

Edited by Raptor22
Took a second look

Share this post


Link to post
Share on other sites
11 minutes ago, Nazari1382 said:

What? And what is a patch creation kit?

Go back to the original thread for 0.90

It has a thing that has the elements used to make custom mission patches (really just changing the KSTS number). 

I can change the number just fine. I just want to have new patches for the super 25.

Imagine that! The shuttle's soon to be retired and it still has not gotten a single mission patch!

Share this post


Link to post
Share on other sites

Also, add some darn albator to the shuttles! This is the fifth time I have exploded on re-entry!

I have to go nose-first because the nosecone has more heat protection than the shuttle. If I move an inch, I explode and die.

 

Rest In Peace:

 

Jebediah Kerman

Bill Kerman

Bob Kerman

Valentina Kerman

Mitlorf Kerman

Natadi Kerman

Edited by Raptor22
Some people, man...

Share this post


Link to post
Share on other sites
21 minutes ago, Raptor22 said:

Go back to the original thread for 0.90

It has a thing that has the elements used to make custom mission patches (really just changing the KSTS number). 

I can change the number just fine. I just want to have new patches for the super 25.

Imagine that! The shuttle's soon to be retired and it still has not gotten a single mission patch!

Ok, please do not spam the thread with whatever that crap in your last post is. 

1) shuttles dont use ablator. You can add it in cfgs if you want.

2)Change the values in the heat files in the configs folder if you want the parts to be more resistant.

3) The values are meant to make angle and orbit altitude matter. At a certain point having enough maxtemp or ablator just makes heat mean nothing. Edit cfgs if you want to play with it that way.

Share this post


Link to post
Share on other sites

Fine. I guess you guys have no sense of humor then. 

*edited*

There. Happy now?

Share this post


Link to post
Share on other sites
5 minutes ago, Raptor22 said:

Fine. I guess you guys have no sense of humor then. 

*edited*

There. Happy now?

All I saw was a wall of black characters, it looked like broken ascii art. Please keep posts regarding issues you are having clear and to the point guys. 

Share this post


Link to post
Share on other sites
10 minutes ago, Raptor22 said:

Fine. I guess you guys have no sense of humor then. 

*edited*

There. Happy now?

These mod authors have to deal with a lot of crap from a lot of different people, and there is a fine line between humor and sounding like an ass, and in typed letters on a forum, it's massively difficult to tell if you're being funny, an ass, or some in between level of sarcastic. Experience has taught them to expect it to be of ill intent. It's always a good thing to keep that in mind. It might be humor to you, but to them its pointless chaff they have to read through to decide if you have a legit bug, or just sour grapes griping.

Share this post


Link to post
Share on other sites

It seems that 1.1.3 has broken the wheels of the space center vehicle tremendously. They don't move the vehicle at all and when I try to turn the vehicle the wheels turn in a y-axis(up and down).

Never mind, apparently the wheels need to be orientated correctly. You need to fix that issue.

Edited by RYU AZUKU99

Share this post


Link to post
Share on other sites
9 minutes ago, RYU AZUKU99 said:

It seems that 1.1.3 has broken the wheels of the space center vehicle tremendously. They don't move the vehicle at all and when I try to turn the vehicle the wheels turn in a y-axis(up and down).

It hasnt. Ive tested them. Did you build the vehilce yourself, or use the latest craft files? If you built it yourself, you need to rotate the wheels properly. Hit 'S' once when you grab them out of the parts list.

Share this post


Link to post
Share on other sites
10 minutes ago, RYU AZUKU99 said:

It seems that 1.1.3 has broken the wheels of the space center vehicle tremendously. They don't move the vehicle at all and when I try to turn the vehicle the wheels turn in a y-axis(up and down).

Never mind, apparently the wheels need to be orientated correctly. You need to fix that issue.

They are oriented the same way stock wheels are, and there is a reason for that. Are you saying the craft files will not move when you load one?

Share this post


Link to post
Share on other sites

In this newest update, how much is Firespitter a dependency? Does this now (especially the Phase IV parts) use the new stock wheel modules, as well as animation?

Share this post


Link to post
Share on other sites
6 minutes ago, Z3R0_0NL1N3 said:

In this newest update, how much is Firespitter a dependency? Does this now (especially the Phase IV parts) use the new stock wheel modules, as well as animation?

I wanna say Firespitter is really only used by the space center vehicles now...  but I am unsure.

Share this post


Link to post
Share on other sites
12 minutes ago, Avalon304 said:

I wanna say Firespitter is really only used by the space center vehicles now...  but I am unsure.

No, it is used in the IVAs

 

Share this post


Link to post
Share on other sites
9 hours ago, Raptor22 said:

Well, I found another bug. In the original KSO cockpit, the navballs on both sides are missing, and you can't switch the display from the modern hud-type to the navball.

I'm not sure if it's because of the KSO props or because of RPM.

I haven't tested it out in the Super 25's cockpit, but I assume it's the same there.

My next mission will use it, so I'll let you know then.

https://github.com/Mihara/RasterPropMonitor/releases

fix for navballs ^

Edited by Nazari1382

Share this post


Link to post
Share on other sites

Hello all. Great mod, really would love to have a neat small space shuttle as well as grounf vehicles in my carrier. Great job. A humble question though:

Is there any pre 1.1 version of this mod. I'm stuck with 1.0.5 but would love to play with KSO.

Thanx in advance.

Share this post


Link to post
Share on other sites
35 minutes ago, evileye.x said:

Hello all. Great mod, really would love to have a neat small space shuttle as well as grounf vehicles in my carrier. Great job. A humble question though:

Is there any pre 1.1 version of this mod. I'm stuck with 1.0.5 but would love to play with KSO.

Thanx in advance.

If you go to the Spacedock pages for each of the packs you want you can click on 'Changelog' and find the appropriate version there. Please also remember to find the appropriate version of ALL the dependancies for your KSP version (including KM_Gimbal). 

Share this post


Link to post
Share on other sites

i only have 1.1.2 not 1.1.3... so if KSO EX is released for 1.1.3

i cant play ksp with kso since it would be released for 1.1.3...

Edited by BlaZe119

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.