DECQ

[1.2.2] Space Shuttle System new release 26.01.2017

Recommended Posts

Sorry if this was answered recently, I'm just getting back into the swing of things.

Does anyone know if you're able to switch the Shuttle to get the different liveries and names other than just Atlantis?

I am using the most recent version of KSP and everything seems to be in working order other than that.

Thanks

Share this post


Link to post
Share on other sites
1 hour ago, Dnaha said:

Sorry if this was answered recently, I'm just getting back into the swing of things.

Does anyone know if you're able to switch the Shuttle to get the different liveries and names other than just Atlantis?

I am using the most recent version of KSP and everything seems to be in working order other than that.

Thanks

All you need is the latest ksp.wheel and there is a link up above and it works fine

Share this post


Link to post
Share on other sites
7 minutes ago, Abpilot said:

All you need is the latest ksp.wheel and there is a link up above and it works fine

I'm fairly certain I have all the dependencies and everything up to date and all but I will check again. Thanks!

Share this post


Link to post
Share on other sites

Still no luck with switching the textures. I even downloaded ksp.wheel again and reinstalled it. :(

Share this post


Link to post
Share on other sites

Kspwheel only operates the wheels on the shuttle. If you look in the cabin.cfg in your mod folder for shuttle, you will see the following:

 MODULE
 {
  name = SSTUTextureSwitch
  currentTextureSet = Atlantis
  TEXTURESET
  {
   name = Atlantis
  }
  TEXTURESET
  {
   name = Discovery
  }
  TEXTURESET
  {
   name = Endeavour
  }

As you can see the texture switch uses SSTULabs plugin.  GameData\SSTU\Plugins\SSTUTools.dll....  The last time it worked was with KSP 122

Share this post


Link to post
Share on other sites
1 hour ago, znscott said:

Kspwheel only operates the wheels on the shuttle. If you look in the cabin.cfg in your mod folder for shuttle, you will see the following:

 MODULE
 {
  name = SSTUTextureSwitch
  currentTextureSet = Atlantis
  TEXTURESET
  {
   name = Atlantis
  }
  TEXTURESET
  {
   name = Discovery
  }
  TEXTURESET
  {
   name = Endeavour
  }

As you can see the texture switch uses SSTULabs plugin.  GameData\SSTU\Plugins\SSTUTools.dll....  The last time it worked was with KSP 122

Ah I think this may be the issue that I'm having. Thanks!

Share this post


Link to post
Share on other sites
11 hours ago, Dnaha said:

Still no luck with switching the textures. I even downloaded ksp.wheel again and reinstalled it. :(

This I think should fix it

https://ufile.io/x0obk

Share this post


Link to post
Share on other sites
5 hours ago, Abpilot said:

This I think should fix it

https://ufile.io/x0obk

Downloaded and still can't switch textures. Are there any potential conflicts with other mods? I read somewhere in the earlier pages that Astronomer's Pack or Stock Visual Enhancements could cause some issues.

Thanks for all your help so far btw I really appreciate it

Share this post


Link to post
Share on other sites
6 hours ago, Dnaha said:

Downloaded and still can't switch textures. Are there any potential conflicts with other mods? I read somewhere in the earlier pages that Astronomer's Pack or Stock Visual Enhancements could cause some issues.

Thanks for all your help so far btw I really appreciate it

Please bear in mind i could be wrong with the links...try using the latest texture replacer (texture replacer replaced) I haven’t tried them because I actually love shuttle Atlantis so i dont really care...if nothing works then its forever Atlantis.

STS122_Atlantis.jpg

Share this post


Link to post
Share on other sites
11 minutes ago, Abpilot said:

Please bear in mind i could be wrong with the links...try using the latest texture replacer (texture replacer replaced) I haven’t tried them because I actually love shuttle Atlantis so i dont really care...if nothing works then its forever Atlantis.

 

No worries! I'm taking a historic approach to my sandbox playthrough so I have yet to reach the Shuttle. I will give texture replacer a go as well again.

I love Endeavour and Columbia so I really want to be able to fly them (but if I only can use Atlantis I'll take it since it's better than nothing lol)

Share this post


Link to post
Share on other sites
33 minutes ago, TheKSPBeginner said:

Mod has no parts.

I'm sure it does.

How did youj install it?

Did you install all the required mods?

Share this post


Link to post
Share on other sites
On 1/12/2018 at 5:22 AM, JohnMcLane said:

What does this mean?

This mod works fine in 1.2.2

AND in 1.3.0 and 1.3.1 if you update the dependencies.

Also having this same problem...hmm.  I'm still tinkering

 

Share this post


Link to post
Share on other sites

Anyone ever try landing the Shuttle by gliding only and actually landing at the official landing strip without ever using the OMS?  I have done this successfully ONCE out of 18 flights so far. There is serious mathematics and algebra involved it seems to land this thing with zero engine use from de-orbit burn. Anyone have any pointers for me to have a more success rate?  Im tired of the "authorized" water landings LOL

Share this post


Link to post
Share on other sites
On 3/14/2016 at 1:55 PM, DECQ said:

Dragon did not go out of the forum, all add-ons that I put on the forum we are doing together.
Thank you for the nice words, to be continued. :)

Decq can you make the sss for rss and ro please

Share this post


Link to post
Share on other sites
On 2/24/2018 at 1:34 AM, lextacy said:

Anyone ever try landing the Shuttle by gliding only and actually landing at the official landing strip without ever using the OMS?  I have done this successfully ONCE out of 18 flights so far. There is serious mathematics and algebra involved it seems to land this thing with zero engine use from de-orbit burn. Anyone have any pointers for me to have a more success rate?  Im tired of the "authorized" water landings LOL

The way to really do this well is to get kSPRC going, and actually do the math in flight.  Working backwards, assuming a certain AoA, and calculating the rate of descent, loss of speed and drag, and determine where your PE would need to be post-burn in order to successfully place you on a trajectory for landing at KSC.  

That's what they have to do in real life, and the only way that it works.  The computer holds the AoA the whole time during descent, as well, to prevent problems.  I suppose a cheap work around to this through trial and error would be to start at a set orbital velocity and altitude, and using the same amount of burn to place the same PE, use a static AoA to measure how long around the globe it takes you to reach an approach vector for landing, and then over several tries, hone in your own visual accuracy on when to burn based on that familiarity and hold those parameters in de-orbiting rigidly to get reliable results.

 

2 hours ago, KspLover777 said:

Decq can you make the sss for rss and ro please

To get this to work with RSS - if you don't have enough dV to get to orbit or maneuver, you can go into the part configs and change their values, increasing the amount of fuel the ET and fuselage can hold, how powerful the engines are, and even affecting the mass, should that need to be (but it shouldn't.)  

I've managed to get it to work by just altering how much Monoprob the OMS engines have access too, as well as increasing the internal volume of the External Tank.  

Share this post


Link to post
Share on other sites
14 hours ago, Bosun said:

The way to really do this well is to get kSPRC going, and actually do the math in flight.  Working backwards, assuming a certain AoA, and calculating the rate of descent, loss of speed and drag, and determine where your PE would need to be post-burn in order to successfully place you on a trajectory for landing at KSC.  

That's what they have to do in real life, and the only way that it works.  The computer holds the AoA the whole time during descent, as well, to prevent problems.  I suppose a cheap work around to this through trial and error would be to start at a set orbital velocity and altitude, and using the same amount of burn to place the same PE, use a static AoA to measure how long around the globe it takes you to reach an approach vector for landing, and then over several tries, hone in your own visual accuracy on when to burn based on that familiarity and hold those parameters in de-orbiting rigidly to get reliable results.

 

To get this to work with RSS - if you don't have enough dV to get to orbit or maneuver, you can go into the part configs and change their values, increasing the amount of fuel the ET and fuselage can hold, how powerful the engines are, and even affecting the mass, should that need to be (but it shouldn't.)  

I've managed to get it to work by just altering how much Monoprob the OMS engines have access too, as well as increasing the internal volume of the External Tank.  

Everytime I do that the shuttle won't take off you know hellblazer i change like the ammount of ET and change propellant to LqOxegen but won't even take off

Share this post


Link to post
Share on other sites

You also have to change the ISP values, rate and Engine Configs for power, max thrust.   If you increase fuel, you increase weight.  Without increasing power, you won't take off. 

Speaking of - I can get to orbit unloaded wth serious mod to the configs....

DECQ -  Despite changing 'rate' in the Config files, I cannot seem to change the ISP to get efficient enough to get a satellite in orbit. 

How/Where in your configs for Engine OSM/SSME do I change the ISP?  Is it not labeled ISP?   

Once I get a working config file, maybe I'l share it with you all.

Share this post


Link to post
Share on other sites
6 hours ago, Bosun said:

You also have to change the ISP values, rate and Engine Configs for power, max thrust.   If you increase fuel, you increase weight.  Without increasing power, you won't take off. 

Speaking of - I can get to orbit unloaded wth serious mod to the configs....

DECQ -  Despite changing 'rate' in the Config files, I cannot seem to change the ISP to get efficient enough to get a satellite in orbit. 

How/Where in your configs for Engine OSM/SSME do I change the ISP?  Is it not labeled ISP?   

Once I get a working config file, maybe I'l share it with you all.

I increase thrust too still won't take off

and lower the weight

Share this post


Link to post
Share on other sites

Just to give an idea, KSP, 

In loading up the Shuttle stock, as DECQ programmed it for stock, without changing anything, you should be able to have it lift off, it just will not make it to orbit.  

When I changed configs, I added a 1 in front of the max thrust, and a 1 in front of max resources.  After that didn't work, I doubled both of those.   When that didn't, I made it '2', etc I simply kept 'scaling' up the specs until it did.  

However, I still don't have it efficient enough to carry payload, as the increased weight of the fuel takes away the gains I've made.  I can orbit it.  I cannot take payload yet.  

But give me some time.  I'm still tinkering with it. 

Edited by Bosun

Share this post


Link to post
Share on other sites
22 hours ago, Bosun said:

Just to give an idea, KSP, 

In loading up the Shuttle stock, as DECQ programmed it for stock, without changing anything, you should be able to have it lift off, it just will not make it to orbit.  

When I changed configs, I added a 1 in front of the max thrust, and a 1 in front of max resources.  After that didn't work, I doubled both of those.   When that didn't, I made it '2', etc I simply kept 'scaling' up the specs until it did.  

However, I still don't have it efficient enough to carry payload, as the increased weight of the fuel takes away the gains I've made.  I can orbit it.  I cannot take payload yet.  

But give me some time.  I'm still tinkering with it. 

Thanks also hopefully you change the mass

Share this post


Link to post
Share on other sites

Mass, yes.  

Atmo Keys are ISP in this code, found'em.    Change those. 

I downloaded Real Scale Boosters, and took the stats from the Shuttle SRB in that mod, and started porting the numbers over to DECQs.  I like that DECQ's shuttle feels more visually to scale with the Kerbals, as well as to the Earth.  Real Scale Boosters parts a lot of times seem 'too big' visually, but might just be me.  

I'm close.  Really close to to nailing a good set of parameters for it.  It's slightly different than RSB, but it's close

Share this post


Link to post
Share on other sites
On 3/1/2018 at 12:51 AM, Bosun said:

Mass, yes.  

Atmo Keys are ISP in this code, found'em.    Change those. 

I downloaded Real Scale Boosters, and took the stats from the Shuttle SRB in that mod, and started porting the numbers over to DECQs.  I like that DECQ's shuttle feels more visually to scale with the Kerbals, as well as to the Earth.  Real Scale Boosters parts a lot of times seem 'too big' visually, but might just be me.  

I'm close.  Really close to to nailing a good set of parameters for it.  It's slightly different than RSB, but it's close

Can' t wait

Share this post


Link to post
Share on other sites
On 2/18/2018 at 3:52 PM, Abpilot said:

All you need is the latest ksp.wheel and there is a link up above and it works fine

sstu is the mod that changes livery i look in cfg and its says sstu change

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.