DECQ

[1.2.2] Space Shuttle System new release 26.01.2017

Recommended Posts

Well, I've managed to get the Shuttle into orbit in RSS.  

There is, however, not much I am able to manage so far in balancing it's flight, (weight and drag) to get it to re-enter using the correct profiles.  

The craft is balanced with the end heavy so that upon re-entry even with mild payload, the COG is mid, tending aft.  This leads to impossible re-entry.  

Still tweaking the mass on the nose, though, to make it enough, it starts to mess up launching.  ::sigh:: Getting there, but it was never designed (the mod) to fit with the RSS forces.  It's like trying to fly a Balsa-wood plane at real plane speeds.

Share this post


Link to post
Share on other sites
On 3/10/2018 at 1:19 AM, Bosun said:

Well, I've managed to get the Shuttle into orbit in RSS.  

There is, however, not much I am able to manage so far in balancing it's flight, (weight and drag) to get it to re-enter using the correct profiles.  

The craft is balanced with the end heavy so that upon re-entry even with mild payload, the COG is mid, tending aft.  This leads to impossible re-entry.  

Still tweaking the mass on the nose, though, to make it enough, it starts to mess up launching.  ::sigh:: Getting there, but it was never designed (the mod) to fit with the RSS forces.  It's like trying to fly a Balsa-wood plane at real plane speeds.

let me do the wieght stuff can you give me download?

Share this post


Link to post
Share on other sites
On February 22, 2018 at 8:10 PM, TheKSPBeginner said:

I found most of the parts, but the front is missing.

still need help

Share this post


Link to post
Share on other sites
On 17/03/2018 at 5:37 AM, Angustino said:

Same problem here. Both cockpits are missing. Everything else is there.

Nothing should be wrong...just get the lates ksp.wheel plugin and its all ok

On 08/01/2018 at 11:12 PM, Cheesecake said:

Did you also install the newest version of SSTU? I don't know what this bug cause.

Yes sorry you will need the latest SSTU...working on a plugin firstly for my self only because I haven’t got any permision form @DECQto have it released on here. The plugin is for replacing textures.

Share this post


Link to post
Share on other sites

Is it possible to get this working in 1.4.1? Is anyone working on an update? Whenever I try to build it in the vab the fps is killed

Share this post


Link to post
Share on other sites

To everyone who likes this mod

I'm in the midde of updating this for 1.3. I already fixed the texture switching because there was a breaking change in one of its dependencies.

The only thing I can't find information about are the part modules ModuleEngineThrustController and ModuleSRBThrust. If anyone know something about these, let me know here or via PM.

I will work on balancing the costs, mass, temp for the meantime.

 

I will make a new thread if it's ready for a release.

Share this post


Link to post
Share on other sites
On 2/4/2018 at 12:44 PM, Olympic1 said:

To everyone who likes this mod

I'm in the midde of updating this for 1.3. I already fixed the texture switching because there was a breaking change in one of its dependencies.

The only thing I can't find information about are the part modules ModuleEngineThrustController and ModuleSRBThrust. If anyone know something about these, let me know here or via PM.

I will work on balancing the costs, mass, temp for the meantime.

 

I will make a new thread if it's ready for a release.

Everything came from orbiter 2010 and also css maybe look at my fórum 

 

On 2/4/2018 at 12:44 PM, Olympic1 said:

To everyone who likes this mod

I'm in the midde of updating this for 1.3. I already fixed the texture switching because there was a breaking change in one of its dependencies.

The only thing I can't find information about are the part modules ModuleEngineThrustController and ModuleSRBThrust. If anyone know something about these, let me know here or via PM.

I will work on balancing the costs, mass, temp for the meantime.

 

I will make a new thread if it's ready for a release.

Hope fully you Can make it work for ro

On 10/3/2018 at 1:19 AM, Bosun said:

Well, I've managed to get the Shuttle into orbit in RSS.  

There is, however, not much I am able to manage so far in balancing it's flight, (weight and drag) to get it to re-enter using the correct profiles.  

The craft is balanced with the end heavy so that upon re-entry even with mild payload, the COG is mid, tending aft.  This leads to impossible re-entry.  

Still tweaking the mass on the nose, though, to make it enough, it starts to mess up launching.  ::sigh:: Getting there, but it was never designed (the mod) to fit with the RSS forces.  It's like trying to fly a Balsa-wood plane at real plane speeds.

Hoy is it going 

How is it going 

Edited by KspLover777

Share this post


Link to post
Share on other sites

this is pretty old so those modules may be deprecated. i would use a stock srb definition and then use this to get the numbers 

https://ksp.sarbian.com/jenkins/job/AmazingCurveEditor/9/artifact/AmazingCurveEditor-1.1.0.0.zip

it may still work. 

should be able to get the numbers from the curve editor and then set up the engines and srb's using it. 

i cant remember if it was odyssey or gateway on youtube where felbourn does a good job of showing how to set srb and engine curves up so it will automatically slow down until it passes max q etc...

 

Share this post


Link to post
Share on other sites
16 minutes ago, COL.R.Neville said:

this is pretty old so those modules may be deprecated. i would use a stock srb definition and then use this to get the numbers 

https://ksp.sarbian.com/jenkins/job/AmazingCurveEditor/9/artifact/AmazingCurveEditor-1.1.0.0.zip

it may still work. 

should be able to get the numbers from the curve editor and then set up the engines and srb's using it. 

i cant remember if it was odyssey or gateway on youtube where felbourn does a good job of showing how to set srb and engine curves up so it will automatically slow down until it passes max q etc...

 

Thx, will use that

Share this post


Link to post
Share on other sites

A few posts have been removed here, because discussion was rapidly descending into unproductive bickering.  A few things to bear in mind:

  • First, please be careful about asking modders for updates, particularly if KSP has recently updated to a new version.  Remember that modders aren't getting paid for this, and modding takes a lot of hard work, and they're just doing this as a hobby in their spare time.  Modders are very attached to their mods, and they know if the mod is broken on the new KSP, okay?  So just be patient, and it'll be ready when it's ready.  In general... best not to ask for updates; breathing down their neck won't make it arrive any faster.  :wink:
  • Second, cut newbies a little slack, okay?  Yes, it may frustrate you if you see the 100th person in a row ask "Update to 1.4.2 please!" or whatever.  However, if that person is a newbie, then they don't realize that they're the 100th person to ask that.  They don't mean any harm, and they don't realize that they're stepping on any toes.  So, maybe don't jump down their throats about it?  Yelling at someone about their very first post on the forum isn't very welcoming.  So... let's show a bit of tolerance to folks who are new here and may not know the ropes yet.  It's fine to let them know, nicely, what the lay of the land is here-- but please be friendly about it so that they feel welcome in the forum.  Don't yell at them.  It doesn't help.

Thank you for your understanding.

Share this post


Link to post
Share on other sites
1 hour ago, Snark said:

A few posts have been removed here, because discussion was rapidly descending into unproductive bickering.  A few things to bear in mind:

  • First, please be careful about asking modders for updates, particularly if KSP has recently updated to a new version.  Remember that modders aren't getting paid for this, and modding takes a lot of hard work, and they're just doing this as a hobby in their spare time.  Modders are very attached to their mods, and they know if the mod is broken on the new KSP, okay?  So just be patient, and it'll be ready when it's ready.  In general... best not to ask for updates; breathing down their neck won't make it arrive any faster.  :wink:
  • Second, cut newbies a little slack, okay?  Yes, it may frustrate you if you see the 100th person in a row ask "Update to 1.4.2 please!" or whatever.  However, if that person is a newbie, then they don't realize that they're the 100th person to ask that.  They don't mean any harm, and they don't realize that they're stepping on any toes.  So, maybe don't jump down their throats about it?  Yelling at someone about their very first post on the forum isn't very welcoming.  So... let's show a bit of tolerance to folks who are new here and may not know the ropes yet.  It's fine to let them know, nicely, what the lay of the land is here-- but please be friendly about it so that they feel welcome in the forum.  Don't yell at them.  It doesn't help.

Thank you for your understanding.

Hello, for information, the modder said, the mod is finish, he don't want to continue SSS (1.2.2 was release 1 year ago) and I only request the texture because @Olympic1 have already fixed them. Bye

Edited by kylianrogers

Share this post


Link to post
Share on other sites
On 4/2/2018 at 10:44 AM, Olympic1 said:

To everyone who likes this mod

I'm in the midde of updating this for 1.3. I already fixed the texture switching because there was a breaking change in one of its dependencies.

The only thing I can't find information about are the part modules ModuleEngineThrustController and ModuleSRBThrust. If anyone know something about these, let me know here or via PM.

I will work on balancing the costs, mass, temp for the meantime.

 

I will make a new thread if it's ready for a release.

I am assuming you spoke with DECQ about doing so, so you have his express permission?

Share this post


Link to post
Share on other sites
On 4/10/2018 at 2:10 AM, Sampa said:

I am assuming you spoke with DECQ about doing so, so you have his express permission?

You guys know that Olympic upload the mod so he mostly DEV of this mod

Share this post


Link to post
Share on other sites
17 hours ago, KspLover777 said:

You guys know that Olympic upload the mod so he mostly DEV of this mod

I was unaware of this.  I only am just coming back to the KSP forums recently, so been out of the loop for a LONG while.

Share this post


Link to post
Share on other sites

Curious if the updates to the Shuttle mod will also be Kerbal versions meaning not just RO version.

Where I'm coming from is basically I'd like to see the shuttle get into orbit and land without modifying the files (as I've had to do in order to get the shuttle with payload into Kerbal orbit) or adding additional mods like RO.

Using MechJeb for landing the shuttle is proving difficult as well without it flipping and spinning out of control. Not having enough lift in order to bring the nose up is one example.

At a guess I'm thinking the LiftControl and possibly Drag figures are wrong, but finding the sweet spot is proving difficult.

Share this post


Link to post
Share on other sites

you should be able to just use firespitter for texture switching. or b9partswitch for model and textures. 

3 hours ago, Radar said:

Curious if the updates to the Shuttle mod will also be Kerbal versions meaning not just RO version.

Where I'm coming from is basically I'd like to see the shuttle get into orbit and land without modifying the files (as I've had to do in order to get the shuttle with payload into Kerbal orbit) or adding additional mods like RO.

Using MechJeb for landing the shuttle is proving difficult as well without it flipping and spinning out of control. Not having enough lift in order to bring the nose up is one example.

At a guess I'm thinking the LiftControl and possibly Drag figures are wrong, but finding the sweet spot is proving difficult.

almost all these mods you kinda have to tweak for you. stuff handles differently at 60fps than at 10 or 3 hehe. change what you need to make it work for you. if you mess around trying to use stuff as is you will just get frustrated. 

i just add more pitch and roll sas.

for mechjeb look at the rcs system and put rcs build aid on it to make sure everything is firing in the right directions you'd be surprised how messed up some stuff is.

 look at the figures for the retractable lifting surfaces mod body flap and see if there needs to be something updated or added to this one. 

what you can also do is hide a small probe core in the rear that you angle about 20 degrees and action group it that way you can just do a control from here and then just hit sas prograde and it will hold a 20 degree nose up for you. 

Edited by COL.R.Neville

Share this post


Link to post
Share on other sites
23 hours ago, TheKSPBeginner said:

Add the front of the shuttle, please

You are meaning the Cockpit? They (there are two, one analog and one with glas-cockpit) are already included (as we said several times yet).

Share this post


Link to post
Share on other sites

I have two questions for anyone who can help,

1) When I install the SSU, one of the dependencies to run it is "OrbiterSound 4.0". When I boot up OS 4.0 it says to select the folder "(Where the Orbiter.exe is located)" I have searched throughout the SSU file and have not found any "Orbiter.exe" file.  Where is the "Orbiter.exe" file, and do I need it to use the SSU?

2) Does the SSU work on KSP 1.1.3 or 1.3? My 1.2.2 does not work for unknown reasons.

Edited by SupremeEgg

Share this post


Link to post
Share on other sites
28 minutes ago, kemp8589 said:

how to install this?

Hi Kemp, welcome to the forums, most mods you simply copy the contents of the mod into the gamedata folder (there are already a few threads on how to install mods on the gameplay questions section)

You should always check the first post of the mod as well, since the authors usually post dependencies and recommendations there.

Share this post


Link to post
Share on other sites
On April 16, 2018 at 5:13 PM, Cheesecake said:

You are meaning the Cockpit? They (there are two, one analog and one with glas-cockpit) are already included (as we said several times yet).

It's not showing up

Share this post


Link to post
Share on other sites
1 hour ago, TheKSPBeginner said:

It's not showing up

When you press 'C' on the keyboard nothing happens ? Normally this would put you in the cockpit view.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.