Jump to content

[1.12.x] KRASH - Kerbal Ramification Artificial Simulation Hub (simulation mod for KSP) - Cost settings have been change


linuxgurugamer
 Share

Recommended Posts

  • 1 month later...

Here is an interesting crash:

Spoiler

[LOG 17:04:16.382] Game State Saved to saves/World/KRASHRevert
[EXC 17:04:16.535] ArgumentNullException: Value cannot be null.
Parameter name: source
    System.Linq.Enumerable.Where[TSource] (System.Collections.Generic.IEnumerable`1[T] source, System.Func`2[T,TResult] predicate) (at <fbb5ed17eb6e46c680000f8910ebb50c>:0)
    KRASH.LaunchGUI.setLaunchSite (KRASH.LaunchGUI+LaunchSite site) (at <adc60f33a2914a75861553c1e58cdfa8>:0)
    KRASH.KRASH.OnLeavingEditor (EditorFacility facility, KRASH.LaunchGUI+LaunchSite launchSite) (at <adc60f33a2914a75861553c1e58cdfa8>:0)
    KRASH.KRASH.Activate () (at <adc60f33a2914a75861553c1e58cdfa8>:0)
    KRASH.LaunchGUI.LaunchSim () (at <adc60f33a2914a75861553c1e58cdfa8>:0)
    KRASH.LaunchGUI.drawRightSelectorWindow (KRASH.LaunchGUI+SelectionType type) (at <adc60f33a2914a75861553c1e58cdfa8>:0)
    KRASH.LaunchGUI.drawSelectorWindow (System.Int32 id) (at <adc60f33a2914a75861553c1e58cdfa8>:0)
    UnityEngine.GUI.CallWindowDelegate (UnityEngine.GUI+WindowFunction func, System.Int32 id, System.Int32 instanceID, UnityEngine.GUISkin _skin, System.Int32 forceRect, System.Single width, System.Single height, UnityEngine.GUIStyle style) (at <5c0adbf4bfd64247bdedbb543f29b763>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
[LOG 17:04:18.485] QuickStart(QPersistent)[2.20]: autoSaveShip: save
 

This only happens when I try to launch the sea dragon, yet from the code it should just pick the launch site. It works for other craft

Link to comment
Share on other sites

  • 1 month later...
On 2/11/2021 at 12:14 AM, siimav said:

¯\_(ツ)_/¯

When KRASH reverts back to the pre-simulation state, it somehow doesn't reset everything. This includes messages from completed contracts and many other variables that should be reloaded from the save file.

this happened to me. I simulated a crewd vehicle, got the milestone archivement (firt time in orbit) in the simulation, terminated, build the craft and launched, but the archivement was not granted again.  I havent completed a contract in a simulation yet so I dont know if that also doesnt revert.

Im on 1.11.2, stock, with the latest version from CKAN (0.5.33.3)

Link to comment
Share on other sites

  • 2 weeks later...
Posted (edited)

Hi guys,

Can someone explain the use of atmosphere multiplier? Why would I not want to sim in the same environment as I will fly?

Oops. I see now in the video it doesn't change the atmosphere, it multiplies the mission cost as soon as the simulator encounters atmosphere. So I guess with 1 there's no processing penalty for being in atmosphere. However, set at 1.5x, all costs go 50% up if you hit the atmosphere since my simulation hardware needs to work harder.
(ironic, that I already paid for my computer, and now I install software to charge me more (in fake credits which I honor), to make my life harder :))

Edited by ceauke
Link to comment
Share on other sites

  • 3 weeks later...

I can't seem to find a way to run simulations from the alternate launch sites available in making history (woomerang and desert). Does anyone know if this is possible? If not, would it be possible to add via mm patch? If not, @linuxgurugamer could you add those options?

 

Edited by Errol
Link to comment
Share on other sites

there is a bug that happens when time warping in a simulation. I was in a suborbital trayectory over the Mun and as soon as I hit timewarp, I jumped to a different orbit, 500 KM kilometers ahead, still suborbital but now landing in a total different place. Exiting timewarp did not put me back to my original orbit. Anyone experienced this before?

Link to comment
Share on other sites

1 hour ago, SiCaRiO31 said:

there is a bug that happens when time warping in a simulation. I was in a suborbital trayectory over the Mun and as soon as I hit timewarp, I jumped to a different orbit, 500 KM kilometers ahead, still suborbital but now landing in a total different place. Exiting timewarp did not put me back to my original orbit. Anyone experienced this before?

Yes, it's a known issue, though it only happens AFAIK if you start the simulation at the Mun. I've never seen it happen if I start the simulation launching from Kerbin.
 

 

Link to comment
Share on other sites

On 6/15/2021 at 12:22 PM, SiCaRiO31 said:

there is a bug that happens when time warping in a simulation. I was in a suborbital trayectory over the Mun and as soon as I hit timewarp, I jumped to a different orbit, 500 KM kilometers ahead, still suborbital but now landing in a total different place. Exiting timewarp did not put me back to my original orbit. Anyone experienced this before?

FWIW, I've had a bug like this even without KRASH (I recently uninstalled it because I never used it.)

I'm not sure why it happens, but I've noticed that if I play for too long, the LAN of my orbit will start to "wander" - time warping just makes it more visible because of the sudden jump that it does. I think it's recalculating the orbit line once you leave time warp.

I almost think I should start a thread for this somewhere, and maybe we can crowdsource the mods that everyone has in common...

Edited by etmoonshade
leaving time warp, not entering orbit. :V
Link to comment
Share on other sites

13 hours ago, etmoonshade said:

FWIW, I've had a bug like this even without KRASH (I recently uninstalled it because I never used it.)

I'm not sure why it happens, but I've noticed that if I play for too long, the LAN of my orbit will start to "wander" - time warping just makes it more visible because of the sudden jump that it does. I think it's recalculating the orbit line once you go into orbit.

I almost think I should start a thread for this somewhere, and maybe we can crowdsource the mods that everyone has in common...

Do you have HyperEdit installed?

Link to comment
Share on other sites

On 6/16/2021 at 8:01 AM, linuxgurugamer said:

Do you have HyperEdit installed?

Always. :D

Interesting thought though. HyperEdit is kind of on a "let it ride and let's pray it doesn't break" maintenance cycle since something like 1.8 (unless I'm totally misunderstanding what Ezrelic's been saying in response to bug reports...)

Link to comment
Share on other sites

1 hour ago, etmoonshade said:

Always. :D

Interesting thought though. HyperEdit is kind of on a "let it ride and let's pray it doesn't break" maintenance cycle since something like 1.8 (unless I'm totally misunderstanding what Ezrelic's been saying in response to bug reports...)

Yes.  I have a sneaking suspicision that this problem is caused by Hyperedit just being there (no idea why), KRASH actually uses some code from Hyperedit

Link to comment
Share on other sites

I noticed a minor bug.  The KRASH VAB interface seems to give too low an estimate of sim setup costs (I was using a custom config w/ 5% of parts fixed cost, and 0% for everything else), which can let you launch a sim with a 'limit max cost' setting less than the minimum cost of the sim.  The sim launches and immediately brings up the escape menu.

Link to comment
Share on other sites

  • 3 weeks later...
On 6/20/2021 at 11:07 AM, linuxgurugamer said:

Yes.  I have a sneaking suspicision that this problem is caused by Hyperedit just being there (no idea why), KRASH actually uses some code from Hyperedit

FWIW, i've run into this bug without Hyperedit installed. I've got a ton of other mods installed though, so i can't rule out interactions with something else on my mod list, but i'd bet some money the bugs native to KRASH

Link to comment
Share on other sites

  • 3 weeks later...
On 6/20/2021 at 12:07 PM, linuxgurugamer said:

Yes.  I have a sneaking suspicision that this problem is caused by Hyperedit just being there (no idea why), KRASH actually uses some code from Hyperedit

I tested without HyperEdit installed and this bug (the vessel jumping when starting TimeWarp) still happens!

This bug also existis on HyperEdit, if I use it to set a orbit around another planet or moon; but with HyperEdit, if I change to another vessel and cames back (using Haystack), the bug goes away. But I can't do this using KRASH, the vessel gets teleported to the new location, crashing into another vessel!

Thanks.

Link to comment
Share on other sites

  • 2 weeks later...

Has anybody run KRASH on 1.12.X? I just got a new laptop, added 000_ClickThroughBlocker, 001_ToolbarControl, and KRASH to the GameData directory, but I'm not seeing the toolbar for launching a simulation with KRASH. Not sure if I botched my install or if there is an issue running on 1.12.X of KSP. Settings for all three plugins are showing up in the game difficulty menu.

Link to comment
Share on other sites

3 hours ago, cfogrady said:

Has anybody run KRASH on 1.12.X? I just got a new laptop, added 000_ClickThroughBlocker, 001_ToolbarControl, and KRASH to the GameData directory, but I'm not seeing the toolbar for launching a simulation with KRASH. Not sure if I botched my install or if there is an issue running on 1.12.X of KSP. Settings for all three plugins are showing up in the game difficulty menu.

I've been using it on 1.12 for a while now, no problems.  Check your install (would be a great idea if you only used CKAN to install mods which are supported by CKAN) and if you are still having a problem, post a log file

New release, 0.5.33.4

  • Added AssemblyFileVersion
  • Updated version file for 1.12
     
Link to comment
Share on other sites

9 minutes ago, linuxgurugamer said:

I've been using it on 1.12 for a while now, no problems.  Check your install (would be a great idea if you only used CKAN to install mods which are supported by CKAN) and if you are still having a problem, post a log file

Thanks. I'll try clearing stuff out. Used CKAN first, and it didn't work, so then tried manually installing stuff... Had tried installing some other stuff using curseforge first, so maybe that messed it up.

Link to comment
Share on other sites

  • 3 weeks later...

New release 0.5.33.5

  • Thanks to github user @tivec for this:
    • Change teleport to use FlightGlobals.SetShipOrbit.  This should fix the issues with Vessel jumping in orbit when time warping, and Orbit parameters are changed when going to time-warp if sim is started not from Kerbin
Link to comment
Share on other sites

Sometimes I click through the KRASH window and sometimes not.

Anyway, thank you for maintaining this mod. It's extremely useful in simulating power needed for mining.

Edited by Krzeszny
Link to comment
Share on other sites

  • 2 weeks later...

While the Landed tab allows inputting an altitude, the real spawn altitude is never below a predetermined minimum (the default value) connected with the vessel's size and the minimum altitude is always too high.

For examply, my test lander is landed at 3 meters AGL but it spawns at 19 meters AGL (even if I choose 4 meters) and keeps falling for 15 seconds (Minmus).

Just so you don't say "no logs no support" https://drive.google.com/file/d/1eDJU0oZmCe5KH1JF6Vj6uFmMUeaw1vvg/view?usp=sharing

Edited by Krzeszny
Link to comment
Share on other sites

4 hours ago, Krzeszny said:

While the Landed tab allows inputting an altitude, the real spawn altitude is never below a predetermined minimum (the default value) connected with the vessel's size and the minimum altitude is always too high.

That's normal, it's for safety

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...