Jump to content

[1.11+] HabTech2 | Stockalike ISS Parts! | 0.2.5


Recommended Posts

2 minutes ago, LawnDartLeo said:

@sslaptnhablhat, In the VAB you can select appearance as either bulkhead or bare.  In the old days, this would have been another piece to add. I was looking for the piece and there is none because it is applied at the part level as an optional appearance.

Right ... I understand now . But I still don t see how this is a problem ,because every habitable module has a switchable bulkhead and it means 1 or 2 less parts per craft .

Link to post
Share on other sites
21 minutes ago, MashAndBangers said:

Skylab MK II just got a bit more crowded.  Added ESA Columbus and Roscosmos Zvedza, Zarya, and one of the Poisk brothers.  Also ESA now supplying the station with the ATV.

YLeTiUv.png

 

Looks sick!

Question, Where's that sweet ATV from?

Link to post
Share on other sites

Me too. I just came to report it.

KSP 1.10 appears to lock up while it is trying to load the double-axis solar array. I'll see about doing some detective work (is it a mod interaction etc) and then getting a log... all in due course.

What a nuisance! This is such a good mod!

Link to post
Share on other sites
1 hour ago, DefenderX1 said:

Anyone else have an issue with KSP unable to load this mod after the 1.10 update?

27 minutes ago, softweir said:

Me too. I just came to report it.

KSP 1.10 appears to lock up while it is trying to load the double-axis solar array. I'll see about doing some detective work (is it a mod interaction etc) and then getting a log... all in due course.

What a nuisance! This is such a good mod!

That’s frustrating. Will do some testing later. That solar array part has caused no end of trouble...

Link to post
Share on other sites
3 hours ago, benjee10 said:

That’s frustrating. Will do some testing later. That solar array part has caused no end of trouble...

And yet it's the most awesome part of the mod (IMO). So gorgeous. That and the central truss are why I downloaded it in the first place. I really hope it's fixed soon!

Link to post
Share on other sites
5 hours ago, Cheesecake said:

However, it is released in the last dev-Version (0.2.2, JEM exposed facility).

 

That doesnt mean it' s released yet .

4 hours ago, DefenderX1 said:

Anyone else have an issue with KSP unable to load this mod after the 1.10 update?

1,10 has broken other part mods so it' s no surprise .

Link to post
Share on other sites
7 hours ago, benjee10 said:

That’s frustrating. Will do some testing later. That solar array part has caused no end of trouble...

I don't know if you've had a chance to look at this. On an otherwise un-modded copy of KSP, using the public release of HabTech2, part-loading freezes at 'HabTech2/Parts/Trusses/ht2_solarArray_duo/ht2_solarArray_duo'. KSP continues to use CPU cycles, very busily, but doesn't progress and needs to be killed from the Windows TaskManager.

The end of the KSP.log has the relevant lines:

Spoiler

[LOG 23:02:18.401] PartLoader: Part 'HabTech2/Parts/Trusses/ht2_solarArray_duo/ht2_solarArray_duo' has no database record. Creating.
[LOG 23:02:18.401] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[ERR 23:02:18.412] [Physics.PhysX] QuickHullConvexHullLib::findSimplex: Simplex input points appers to be colinear.

[WRN 23:02:18.425] DragCubeSystem: Part 'ht2.solarArray.duo' has more than two IMultipleDragCube part modules. You should consider procedural drag cubes.
[LOG 23:02:18.425] DragCubeSystem: Creating drag cubes for part 'ht2.solarArray.duo'
[EXC 23:02:18.720] NullReferenceException: Object reference not set to an instance of an object
    ModuleDeployablePart.AssumeDragCubePosition (System.String name) (at <c168e21ec56346b082f89043e76162e1>:0)
    DragCubeSystem+<RenderDragCubes>d__34.MoveNext () (at <c168e21ec56346b082f89043e76162e1>:0)
    UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <5aeafee3fea24f37abd1315553f2cfa6>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

The full KSP log is HERE.

Good luck!

Link to post
Share on other sites
15 minutes ago, softweir said:

I don't know if you've had a chance to look at this. On an otherwise un-modded copy of KSP, using the public release of HabTech2, part-loading freezes at 'HabTech2/Parts/Trusses/ht2_solarArray_duo/ht2_solarArray_duo'. KSP continues to use CPU cycles, very busily, but doesn't progress and needs to be killed from the Windows TaskManager.

The end of the KSP.log has the relevant lines:

  Hide contents

[LOG 23:02:18.401] PartLoader: Part 'HabTech2/Parts/Trusses/ht2_solarArray_duo/ht2_solarArray_duo' has no database record. Creating.
[LOG 23:02:18.401] [DragCubeSystem]: Drag cubes not found or cannot be read for part Part. Generating New drag cubes.
[ERR 23:02:18.412] [Physics.PhysX] QuickHullConvexHullLib::findSimplex: Simplex input points appers to be colinear.

[WRN 23:02:18.425] DragCubeSystem: Part 'ht2.solarArray.duo' has more than two IMultipleDragCube part modules. You should consider procedural drag cubes.
[LOG 23:02:18.425] DragCubeSystem: Creating drag cubes for part 'ht2.solarArray.duo'
[EXC 23:02:18.720] NullReferenceException: Object reference not set to an instance of an object
    ModuleDeployablePart.AssumeDragCubePosition (System.String name) (at <c168e21ec56346b082f89043e76162e1>:0)
    DragCubeSystem+<RenderDragCubes>d__34.MoveNext () (at <c168e21ec56346b082f89043e76162e1>:0)
    UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <5aeafee3fea24f37abd1315553f2cfa6>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

The full KSP log is HERE.

Good luck!

Thanks! Sounds like it's probably something to do with the changes to the drag cubes with the last update. 

Link to post
Share on other sites

@benjee10  Just a heads up.

In the current version of HabTech2 on GitHub there's no 'Engines' directory in the 'Benjee10_sharedAssets' folder. I don't know if that was intentional or an oversight, but it's currently necessary to install the 'Benjee10_sharedAssets' folder from ReDirect or SOCK instead if you're using all three and you want to have engines for the Orion and the Shuttle.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...