raidernick

[1.8.x, 1.9.x] Soviet Spacecraft (Soyuz/Vostok/Voskhod/LOK/LK) - 4-16-20

Recommended Posts

7 hours ago, wat4_dor said:

when will the mod be updated to game version 1.7 or 1.6.1?

Is there a need for an update? As far as I know this mod works in 1.6.x and 1.7.x.

Share this post


Link to post
Share on other sites
3 hours ago, Cheesecake said:

Is there a need for an update? As far as I know this mod works in 1.6.x and 1.7.x.

Personally, I downloaded to previous versions of KSP mod via CKAN.The mod may be available, but the modes with which it is associated (for example, station "salute", etc.) the latest version 1.4.2

Share this post


Link to post
Share on other sites
14 hours ago, wat4_dor said:

Personally, I downloaded to previous versions of KSP mod via CKAN.The mod may be available, but the modes with which it is associated (for example, station "salute", etc.) the latest version 1.4.2

That`s only CKAN. It doesn`t say anything about compatibility. You can download and install it manually too.

Share this post


Link to post
Share on other sites
On 5/2/2019 at 4:57 AM, wat4_dor said:

when will the mod be updated to game version 1.7 or 1.6.1?

The mod is ksp version independent, the only thing that needs updating regularly is the plugin, which I did, it's just not posted here yet. You won't get an official update until RO for 1.6 is released as both my mods and RO have breaking changes for my stuff if not used together on that specific version.

Edited by raidernick

Share this post


Link to post
Share on other sites

UPDATE v1.8

Changelog:

  • Update for KSP 1.6.x/1.7.x
  • Fix possible apas docking problem
  • Fix mm errors with TR config
  • Fix reflections

Required Dependencies below:

 

https://github.com/KSP-RO/SovietSpacecraft/releases/tag/v1.8

 

Edited by raidernick

Share this post


Link to post
Share on other sites
1 hour ago, Sammakko78 said:

It now says that i need TRReflection? What is that.

Which mod-version did you install on which KSP-version? It looks like you have a very old version of this mod because TRR was replaced by TU a while ago.

Share this post


Link to post
Share on other sites
On 3/6/2016 at 3:14 AM, raidernick said:

-If you are using 24 hour days instead of the default 6 hour days HERE is an optional module manager config for TAC Life Support.

The link is not working, does anyone happen to have the config handy?

Share this post


Link to post
Share on other sites

UPDATE v1.8.2

Changelog:

  • fix lk rotation and iva view
  • zond and soyuz rcs fix
  • separate landing srbs from zond and soyuz pods, these need to be added now to use the landing rockets
  • fix apas75 rotation for ASTP

Required Dependencies below:

https://github.com/KSP-RO/SovietSpacecraft/releases/tag/v1.8.2

Share this post


Link to post
Share on other sites

I'm having problems with soyuz orbital modules, with an orbital module even completely empty, I get only 6400 m/s on the R7 rocket while without it I get 8900 m/s. Completely filling the orbital module with fuel has only a minimal effect on delta-v. 

I'm still able to get stuff like Zond descent module and probes using the R7 into orbit, its the orbital module thats screwing me over. I guess i'll try re-installing it. (using v1.6.1 w/ RSS+RO)

Edit 1: I'm also having problems with electricity as well, for some reason the soyuz modules consume way more electricity than they should (they consume much, much more than the solar panels can generate), either that and/or the solar panels arn't generating as much power as they should.

Not sure if this mod is the cause, but I thought it's something worth mentioning. 

Edited by tychochallenge

Share this post


Link to post
Share on other sites
On 11/13/2019 at 5:59 PM, tychochallenge said:

I'm having problems with soyuz orbital modules, with an orbital module even completely empty, I get only 6400 m/s on the R7 rocket while without it I get 8900 m/s. Completely filling the orbital module with fuel has only a minimal effect on delta-v. 

I'm still able to get stuff like Zond descent module and probes using the R7 into orbit, its the orbital module thats screwing me over. I guess i'll try re-installing it. (using v1.6.1 w/ RSS+RO)

Edit 1: I'm also having problems with electricity as well, for some reason the soyuz modules consume way more electricity than they should (they consume much, much more than the solar panels can generate), either that and/or the solar panels arn't generating as much power as they should.

Not sure if this mod is the cause, but I thought it's something worth mentioning. 

No clue about the orbital modules so I can't help you there they work fine for me. As for the power usage, yes that is an issue that needs to be addressed in the next update. There is actually a bug in RSS where at high time warp levels, power usage and solar panel EC production doesn't work correctly. The panels won't charge enough and the probe EC usage will be higher than it should be. Try low time warp levels. You can get the EC fix by using the latest PR i have for RO. Note, the EC usage will still be very high, I am using the exact published solar panel wattage and EC usage for the pods of that era. You will NEED to keep the panels pointed at the sun with 100% exposure at all times or it will drain faster than it collects. Also, the time warp issue is still there. I found it's easier to just set the command pod to auto hibernate when in warp to avoid that bug altogether.

Share this post


Link to post
Share on other sites

Thanks for the update, unfortunately charge rates for me are still the same, my zond spacecraft uses more than 20 electricity per second with the avionics, and 4.07 per second without, while the solar panels only charge at around 0.6 per second at full exposure.

Although recently i've been having some problems with kerbalism, so i'll remove a couple of troublesome mods and see if it helps.

Edit: Turns out Kerbalism was the problem all along. Removing it solved both the orbital module issues and the electricity charge.

Edited by tychochallenge

Share this post


Link to post
Share on other sites
6 hours ago, tychochallenge said:

Edit: Turns out Kerbalism was the problem all along. Removing it solved both the orbital module issues and the electricity charge.

yeah I provide no support for kerbalism

Share this post


Link to post
Share on other sites
22 hours ago, raidernick said:

yeah I provide no support for kerbalism

Well, thats strange, considering that the readme file in the Kerbalism folder lists your mod under "supported mods".

I'll do a little more tinkering to see if I can get them to work together.

Edit 1: I was tinkering with the TKS module and found that if I have the "habitat" from Kerbalism enabled for that module, the mass is quadrupled. Currently editing some files, i'll let you know if I find a way!

Edited by tychochallenge

Share this post


Link to post
Share on other sites
2 hours ago, tychochallenge said:

Well, thats strange, considering that the readme file in the Kerbalism folder lists your mod under "supported mods".

I have never used kerbalism before, you should bring that up with whoever made it because it's false advertising and sending people to complain to me when it doesn't work, when I have absolutely nothing to do with it. I don't like getting false bug reports.

Share this post


Link to post
Share on other sites

@tychochallenge which readme in which where? And when? I cant' find anything related to Raidernick's mods in any Kerbalism Readme of the last weeks.

The only thing that you could have misinterpreted that I found in a Kerbalism Readme is this:

Quote

Make sure to install exactly one configuration pack only.\
Don't combine packs unless there is explicit instructions to do so.
- [ROKerbalism](https://github.com/Standecco/ROKerbalism) for Realism Overhaul / RP-1 by standecco
- [SIMPLEX Living](https://spacedock.info/mod/2067) by theJesuit
- [KerbalismScienceOnly](https://github.com/Kerbalism/KerbalismScienceOnly/releases) for Kerbalism with the science feature only

 

Share this post


Link to post
Share on other sites

Sorry for dragging this issue on, i've concluded that my problems arn't related to this mod, but rather kerbalism in general, since I'm getting the same problems with stock spacecraft as well.

The readme file in question is in the KerbalismConfig folder for RO and part of it reads as such: 

Spoiler

Supported mods:

- Ven's stock revamp
- FASA
- ROCapsules
- SXT
- CxAerospace
- RN Soyuz
- RN US Probes (partial)
- Bluedog Design Bureau (partial)
- Tokamak Industries
- More to come!
 

I don't know when the readme file was last updated, it may be outdated. 

Anyway i'll bring this up with on the Kerbalism forum and hopefully I can solve this issue. Thank you for your help!

Share this post


Link to post
Share on other sites

@tychochallenge That readme is from ROKerbalism, which is a Kerbalism config pack maintained by @Standecco
The Kerbalism people / contributors offer no support in any form for RO, although we cooperate with the people behind RO-RP1 and ROKerbalism.
I suggest you bring any issue to the RO-RP1-Kerbalism discord channel : https://discord.gg/xxBvKB

Share this post


Link to post
Share on other sites

@tychochallenge I am responsible for that config and I fully take any support responsability. The "supported" part is in my readme, not in RN's mod, so it's me that you should ask to fix it.
That said, I can't really help without more information. What is the capsule you're trying to use, and are you absolutely certain that you have installed everything properly? I never had such wild EC consumption, nor anyone ever reported similar numbers

Edited by Standecco

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.