Jump to content

[1.11.x] Endurance (from Interstellar) Continued... (V1.13) 20th Feb 2021


JPLRepo
 Share

Recommended Posts

@Jasseji It took me a bit (like, walk away from the PC for a bit, return, and look at it in the VAB in-game) but I think I get what you mean. You're asking for the control node to be flat relative to the ship and not angled like the hatch itself? Yeah that would cure a serious docking problem. I can make that happen.

Link to comment
Share on other sites

1 minute ago, JadeOfMaar said:

@Jasseji It took me a bit (like, walk away from the PC for a bit, return, and look at it in the VAB in-game) but I think I get what you mean. You're asking for the control node to be flat relative to the ship and not angled like the hatch itself? Yeah that would cure a serious docking problem. I can make that happen.

yes, exactly! I wonder if that would work if the Control Node of the Docking Port itself would be angled too (i dont know if that is possible at all) so basically when you are aligned in line with the ship and docking port Base then any docking indicator would show you that you are properly zeroed

Quick mockup in Paint


https://imgur.com/RQeuraT

Link to comment
Share on other sites

@Jasseji Once you know how the xyz works for rotating things in Unity, you can add multiple control point orientations to a command part. Here's the Ranger with the flatly parallel Reverse orientation.

1vRd49W.jpg

Docked back to its docking target.

EFl6rMg.jpg

And orientation switched again to Forward. See 3rd PAW button "Control Point: X" after the Vessel Naming section. (Note: I'm also adding the options for Forward, Reverse, Up, Down to the Lander to help its own docking orientation problem.)

tpZ2Gnm.jpg

Link to comment
Share on other sites

1 minute ago, JadeOfMaar said:

@Jasseji Once you know how the xyz works for rotating things in Unity, you can add multiple control point orientations to a command part. Here's the Ranger with the flatly parallel Reverse orientation.

1vRd49W.jpg

Docked back to its docking target.

EFl6rMg.jpg

And orientation switched again to Forward. See 3rd PAW button "Control Point: X" after the Vessel Naming section. (Note: I'm also adding the options for Forward, Reverse, Up, Down to the Lander to help its own docking orientation problem.)

tpZ2Gnm.jpg

yup, would love to fiddle with this in Unity but last time i had it working was in 2016, recently tho i cant get it to open any part ;)

Great thing 

 

Link to comment
Share on other sites

@Jasseji Yeah, not all part makers' models can be ripped back into .fbx files. If Endurance parts could be ripped, I would have gone on to ask permission from Benjee10 (their maker) so I could change the materials and add normals and emissives.

I asked him about source files but he told me those are long gone.

Link to comment
Share on other sites

2 minutes ago, JadeOfMaar said:

@Jasseji Yeah, not all part makers' models can be ripped back into .fbx files. If Endurance parts could be ripped, I would have gone on to ask permission from Benjee10 (their maker) so I could change the materials and add normals and emissives.

I asked him about source files but he told me those are long gone.

the Models/Meshes arent the issue here, i cant even open any IVA's, basically nothing is working in Unity as i remember it from a few years back :D

if you're ok with Texturing, i can try to pump out some models, the shapes arent that complicated.

 

 

Link to comment
Share on other sites

On 4/25/2021 at 1:20 AM, Jasseji said:

hey sorry but what config do you refer to ? i have RP and the Endurance but still am missing any RCS on the Ranger

Well I was referring to my own RP config. 

I dont know how to fold the text so I'll just paste the cfg content here:

 

    %EFFECTS
    {
        %RCSrunning
        {
            AUDIO_MULTI_POOL
            {
                channel = Ship
                transformName = RCS
                clip = sound_rocket_mini
                volume = 0.0 0.0
                volume = 0.02 0.1
                volume = 0.5 0.1
                volume = 1.0 0.1
                pitch = 0.0 0.75
                pitch = 1.0 1.5
                loop = true
            }
            MODEL_MULTI_PARTICLE
            {
                modelName = Squad/FX/Monoprop_small
                transformName = RCS
                emission = 0.0 0.0
                emission = 0.1 0.0
                emission = 1.0 1.0
                speed = 0.0 0.8
                speed = 1.0 1.0
                localRotation = -90, 0, 0
            }
        }
    }

    @MODULE[ModuleRCS*]
    {
        @name = ModuleRCSFX
        @runningEffectName = RCSrunning
    }
 

 

 

Link to comment
Share on other sites

47 minutes ago, mark7 said:

Well I was referring to my own RP config. 

I dont know how to fold the text so I'll just paste the cfg content here:

 

    %EFFECTS
    {
        %RCSrunning
        {
            AUDIO_MULTI_POOL
            {
                channel = Ship
                transformName = RCS
                clip = sound_rocket_mini
                volume = 0.0 0.0
                volume = 0.02 0.1
                volume = 0.5 0.1
                volume = 1.0 0.1
                pitch = 0.0 0.75
                pitch = 1.0 1.5
                loop = true
            }
            MODEL_MULTI_PARTICLE
            {
                modelName = Squad/FX/Monoprop_small
                transformName = RCS
                emission = 0.0 0.0
                emission = 0.1 0.0
                emission = 1.0 1.0
                speed = 0.0 0.8
                speed = 1.0 1.0
                localRotation = -90, 0, 0
            }
        }
    }

    @MODULE[ModuleRCS*]
    {
        @name = ModuleRCSFX
        @runningEffectName = RCSrunning
    }
 

 

 

ah, as a general MM Patch, yes ?

Link to comment
Share on other sites

On 4/26/2021 at 8:36 PM, JadeOfMaar said:

@Jasseji Yeah, not all part makers' models can be ripped back into .fbx files. If Endurance parts could be ripped, I would have gone on to ask permission from Benjee10 (their maker) so I could change the materials and add normals and emissives.

I asked him about source files but he told me those are long gone.

I managed to rip them out actually but decided to redo them, started with the docking ports but if you want to do the Texturing then feel free :D

I am redoing the parts mostly due to low polycount, will see how it will turn out

Link to comment
Share on other sites

Hey guys! Love the mod, but I am having some issues with the reactors, after they run for some time, they say that there is "zero efficiently". No matter what I try, nothing seems to work. Any help is appreciated! 

Link to comment
Share on other sites

18 hours ago, Jeb_Slayer said:

Hey guys! Love the mod, but I am having some issues with the reactors, after they run for some time, they say that there is "zero efficiently". No matter what I try, nothing seems to work. Any help is appreciated! 

Just like with the stock ISRU, those reactors need some cooling so look at the part info for whatever needs it, see how much cooling is needed, and attach a radiator that can meet the needs. (The needs are pretty small. You won't have to spam them.)

Link to comment
Share on other sites

4 minutes ago, JadeOfMaar said:

Just like with the stock ISRU, those reactors need some cooling so look at the part info for whatever needs it, see how much cooling is needed, and attach a radiator that can meet the needs. (The needs are pretty small. You won't have to spam them.)

Ok sweet! I was under the impression that the crafts came with enough heat radiation built in, but that makes sense. thanks again

Link to comment
Share on other sites

2 hours ago, JadeOfMaar said:

Just like with the stock ISRU, those reactors need some cooling so look at the part info for whatever needs it, see how much cooling is needed, and attach a radiator that can meet the needs. (The needs are pretty small. You won't have to spam them.)

Well I tried that, and it still did the same thing. It will say no efficiency and have the temperature at about 100 degrees, and nothing else will happen. It doesn't appear to have a common causation, and all the Non Endurance craft do it (Ranger, Viper, Lander). Any other suggestions?

Link to comment
Share on other sites

  • 4 weeks later...
Posted (edited)
On 5/4/2016 at 7:37 PM, JPLRepo said:

think the lazarus module was wip... https://drive.google.com/folderview?id=0B1DhFQzCfzY4V2RrWDdlZVNpTjQ&usp=drive_web

there is reference to it in Benjee10's google drive under the misc folder..

and here is some early pics.. http://imgur.com/a/TO4X0#4 from one of the testers.

Not that bothered about it just want the lander working again :)

If i can figure out how to use blender i'll try and get this part working for you to add to the mod. stuff that way to complicated :)

Got the module working is KSP 1.1.2 - the built in rcs works (some particles come from top and bottom of module)

still needs to test the solar panel

Textures are a bit basic.. maybe someone could make a nicer one :) 

 

Ok you're right. I had that but I must have overlooked it as it wasn't part of the distributed parts.
I'll put it on the list after getting the rest working.

did we every get the Lazarus module for this?

 

Edited by Phers
Link to comment
Share on other sites

  • 2 weeks later...
On 5/11/2021 at 9:33 PM, Jeb_Slayer said:

Well I tried that, and it still did the same thing. It will say no efficiency and have the temperature at about 100 degrees, and nothing else will happen. It doesn't appear to have a common causation, and all the Non Endurance craft do it (Ranger, Viper, Lander). Any other suggestions?

I have this same issue with Rangers & Landers (haven't tried the Viper). The only pattern I've been able to sort of discern is that the problem usually appears if I launch them on top of a rocket stack, and usually doesn't if they are started & flown off the ground individually from KSC.  When the reactor is started, it doesn't build any heat and will just sit at 100deg or less, saying 'zero efficiency' and not producing any power, making the craft unusable.

Link to comment
Share on other sites

  • 2 months later...

" So when I started the Ranger/Viper/Lander engines, it shows "Liquid Fuel" and "Electric Charge." But when I throttle up the Electric charge drains very quickly and the engines flame out (then boom to the ground.) I have the fuel cell on. Also the lander's color is very weird. "

copied from curseforge, i have the same problem. Game version 1.12

Link to comment
Share on other sites

@atomiclabmonkey @kish167 These crafts are supposed to have two power sources in them: the fuel cell (for backup power) and a tokamak fusion reactor (primary power) which requires FusionPellets. If you're not getting these then I must assume you don't have Community Resource Pack which is required for the primary power.

Link to comment
Share on other sites

Don't work Landing Leg on ranger? help me please..

Spoiler

    }
    MODULE
    {
        name = ENLandingLeg
        //uses animation referenced above
        animationID = 0
        //controlled by moduleControl below
        controlID = 0
        suspensionTransformNames = LeftFrontLegStrut, RightFrontLegStrut, LeftRearLegStrut, RightRearLegStrut
        wheelColliderNames = LeftFrontwheelCollider, RightFrontwheelCollider, LeftRearwheelCollider, RightRearwheelCollider
        footColliderNames = landing.foot.left.collider, landing.foot.right.collider, left.rear gear.foot.collider, right.rear gear.foot.collider        
    }

 

Link to comment
Share on other sites

On 8/25/2021 at 2:24 AM, sh_temp_el said:

Don't work Landing Leg on ranger? help me please..

  Reveal hidden contents

    }
    MODULE
    {
        name = ENLandingLeg
        //uses animation referenced above
        animationID = 0
        //controlled by moduleControl below
        controlID = 0
        suspensionTransformNames = LeftFrontLegStrut, RightFrontLegStrut, LeftRearLegStrut, RightRearLegStrut
        wheelColliderNames = LeftFrontwheelCollider, RightFrontwheelCollider, LeftRearwheelCollider, RightRearwheelCollider
        footColliderNames = landing.foot.left.collider, landing.foot.right.collider, left.rear gear.foot.collider, right.rear gear.foot.collider        
    }

 

That can't be helped, sorry. Functionally you don't lose out since the landing legs are built into the craft. You touch down (gently) with the craft body either way.

On 8/28/2021 at 9:22 AM, A-Aeronautics said:

Is this mod compatible with RO? Thanks!

No, it's not, sorry.

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...