JPLRepo

[1.7.x] Endurance (from Interstellar) Continued... (V1.9) 29th Jun 2019

Recommended Posts

I also have the Ranger docking port bug, resulting in the disappearance of a Ranger during my video using this mod. I swear I made perfect contact 10 times until just letting the Ranger drift off/ It was hilarious, my sister was asking why I was laughing and I showed her the Ranger drifting off, and it's RCS thrusters were active without me controlling it. We both died.

 

Edited by themaster401

Share this post


Link to post
Share on other sites

Yeah ok everyone. I found the docking ports problem. They are bugged out...
I have a fix. Just seeing if I can do anything about the ScienceLab as well first before I put out a fix release.

Share this post


Link to post
Share on other sites
13 hours ago, JPLRepo said:

Yeah ok everyone. I found the docking ports problem. They are bugged out...
I have a fix. Just seeing if I can do anything about the ScienceLab as well first before I put out a fix release.

So I have fixed the docking ports. Hopefully once and for all. And tested them in flight.
I cannot find a fix for the ScienceLab Legs. I believe this is related to the physics issues in 1.1.2. It seems ok as long as you don't launch your vessel with the sciencelab legs deployed.
I just need to do a bit more testing and a couple of extra bits I have been working on before I package an updated version. Hopefully tomorrow or the next day.

Share this post


Link to post
Share on other sites

Hey JPL, did you perhaps encounter any problems with docking the Landers to Ground base units ?

I seem to be facing an issue, the docking doesnt want to finalise, looks like a collider issue maybe but i am not sure 100%, will test with different docking ports

Share this post


Link to post
Share on other sites
Just now, Jasseji said:

Hey JPL, did you perhaps encounter any problems with docking the Landers to Ground base units ?

I seem to be facing an issue, the docking doesnt want to finalise, looks like a collider issue maybe but i am not sure 100%, will test with different docking ports

The docking ports are busted.. I have a fix, but I haven't released it yet.

Share this post


Link to post
Share on other sites

I am using different docking ports (i read the comment here and didnt even try with the provided ones)

 

Also one issue when trying EVA from Lander - the Game says "Hatch obstructed" although it isnt...

Share this post


Link to post
Share on other sites
20 minutes ago, Jasseji said:

I am using different docking ports (i read the comment here and didnt even try with the provided ones)

 

Also one issue when trying EVA from Lander - the Game says "Hatch obstructed" although it isnt...

hmmm.. you are using V1? I had that in testing but thought it was fixed. Just started up KSP testbed and it's fine. So either I fixed it and it will be in the next version, or you have something else going on.
 

Share this post


Link to post
Share on other sites

yes, V1, i have redownloaded it again today and just test on runway - Hatch Obstructed

Share this post


Link to post
Share on other sites
8 hours ago, Jasseji said:

yes, V1, i have redownloaded it again today and just test on runway - Hatch Obstructed

Yeah sorry. there was a fix in the OP for the hatches. I'd completely forgotten about.


Doesn't matter now.
V1.1 has been released. It includes the hatch fix... plus docking port fixes, lander/ranger stability fixes, few other things.
See the ChangeLog in the OP for the full list.

Share this post


Link to post
Share on other sites
1 minute ago, Starslinger999 said:

Status Report on the Deep Freeze Module! :kiss:

Are you volunteering to make one?
Status report is: Modelling comes after mod maintenance. I do not have enough hours in the day.
Therefore it is On the list, underneath fixing the existing Endurance IVAs and missing IVAs. ETA: Unknown.

Hence - I asked for volunteer modellers a month or so ago? None have come forward.

Share this post


Link to post
Share on other sites

Anyone could share a craft file of rangers and endurance.Btw that engines are glorious

Share this post


Link to post
Share on other sites
Just now, Syczek said:

Anyone could share a craft file of rangers and endurance.Btw that engines are glorious

Oh... I have a craft file pack that's 95% complete.. Just didn't get time to put in today's release.
I'll package it up and put a link up tomorrow.

Share this post


Link to post
Share on other sites
8 minutes ago, JPLRepo said:

Oh... I have a craft file pack that's 95% complete.. Just didn't get time to put in today's release.
I'll package it up and put a link up tomorrow.

Thank you very kindly.engines of endurance of great.anyways love that movie,nolan did great job

Share this post


Link to post
Share on other sites
8 minutes ago, Syczek said:

Thank you very kindly.engines of endurance of great.anyways love that movie,nolan did great job

I've also got an RSS Module Manage config file ready, but untested. if anyone is interested in testing that for me drop me a PM.

Share this post


Link to post
Share on other sites

@Syczek and anyone else.
Example Craft files Zip link added to OP. Or here.
Thanks go to @skylon7 for creating them.
I'll include the zip into the official release in the next version. Pending any feedback changes.

Share this post


Link to post
Share on other sites
20 hours ago, JPLRepo said:

@Syczek and anyone else.
Example Craft files Zip link added to OP. Or here.
Thanks go to @skylon7 for creating them.
I'll include the zip into the official release in the next version. Pending any feedback changes.

great man thanks,btw endurance deep space engine are badass.They take my vessel to moon with using only 10% of fuel.Rest goes to going back(uh maybe cause i speed up to 6 km/s then decelarate near kerbin)Anyways when i build up The endurance i going to valentine system :D There will be no time for caution:D I hope this engines are capable to reaching near ftl without doing slingshots

Edited by Syczek

Share this post


Link to post
Share on other sites

Again, i come bearing bad news...

When undocking a Ranger from the Endurance, both 'control from here' entries activate the control from docking port. 

 

Share this post


Link to post
Share on other sites
7 hours ago, Denko666 said:

Again, i come bearing bad news...

When undocking a Ranger from the Endurance, both 'control from here' entries activate the control from docking port. 

 

Hmm yeah thought that might happen with the integrated docking port. Fix one problem (blocked hatch) and create another. I'll take a look but my guess is a part (the ranger with the integrated port is one part) can only have one control from here. So I will probably just have to remove the rear one, but I'll see what else, if anything, can be done.

Edited by JPLRepo

Share this post


Link to post
Share on other sites
On 2016-05-14 at 8:09 AM, Wolfdog said:

The Ranger is also insanely hard to get into orbit. I did it many times with the 1.0.5 version, with fuel to spare, but now I can't no matter how hard I try - I always run out of fuel.

I too, can't get the darn thing to orbit. I mean hell, the open cycle mode flames-out at 3km high...that's a little...well. It's darned annoying, since in closed cycle TWR drops like a stone.

Share this post


Link to post
Share on other sites

New version is good, so far. But like others said I wish the Ranger had the performance like it once did (IMO it should be able to land and take back off from most planets), and the Lander had the looks it once did (that compressed looking stub look is not nice at all IMO).

The biggest gripe I have at the moment is with the game itself though. I wish to test the mod some more, but KSP keeps crashing on me (the crashes are definitely not related to this mod) and this kills my fun. @JPLRepo sorry man, KSP gives me too much of a headache lately for any extended testing sessions. Hope the next patches fixes it a bit and I'll be back at your service.

Share this post


Link to post
Share on other sites
49 minutes ago, Dafni said:

New version is good, so far. But like others said I wish the Ranger had the performance like it once did (IMO it should be able to land and take back off from most planets), and the Lander had the looks it once did (that compressed looking stub look is not nice at all IMO).

The biggest gripe I have at the moment is with the game itself though. I wish to test the mod some more, but KSP keeps crashing on me (the crashes are definitely not related to this mod) and this kills my fun. @JPLRepo sorry man, KSP gives me too much of a headache lately for any extended testing sessions. Hope the next patches fixes it a bit and I'll be back at your service.

Glad to notice im not the only one on which ksp regularly goes belly up. 

Hint tho: the frequency of crashing seems to be related to what antialiasing settings i put in game and in the videodriver.

Share this post


Link to post
Share on other sites

I've been running KSP in OpenGL with texture manager installed and it's been running incredibly stable. You may want to try them out, if you haven't.

Also @JPLRepo, how hard is it to make a model for KSP? I started learning 3D modelling just about a week ago and advancing quite slowly.

Share this post


Link to post
Share on other sites

@Denko666 @Dafni
I'll look into the Ranger performance again.
Squad have said 1.1.3 will contain a bunch of fixes, so let's hope hey! Fingers Crossed!

@Greythorn032 I'm not sure how to answer your question. It's one of those how long is a piece of string scenarios.
If you have only been doing it a week, then keep learning and trying. Check the Add-On Development sub-forum, there is also a sub-sub-forum on Modelling in there.

 

Share this post


Link to post
Share on other sites

@JPLRepo sorry i haven't been following everything here, what kind of help with modelling do you require ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.