JPLRepo

[1.8.x] Endurance (from Interstellar) Continued... (V1.10) 20th Oct 2019

Recommended Posts

On 8/1/2017 at 1:02 AM, Kilo60 said:

Ok Got it.

 

How about Saved Games?

 

I have the Endurance Ring Built and In Kerbin Orbit with Landers and Rangers attached...

 

Will I have to rebuild them in the VAB and Relaunch via a new game or will the new update overwrite everything in my current game state?

 

Thanks Again!

You'll be fine.

31 minutes ago, Phers said:

whatever happened to the Lazarus module?

 

 

It never got finished.

Share this post


Link to post
Share on other sites
On 7/31/2017 at 6:58 AM, JPLRepo said:

No.  Been raised and discussed before. You cannot have it seperate. Otherwise there isn't hatch. 

Could you please point me to the discussion? Today I been making researches on this bug in 1.3 with 

controlTransformName = controlNode

but no success yet. As far as I know it works fine in SSTU so you could select particular docking port. And obvious obstacle of a front docking node makes problems to use it with MJ.

Also I've made a simple mock up for deep freeze cryo module(Original mod have a lack of this module) for kerbals on a base of habitation module. Works fine as expected but need some IVA and texturing work at least.


Particularly I could do it myself but unfortunately I'm not good with blender, only Maya. If you could point me to working maya plugin to work with *.mu files I'll try to do my best. And I think models in this mod need some optimization because it is over 23000 vertices for a single Endurance module. I think it is possible to use normal map for micro details.

Share this post


Link to post
Share on other sites

We need the Ranger Adapter for the Saturn V rocket in this mod.. How else am I going to launch them to orbit!

ref2-41230.jpg

 

Share this post


Link to post
Share on other sites
1 minute ago, Pepethecat said:

We need the Ranger Adapter for the Saturn V rocket in this mod.. How else am I going to launch them to orbit!

I thought it is a SSTO.

Share this post


Link to post
Share on other sites
1 hour ago, kremonia said:

Could you please point me to the discussion? Today I been making researches on this bug in 1.3 with 


controlTransformName = controlNode

but no success yet. As far as I know it works fine in SSTU so you could select particular docking port. And obvious obstacle of a front docking node makes problems to use it with MJ.

Also I've made a simple mock up for deep freeze cryo module(Original mod have a lack of this module) for kerbals on a base of habitation module. Works fine as expected but need some IVA and texturing work at least.


Particularly I could do it myself but unfortunately I'm not good with blender, only Maya. If you could point me to working maya plugin to work with *.mu files I'll try to do my best. And I think models in this mod need some optimization because it is over 23000 vertices for a single Endurance module. I think it is possible to use normal map for micro details.

Unity works with .obj and .dae files, also it natively supports importing assets saved in Modo's native format - only thing you would need is to load the existing .mu in blender, export it as something Maya recognises and load it there - but you need the .mu only as a size reference so it doesnt need textures, afterwards you remove it from the scene anyway

Anyways, you can export from Maya to Unity even the native .mb or .ma files, the only thing you need the .mu for is to have a size reference - after that you can just export from maya directly to Unity

Edit: 23000 verts, that's nothing, i am now doing a 3-piece model where the large piece has over 750.000 and the smaller ones have ~200.000 but it's not made for public :wink:

Edited by Jasseji

Share this post


Link to post
Share on other sites
1 hour ago, Jasseji said:

Unity works with .obj and .dae files, also it natively supports importing assets saved in Modo's native format - only thing you would need is to load the existing .mu in blender, export it as something Maya recognises and load it there - but you need the .mu only as a size reference so it doesnt need textures, afterwards you remove it from the scene anyway

Anyways, you can export from Maya to Unity even the native .mb or .ma files, the only thing you need the .mu for is to have a size reference - after that you can just export from maya directly to Unity

As I know there is some ksp tools package for unity but I didn't dig deep enough. And always have scale problems in Unity while importing *.fbx.

1 hour ago, Jasseji said:

Edit: 23000 verts, that's nothing, i am now doing a 3-piece model where the large piece has over 750.000 and the smaller ones have ~200.000 but it's not made for public :wink:

There is a huge difference between in-game model and high poly model reference. Imho, it does not make sense for KSP even if you have double GF1080Ti. As i know but not very sure KSP trying to bake meshes when you attaching it in SPH or VAB each time. Less vertices - more performance.

Edited by kremonia

Share this post


Link to post
Share on other sites

Anyone have an idea where is the problem in switching back from docking port control point back to Ranger. It seems to work just one time when referencing docking port and that's it. I didn't find any reference for any property to define pod's control point, looks like it uses root model axis.

Share this post


Link to post
Share on other sites

Screenshots sure are lacking for this awesome ship. So far I've detected a few things out of place or lacking in this awesome mod. But I can sort them out myself and I'll share. 

Although...I must say this immediately. The docking ports are all missing from the Coupling category. I've noticed only one under Utility in the VAB but there are 4 part configs.

z6NvwG1.jpg

5WdBpTH.jpg

nWbTsZR.jpg

Edited by JadeOfMaar

Share this post


Link to post
Share on other sites

I feel that the lander is horribly unbalanced with the engines it just ends up spinning around even with the VTOL engines on. I don't know it might be me and not the craft. The ranger engine can only run for a few seconds at full throttle before running out of electricity. The big flag can't be picked up in the editor or tweaked. These might be because of me but I thought I should let you know. Also everything else in this mod is awesome!!

Share this post


Link to post
Share on other sites

Dear Great and Honorable JPLRepo

I have been a fan of this mod for a very long time and am in a bit of a pickle. This mod works great in 1.1.3 but when I boot it up with 1.2.2 the game crashes while loading. Here is the crash dump, I am using version 1.4.

Please reply at your earliest convenience

Crash Dump

https://drive.google.com/drive/folders/0B76hhQgc047_czlNWW81SGF1c1U?usp=sharing

 

Share this post


Link to post
Share on other sites
2 hours ago, Neil Kerman said:

Dear Great and Honorable JPLRepo

I have been a fan of this mod for a very long time and am in a bit of a pickle. This mod works great in 1.1.3 but when I boot it up with 1.2.2 the game crashes while loading. Here is the crash dump, I am using version 1.4.

Please reply at your earliest convenience

Crash Dump

https://drive.google.com/drive/folders/0B76hhQgc047_czlNWW81SGF1c1U?usp=sharing

mono.dll caused an Access Violation (0xc0000005)

Not enough memory try to free some. Also you can reduce texture quality in game launcher (run Launcher.exe there is some gear icon for options) It's works fine for me on 1.3 with ~100 mods.

Edited by kremonia

Share this post


Link to post
Share on other sites
4 hours ago, Neil Kerman said:

Dear Great and Honorable JPLRepo

I have been a fan of this mod for a very long time and am in a bit of a pickle. This mod works great in 1.1.3 but when I boot it up with 1.2.2 the game crashes while loading. Here is the crash dump, I am using version 1.4.

Please reply at your earliest convenience

Crash Dump

https://drive.google.com/drive/folders/0B76hhQgc047_czlNWW81SGF1c1U?usp=sharing

 

V1.4 is for KSP 1.3 not KSP 1.2.2

Share this post


Link to post
Share on other sites

Is there any version for 1.2.2? If so where can it be downloaded?

Edited by Neil Kerman

Share this post


Link to post
Share on other sites

Thank you! :D I really love this mod and the film it's based on!

Share this post


Link to post
Share on other sites

Does anyone have a screenshot of a colony they set up with this mod?

Share this post


Link to post
Share on other sites
On 8/16/2017 at 2:19 PM, kremonia said:

I thought it is a SSTO.

Yes it is for planetary exploration but watch the launch scene and they were clearly launched on a rocket, Because they needed to send 2 at once and why use the ranger fuel to get it to earth orbit? You need that fuel for exploration!

 

Share this post


Link to post
Share on other sites

OK, well then why not use a smaller non-Saturn 5 rocket? I don't think you need a Saturn 5 to get 2 things smaller than a space shuttles into earth orbit

20 hours ago, Pepethecat said:

Yes it is for planetary exploration but watch the launch scene and they were clearly launched on a rocket, Because they needed to send 2 at once and why use the ranger fuel to get it to earth orbit? You need that fuel for exploration!

 

 

Edited by Neil Kerman

Share this post


Link to post
Share on other sites
On 8/24/2017 at 0:25 AM, Kilo60 said:

Who said you can't use a rocket to get both Rangers in KLO...!

 

F3CA9B5E6892613CD731EBA99031FA00587689ED

I never said you can't. I said I would like the Adapter so I can launch them on a Saturn V and make it look like the same thing in the movie.

 

On 8/20/2017 at 6:37 PM, Neil Kerman said:

OK, well then why not use a smaller non-Saturn 5 rocket? I don't think you need a Saturn 5 to get 2 things smaller than a space shuttles into earth orbit

 

Because in the movie they clearly had funding issues and stuff since ya know... The earth is dying and all.. So they didn't have the money to research a new rocket system that could lift the weight of 2 Rangers into orbit.. So they used the Old Saturn V Rocket. Plus 2 rangers are heavy. The shuttle had engines on it so it kinda lifted itself and all.. Rangers didn't. The rangers are also packed with food, supplies, water.. 4 Cryogenic Beds.. People, Computers, and all that... 

 

I just realized your description for your profile... XD

 

Share this post


Link to post
Share on other sites

Using v1.2 on KSP 1.2.2 in RSS&FAR conditions, the ranger is totally unflyable. Even the slightest yaw would cause it enter some uncontrollable spin. I wanna ask if this problem is noticed and/or solved in the latest version.

Share this post


Link to post
Share on other sites
7 hours ago, mark7 said:

Using v1.2 on KSP 1.2.2 in RSS&FAR conditions, the ranger is totally unflyable. Even the slightest yaw would cause it enter some uncontrollable spin. I wanna ask if this problem is noticed and/or solved in the latest version.

Please use the latest version of this mod for and in KSP 1.3. Your issues have likely been fixed. (The crafts all seem fine to me)

Share this post


Link to post
Share on other sites

I have this idea for a project involving this mod but would like advice

I am trying to do a shot for shot remake of Interstellar, wherein during scenes that were impossible or incredibly difficult to replicate in game I would sub in the original footage from the film, eg the final scenes in Cooper Station, and will for dialogue/soundtrack simply sub in the audio from the original film

Any advice?

on an unrelated note

On 8/25/2017 at 6:35 PM, Pepethecat said:

I never said you can't. I said I would like the Adapter so I can launch them on a Saturn V and make it look like the same thing in the movie.

 

Because in the movie they clearly had funding issues and stuff since ya know... The earth is dying and all.. So they didn't have the money to research a new rocket system that could lift the weight of 2 Rangers into orbit.. So they used the Old Saturn V Rocket. Plus 2 rangers are heavy. The shuttle had engines on it so it kinda lifted itself and all.. Rangers didn't. The rangers are also packed with food, supplies, water.. 4 Cryogenic Beds.. People, Computers, and all that... 

 

I just realized your description for your profile... XD

 

The Rangers do have their own engines, though I would concede that the earth's imminent death might have slowed p RnD a mite

Edited by Neil Kerman

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.