Jump to content

[1.10.X] Kerbal Planetary Base Systems v1.6.12 [14. July 2020]


Recommended Posts

42 minutes ago, overkill13 said:

Almost every mod I use has multiple folders for parts.  Some for different part categories, others for different vehicles within the mod itself.

Really? Oh. Alright then. I guess I pay more attention to KPBS's setup than those other mods' then. Pay no attention to me!

Link to post
Share on other sites
10 hours ago, Merkov said:

Really? Oh. Alright then. I guess I pay more attention to KPBS's setup than those other mods' then. Pay no attention to me!

I must correct myself.  I reread your comment and had another look at the folder structure in KPBS.  It is indeed unusual, but not unheard of, to split the mod inside itself BEFORE setting up parts folders.

Edited by overkill13
Link to post
Share on other sites
4 hours ago, overkill13 said:

I must correct myself.  I reread your comment and had another look at the folder structure in KPBS.  It is indeed unusual, but not unheard of, to split the mod inside itself BEFORE setting up parts folders.

I still stand by my previous "pay no attention to me" statement.

Link to post
Share on other sites
On 7/19/2017 at 10:06 AM, Nils277 said:

@Bishiba Just tried this out and for me the CO2 Harvester works as intended. Also i can't really see the reason for the 5% load. For me the Harvester started at around 75% on duna. What version of KPBS do you have? There was a version some time ago where the efficiency of the convertes and harvesters depended on whether there are engineer on board and how skilled they are. This is not the case for the latest versions though.

Hi, latest version of KSP and also the related mods. Does the co2 vary on different biomes? Do i need another mod that adds different atmospheric biomes?

Link to post
Share on other sites
21 hours ago, Bishiba said:

Hi, latest version of KSP and also the related mods. Does the co2 vary on different biomes? Do i need another mod that adds different atmospheric biomes?

I don't know of any mod that does change the atmosphere depending on atmosphere. One reason already mentioned might be your difficulty settings. Do you have a higher difficulty setting for resource abundance than normal? When you set the resources abundance to be lower than normal than there is the chance that you had bad luck and the co2 on Duna was randomly chosen in your save to be quite low. 

 

Link to post
Share on other sites

@Nils277, Good day.

I'm starting a new playthrough and i've been checking your mods. Question though, regarding the main big mods. I wanted to replicate Sir Scott Manley's playthrough and then some so i'm making a set of mods. I was thinking USI, NearFuture, B9, Extra Planetary, ScanSat, Karbonite, Strategia so on. I wanted to ask if there's known issues "Game Breaking issues" on them working together at this version of your mod and can you recommend additional mods that compliments my set including yours. ^.^ . Oh and i've been getting this hatch obstructions, wondering if you know what's causing these weird interactions.

Link to post
Share on other sites
7 hours ago, Beetlecat said:

In the OP:

 

Hello

This one is working great with 1.3 and last releases of KPBS and MKS. I'm currently building an münar hybrid base with KPBS and MKS.

But, caution all KPBS modules deployments are now charged as MKS do. Also, one great thing is the docking ports in the KPBS form factor (both standard and construction one) giving my modular base a great looking (sent a vessel with an engineer to change the docking ports).

See you,

Vive_moi

Link to post
Share on other sites
21 hours ago, LittleAlienDude said:

@Nils277, Good day.

I'm starting a new playthrough and i've been checking your mods. Question though, regarding the main big mods. I wanted to replicate Sir Scott Manley's playthrough and then some so i'm making a set of mods. I was thinking USI, NearFuture, B9, Extra Planetary, ScanSat, Karbonite, Strategia so on. I wanted to ask if there's known issues "Game Breaking issues" on them working together at this version of your mod and can you recommend additional mods that compliments my set including yours. ^.^ . Oh and i've been getting this hatch obstructions, wondering if you know what's causing these weird interactions.

There are no game breaking issues with MKS I know of. To make KPBS and MKS work together you need the MKS patch mentioned in the OP under 'Supported Mods'.

Can you remind me under which circumstances and for which parts the obstruction happens? I can't remember that issue to be honest 

Link to post
Share on other sites
6 hours ago, Vive_moi said:

This one is working great with 1.3 and last releases of KPBS and MKS. I'm currently building an münar hybrid base with KPBS and MKS.

But, caution all KPBS modules deployments are now charged as MKS do. Also, one great thing is the docking ports in the KPBS form factor (both standard and construction one) giving my modular base a great looking (sent a vessel with an engineer to change the docking ports).

Just to be clear: The KPBS form factor docking port is from the base mod.  The construction version of it is from the integration pack.

And KPBS by itself is balanced with regards to USI-LS - it's parts just don't have any use in the MKS system besides looking pretty.  :wink:  The integration pack aims to change that - though it's not fully finished.   (I tend to work on things when they impact me, and my 1.3 career hasn't advanced to the point where I'm deploying KPBS parts...)

Link to post
Share on other sites
19 minutes ago, DStaal said:

Just to be clear: The KPBS form factor docking port is from the base mod.  The construction version of it is from the integration pack.

Oh, I had a look to my save. The standard docking port is not visible because not researched yet. But, the construction docking port has been available as soon as installed the pack. That's why I guessed the docking ports were from the pack, just not unlocked by the same tech node.

See you,

Vive_moi

Link to post
Share on other sites
6 minutes ago, Vive_moi said:

Oh, I had a look to my save. The standard docking port is not visible because not researched yet. But, the construction docking port has been available as soon as installed the pack. That's why I guessed the docking ports were from the pack, just not unlocked by the same tech node.

See you,

Vive_moi

Something's screwy there then - it should be available in the same node as the original.  (I literally don't touch that.)

Link to post
Share on other sites

@DStaal There is something strange in my install. In the KPBS cfg, the K&K docking port is under UnmannedTech as it must be. But, in the game it is under advUnmannedTech. However, the K&k Construction Docking port is correctly placed in the UnmannedTech node.

I don't why. Perhaps a mod is modifying the original one but not the inherited one.

Thanks for your answer.

Vive_moi

Link to post
Share on other sites
18 minutes ago, Vive_moi said:

@DStaal There is something strange in my install. In the KPBS cfg, the K&K docking port is under UnmannedTech as it must be. But, in the game it is under advUnmannedTech. However, the K&k Construction Docking port is correctly placed in the UnmannedTech node.

I don't why. Perhaps a mod is modifying the original one but not the inherited one.

Thanks for your answer.

Vive_moi

Hmm.  Looking things over - KPBS has a CTT config, which probably don't get applied to the construction variants.  That's probably what's going on.

(Now my question is what's the best fix...)

Link to post
Share on other sites

@DStaal I tired this at the end of the Construction_port.cfg (just after the NEEDS:[ConnectedLivingSpace])

@PART[KKAOSS_MKSAddon_Construction_Port]:NEEDS[CommunityTechTree]
{
    @TechRequired = advMetalworks
}

@PART[KKAOSS_MKSAddon_Construction_Port_Habitat]:NEEDS[CommunityTechTree]
{
    @TechRequired = advUnmanned
}

Now the construction ports are placed with the KPBS ones.

If that helps. :-)

Vive_moi

Link to post
Share on other sites

Yep, that's one fix.  Whether it's the best is the question - it then requires me to keep track of where the docking ports are placed, and update my configs if they get moved.  :wink:  (And if something else moves them they might not be moved as well.)

I'm thinking if I put in :AFTER[PlanetarySurfaceStructures] on the creation nodes (the +PART line), then they'll get moved automatically in most cases.

Link to post
Share on other sites
2 hours ago, DStaal said:

Yep, that's one fix.  Whether it's the best is the question - it then requires me to keep track of where the docking ports are placed, and update my configs if they get moved.  :wink:  (And if something else moves them they might not be moved as well.)

I'm thinking if I put in :AFTER[PlanetarySurfaceStructures] on the creation nodes (the +PART line), then they'll get moved automatically in most cases.

The only other decent alternative I can think of is having a seperate CTT config for the integration patch, but that requires manually editing nodes every time there's a change in the KPBS side. Not that those should be terribly frequent anymore.

Link to post
Share on other sites
  • 2 weeks later...

Weird  -My KSP AVC is telling me I'm out of date with this mods version 1.45 and I should update to 1.5. Did I miss an update somewhere as Github only shows 1.45.

Or have stuffed my KSP install somehow?

Edited by wile1411
Link to post
Share on other sites

Update to 1.5.0

Features

qnGccIJ.png

Changelog

Quote

General:

  • Updated CRP

New Parts:

  • Added parts for a nuclear reactor (3x)
  • Added flatbed part

Mod Support:

  • Added Scrap Metal Storage for Extraplanetary Launchpads
  • Added support for OSE-Workshop
  • Added support for Ground Construction
  • The Electron and Carbon Extractor can now optionally dump oxygen when TAC-LS is used
  • Updated support for CLS and CTT

Bug Fixes:

  • Fixed missing translation bugs (translation pending)
  • Fixed ISRU (and other parts) not being accepted for contracts (will only affect new contracts)

Download

qYx9XCm.png%5D m2mGwCV.png yF5F5Cc.png

@wile1411 You didn't do anything wrong. I just pushed the changes for 1.5.0 too early on github before making the official release :wink: 

Edited by Nils277
Link to post
Share on other sites

Played around a bit with Gimp to "enhance" the screenshot used for the main image in the OP:

Before:

bayFEql.png

After:

2SFzY3Y.png

What do you think?

Edited by Nils277
Link to post
Share on other sites

@Nils277 Just a heads up I've asked the people on the Near Future thread for help in troubleshooting the NF reactor patch supplied with this update. I've posted a screenshot and log file in this post if you would like to have a look there?

When using just NF and KPBS together I get a massive log spam about "GUI error on screen about pushing more GUIClips than you are popping"

The Reactor GUI doesn't function correctly and shows nothing other than a grey box..

Link to post
Share on other sites
3 hours ago, Nils277 said:

Played around a bit with Gimp to "enhance" the screenshot used for the main image in the OP:

Before:

bayFEql.png

After:

2SFzY3Y.png

What do you think?

While the one on the bottom is beautiful, if I were coming in to look at the mod I wouldn't trust it - it's obviously been manipped, and therefore may not be representative of the mod.  The original I'd trust quite a bit more, as it looks like a screen shot from the game.  (It's also less 'noisy', in that all the details are the parts which we're looking at, instead of the terrain which is just a distraction.)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...