Jump to content

[1.10.X] Kerbal Planetary Base Systems v1.6.12 [14. July 2020]


Recommended Posts

My computer is ready for a 64-bit system. Can you tell me if I can play the MOD after my computer has risen to 64 bits?

Processor AMD Athlon II X2 250 dual core
Video card ATI Radeon 3000 Graphics
4 GB of memory

Edited by happliy
Link to post
Share on other sites

@Nils277 Apparently I need 5 posts to pm you which I don't have, so I'm going to link the files here, sorry:( Base only file for VAB is there. Also the save file named 1 is in full sized RSS mod, Moon Base Alpha is the base that I showed at imgur post, I don't know if it will work for you because of RSS. Base already has a level 4 engineer and transferring en u worked for me as intended.

Base Files

Thanks again!

Link to post
Share on other sites
4 hours ago, Nils277 said:

@Mr. Truffles Regarding the reactor. Do you have NFE installed? The NFE version of the reactor uses cumstom modules to generate power. Maye TAC-LS does not recognize them. The reactor turning off might also be a problem that it automaticalls shuts down when it overheats.

@Nils277 Thanks a lot for your quick reply! I dont have NFE installed, so that should not be the problem. I have a LOT of other mods installed though, so it would of course be possible that one of them messes with your reactor.

Also, overheating should not be an issue. I tested the reactor quite extensively in sandbox mode on two bases on Laythe and Minmus. Both have more than enough radiators to keep the reactor running. At least i did not encounter any issues when i timewarped for days and weeks. I also did a quick test on the launchpad with too little cooling to see how it looks like when the reactor overheats. Thats not what happens on Laythe and Minmus. Also, the two bases are totally fine when i switch to them. The Laythe base for example has a battery capacitiy of around 15000 electric charge. When TAC-LS tells me it is running out of power and i switch over, the batteries are completely full and the reactor is running fine. If the base was really running out of power they should be at least partly empty. I mean, the reactor is powerfull, but not powerfull enough to recharge those batteries in that one second it takes me to check on them. And as soon as i switch to another vessel the clock for energy remaining on TAC-LS is ticking down again, as if the Laythe base had no energy production at all.

I will fiddle around with it a bit more, maybe i can find the issue. Thanks again for this great mod, very nice work!

Edited by Mr. Truffles
Link to post
Share on other sites

Thanks for the work you do on KPBS! I consider your mods a must-have in my stock KSP game. However, I was wondering, could you please create an analog for EPL's space based parts? EPL is also a must have feature for KSP, however, it's packaged models for the orbital construction/recycling/etc... are so bad. I adore your work so much, i'd even be willing to donate to patreon if you could create some EPL analog parts for the orbital construction.

Thanks for all your hard work!

Link to post
Share on other sites
8 hours ago, Jalaris said:

Thanks for the work you do on KPBS! I consider your mods a must-have in my stock KSP game. However, I was wondering, could you please create an analog for EPL's space based parts? EPL is also a must have feature for KSP, however, it's packaged models for the orbital construction/recycling/etc... are so bad. I adore your work so much, i'd even be willing to donate to patreon if you could create some EPL analog parts for the orbital construction.

Thanks for all your hard work!

This mod already has some EL parts for ground-based construction.  Space-based construction would be out of scope for this mod: It's *planetary* base systems, after all.

Might I suggest the mod below?  It hasn't seen any updates since 1.2.2 - but it's just a parts mod, so it hasn't needed any:

 

Link to post
Share on other sites
On 30.10.2017 at 11:43 AM, happliy said:

My computer is ready for a 64-bit system. Can you tell me if I can play the MOD after my computer has risen to 64 bits?

Processor AMD Athlon II X2 250 dual core
Video card ATI Radeon 3000 Graphics
4 GB of memory

Should not be a big problem. Though 8+ Gb of memory is recommended for both x64bit system and heavily modded game.

Link to post
Share on other sites
On 30.10.2017 at 10:20 AM, RexPowerColt said:

@Nils277 Apparently I need 5 posts to pm you which I don't have, so I'm going to link the files here, sorry:( Base only file for VAB is there. Also the save file named 1 is in full sized RSS mod, Moon Base Alpha is the base that I showed at imgur post, I don't know if it will work for you because of RSS. Base already has a level 4 engineer and transferring en u worked for me as intended.

Base Files

Thanks again!

Thanks. I found the reason for the issue and will make a release with a fix for the transfer of depleted fuel soonTM

On 30.10.2017 at 1:06 PM, Mr. Truffles said:

@Nils277 Thanks a lot for your quick reply! I dont have NFE installed, so that should not be the problem. I have a LOT of other mods installed though, so it would of course be possible that one of them messes with your reactor.

Also, overheating should not be an issue. I tested the reactor quite extensively in sandbox mode on two bases on Laythe and Minmus. Both have more than enough radiators to keep the reactor running. At least i did not encounter any issues when i timewarped for days and weeks. I also did a quick test on the launchpad with too little cooling to see how it looks like when the reactor overheats. Thats not what happens on Laythe and Minmus. Also, the two bases are totally fine when i switch to them. The Laythe base for example has a battery capacitiy of around 15000 electric charge. When TAC-LS tells me it is running out of power and i switch over, the batteries are completely full and the reactor is running fine. If the base was really running out of power they should be at least partly empty. I mean, the reactor is powerfull, but not powerfull enough to recharge those batteries in that one second it takes me to check on them. And as soon as i switch to another vessel the clock for energy remaining on TAC-LS is ticking down again, as if the Laythe base had no energy production at all.

I will fiddle around with it a bit more, maybe i can find the issue. Thanks again for this great mod, very nice work!

Seems weird. I really sounds like a problem of TAC-LS. Or the system that runs the resources in the background. Even small foating point errors might cause this when run for a longer time. 

Link to post
Share on other sites
5 hours ago, Nils277 said:

Thanks. I found the reason for the issue and will make a release with a fix for the transfer of depleted fuel soonTM

Seems weird. I really sounds like a problem of TAC-LS. Or the system that runs the resources in the background. Even small foating point errors might cause this when run for a longer time. 

I'm having the same problem with fuel cells and mining in the Mun. The fuel cells and mining can keep the EC at 95% all the Mun night, but when I warp from the launchpad the EC drains out in 1 day and kill the kerbals. When I go check it, the EC is at 95% and fuel are full. Solar panels updates without problems.

Any sugestions? :(

EDIT: seems that TAC-LS dont suport fuel cells at all, the main page says it supports only solar panels and generators. I will try to add a RTG and see how it works. Not a problem with KPBS at all. I find it one of the best mods.

As a sugestion for this limitation with TAC-LS, you could add a modular RGT for the bases, with around 5 or 6 EC/s.

TqecLMn.png

ecnWjWH.png

Edited by kerbalfreak
Link to post
Share on other sites

The RTG solved the EC problem, but now other resorces drops during time-warp from the Space Center or other vessels, and even dont save the wastes properly... With the base loaded I can warp for years without any resource changing.

Is this suposed to happen with TAC-LS or I'm having a bug?

Link to post
Share on other sites

@Mr. Truffles and @kerbalfreak 
So you say that that the resources (especially EC) deplete on the vessel when the vessel is not active and you timewarp, e.g. when you timewarp at the KSC. BUT it only depletes for TAC-LS, meaning that TAC-LS thinks that the resources are depleted but the resource are still there when you switch to the vessel in question.
E.g, TAC-LS says that the vessel/base runs out of food but when you switch to it, the food is still there. Is that right?

@kerbalfreak What do you mean by "and even dont save the wastes properly" does this mean that the waste does not only deplete for TAC-LS but is also depleted when you switch to the vessel?

I think maybe @JPLRepo can shed some light on the TAC-LS behaviour?

Link to post
Share on other sites
3 hours ago, Nils277 said:

@Mr. Truffles and @kerbalfreak 
So you say that that the resources (especially EC) deplete on the vessel when the vessel is not active and you timewarp, e.g. when you timewarp at the KSC. BUT it only depletes for TAC-LS, meaning that TAC-LS thinks that the resources are depleted but the resource are still there when you switch to the vessel in question.
E.g, TAC-LS says that the vessel/base runs out of food but when you switch to it, the food is still there. Is that right?

@kerbalfreak What do you mean by "and even dont save the wastes properly" does this mean that the waste does not only deplete for TAC-LS but is also depleted when you switch to the vessel?

I think maybe @JPLRepo can shed some light on the TAC-LS behaviour?

Seems that TAC-LS simple don1t support fuel cells, only solar panels and generators. I solved this problem adding a big RTG. I will send some printscreens of the resources:

First one, from the base (The "Kebin-Mun Base", the second one is not supposed to be self-sustaining) :
 

Spoiler

nz17Tte.png

After I warp for almost a year. Only water changes a little because of the 95% cap of the drill (if I remove the water it fills up again) :
 

Spoiler

Cln4LV0.png

When I try to warp from the Launch Pad or other vessel:
 

Spoiler

khhdz6A.png

When I get back to the base, I found this. Food has dropped, and even havent left no waste behind. CO2 stays up all the time, and has some WasteWater.
 

Spoiler

OVxhSjc.png.


If I warp for half a year away from the base it kills everyone. I'm taking a look at  USI-LS, the counter don't consider the resources recyclers, but when I return to the base everything is calcule correctly, self-sustaining or not. Still not ideal, but usable. Will take a look at Kerbalism.

Link to post
Share on other sites
15 hours ago, Nils277 said:

@Mr. Truffles and @kerbalfreak 
So you say that that the resources (especially EC) deplete on the vessel when the vessel is not active and you timewarp, e.g. when you timewarp at the KSC. BUT it only depletes for TAC-LS, meaning that TAC-LS thinks that the resources are depleted but the resource are still there when you switch to the vessel in question.
E.g, TAC-LS says that the vessel/base runs out of food but when you switch to it, the food is still there. Is that right?

@kerbalfreak What do you mean by "and even dont save the wastes properly" does this mean that the waste does not only deplete for TAC-LS but is also depleted when you switch to the vessel?

I think maybe @JPLRepo can shed some light on the TAC-LS behaviour?

That is correct. I personally only encountered that behaviour with EC and only with the KPBS nuclear reactor, though i have to admit that i very rarely use anything other than solar panels and RTGs. So it might just be a problem with depletable energy resources in general. If that is the case it most likely has to be a problem with TAC-LS. I will go and test that a bit more as soon as a have the time.

Link to post
Share on other sites

@Nils277 

Patch for KPBS Greenhouse's ScienceExperiment to USI LS  Greenhouses is something like that

Spoiler
@PART[*]:HAS[@MODULE[ModuleResourceConverter_USI]:HAS[#ConverterName[Agroponics]]]:NEEDS[USILifeSupport,PlanetaryBaseInc]
{
    &MODULE[ModuleScienceExperiment]
	{
		name = ModuleScienceExperiment
		experimentID = KPBS_plantgrowthstudy
		experimentActionName = #LOC_KPBS.greenhouseexperiment.conduct
                resetActionName = #LOC_KPBS.greenhouseexperiment.discard
		reviewActionName = #LOC_KPBS.greenhouseexperiment.review
		useStaging = False
		useActionGroups = True
		hideUIwhenUnavailable = True
		xmitDataScalar = 0.4
		FxModules = 0
		dataIsCollectable = True
		collectActionName = #LOC_KPBS.greenhouseexperiment.collect
		interactionRange = 1.2
		usageReqMaskInternal = 1
		usageReqMaskExternal = 8
	}

    &MODULE
	{
		name = ModuleScienceContainer
		reviewActionName = #autoLOC_502201
		storeActionName = #autoLOC_502202
		collectActionName = #autoLOC_238018
		evaOnlyStorage = True
		storageRange = 2.0
	}
}

 

 

Edited by flart
Link to post
Share on other sites

I am confused on how to set up a base properly. I have everything I need, I line up the parts with each piece having a docking port, but then when they dock, one side ends up crooked and off of the ground. I have to individually retract each landing gear to even the part out, and then they dock uneven and crooked.

Link to post
Share on other sites

Hey Nils, or DStaal I suppose, would you guys have readily available the expanded volume of all the KPBS parts?  I'm trying to do a balance pass on Dstaal's configs for USI-LS and MKS and the volume of the parts is a pretty critical component of it all.

Edited by tsaven
Link to post
Share on other sites
On 14.11.2017 at 9:38 PM, tsaven said:

Hey Nils, or DStaal I suppose, would you guys have readily available the expanded volume of all the KPBS parts?  I'm trying to do a balance pass on Dstaal's configs for USI-LS and MKS and the volume of the parts is a pretty critical component of it all.

I never really calculated the volumes of the parts. But the patch for Kerbalism contains the volumes in the PlanetaryBaseInc\ModSupport\Configs\Kerbalism\KPBS_MM_Kerbalism_Habitation.cfg file. I think they were done by @schrema. At least that what was said in the pull request :wink: 

Edited by Nils277
Link to post
Share on other sites
7 hours ago, Nils277 said:

I never really calculated the volumes of the parts. But the patch for Kerbalism contains the volumes in the PlanetaryBaseInc\ModSupport\Configs\Kerbalism\KPBS_MM_Kerbalism_Habitation.cfg file. I think they were done by @schrema. At least that what was said in the pull request :wink: 

Awesome!  Glad that someone else has done the legwork on this.  It looks like the numbers he came up with are only slightly larger than what I had guessed at by eyeballing it, so I'm going to recalculate my figures based off of his calculations.

Once I run it by DStaal you can expect a PR from me with updated configs for USI-LS.

Link to post
Share on other sites

Nils

i know that it has been asked before, but if you can put it on your list of improvements I’ll appreciate it. I think we need a structural part in Kbps shape that can be stacked (or procedurally change length) to allow modules to have the same size. Very useful if you are building a symmetrical base. Currently I solve my issue by installing multiple Kbps control modules, so while not a perfect solution a similar part to the control module without the sas function is all we need if we make it passable and cls compliant.

Link to post
Share on other sites

Does anyone else want to chime in on these revised balance numbers for USI-LS?  There's a good deal of nerfing going on due to the physically small size of the units, but some do get buffed a little. 

https://docs.google.com/spreadsheets/d/1vQYEpfq3YMRCbIYQUJdH_hyT2GsjzMR_nPrIBD7Seb0/edit?usp=sharing

Open to input on how things that can be changed are adjusted, for example less multiplier in exchange for more throughput on the Greenhouse.

Edited by tsaven
Forgot the link...
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...