Jump to content

[1.11.X] Kerbal Planetary Base Systems v1.6.13 [23. April 2021]


Recommended Posts

 

6 minutes ago, SpaceSecks said:

I'm a bit confused trying to attach any of the fuel or battery components of the mod, or any of the other pieces that are "half sections" of the other parts. My problem is there is only one attachment point on these part, and it doesn't allow for proper alignment with say, the mk2 habitat module. Like shouldn't the two half parts attach together to make a whole and then be able to attach to the other full size pieces? Am I missing something obvious? Does this question even make sense?

There are frames within this mod which are designed to fit the half pieces.  They have attachment nodes to align these pieces within the frame itself.

Link to post
Share on other sites

Hi. Thank you for the great mod.

I have a question about Kerbalism support. There is a nuclear reactor in this mod which does not have a radiation source attached when Kerbalism is installed. Do you know if anyone has made a fix for this issue previously?

Link to post
Share on other sites

I've noticed that on sprawling bases when landed on non-perfectly-flat spots (e.g. not on Minmus' flats), there are times when I'll come out of time-warp and the base will flip up in the air and crash down and break stuff.  You can also see this effect (although in a smaller  way), by just time-warping briefly.  What I'm seeing is that when you're not time-warping, the ship will flex a bit to conform to the slight variations in the surface.  When you're time-warping, it undoes whatever flexing it did, causing some parts to clip into the surface.  When you come out of time-warp, KSP detects the collision and chucks the clipping part of the base up.

I believe that it's worse when you come back to the ship from, say, a long time warp spent elsewhere.  That'd probably be because of some floating point errors in the calculation of the planet's rotation and the ship's relationship to the planet.

Obviously, this isn't really specific to KPBS - you can also see shenanigans like this with landing struts on other ships.  But it seems to me like with KPBS, the effect is worse just because typical KPBS bases (particularly large sprawling ones like I tend to have), have a large footprint, and so the error gets magnified.

Is there a recommended way to build bases to avoid this sort of problem?  I know that MKS has implemented an "Inertial Dampener" that seems aimed at fixing this sort of thing...

 

Link to post
Share on other sites
22 minutes ago, NermNermNerm said:

Is there a recommended way to build bases to avoid this sort of problem?  I know that MKS has implemented an "Inertial Dampener" that seems aimed at fixing this sort of thing...

I use the USI Inertial Dampener for all my bases, it shows as a "Ground Tether" option in the right click menu. I also avoid warp while in physics range of something on the ground. That's just begging for a Kraken attack. I'll shift focus to a satellite to warp and then come back to the base when done.

I also try to use the KPBS legs so if something explodes on load it's usually just a leg here or there. The only other thing is to try to find the flattest spot possible. It's easy on Minmus plains, but the Mun or Duna  can be really tough. I'll try to keep the base centered an a slight rise, so the edges might be off the ground, but it's better than clipping into the ground.

I use the following patch to add the "Ground Tether" switch to all command modules.

//
// Add USI-Tools Ground Tether option to command modules
@PART[*]:HAS[@MODULE[ModuleCommand],!MODULE[USI_InertialDampener]]:FINAL
{
    MODULE
    {
	name = USI_InertialDampener
    }
}

 

Link to post
Share on other sites
  • 2 weeks later...
  • 3 weeks later...

Hello! I am having a problem with some parts from KPBS. When I was running a previous version of this mod (1.45 I think), after updating the game to 1.7.3 the deployable parts ceased to deploy: the greenhouse, the habitat and science lab. Kerbals could get in, but their IVA was all clipped and glitched. Everything else worked fine.

Now I downloaded the newest version of the KPBS mod (1.7.2), the deployable parts deploy again (yay!), but everything else stopped working. The recyclers don't recycle, the algae farm doesn't algae anymore and all the greenhouse modules from this mod decided to take a permanent vacation from all that food growing stuff. I'm using USI Life Support, which has been working brilliantly alongside KPBS' older version.

--------------------------------------------------------------------------------------------------------------------------------------------------------------------
Nope, I found the source of the problem and the solution before I finished writing. Versions of Kerbal Planetary Base Systems and USI Life Support have to match in order to be able to cooperate. My USI version was outdated, that's why the recyclers and greenhouses didn't work. Perhaps this will help other people who are as dumb as me. :P

Allow me to take this opportunity to thank the creators and maintainers of this mod. I use a bunch of part mods, but the parts provided by Kerbal Planetary Base Systems are definitely the most beautiful and fun parts to play with. <3

Edited by Aelipse
Link to post
Share on other sites

Thank You for this great mod! I installed it yesterday via CKAN (together with the two Community Packs) and I´m already designing a new station for Duna. It makes a lot of fun!

But getting deeper into using the parts of this mod, I experience some parts missing.
For example there is no K&K Bi- and Tri-coupler, no attachable landing gear, central hub and landing controls.

Do I need some other mod in order to let these parts appear or do I overlook some central point here.
I use the last KSP version 1.7.3.2594 and play in career mode.

If needed I can provide more details about other mods or the exact amount of missing parts.

Thank You for Your help in advance!

 

Link to post
Share on other sites
18 minutes ago, Dacemotion said:

Thank You for this great mod! I installed it yesterday via CKAN (together with the two Community Packs) and I´m already designing a new station for Duna. It makes a lot of fun!

But getting deeper into using the parts of this mod, I experience some parts missing.
For example there is no K&K Bi- and Tri-coupler, no attachable landing gear, central hub and landing controls.

Do I need some other mod in order to let these parts appear or do I overlook some central point here.
I use the last KSP version 1.7.3.2594 and play in career mode.

If needed I can provide more details about other mods or the exact amount of missing parts.

Thank You for Your help in advance!

 

You may not have the research nodes that those items are in unlocked yet since you are in career mode

Link to post
Share on other sites
  • 2 weeks later...

Hello - love the mod! thanks! Only strange thing I'm seeing is that the K&K Flexible Corridor ports will only connect with other identical ports  but not with normal K&K Docking-Ports. This seems to be backwards of what the descriptions says. I'm running the laterst version of KPBS 2.3.7.1.5

This is ok for me if intended. I use this in combination with MKS, but did spend some time not understanding why it wasn't working the way it should have until I tried connecting 2 corridors together. Or is this a bug with MKS? or am I doing something wrong?

Edited by Atlas Gaming
Link to post
Share on other sites
  • 1 month later...

How do you guys connect your "modules" once you've landed them on a planet? Seems like unless I put these things on wheels its gonna be hard to line up docking ports. 

Also how do you guys land your planetary bases? I tried the meerkat engines (one on the front and one on the back) and my lander turned into a pinwheel over the mun, lol. 

Thanks guys. :) Sorry I'm a noob.

Link to post
Share on other sites
3 hours ago, radni said:

How do you guys connect your "modules" once you've landed them on a planet? Seems like unless I put these things on wheels its gonna be hard to line up docking ports. 

Also how do you guys land your planetary bases? I tried the meerkat engines (one on the front and one on the back) and my lander turned into a pinwheel over the mun, lol. 

Thanks guys. :) Sorry I'm a noob.

There's wheels as part of the pack, specifically for that type of docking.  ;)  Note that docking on the ground is difficult if the ground isn't exactly level, as it's harder to line the docking ports up exactly.

I've landed them fine with the Meerkats - you just need to make sure you've got the base balanced with the center of thrust under the center of mass.  (And that you don't *move* the center of mass as your fuel tanks empty...)  TCA can help, though a couple of Twitch or Spider engines can be useful with TCA or it won't have full control.

Link to post
Share on other sites

I usually incorporate Extraplanetary Launchpads and build my base in stages on the surface. Can take longer but somewhat more satisfying, having to mine and process resources to get what you need.

Link to post
Share on other sites
54 minutes ago, Pleb said:

I usually incorporate Extraplanetary Launchpads and build my base in stages on the surface. Can take longer but somewhat more satisfying, having to mine and process resources to get what you need.

I haven't used EL in ages. Is it pretty stable?

Link to post
Share on other sites
2 hours ago, Starwaster said:

I haven't used EL in ages. Is it pretty stable?

Fairly, I build a massive base in the VAB, break it into pieces and put wheels on them (and a probe core to control said pieces, pretty sure it's part of this mod) and then build the pieces at the base using stakes. Then wheel them to where they need to go and connect. Then take the wheels and probe cores off and recycle!

Link to post
Share on other sites
  • 2 weeks later...
18 hours ago, Marjammer said:

Just out of curiosity, is an update for 1.80 coming?

Yes, i'm already working on the update and try get have a running version soonTM  ;) 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...