Nils277

[1.7.X] Kerbal Planetary Base Systems v1.6.9 [25. April 2019]

Recommended Posts

Posted (edited)

I've ran into issues with the mod too after updating to 1.7. When I tried to load some saved bases I had built in the SPH using KPBS parts, while that base was loading I got errors that some of those parts were missing and sure enough, when the base loaded, some parts were missing from it. So for me to get those bases back like they were when I built them, I'm going to have to wait for this mod to update. Got a couple of other mods that also not playing nice but all this is to be expected every time KSP updates when you are running mods. With this aggressive schedule Squad has in updating this game, the mods are practically always in a state of flux trying to catch up to the game version.

Edited by MikeO89

Share this post


Link to post
Share on other sites

Any word on the 1.7 update?

 

Waiting to deploy my base to Duna...

Share this post


Link to post
Share on other sites
6 hours ago, Kilo60 said:

Any word on the 1.7 update?

 

Waiting to deploy my base to Duna...

let Nils work at his own pace, he does this for free. it is also frown upon in this forum. It will be ready soon 

Share this post


Link to post
Share on other sites

Anyone else having the issue that the Expandable Habitat, Laboratory, and the Greenhouse do not have the option of deploying. They are just always tucked in. Playing on 1.7 by the way.

Share this post


Link to post
Share on other sites
4 minutes ago, Hotdiggitydog said:

Anyone else having the issue that the Expandable Habitat, Laboratory, and the Greenhouse do not have the option of deploying. They are just always tucked in. Playing on 1.7 by the way.

KPBS is broken on 1.7 

Share this post


Link to post
Share on other sites
12 minutes ago, Tonka Crash said:

KPBS is broken on 1.7 

Is there any date which it will be fixed? I need to decide whether to revert to 1.6.1 or stay and wait for this to be fixed.

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/20/2019 at 11:47 AM, Hotdiggitydog said:

Is there any date which it will be fixed? I need to decide whether to revert to 1.6.1 or stay and wait for this to be fixed.

[snip] From what I know of the problem it's relatively easy to fix, but the next release of KPBS also relies on new functionality from KAS that is also broken and KAS's mod maker is out of town and unable to fix KAS until his trip is over. This could be another a week.

Edited by Vanamonde

Share this post


Link to post
Share on other sites
Posted (edited)

Since the most recent update for kerbal, I can no longer deploy the modules. at first i thought this was a simple glitch so i uninstalled the mod and reinstalled it, and it still does not allow me to deploy the modules, i can use the different parts just fine, but that is it. please fix, if you need screen shots of the problem let me know. thanks!

 
 
Edited by blaze214263

Share this post


Link to post
Share on other sites

Some posts have been removed or edited. 

Guys, asking about mod updates is not against any rules. It's only a problem if it's done rudely or repetitively. And even then, what we ask you to do is report such posts to the moderators so that we can deal with it rather than grousing at each other and making newbies feel unwelcome. 

Share this post


Link to post
Share on other sites

I know there is always growing pains after each update. Just how it is when using mods. I find I keep the main version updated to latest and use it mainly to see what Squad has thrown down the pike. Since I refuse to play without my chosen mods, the newest version doesn't always play nice with mods (as in this case) until the mods get updated (if they do). So for the ones that do, I'll patiently wait cause I gotta have em. For my main squeeze, I still have my trusty copy of 1.4.3 that remains my favorite. That is the one I still play (and don't touch) for the best stability and speed (and it plays well with all my mods). No other versions I've played play as smooth as 1.4.3 so I'll keep it forever.

Share this post


Link to post
Share on other sites

Update to 1.6.9

Changelog:

Quote

General:

  • Recompile for KSP 1.7.0 (thanks to @Tonka Crash), the Modules now work again!

Mod Support

  • Highly improved support for KAS with the flexible tube (thanks to @IgorZ), it behaves like the old version now.

Download:

oYvtZpW.pngUVVt0OP.pnglMOxt2k.png

Share this post


Link to post
Share on other sites

Thank you. New version works perfect in KSP 1.7. Your work is much appreciated. You rock.

Share this post


Link to post
Share on other sites

Ok. So I have been playing Kerbal Space Program for years. (Still pretty junk at it to be honest. But I get it done eventually.) However I recently started looking into mods and came across this one. The prospects this offers is amazing. So I downloaded it (and a bunch of other mods.) Went into the game and got a bunch of errors (caused by other mods like Chatterer which is currently broken.) So I went through and just wiped put the game data folder completely and validated game files to redownload them. Then reinstalled this mod alone to try it before moving on to the next mod. But it wont work

 Game works perfect. Loads quickly. No issues. But none of these parts or anything are available. Went instantly to sandbox mode to test the parts and learn about them. I want to get this mod and intersteller expanded to work before I stream this on twitch again. Please help!!

Share this post


Link to post
Share on other sites
Posted (edited)

Yes indeed I did. I went through and read quite a few things to ensure i wasnt wasting anyone's time. After all, Research is the lifeblood of a scientist. After finding no fixes and ensuring that everything i was supposed to have done was in fact done. I came to forums. Thank you for the welcome. I am wiping the data folder now and redownloading everything to try again.

Edited by Glitchiethedragon
added more and added thank you

Share this post


Link to post
Share on other sites
15 minutes ago, Glitchiethedragon said:

Yes indeed I did. I went through and read quite a few things to ensure i wasnt wasting anyone's time. After all, Research is the lifeblood of a scientist. After finding no fixes and ensuring that everything i was supposed to have done was in fact done. I came to forums. Thank you for the welcome. I am wiping the data folder now and redownloading everything to try again.

ok. so it turns out that even though I have an IQ of 146. I can still be very...very.....Very Dumb. lol. Turns out i was installing the mod [and apparently all other mods] into the wrong folder as I was installing them under Steamlibrary>common>kerbalspaceprogram>gamedata>squad

for anyone that comes after me with this issue. back up one folderand install them under gamedata not squad. I feel so dumb now lol. but live and learn

Share this post


Link to post
Share on other sites

i have the newest version of ModuleManager AND Kerbal Planetary Base Systems, but it dont work! I Have also tried installing it with CKAN, but there i cannot even select to download the mod! Please help, the mod look amazing!!!

Share this post


Link to post
Share on other sites
17 minutes ago, FracxPlayz said:

i have the newest version of ModuleManager AND Kerbal Planetary Base Systems, but it dont work! I Have also tried installing it with CKAN, but there i cannot even select to download the mod! Please help, the mod look amazing!!!

Can you give more detail please? Like WHERE you are installing it to?

Share this post


Link to post
Share on other sites
3 hours ago, GamerGuest64 said:

I just wanted to make sure, is this mod compatible with CTT?

Did you read the first post in this thread? CTT is listed under the supported mods. 

Share this post


Link to post
Share on other sites
19 hours ago, Tonka Crash said:

Did you read the first post in this thread? CTT is listed under the supported mods. 

I tend to be blind. Thanks.

Share this post


Link to post
Share on other sites
On 5/4/2019 at 1:36 PM, stali79 said:

Can you give more detail please? Like WHERE you are installing it to?

yes. i have tried installing it manually, in the GameData Folder, and i followed a toturial on yt where to install CKAN ( in the Kerbal Space Program Folder ) and i have tried to download the zip from different websites, and reinstalling the game. 

Share this post


Link to post
Share on other sites
29 minutes ago, FracxPlayz said:

yes. i have tried installing it manually, in the GameData Folder, and i followed a toturial on yt where to install CKAN ( in the Kerbal Space Program Folder ) and i have tried to download the zip from different websites, and reinstalling the game. 

I install 99% of my mods with CKAN including KPBS. You need to provide more information than "it dont work".

All mods go under GameData. You also have to have all the dependencies installed like ModuleManager.

Kerbal Space Program\GameData\Mod1
Kerbal Space Program\GameData\Mod2
Kerbal Space Program\GameData\Mod3
Kerbal Space Program\GameData\PlanetaryBaseInc (<== this mod)
...
Kerbal Space Program\GameData\Squad
Kerbal Space Program\GameData\SquadExpansion
...
Kerbal Space Program\GameData\ModuleManager.4.0.2.dll

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.