Nils277

[1.7.X] Kerbal Planetary Base Systems v1.6.9 [25. April 2019]

Recommended Posts

On 21.1.2018 at 1:11 AM, AlliedForth said:

I don’t know when or why you deleted the flexible corridors/tubes, but i just downloaded the new version and i miss them. 

Any chance to put them in again? Or went something wrong?

The ones changig their size should be in the mod. This should not have changed. Maybe you can try to redownload the mod. Or are they still locked in the TechTree?

22 hours ago, MK Ultra said:

Hi i am wondering if anyone has a fix for why the parts supplied by this mod are highlighted in light blue when I load a craft in situ. This is extremely obnoxious and requires hovering the mouse over the parts for the highlighting to go away. Thanks for any suggestions!

That one was a giant DERP from my side. I forgot to remove some testing code from the converter module which highlights all parts with a converter. I fixed it in my dev. version already but did not have the time yet to make an official update yet. Will do so soon.

Share this post


Link to post
Share on other sites

Thanks for the reply, sadly i (literally) broke  my wifi adapter, so i cant redownload it at the moment. I doubt something went wrong with the download making only this one part disappear, since i dont use ckan or something. Probably some other mod is corrupting it, i’ll see what causes the problem.

Could you give me the name of the part which should be able to extend a tube from it so i don’t accidentally try it with the wrong one?

 

Thx for your reply, awesome mod!

Share this post


Link to post
Share on other sites
9 hours ago, AlliedForth said:

Thanks for the reply, sadly i (literally) broke  my wifi adapter, so i cant redownload it at the moment. I doubt something went wrong with the download making only this one part disappear, since i dont use ckan or something. Probably some other mod is corrupting it, i’ll see what causes the problem.

Could you give me the name of the part which should be able to extend a tube from it so i don’t accidentally try it with the wrong one?

 

Thx for your reply, awesome mod!

It is named "K&K Flexible Corridor". I just forgot, this part is only available when you have the "Kerbal Attachment System"(KAS) Mod installed. Maybe this is the problem

Update to 1.5.9

Changelog:

Quote

General:

  • Updated CCK to version 0.8.0.0

Localization:

  • Fixed cropped text for russian KSPedia. Thanks to @Sebra

Enhancements:

  • The storage of nuclear fuel can now transfer to all nuclear fuel storage instead of KPBS only

Bug Fixes:

  • Fixed erroneously blue highlighting of the converter

Download:

oYvtZpW.png UVVt0OP.png lMOxt2k.png

Share this post


Link to post
Share on other sites

You have a GameData directory inside the GameData directory, that surely is wrong. The "PlanetaryBaseInc" folder needs to be on the same level as "BetterTimeWarp" and "Community Tech Tree" from your screenshot.

Modders sometimes include the GameData directory in the download as a reference point, you only have to install the subdirectories then.

Share this post


Link to post
Share on other sites

Good day. I met some problem with mode connected with items purchasing. Due to unknown reason some modules appeares twice in research tree node and buying this module in R&D doesn't make it available for using during ship building. Example: here. Also some modules also appeares twice or thrice but are availble for buying. Carreer was started approximately in summer with previous KPBS version, I tried to update mode but it didn't solve the problem. So if there are any possible solutions for this problem or I just have to start new carreer?

Thanks.

Share this post


Link to post
Share on other sites

Well, don't know how to delete post, so here the solution:

Spoiler

1. Copy needed saves to another place, fully deinstall the game and mods and install game & mods again.

2. Open .sfs file and find in "Tech" all information about modules that appeares in file multiple times (in one "Tech" section). Delete all occurences of such items.

3. Calculate MD5 of .sfs file and write it to .loadmeta file.

4. Return files back to "saves" folder of game, load game.

Problem was only with KPBS items, no any other items (even from modes) cause such problems, so - maybe it's possible to create some protection against this (multiple records about one item in Tech part of save)?

Share this post


Link to post
Share on other sites
11 hours ago, sky_kell said:

Good day. I met some problem with mode connected with items purchasing. Due to unknown reason some modules appeares twice in research tree node and buying this module in R&D doesn't make it available for using during ship building. Example: here. Also some modules also appeares twice or thrice but are availble for buying. Carreer was started approximately in summer with previous KPBS version, I tried to update mode but it didn't solve the problem. So if there are any possible solutions for this problem or I just have to start new carreer?

Thanks.

This is unfortunately an old and know bug that i'm not able to fix because it is a bug from KSP itself that surfaces in some corner cases. This bug is caused in the career and science mode when you play a mod that has support for one of the TechTree mods (e.g. Community Tech Tree). When you play one of these two modes and install or uninstall one of the TechTree mods then some parts are moved into other nodes in the TechTree. However KSP does not delete them from the old Node which causes some parts to appear multiple times depending on how often you installed /uninstalled a mod for the Tech Tree.

This cannot be fixed once it appeared. You'd have to start a new career to get rid of it. To prevent this from happening again i would advice to not install/uninstall mods for the TechTree too frequently or to make sure that you always use the same mod every time you play career/science mode. 

Edited by Nils277

Share this post


Link to post
Share on other sites

I am getting back into installing KSP, and MM spits out an error on load:

[ERR 11:40:26.064] [ModuleManager] Error - more than one pass specifier on a node: PlanetaryBaseInc/ModSupport/Configs/LifeSupport/KPBS_MM_TAC_LS/@PART[KKAOSS_Habitat_MK2_g]:FOR[PlanetarySurfaceStructures]:AFTER[TacLifeSupport]

[ERR 11:40:26.068] [ModuleManager] Error - more than one pass specifier on a node: PlanetaryBaseInc/ModSupport/Configs/LifeSupport/KPBS_MM_TAC_LS/@PART[KKAOSS_Habitat_MK1_g]:FOR[PlanetarySurfaceStructures]:AFTER[TacLifeSupport]

[ERR 11:40:26.070] [ModuleManager] Error - more than one pass specifier on a node: PlanetaryBaseInc/ModSupport/Configs/LifeSupport/KPBS_MM_TAC_LS/@PART[KKAOSS_Central_Hub]:FOR[PlanetarySurfaceStructures]:AFTER[TacLifeSupport]

It happens on line 14323 in the log.

Mods by directory (sub directories of GameData):
  000_TexturesUnlimited
  000_USITools
  ASET
  CommunityCategoryKit
  CommunityResourcePack
  CxAerospace
  EnvironmentalVisualEnhancements
  JSI
  KerbetrotterLtd
  ModRocketSysLite
  MunarIndustries
  NearFutureConstruction
  NearFutureProps
  NearFutureSpacecraft
  Nereid
  PlanetaryBaseInc
  REPOSoftTech
  ScifiVisualEnchancements
  Squad
  StationPartsExpansionRedux
  ThunderAerospace
  TriggerTech
  UmbraSpaceIndustries
  UniversalStorage

 

Windows 10 Enterprise, KSP 1.3.1.1891 (WindowsPlayer x64) en-us.

Is it something I should worry about and is there any further information you need right now?

Share this post


Link to post
Share on other sites

@Freshmeat I see in your log that you use version 1.5.7 of this mod. The bug you encountered has been fixed in version 1.5.8. It should be fixed if you download and install the latest version :wink: 

Share this post


Link to post
Share on other sites

Oops :blush: Thanks, solved it. This is why I am a bit reluctant to initiate my Eve mission, I know I am gonna miss something absolutely obvious.:confused:

Share this post


Link to post
Share on other sites

I may be missing it but I can't seem to find the part that connects two "halves" together. In the mission to Eve images there seems to be a way to dock two pieces together to make it fit a rocket. Can't seem to find that piece anywhere. Thanks! I'm sure I'm just overlooking it.

Share this post


Link to post
Share on other sites
8 hours ago, xlilcasper said:

I may be missing it but I can't seem to find the part that connects two "halves" together. In the mission to Eve images there seems to be a way to dock two pieces together to make it fit a rocket. Can't seem to find that piece anywhere. Thanks! I'm sure I'm just overlooking it.

I guess you are referring to the Bi-Coupler. It's icon is a black disk, which I too find hard to locate. There's also an Tri-Coupler. I'm using version 1.5.5, can't say if there's a problem with more recent ones.

FqPdTOh.pnggna9Bjp.pngMIfdnnP.png

Share this post


Link to post
Share on other sites

Filter Extensions

makes finding things like that a snap, and it just happens that this mod adds its own custom category to make it even easier!

Edited by TK421d

Share this post


Link to post
Share on other sites

The only real annoyance I have with this mod is that if I use a part from it on something that isn't base, say if I use the MAL computer on an interplanetary vehicle, the game keeps resetting its icon to a base icon. I get that it should default to that after launch, but it's impossible to change it permanently. Any chance you could fix that?

Share this post


Link to post
Share on other sites

Hi @Nils277! Many thanks for the mod.

I'm using it with USI-LS, and noted that the Algae Farm has 2 modes, dry and wet. It's possible/supposed to make self-sustaining bases with the dry mode, or it only increases the time the supplies will last?

Also, there are many parts that are hidden if you don't use certain mod's, would be nice to include some pics of them to the imgur album. I'm considering to use Extraplanetary Launchpads or OSE Workshop just for the parts KPBS has for them, that I discovered just recently. That would show the full potential and content of this great mod.

Share this post


Link to post
Share on other sites

I know that you need tac or anything else for the greenhouse but do we need a life support mod installed? rn I'm using kerbalism

Share this post


Link to post
Share on other sites
10 hours ago, Katieop3 said:

I know that you need tac or anything else for the greenhouse but do we need a life support mod installed? rn I'm using kerbalism

No, it can work without any other mod, you'll only lose some parts that will become hidden. The parts adapts related to the mods you are using, right now it supports all the relevant life-support mods for KSP. The patches for Kerbalism is the GameData\PlanetaryBaseInc\ModSupport\Configs\Kerbalism folder. Like this one for habitation:

 

Spoiler

//-------------The Habitat MK2-----------------
@PART[KKAOSS_Habitat_MK2_g]:FOR[PlanetarySurfaceStructures]:NEEDS[Kerbalism&FeatureHabitat]:AFTER[Kerbalism]
{
    @MODULE[Habitat]
    {
        volume = 16.56
        surface = 23.29
        //inflate = Habitat_MK2_deploy
        state = disabled
    }
    //!MODULE[PlanetaryModule]:HAS[#animationName[Habitat_MK2_deploy]] {}
}

//-------------The Laboratory-----------------
@PART[KKAOSS_Science_g]:FOR[PlanetarySurfaceStructures]:NEEDS[Kerbalism&FeatureHabitat]:AFTER[Kerbalism]
{
    @MODULE[Habitat]
    {
        volume = 19.32
        surface = 27.17
        //inflate = Science_Deploy
        state = disabled
    }
    //!MODULE[PlanetaryModule]:HAS[#animationName[Science_Deploy]] {}
}

//-------------The Greenhouse-----------------
@PART[KKAOSS_Greenhouse_g]:FOR[PlanetarySurfaceStructures]:NEEDS[Kerbalism&FeatureHabitat]:AFTER[Kerbalism]
{
    @MODULE[Habitat]
    {
        volume = 23.19
        surface = 32.61
        //inflate = Greenhouse_Deploy
        state = disabled
    }
    //!MODULE[PlanetaryModule]:HAS[#animationName[Greenhouse_Deploy]] {}
}

//-------------The Control Room-----------------
@PART[KKAOSS_Control_g]:FOR[PlanetarySurfaceStructures]:NEEDS[Kerbalism&FeatureHabitat]:AFTER[Kerbalism]
{
    @MODULE[Habitat]
    {
        volume = 3.68
        surface = 7.76
    }
}

//-------------The Cupola-----------------
@PART[KKAOSS_Cupola_g]:FOR[PlanetarySurfaceStructures]:NEEDS[Kerbalism&FeatureHabitat]:AFTER[Kerbalism]
{
    @MODULE[Habitat]
    {
        volume = 2.45
        surface = 5.17
    }
}

//-------------The Freezer-----------------
@PART[CRY-5000Freezer]:FOR[PlanetarySurfaceStructures]:NEEDS[Kerbalism&FeatureHabitat]:AFTER[Kerbalism]
{
    @MODULE[Habitat]
    {
        volume = 7.36
        surface = 15.53
    }
}

//-------------The Habitat MK1-----------------
@PART[KKAOSS_Habitat_MK1_g]:FOR[PlanetarySurfaceStructures]:NEEDS[Kerbalism&FeatureHabitat]:AFTER[Kerbalism]
{
    @MODULE[Habitat]
    {
        volume = 7.36
        surface = 15.53
    }
}

//-------------The Central Hub-----------------
@PART[KKAOSS_Central_Hub]:FOR[PlanetarySurfaceStructures]:NEEDS[Kerbalism&FeatureHabitat]:AFTER[Kerbalism]
{
    @MODULE[Habitat]
    {
        volume = 22.08
        surface = 23.56
    }
}

//-------------The Airlock-----------------
@PART[KKAOSS_airlock_mid_g]:FOR[PlanetarySurfaceStructures]:NEEDS[Kerbalism&FeatureHabitat]:AFTER[Kerbalism]
{
    @MODULE[Habitat]
    {
        volume = 1.84
        surface = 3.88
    }
}

//-------------The Airlock End-----------------
@PART[KKAOSS_airlock_end_g]:FOR[PlanetarySurfaceStructures]:NEEDS[Kerbalism&FeatureHabitat]:AFTER[Kerbalism]
{
    @MODULE[Habitat]
    {
        volume = 1.71
        surface = 3.62
    }
}

 

Share this post


Link to post
Share on other sites

As the others said, great thanks for the awesome mod :)

 

And a question/suggestion: what about adding support for the Hangar mod so that stuff we put in KPBS existing hangar doesnt stress the system?

Much thanks :)

 

Share this post


Link to post
Share on other sites

Hey guys, I'd posted about this before a few months ago and I finally got around to double-checking all of my calculations to make sure it all made sense.

I've submitted Pull Requests to re-balance the KPBS parts for USI-LS.  As it currently stands they are very over-powered (and over-heavy) when compared to everything else in the USInivers, my tweaks will bring them into line with RoverDude's balance guidelines (which are available here: https://docs.google.com/spreadsheets/d/1ZI_0InZjd1tfrNDj8RWq45W6cg1UDm6BAkn2jB18Tsk/edit?usp=sharing)

I'm very open to suggestions, I made decisions on trade-offs based partially on what made sense to me, but also from discussions that I read in the KPBS/MKS thread.  Some things (Such as balancing Kerbal Months Vs Mulitplier vs Supplies storage) are kinda fuzzy on intentions so I made my best guess, and I'm very open to debate on them.

You're welcome to check out my Pull requests, or look at my spreadsheet of notes here: https://docs.google.com/spreadsheets/d/1vQYEpfq3YMRCbIYQUJdH_hyT2GsjzMR_nPrIBD7Seb0/edit?usp=sharing

*Edit* @DStaal, if you're active these days this might impact you. 

Edited by tsaven
Calling DStaal

Share this post


Link to post
Share on other sites

I've played around with the 2 major base-building mods that add significant gameplay elements, i.e. MKS and Pathfinder, but in the end, I think KPBS with TAC-LS and EL is really going to be the right level of complexity for me to actually play a career save to my designated "end." On that note I'm going to start a career save with KPBS and FUR for the first time, despite having admired them for a long time but always felt like I "needed" to have a Pathfinder or MKS style mod. 

Having actually installed them for the first time, I just wanted to commend you on the really nice and clean parts and textures, excellent part descriptions, and the relative simplicity of the parts catalog. You've covered pretty much everything that I'll need without too much parts bloat, which I greatly appreciate. 

Looking forward to this save a lot.

Share this post


Link to post
Share on other sites

Hello all,

I cant seem to transfer Kerbals out of the deployable Modules such as the K&K Planentary Habitat MK2.  I can transfer the crew in, but then i cant transfer them out.  The only buttons that appear are: 1. Turn lights on 2. Crew Report 3. (Kerbal's Name)'s Inventory. 

Share this post


Link to post
Share on other sites

@Potatogunmishap @Nils277: sounds like KPBS doesn't tell the part to update. I suggest taking a look at the recent updates to the Tokamak Industries habitat dll (I fixed that problem for those inflatables).

Edited by taniwha

Share this post


Link to post
Share on other sites

@Potatogunmishap @taniwha Hmm, it seems i totally missed that this option was added to the right click menu of the parts. Will take a look at the fixed dll from the Tokamak Industries Habitat and will try to fix that. 

@Potatogunmishap Until this is fixed you can use the right-click menu of the hatches (the ones which allow you to put a kerbal on EVA) to transfer the kerbals to other parts of the vessel.

Share this post


Link to post
Share on other sites
1 minute ago, Nils277 said:

@Potatogunmishap @taniwha Hmm, it seems i totally missed that this option was added to the right click menu of the parts. Will take a look at the fixed dll from the Tokamak Industries Habitat and will try to fix that. 

@Potatogunmishap Until this is fixed you can use the right-click menu of the hatches (the ones which allow you to put a kerbal on EVA) to transfer the kerbals to other parts of the vessel.

Thank you sir!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.