Nils277

[1.8.X] Kerbal Planetary Base Systems v1.6.10 [29. October 2019]

Recommended Posts

41 minutes ago, MasterRevolution said:

mod doesnt crash when I use it alone, but when I use it with SCANsat. Is something wrong with my game or are these two arent compatible together?

I haven' heard that both mods are not compatible. In facts KPBS has config file to interoperate with SCANsat. Can you post a log about this here? (like said above, a link to the log). I need the KSP.log file from KSP main directory after you started KSP with both mods and it crashes.

What happens when you only use SCANsat?

@Snark

Sorry about that foolish advice, you are totally right :wink:  

Share this post


Link to post
Share on other sites

Hello!

First of all I want to say that you have a pretty nice mod, very versatile and with many parts.

This summer I have some free time and if you want i could translate your beautiful mod into Italian. It is my native language, but I also know English pretty well.

I know many people could find this useful, and if you tell me that I can start translating, I'll do my best!

Best regrards

Marzio

Share this post


Link to post
Share on other sites
9 hours ago, Nils277 said:

@ASlyGuy So i looked at the your log and i would really recommend to remove all mods and install all of them again from scratch (or even maybe reinstall KPS as a whole) and make sure all the mods are explicidly supporting KSP 1.3.0.
There are really A LOT of errors and exceptions.

E.g. TAC life support and Kerbal Alarm Clock are spamming the log with errors because of serious errors and there are a whole lot of problems loading some libraries a the beginning. Additionally you seem to have multiple version of some dlls in your installations...e.g. two times the ModuleManager.dll. You only need the one dll for modulemanager. You posted that you have the folders

CKAN - master
Module Manager
ModuleManager-master

These folders are not needed. And actually shouldn't be there are all.
The last thing is, the PlanetarySurfaceStructures.dll from this mod can't be loaded. It is most likely that multiple of your mods are not compatible with KSP 1.3.0 or you have multiple versions installed that might or might not support 1.3.0.

So you'd have to make a complete reinstall of all the mods. This might fix the problem.

Thanks heaps

Share this post


Link to post
Share on other sites

Hi, love the mod. But the basic mechanics of things aren't very well explained in the instructions at aaall.

How the heck do I attach two modules together with the corridor pieces? I can attach the corridor to one module just fine, but at that point I can't do anything but move it back and forth between the two modules I want to actually connect.

Do I really need to specifically install a corridor docking port on the end of the corridor and the second module? If so, why can't that be made easier? You're never going to want to do anything with a corridor but use it to connect to something(s), I question the hassle/design choice of requiring 2-4 extra parts just to do the basic function the 1-piece corridor is meant to fulfill.

I really hope there's a simpler way to do this that just isn't clear, I flew all the way to Minmus multiple times with these base sections and all sorts of spare part, but it never even crossed my mind that I'd need "docking" to manually attach a corridor during EVA :/

*edit* I've thought about it more while waiting for this post to be moderated, and that can't be the way it's done. I have to be missing something right? How do people make long corridors if you have to slap two docking ports on each piece, that'd be ridiculous. Or alternately force you to build everything in the VBA, which seems to blow apart the entire premise of this KPBS/KIS/KAS informal modpack and what it's supposed to let you do with EVA building. I can't for the life of me figure out what the feature I'm missing here is, though.

Edited by AngryH

Share this post


Link to post
Share on other sites
4 hours ago, AngryH said:

Hi, love the mod. But the basic mechanics of things aren't very well explained in the instructions at aaall.

How the heck do I attach two modules together with the corridor pieces? I can attach the corridor to one module just fine, but at that point I can't do anything but move it back and forth between the two modules I want to actually connect.

Do I really need to specifically install a corridor docking port on the end of the corridor and the second module? If so, why can't that be made easier? You're never going to want to do anything with a corridor but use it to connect to something(s), I question the hassle/design choice of requiring 2-4 extra parts just to do the basic function the 1-piece corridor is meant to fulfill.

I really hope there's a simpler way to do this that just isn't clear, I flew all the way to Minmus multiple times with these base sections and all sorts of spare part, but it never even crossed my mind that I'd need "docking" to manually attach a corridor during EVA :/

This mod adds no new mechanics to the game.  Attaching corridors is exactly the same as attaching any other parts in stock.  (Or KAS, in the case of the Flexible Corridor.)

Share this post


Link to post
Share on other sites
15 minutes ago, DStaal said:

This mod adds no new mechanics to the game.  Attaching corridors is exactly the same as attaching any other parts in stock.  (Or KAS, in the case of the Flexible Corridor.)

You're going to have to be clearer, sorry. I don't understand the way you're using "mechanics." I can't manually attach anything or do any kind of construction with an EVA naut in stock, so yes I would certainly say it's adding a new mechanic.

How exactly are you meant to assemble a base on-site using corridors? Are my only two choices really to just build it in the VBA to begin with, or triple the parts required by adding TWO docking ports on each corridor I'm hooking up during EVA construction?

*edit* Oh I get it. You're taking issue with the fact that I'm conflating KPBS and KAS/KIS. They're heavily promoted as a trio on the mod site, and I use them that way. So my original question still stands, with those three mods, what's the intended way to build an on-site base with corridors during EVA.

Edited by AngryH

Share this post


Link to post
Share on other sites
1 hour ago, AngryH said:

You're going to have to be clearer, sorry. I don't understand the way you're using "mechanics." I can't manually attach anything or do any kind of construction with an EVA naut in stock, so yes I would certainly say it's adding a new mechanic.

How exactly are you meant to assemble a base on-site using corridors? Are my only two choices really to just build it in the VBA to begin with, or triple the parts required by adding TWO docking ports on each corridor I'm hooking up during EVA construction?

*edit* Oh I get it. You're taking issue with the fact that I'm conflating KPBS and KAS/KIS. They're heavily promoted as a trio on the mod site, and I use them that way. So my original question still stands, with those three mods, what's the intended way to build an on-site base with corridors during EVA.

Just those three mods?  Docking - just like if you wanted to build a base using stock parts, docking port to docking port.  Or have lots of Kerbals on hand to help lift things into place via KIS.  (More Kerbals will help each other lift.)  Again, just like with stock parts.  There are other mods out there which can help with more permanent docking, or with helping lifting things into place, if you want.  This mod just adds some nice parts.

You appear to be thinking this mod will do something special with those corridors - it doesn't.  They are just parts like any other.  Attaching/detaching, assembly, etc. are all done exactly the same as with any other part.

Share this post


Link to post
Share on other sites

I don't use KAS/KIS, but I also don't really use the corridors from this mod. I dock modules together. I don't see the corridors as even needed, because if things are attached on both ends, they look pretty much the same to the stock structural fuselage. For me the best parts are the extendable motorized wheels, the extendable modules, the flat bottom modules, and the greenhouse/algae farm/life support stuff that also more or less fits a 2.5m profile.

I haven't had any need of corridors - excepting the corridor with landing leg mounts, that i used as a structural piece - and also the corridors with multiple nodes that changes appearance based on attached nodes.

I also haven't used the garage parts because they don't fit in a mk3 cargobay (and fitting in a mk3 cargobay is very appealing to me). I haven't used the service bay because I don't care about aerodynamics for the base parts, and I couldn't make any useful vehicle that I could store in & deploy from it.

Pics of stuff I made with this mod:

Spoiler

W7Eh37s.png

F8OOX3t.png

^ Same base connected slightly different, delivered with a different dropship... and fueling a large tanker:

jNCY8La.png

One of the few bases I made that wasn't designed to be delivered inside a mk3 bay (aside from the core module, additional modules were delivered by skycrane, which is still attached to one of the modules in this image), also one of the few to make use of the landing engines in this pack:

nTX6baf.png

an early experiment with mk3 cargobay modules, using the 4 way corridor: 

gdP6hnf.png

and early experiments with deliverable modules, using corridors with wheels on one end - I was able to eliminate this by having a detachable trolley at the front once I found the extendable wheels were powerful enough to slowly push the module the final few meters once the trolley at the front was removed:

Vz624C5.png

and lastly, an example of use of these parts outside of the context of surface bases:

0WUX3Ah.png

 

 

Share this post


Link to post
Share on other sites

@AngryH Like @DStaal already said, when you want to create a large base on site (which is the most common case) you have to create multiple smaller sections, fly them to the desired location and connect them via docking ports. Its the same way as KSP works all the time. You can use the docking ports from the Konstruction mod to weld the ports once they are connected and reduce the partcount. You can also use the K&K Flexible Corridor which is added when KAS is installed. With this part you can do exactly what you want on EVA with a Kerbal. (It works the same way as the fuel pipes from KAS).

One question though, where exactly did you get the information about the " KPBS/KIS/KAS informal modpack"?

@Jeb is never wrong That would be really cool! :) 

Share this post


Link to post
Share on other sites
56 minutes ago, Jeb is never wrong said:

Sorry if I'm bothering you, but what do you mean with "After spinning of the caravan branch"?

 

The context is probably helpful.  That's in '#LOC_KPBS.agency.desc'

And I think he probably meant 'After spinning off the caravan branch' - The company used to make both caravans (mobile homes) and spaceships, but has separated into two businesses, this one being the larger/keeping the name/etc.

Share this post


Link to post
Share on other sites
7 minutes ago, DStaal said:

The context is probably helpful.  That's in '#LOC_KPBS.agency.desc'

And I think he probably meant 'After spinning off the caravan branch' - The company used to make both caravans (mobile homes) and spaceships, but has separated into two businesses, this one being the larger/keeping the name/etc.

Thanks

Share this post


Link to post
Share on other sites

@Jeb is never wrong It's like @DStaal said. "K&K Advanced Orbit and Surface Structures" is a big company that had branches (or one can also say departments or business units) doing different things. One of those branches was creating caravans, but was separated into another company or sold to another company (that is left unclear), so that "K&K Advanced Orbit and Surface Structures" can focus on making bases.

I accidentally made a typo in that text, this will be fixed in the next update. 

Edited by Nils277
removing typo in the word "typo"

Share this post


Link to post
Share on other sites

I have a problem with Kerbal Planetary Base Systems and any help would be appreciated.

For some exposition, I'm constructing a Mun Base. I recently landed my first crew in a Mk 1-2 command module from the stock game. I was easily able to explore the area with my rover, plant flags, and get back into the cockpit. When I try to put my Kerbonauts into the KPBS habitation module however, I can't seem to get into the vessel. Whether I attempt to enter through the airlock or side door, nothing happens. How can I get inside?

Thanks for the help.

Share this post


Link to post
Share on other sites
On 6/29/2017 at 11:13 PM, MCSquared said:

I have a problem with Kerbal Planetary Base Systems and any help would be appreciated.

For some exposition, I'm constructing a Mun Base. I recently landed my first crew in a Mk 1-2 command module from the stock game. I was easily able to explore the area with my rover, plant flags, and get back into the cockpit. When I try to put my Kerbonauts into the KPBS habitation module however, I can't seem to get into the vessel. Whether I attempt to enter through the airlock or side door, nothing happens. How can I get inside?

Thanks for the help.

Is the module expanded? Can you post picture of ship? Do you have CLS installed? Also does the stock grab, board menu selections appear when you are near the doors?

Share this post


Link to post
Share on other sites

Okay - a simple if stupid question. I have landed a garage on the Mun with a rover inside. The ramp is down...how do I unlock the rover so that it drives out? My wheels just spin :/

Share this post


Link to post
Share on other sites
5 minutes ago, OscarJade said:

Okay - a simple if stupid question. I have landed a garage on the Mun with a rover inside. The ramp is down...how do I unlock the rover so that it drives out? My wheels just spin :/

How did you attach it?  Ideally you attached it with a decoupler or docking port, so you detach it by releasing them.   If not...  Well, you might see if you can detach it via KIS.

Share this post


Link to post
Share on other sites

Well, I had it attached at the rear of the garage with an adapter that comnected the garage to the decoupler...I decoupled the decoupler, then decoupled the adaptor. My ramp is open and so is the back of the garage now. But I'm stuck in the garage spinning my wheels. 

The last time I tried to load KAS/KAS, post 1.3, the game crashed during loading :/ Guess I can try it again. 

Share this post


Link to post
Share on other sites
3 minutes ago, OscarJade said:

Well, I had it attached at the rear of the garage with an adapter that comnected the garage to the decoupler...I decoupled the decoupler, then decoupled the adaptor. My ramp is open and so is the back of the garage now. But I'm stuck in the garage spinning my wheels. 

The last time I tried to load KAS/KAS, post 1.3, the game crashed during loading :/ Guess I can try it again. 

Ok, so it sounds like you've actually decoupled and are just stuck - got any pics?  I'm guessing you've got a rover that's slightly to big somehow, or you're not lined up to exit.  (Hard to tell, since you haven't told us anything about the rover.)

Share this post


Link to post
Share on other sites

It's a Lynx in a double-length K&K garage. I reverted the flight and am now just troubleshooting on the runway.

Will try to provide a pic.

10 minutes ago, DStaal said:

Ok, so it sounds like you've actually decoupled and are just stuck - got any pics?  I'm guessing you've got a rover that's slightly to big somehow, or you're not lined up to exit.  (Hard to tell, since you haven't told us anything about the rover.)

Share this post


Link to post
Share on other sites
13 minutes ago, DStaal said:

Steam actually doesn't put up great-quality pics, so it's a bit hard to see the details here.  Is there something on the roof of your rover?  It looks like there might be - and that could be your problem, if it's wedged in.

Yeah...embarrassingly I have a magnetometer that might be sticking...but I would have expected at least some lateral wiggling if that were the only issue. Still, I'll remove it and see.

EDIT: Nope, not the issue. The garage simply won't let me go.

Edited by OscarJade

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.