Jump to content

How to make Emissive Animations in KSP with the Color Animation Editor


Recommended Posts

2 hours ago, nli2work said:

Yea. I did some more tests and your methods definitely give a better results. Far as "spill over" it's the Emissive map multiplied to Emissive Color. Pushing Emissive Color past one increases channel value of non-0 pixels in the Emissive map till it's 1, beyond which it's clipped to 1, until your emissive color value is high enough the entire gradient in emissvive map is 1.

@Porkjet, push for Animator. :D

 

Yep, that's it exactly. :D Something I suggested elsewhere was also to have FXModuleAnimateThrottle capable of animating the emissive itself, with an "emissiveCurve". I have no idea if they'll go that route or not, but it might be simpler to implement. Animator would be good too though! :)

 

Link to post
Share on other sites

Where actually is parttools 1.1? I was well into modding by the time I realized .23 wasn't supposed to work with Unity 5 (a discovery that explained so, so very much in terms of difficulty), and animations have been the final tripping point after convincing everything else to work. My troubles would be over, only I can't actually find parttools 1.1 anywhere. .23 seems to be the newest version available and googling has revealed nothing. Did it ship with 1.1? I never switched to steam. 

 

Edit: Nevermind, turned it up.

Edited by Balto-the-Wolf-Dog
Link to post
Share on other sites

 

nli2work

Thank you so much!

 

 

edited later:

 

On 30.03.2016 at 7:16 AM, martinezfg11 said:

 and when activating one of the emissive animations, it caused some issues. Namely the screen darkened

I have same issue,.. screen darkened. but animation played well.

 

and I noticed a strange shaking at the time of the animation start

Edited by alexustas
Link to post
Share on other sites
47 minutes ago, alexustas said:

 

nli2work

Thank you so much!

 

 

edited later:

 

I have same issue,.. screen darkened. but animation played well.

 

and I noticed a strange shaking at the time of the animation start

I think you have to use the new color animation tool that the 1.1 part tools came with.

By the way, I'm super excited your working on those parts again :).

Link to post
Share on other sites

So I think the issue has to do with adding multiple Emissive Animations per part.. I don't understand how the compiler is supposed to work. I have two different animations that I want to play on different parts but the dark screen issue only happens if the part is the root part... 

Link to post
Share on other sites

 

I looked at the video above. That screen-darkening thing is really strange. I've never seen that. It could be a newer KSP bug... Or maybe there's another mod messing with it? It's as if the ambient light setting for the scene is reverting to some default or something.

 

 

Link to post
Share on other sites
11 hours ago, martinezfg11 said:

So I think the issue has to do with adding multiple Emissive Animations per part.. I don't understand how the compiler is supposed to work. I have two different animations that I want to play on different parts but the dark screen issue only happens if the part is the root part... 

I'll give that a test tonight. I have multiple emissives on same part too, granted one is controlled by module light and not animate generic. Though Alexusta's rover part appears to have only 1 emissive animation, it still darkened the scene.

Edited by nli2work
Link to post
Share on other sites
  • 4 weeks later...

hi all,

i tryed today to make emmisive_color animation with Unity5 for my pod's but probably i dont understand it realy. 

- have only understood the beginning ( first article on this thread)

  but after - include the property and assign it dont work realy ??

 

possible if exist a link of a 'step by step' video ?  (dont found nothing on forum)

would be very grateful !

cheers

Edited by RaendyLeBeau
Link to post
Share on other sites
  • 4 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...