Jump to content

[1.3.0] KSP Chroma Control


FauserneEist
 Share

Recommended Posts

6 hours ago, FauserneEist said:

Sorry, but so far the mod is Windoze only... I can't do anything for mac users because I don't own a mac. Therefore I can't test the code on mac either...

Fine then, I guess I have to build my own windoze PC!

 

(I'm actually about to do that :wink: )

Link to comment
Share on other sites

  • 4 months later...

I just got an Ornata Chroma, and I love it! But...

 

I CAN'T GET THIS GOD FORSAKEN MOD TO SHOW ANYTHING IN-GAME.

I love this mod but even using CKAN, then trying to do manual installation, and both times it just won't work. I've done it with custom lights, and the spectrum cycling, and still, nothing. Can I get any support here?
 

Link to comment
Share on other sites

2 hours ago, YukiSama said:

I just got an Ornata Chroma, and I love it! But...

 

I CAN'T GET THIS GOD FORSAKEN MOD TO SHOW ANYTHING IN-GAME.

I love this mod but even using CKAN, then trying to do manual installation, and both times it just won't work. I've done it with custom lights, and the spectrum cycling, and still, nothing. Can I get any support here?
 

Dear adventurer. Yelling at the developer who spend 50+ hours of his spare time to create this free mod is of course the first step on the magnificent journey of getting excellent support. The next assignment on your quest to achieve a working setup would be to check, that you use the latest KSP version and the latest version of the mod (on github or on curse - special sidequest: find the links in the first post for special kharma). Next you need to make sure, the zip file you downloaded is correctly placed in the right folder (GameData, right next to the Squad folder). Also make sure, you're not using any fancy settings in the Chroma software. The default light setting should work fine. Find out if KSP.exe actually shows up in the list of Chroma enabled applications. If you used all the ingredients correctly, the soup of mod-usage should be ready to consume. Start the game and see if it works. Should this not be the case, collect the game log file from the root folder of the game (output_log.txt) and find a way to get it to the almighty developer (humble me). Ideally thou shalt create a bug report on github but a personal forum telegram might work as well.

Should none of the suggested tasks resolve your predicamet, remember: the support game is one of microtransactions. You can get personal teamviewer support buy just paying 6 euros per five minutes of remote work. While it might seem expensive at first glance, you'll find the market will not spawn much cheaper support for any such problems.

Link to comment
Share on other sites

  • 4 weeks later...
1 hour ago, Rohaq said:

It's still marked as KSP 1.2 max at the moment.

That's because it still is KSP 1.2 max at the moment. For 1.3, it'll be ready when it's ready.

(Don't worry.. I'm hanging on the update too.. but pestering doesn't help.)

Link to comment
Share on other sites

1 hour ago, JAFO said:

That's because it still is KSP 1.2 max at the moment. For 1.3, it'll be ready when it's ready.

(Don't worry.. I'm hanging on the update too.. but pestering doesn't help.)

Ah, I thought it was 1.3.0 compatible, from the topic title.

Link to comment
Share on other sites

27 minutes ago, FauserneEist said:

It actually is compatible with 1.3.0, I didn't know I had to update CKAN. At the moment it is incompatible with the current Razer SDK. I don't know why they don't keep it backwards-compatible...

From reading the CKAN FAQs, I'm not sure; it suggests there are bots that should detect new versions so long as it's hosted on certain sites, but you can also update the ksp_version in the appropriate netkan file on https://github.com/KSP-CKAN/NetKAN - Fork it off, change it, and send a pull request, and then supposedly all you've gotta do is wait.

Link to comment
Share on other sites

5 hours ago, FauserneEist said:

It actually is compatible with 1.3.0, I didn't know I had to update CKAN. At the moment it is incompatible with the current Razer SDK. I don't know why they don't keep it backwards-compatible...

Ahh.. my apologies.. somehow I had it in my head that you were waiting until you had it working again with the current SDK before releasing a 1.3 version. Sorry for any confusion, @Rohaq.

Link to comment
Share on other sites

  • 1 year later...

Help! I Used this mod in version 1.6 and now my keyboard is stuck with qweasd as yellow, 1 as blue, 234 as white, f as pink, x and c as red, and shift as pink! I cant  change it manually in the synapse app! How do I fix this?

Edit: Nevermind, I resolved this problem by moving the .xml file back into the mod file

Edited by JaggedToaster30
Problem resolved
Link to comment
Share on other sites

  • 8 months later...
  • 1 year later...
  • 6 months later...
On 2/5/2021 at 5:29 PM, 53miner53 said:

Can we get support for the headphone stands? It would be nice if it did the same things as a mousepad would.

I think I might be able to do that. *might*

I have just asked @FauserneEistpermission to adopt this glorious mod.

Spoiler

Greetings.

I am asking for your permission to update / continue / adopt / release the above named wonderful mod; unless somebody did already.

...

A posting on the related forum thread would be swell along with thread tagging and telling  @HebaruSan / @DasSkelettabout this adoption so CKAN will be smoothly updated.

Thank you kindly in advance!

KSP Chroma Control:  License MIT 68747470733a2f2f692e706f7374696d672e6363

68747470733a2f2f696d672e736869656c64732e

GitHub

 

Just a heads up. news when there is news.

Link to comment
Share on other sites

  • 1 month later...
  • 3 months later...
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...