ShotgunNinja

[1.3.0] Kerbalism v1.2.9

Recommended Posts

I'm really liking this mod so far, still learning how the basics work.  I've placed a sat with power in roughly a 400x400 Kerbin orbit, and turned all the antennas "relay" feature on.  However in the VAB when I'm creating my next craft, the signal section shows no relay?  Am I missing something? 

Share this post


Link to post
Share on other sites

it is possible, that someone can make a little youtube video to show the mod?

Share this post


Link to post
Share on other sites

What can I do if I want water to be a requirement for my kerbals? Have you thought about doing anything to give us more control over your plugin via config files? Your mod sounds like exactly the life support mod this game always needed, but with a modding community this large and active, it really needs more flexibility. For instance I'd like beer and tacos from KIS to some how keep my kerbals sane on long voyages. 

Share this post


Link to post
Share on other sites

 

@Box of Stardust I have no idea what could be.

 

@jdub3350 The 'relay' you see in the planner tell you if the vessel you are creating has an antenna set as relay.

 

@Fraz86  I'm doing these changes:

  • retractable and non-retractable panels output the same
  • the big fixed panel output 0.32, mass tweaked
  • reduce RTG to 0.32
  • increase small fuel cell to 1.0

The others remain the same, at least for now. I'm also rearranging the MM patches so one can just delete what he don't want. Thanks for the info on NearFuture.

Share this post


Link to post
Share on other sites

I'm having a problem. The food modules don't cost anything. By taking the starting food out, I'm left with negative costs.

Picture --> https://www.dropbox.com/s/l50sryt8v9s61wc/Kerbalism%20Food%20Bug.png?dl=0

KSP_64 Log --> https://www.dropbox.com/s/w1asft3v2fmjdz1/output_log%20%28Kerbalism%20Food%20Bug%29.txt?dl=0

KSP Log --> https://www.dropbox.com/s/2l1ztijcveyck0k/KSP%20%28Kerbalism%20Food%20Bug%29.log?dl=0

Clean, Fresh re-install of KSP. Only running Kerbalism to trace the issue.

 

Edited by Razorfang
Additional info.

Share this post


Link to post
Share on other sites

@CloudyMN1979 You gave me an idea to how I can reorganize the lifesupport. I could create a module, ModuleLifeSupport, that require an arbitrary resource. Then port the existing life support mechanics over there. That way you could implement the Beer and Tacos thing. Also that could be used to water.

 

 

@Razorfang Are you using 0.9.9.0? Please update to current version. Nevermind, saw the log. Will check this.

Edited by ShotgunNinja

Share this post


Link to post
Share on other sites

I'd change the license to GPl or MIT, it isn't the best idea to give everyone your mod and let them say it's theirs, a GPL license will be the same but they can't sell your mod or say it's theirs, and they can still pick it up if you leave.

Share this post


Link to post
Share on other sites

 

@Razorfang I don't understand how its possible your part cost is 0.

 

@legoclone09 I want to not worry about license at all, and the Unlicense seemed just natural.

Edited by ShotgunNinja

Share this post


Link to post
Share on other sites

I don't know either. It's a clean install of KSP with only this and Module Manager installed. After you asked about the version, I tested it on all versions. 9.9.0, 9.9.1, and 9.9.2 all show the same bug for me.

It only happens with the food tanks. The proper price shows in the R&D building before the node is purchased, but then it changes to the cost of the food when the tank is full upon purchase. Tried both 64 and 32 bit versions just to be sure.

Edited by Razorfang
additional information

Share this post


Link to post
Share on other sites

I think I've figured out the bug. The unit cost of the food is 66. The small food can holds up to 100, and the large food can holds up to 500. The part cost on the small can is 5000, and the part cost on the large can is 20000. After playing around with the cfg files I found that when the maximum cost of the contained food exceeds the part cost, the cost defaults to the cost of the currently contained food. If you drag the food slider to 0, you end up with a negative cost. It seems that even though the costs are based around the can half full, the game assumes they are completely full for cost calculations for some reason.

Share this post


Link to post
Share on other sites

Well, I think I broke something important in my save file, because now nothing new I launch has working antennas.

Is there anywhere in the save file that defines the behavior of the antennas, other than the sections of each active part?

I suppose I can just revert the persistence file to one that had working antennas though...

 

Also, another suggestion- instead of having to click the status panel for it to stay open, can you have it so you can hover over the icon, then have the panel stay open as long as the cursor is in it? Like the behavior of the stock Resources tab. 

Edited by Box of Stardust

Share this post


Link to post
Share on other sites

Yeah, To get it to work right now, I just edited the cfgs to default the tanks to full and readjusted the costs accordingly.

Share this post


Link to post
Share on other sites

Might want to double check your download version. Earlier I downloaded one from spacedock and the zip said 9.9.2, but the dll was 9.9.1.

Share this post


Link to post
Share on other sites

@ShotgunNinja no duplicate and I installed only the 0.9.9.2 for the first time , are you looking for the tooltip problem or the error in the log? I'm going to try without mod and see

@Razorfang I checked both from spacedock and github , the zip say 0.9.9.2 but in both cases the dll say 0.9.9.1

Share this post


Link to post
Share on other sites
1 hour ago, ShotgunNinja said:

@Box of Stardust Its supposed to happen already.

You mean the window staying open? It doesn't, unless the icon is clicked to lock the status panel out.

Also, regarding signals being blocked by celestial bodies- I assume this means we won't have control over probes if they're behind a planet. However, this kind of screws up the ability to use even preset maneuver nodes, which is kind of important, and entirely logical that a spacecraft can still maneuver and perform scientific actions on its own if it was programmed to. This also removes the ability to do things like rover missions on the far side of the Mun (unless a relay is in orbit).

Can you change it so that being blocked by a celestial body only restricts data transmission?

Edited by Box of Stardust

Share this post


Link to post
Share on other sites
8 minutes ago, Box of Stardust said:

You mean the window staying open? It doesn't, unless the icon is clicked to lock the status panel out.

Also, regarding signals being blocked by celestial bodies- I assume this means we won't have control over probes if they're behind a planet. However, this kind of screws up the ability to use even preset maneuver nodes, which is kind of important, and entirely logical that a spacecraft can still maneuver on its own if it was programmed to. This also removes the ability to do things like rover missions on the far side of the Mun (unless a relay is in orbit).

Can you instead change it so that being blocked by a celestial body only restricts data transmission?

I never thought of that!  Also are relays possible in this mod as of now?  I haven't tried yet. 

Share this post


Link to post
Share on other sites
Just now, Berlin said:

I never thought of that!  Also are relays possible in this mod as of now?  I haven't tried yet. 

Relays are an option, but so far, I'm trying it out in my old Career save... which, unfortunately, the mod is not exactly backwards-compatible for, so now it's like everything I had in orbit experienced a massive EMP/solar event. :P Old antennas don't work, so everything in orbit is dead.

Fortunately, I've never gotten far enough that I sent stuff out of the Kerbin system, and I sent home all of my crews in anticipation for this mod.

Digression, though. I haven't been able to test relays yet. Now, if I somehow figured out how to get all my antennas working again, I could quickly test it with the given example of rover on far side of Mun and probe relay.

Share this post


Link to post
Share on other sites

@ShotgunNinja great :) , just FYI I tryed without mods and couldnt replicate, I tryed with all mods without Kerbalism because ( I was thining that the error could be triggered when you have already vessel in orbit and add the mod ), but I could not click on the fly button at ALL in the tracking station without your mod, I had to reinstall it to regain control of ships

Share this post


Link to post
Share on other sites
1 minute ago, Box of Stardust said:

Relays are an option, but so far, I'm trying it out in my old Career save... which, unfortunately, the mod is not exactly backwards-compatible for, so now it's like everything I had in orbit experienced a massive EMP/solar event. :P Old antennas don't work, so everything in orbit is dead.

Fortunately, I've never gotten far enough that I sent stuff out of the Kerbin system, and I sent home all of my crews in anticipation for this mod.

Digression, though. I haven't been able to test relays yet. Now, if I somehow figured out how to get all my antennas working again, I could quickly test it with the given example of rover on far side of Mun and probe relay.

So the relay would just consist of another vessel with a working antenna on it acting as a middle man? 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.