ShotgunNinja

[1.3.0] Kerbalism v1.2.9

Recommended Posts

9 hours ago, Risa123 said:

Is any way to turn off timewarp stop because I have big fleet of sats.

you can configure every satellite (in the config tab of kerbalism interface) to stop sending the notifications you don't want to receive (untick battery and signal, basically)

Edited by nanomage

Share this post


Link to post
Share on other sites

Hi,

Is it possible to disable some features and leave others on? For example, use remotetech for communication, and testflight for reliability?

Thanks

Share this post


Link to post
Share on other sites
8 hours ago, tomgle said:

Hi,

Is it possible to disable some features and leave others on? For example, use remotetech for communication, and testflight for reliability?

Thanks

Yes.  In the settings .cfg there are five or so options.  Turn off the ones you wish.  You may find there are unintended consequences with science transmission but I'm not sure!

Actually I think that when RemoteTech installed kerbalism disables its own comm system.

Peace.

Edited by theJesuit

Share this post


Link to post
Share on other sites
4 hours ago, theJesuit said:

Yes.  In the settings .cfg there are five or so options.  Turn off the ones you wish.  You may find there are unintended consequences with science transmission but I'm not sure!

Actually I think that when RemoteTech installed kerbalism disables its own comm system.

Peace.

OK, thanks.

Share this post


Link to post
Share on other sites

Hello

I want to test this mod, and for some reason it closes all Solarpanels from my Satellites. and they battery was empty why this happens?

I have expanded Solarpanels on all my Satellites before, and after removing the mod they stay extended.

 

KSP 1.3 with some other mods!

 

KSP.jpg

 

Edited by SwissSpace93

Share this post


Link to post
Share on other sites
3 hours ago, SwissSpace93 said:

Hello

I want to test this mod, and for some reason it closes all Solarpanels from my Satellites. and they battery was empty why this happens?

I have expanded Solarpanels on all my Satellites before, and after removing the mod they stay extended.

 

KSP 1.3 with some other mods!

 

KSP.jpg

 

I've found that when I first added Kerbalism it had closed all of the solar panels for my ship. This most likely happens because it needs to register the solar panels on all ships when it is first installed, and closes it so it can be registered when you extend it. However, after having extending it once, all solar panels should stay open on further playthroughs.

 

As for EC, that most likely happened because of the solar panel bug. Either send more kerbals to manually open solar panels to charge the crafts again, or edit the config files to add EC.

Share this post


Link to post
Share on other sites
19 hours ago, Zombie_Striker said:

As for EC, that most likely happened because of the solar panel bug. Either send more kerbals to manually open solar panels to charge the crafts again, or edit the config files to add EC.

Or just use the Debug/cheatmenu with alt+F12 and activate infinite electricity for reopen the panels :wink:

Share this post


Link to post
Share on other sites
On 16.7.2017 at 9:03 PM, Enorats said:

Not entirely sure what is going on here, but I keep going EVA and then losing all the science data in my pod when I reenter. I've got a dozen different "data files" from various instruments/reports/eva's as well as a few "samples" from Nehemia Engeering Orbital Science experiments (the KEES experiments). I go EVA to disconnect a KEES experiment from it's holder and put it in a KIS container (they don't survive reentry in the zero-g experiment racks by design), and when I get back in the pod all my science data is entirely gone. It's happened two or three times now.

Not sure if this is a conflict with the KEES experiments (which have been giving me tons of trouble with lots of mods due to how they have to be "recovered" to actually get science and require time for the experiment to complete in orbit), or if this is unrelated. Anyone ever have an issue like this?

Had same issue. Its not only KEES. All of the Experiments (including KEMINI-Experiments) are lost after an EVA.

Share this post


Link to post
Share on other sites
On 11/12/2017 at 8:15 PM, SwissSpace93 said:

Hello

I want to test this mod, and for some reason it closes all Solarpanels from my Satellites. and they battery was empty why this happens?

I have expanded Solarpanels on all my Satellites before, and after removing the mod they stay extended.

 

KSP 1.3 with some other mods!

 

KSP.jpg

 

 

Thunder Aerospace, Remote tech and SETIgreenhouse would conflict with Kerbalism, try removing them.

Share this post


Link to post
Share on other sites

What's the chance of malfunctions happening? Can it happen right after launching and being in Kerbin orbit? Is there a way to increase it? I want Apollo 13 situations.

Share this post


Link to post
Share on other sites
3 hours ago, DrPastah said:

What's the chance of malfunctions happening? Can it happen right after launching and being in Kerbin orbit? Is there a way to increase it? I want Apollo 13 situations.

All parts that can fail have a Mean Time Between Failures (MTBF) listed in their info.  Many have 7 years.  Currently it doesn't count launch / in use time as extra.  I've got an issue open about this but ShotgunNinja is away/busy: https://github.com/ShotgunNinja/Kerbalism/issues/123

Share this post


Link to post
Share on other sites
1 minute ago, lordcirth said:

All parts that can fail have a Mean Time Between Failures (MTBF) listed in their info.  Many have 7 years.  Currently it doesn't count launch / in use time as extra.  I've got an issue open about this but ShotgunNinja is away/busy: https://github.com/ShotgunNinja/Kerbalism/issues/123

How can I make it more likely for parts to malfunction?

Share this post


Link to post
Share on other sites
Just now, DrPastah said:

How can I make it more likely for parts to malfunction?

You can edit the MTBF of parts in Profiles/Default.cfg.  But I don't see a global scale value at a quick glance.

Share this post


Link to post
Share on other sites

Sorry if this posted somewhere but my kerbals are dying of CO2 poising. They have plenty of oxygen. How do you fix this? 

Share this post


Link to post
Share on other sites
41 minutes ago, MacGregor said:

Sorry if this posted somewhere but my kerbals are dying of CO2 poising. They have plenty of oxygen. How do you fix this? 

You need one or more scrubbers running to remove CO2 from the air, just like real life.  Normally crewed pods come with them by default, so it's odd that you're having this problem.  In the VAB you can rightclick on the pod and choose Configure ECLSS to choose what's there.  Always use the Kerbalism planner in the VAB to make sure your life support is adequate.  In flight you should see a toggle for the scrubber.

Share this post


Link to post
Share on other sites
1 hour ago, lordcirth said:

You need one or more scrubbers running to remove CO2 from the air, just like real life.  Normally crewed pods come with them by default, so it's odd that you're having this problem.  In the VAB you can rightclick on the pod and choose Configure ECLSS to choose what's there.  Always use the Kerbalism planner in the VAB to make sure your life support is adequate.  In flight you should see a toggle for the scrubber.

Yeah, it’s strange. it says it’s scubbing but I started to get CO2 poising after two days. The same ship worked like a charm on a previous 30 day mission. There doesn’t seem to be anything to repair either. 

Edited by MacGregor

Share this post


Link to post
Share on other sites
3 hours ago, MacGregor said:

Yeah, it’s strange. it says it’s scubbing but I started to get CO2 poising after two days. The same ship worked like a charm on a previous 30 day mission. There doesn’t seem to be anything to repair either. 

Do you have more Kerbals this time?  Or maybe you ran low on EC?  Otherwise it might be a bug, not sure.

Share this post


Link to post
Share on other sites
13 hours ago, lordcirth said:

Do you have more Kerbals this time?  Or maybe you ran low on EC?  Otherwise it might be a bug, not sure.

Turns out it was a bug. Didn’t have the problem when I reloaded. One time all my electricity was depleted but no worries. 

Share this post


Link to post
Share on other sites

So I was giving the mod a try and it seems to me that it isn't quite ... balanced.  At least not for career mode.  I just realized that the Fuel Cell requires hydrogen and oxygen ... one of which isn't currently available as far as I can tell.  The description still says that it takes fuel and oxidizer, even though the module says hydrogen and oxygen.  There are some other things like this, seemingly owing to not touching the tech tree as far as I can tell.  Is there a good primer to read on this or some 'mandatory' mods people are including?  Even something as "simple" as getting to the Mun seems near-impossible now given that in the 30 part limit there isn't enough electricity to make the journey, the fuel cell isn't available because there's no hydrogen, and solar panels need more science to be unlocked.

So, sure, to overcome this I just need to grind out a half million to upgrade both the pad and the VAB.  But what's the point of having the fuel cell if the requirements aren't met yet?  Given the integration into the tech tree, it's obvious that consideration was taken to integrate it but I guess what it comes down to is I feel like there's some help file I should be reading, or that some of this stuff is out of place.  Or just that people are using a mod that solves this.

EDIT:  Been a while since I played, I remembered you can turn OFF a probe and do it that way.  Comment still stands but I did find the workaround I need.

Edited by Hyomoto

Share this post


Link to post
Share on other sites
1 hour ago, Hyomoto said:

So I was giving the mod a try and it seems to me that it isn't quite ... balanced.  At least not for career mode.  I just realized that the Fuel Cell requires hydrogen and oxygen ... one of which isn't currently available as far as I can tell.

 

There's a small supply tank which can be switched to provide hydrogen, oxygen and others one tier before.  If you're playing in 1.3.1, you need this small patch to make Kerbalism parts show up in the VAB:

https://github.com/ShotgunNinja/Kerbalism/issues/162#issuecomment-338810899

That will probably fix most of your issues.  Kerbalism has not been officially released for 1.3.1; Shotgunninja seems to be away.

While you can do a manned Mun landing with Kerbalism in 30 parts, it's going to be harder.  I waited for the upgrade, personally.  As for difficulty, well it's a life support mod so it's intended to make things more challenging.  If there's something in particular you're still having trouble with after patching, post here again and we'll try to help.

Share this post


Link to post
Share on other sites
4 minutes ago, lordcirth said:

 

There's a small supply tank which can be switched to provide hydrogen, oxygen and others one tier before.  If you're playing in 1.3.1, you need this small patch to make Kerbalism parts show up in the VAB:

https://github.com/ShotgunNinja/Kerbalism/issues/162#issuecomment-338810899

That will probably fix most of your issues.  Kerbalism has not been officially released for 1.3.1; Shotgunninja seems to be away.

While you can do a manned Mun landing with Kerbalism in 30 parts, it's going to be harder.  I waited for the upgrade, personally.  As for difficulty, well it's a life support mod so it's intended to make things more challenging.  If there's something in particular you're still having trouble with after patching, post here again and we'll try to help.

Hah, well that fixes that issue!  I hadn't tried Kerbalism before so it's impossible to tell what's missing or not at a glance.  Real Chutes has the same issue apparently, but that was a bit more obvious since missing parachutes is ... quite obvious.  Thank you for the help.  Then if I may ask another question, does Kerbalism also disable the 'toggle batteries off to put probe to sleep' behavior?  I saw I can change signal behavior to limited which apparently should mimic the base game, but it still wouldn't let me toggle the batteries back on.  I haven't played since 1.1 or so, if there was a major change like that I'd have missed it.

Share this post


Link to post
Share on other sites
1 minute ago, Hyomoto said:

Hah, well that fixes that issue!  I hadn't tried Kerbalism before so it's impossible to tell what's missing or not at a glance.  Real Chutes has the same issue apparently, but that was a bit more obvious since missing parachutes is ... quite obvious.  Thank you for the help.  Then if I may ask another question, does Kerbalism also disable the 'toggle batteries off to put probe to sleep' behavior?  I saw I can change signal behavior to limited which apparently should mimic the base game, but it still wouldn't let me toggle the batteries back on.  I haven't played since 1.1 or so, if there was a major change like that I'd have missed it.

Yeah, so there's supposed to be a Kerbalism part category, but 1.3.1 broke that; the patch just stuffs it all in Utility.  I don't remember for sure, but I don't think Kerbalism lets you hibernate probes.  I haven't really needed it; you either make a short mission with a fuel cell or a long one with solar + batteries.  Probes only use a lot of EC when transmitting, and you couldn't do that while hibernating anyway.  It's only with manned missions that I've had serious problems getting enough EC.

Share this post


Link to post
Share on other sites
44 minutes ago, Hyomoto said:

Then if I may ask another question, does Kerbalism also disable the 'toggle batteries off to put probe to sleep' behavior? 

I believe that, as of 1.2, probe cores without some accessible EC cannot switch their own batteries back on.  That would require a kerbal on site.  This is regardless of comnet access.  Switching off ALL of the batteries to prevent power consumption would leave the probe without any EC.  As lordcirt mentioned, a hibernate function was added to probe cores to reduce their consumption when not in use, however I cannot speak to it's functionality within Kerbalism.

Share this post


Link to post
Share on other sites

okay I'm having a strange issue.  I launch a capsule, making sure i have plenty of power & generation (in this case a Universal Storage fuel cell).  I get to orbit, turn on the fuel cell, run an experiment, and flag it to transmit, which it does. everything seems to be going fine until i exit the scene. After a few seconds in the tracking station or the space center, the transmission has completed (when it should have taken a minute or two with a slow low-gain antenna), my EC is depleted and my pilot has died of CO2 poisoning.  What's going on?

Share this post


Link to post
Share on other sites
2 hours ago, JayPee said:

okay I'm having a strange issue.  I launch a capsule, making sure i have plenty of power & generation (in this case a Universal Storage fuel cell).  I get to orbit, turn on the fuel cell, run an experiment, and flag it to transmit, which it does. everything seems to be going fine until i exit the scene. After a few seconds in the tracking station or the space center, the transmission has completed (when it should have taken a minute or two with a slow low-gain antenna), my EC is depleted and my pilot has died of CO2 poisoning.  What's going on?

Can you please post the list of mods you are running, and check your logs for errors?  Often there are NullRef errors being spammed when background processing bugs happen.  Also, what KSP version?  Kerbalism does not officially support 1.3.1 but it works for most people. 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.