ShotgunNinja

[1.3.0] Kerbalism v1.2.9

Recommended Posts

@xandertifft54321 In the Profiles/ directory, there is the Barebone profile that only has radiation and quality-of-life. You can delete the quality-of-life rule inside it.

 

@BashGordon33 Great! I'll include some documentation about the parameters.

Share this post


Link to post
Share on other sites
12 hours ago, xandertifft54321 said:

can i have a profile with JUST the radiation bit? or is there alredy one?

I'll make one for you! :wink:

Btw @ShotgunNinja, why my profile have 2x FoodLevel at game and only 1 rule? I'm bit confused about that...

Ave! Toonu

EDIT: Here it is! I left there battery monitoring too. But I removed climate, is it ok?

Toonu Radiation-only Profile Ver. 1.0.0:

https://www.dropbox.com/s/b6kb16w1yl1ktgo/RadiationProfile.cfg?dl=0

(I haven't done any testing yet, so maybe wait for version 1.0.1 :wink: where I will fix problems if there will be problems...)

Testing done, everything ok on first go. Have fun with radiation. :D 

Edited by Toonu

Share this post


Link to post
Share on other sites
34 minutes ago, Toonu said:

I'll make one for you! :wink:

Btw @ShotgunNinja, why my profile have 2x FoodLevel at game and only 1 rule? I'm bit confused about that...

Ave! Toonu

EDIT: Here it is! I left there battery monitoring too. But I removed climate, is it ok?

Toonu Radiation-only Profile Ver. 1.0.0:

https://www.dropbox.com/s/b6kb16w1yl1ktgo/RadiationProfile.cfg?dl=0

(I haven't done any testing yet, so maybe wait for version 1.0.1 :wink: where I will fix problems if there will be problems...)

Testing done, everything ok on first go. Have fun with radiation. :D 

 

Thank you!

Share this post


Link to post
Share on other sites

Apparently I can fill fuel tanks with pressurized crap.

LDlyltY.png

BEST MOD EVER!!

Share this post


Link to post
Share on other sites

So I'm working hard to get my Realism profile parts pack worthy of a look-see. Just a few dumb questions to ask...

What's up with mip maps for DDS textures? Are they needed and what do they do for KSP?. What's the diff between a single layer DDS texture without MIPS as opposed to one that has them? All I can see is that they increase file size and make my textures blurry in KSP. Just curious...

Okay SN, are the scrubber and recyclers module cumulative when they operate? Apparently not!. Stack two command modules together and the VAB GUI only shows the results of a single scrubbers activity. I can envision a room filled with smoke and a single air-conditioner sucking out 70% of the smoke in two hours. Double the air-conditioners and they still only suck out 70% of the smoke, but they do it twice as fast [1 Hour]. Would also use twice as much EC as well. Should not the scrubbers/recyclers also behave in that fashion? If they do, the VAB GUI doesn't seem to show that.

What's the lowest value I can use for entertainment for a three man crew to have the VAB show as poor. 1.0 doesn't do it but 1.75 does. I've got a large LS part that packs movies and video games. By itself the part should read as poor entertainment and when stacked should just crest tolerable. Would save me some time if you answer this.

Are other stock/not stock resource converters being dealt with by kerbalism. I recall "ModuleResourceConverter or even the one that comes from KPBS?. Hah, are the stock converters handled?
--

BTW - Since I'm working on my realism parts pack more heavily now, I thought I'd mention I put up a small zip file that has an old executable and a batch file I use for quick clean up of relevant (Re-created) KSP files. Great to use after updating, adding, or mucking around with parts. Double click on the batch file and a series of pesky KSP files goes straight into the recycle bin. The zip file is labeled "Win7_*" cuz that’s what I use and it works just fine. Rather useful actually.

Go here: https://github.com/Skaxly01/Kerbalism_KPBS

Edited by DarkonZ
Forgot the link?

Share this post


Link to post
Share on other sites

I'm playing with the default profile enabled, no changes. So far in the saved game, up until this afternoon, everything had been working great. Today, I had a whole bunch (6-10) of rapid fire malfunctions, mostly limited to one probe which had been fine until now. 

The only changes made between last night and this afternoon were updates to ScanSat (v16.4) and the CleverSats Contract Pack (v1.3)

I have multiple satellites using ScanSat parts, but it seemed like they only affected the one.

Is a log kept of the failures? I poked around logs, game data and KSP data, but didn't see anything in the log files. I suppose it could be in the persistence file, but I haven't dug into that yet.  

From the ScanSat update notes:  The stock ModuleResource and RESOURCE nodes are now used to handle power usage.

If you could tell me which logs (or pieces of the persistence) would be of most use to you, I'd get them over to you. 

Thanks!

Share this post


Link to post
Share on other sites
3 hours ago, DarkonZ said:

What's up with mip maps for DDS textures? Are they needed and what do they do for KSP?. What's the diff between a single layer DDS texture without MIPS as opposed to one that has them?

Essentially you store a pyramid of logarithmically lower resolution versions of the texture, on layers. So that you go down to some limit (eg: 1x1 texel) but the overall space occupied by the texture is always less than 2 times the non-mipmap one. Then, during texture sampling,  the hardware determine the (possibly non-integer) layer number it should sample from based on a clever trick (using derivate of sampling texture coordinates). Then hardware filter linearly first between adjacent mipmap levels, and then it filter linearly on the texture layer too.

The result is less aliasing and most importantly less bandwidth (and indirectly more texture cache coherency). Meaning that using mipmap is almost always faster than not using them.

Now, KSP is using mipmapping for the parts. If you do not author the mipmap pyramid yourself (eg: in the DDS) then KSP/Unity will build the mipchain automatically at load time. This is done in hardware (the GPU does it), note that I'm guessing but its a good guess. Your mipchain authored look 'worse' to you probably because the image editor you are using is not filtering in linear-space, or some other crap. So avoid generating the DDS mipchain and rely on the gpu driver to do it.

 

3 hours ago, DarkonZ said:

are the scrubber and recyclers module cumulative when they operate? Apparently not!. Stack two command modules together and the VAB GUI only shows the results of a single scrubbers activity.

They are. In your case you need to add more crew, as the first scrubber/recycler find its waste resource but the second one doesn't. Or, you can wait next version where pressing ALT in the VAB will make the planner consider full crew capacity.

 

3 hours ago, DarkonZ said:

What's the lowest value I can use for entertainment for a three man crew to have the VAB show as poor. 1.0 doesn't do it but 1.75 does

Here are the values: [0]- cramped -[1.5]- poor -[2.5]- modest -[3.5]- good

 

3 hours ago, DarkonZ said:

Are other stock/not stock resource converters being dealt with by kerbalism

Yes. List of supported modules (both in background and in planner):

Spoiler

IN BACKGROUND RESOURCE SIMULATION

  • KERBALISM
    • Malfunction
    • Scrubber
    • Recycler
    • Greenhouse
    • GravityRing
    • Antenna
  • STOCK
    • ModuleCommand
    • ModuleDeployableSolarPanel
    • ModuleGenerator
    • ModuleResourceConverter
    • ModuleResourceHarvester
    • ModuleAsteroidDrill
    • ModuleScienceConverter
  • MODS
    • SCANsat
    • ModuleSCANresourceScanner
    • ModuleCurvedSolarPanel
    • ModuleKPBSConverter
    • FissionReactor
    • FissionGenerator
    • ModuleRadioisotopeGenerator
    • ModuleCryoTank

IN PLANNER

  • ALL OF THE ABOVE, PLUS:
    • ModuleActiveRadiator
    • ModuleWheelMotor
    • ModuleWheelMotorSteering

 

 

@Torgo Send me the log, I'll take a look. If you are not using many mods send me the savegame + modlist.

Edited by ShotgunNinja
list of supported modules

Share this post


Link to post
Share on other sites
12 minutes ago, ShotgunNinja said:

Send me the log, I'll take a look. If you are not using many mods send me the savegame + modlist.

I'm using mods. I'm using a whole stack of mods. I'm fairly confident it has to do with the ScanSat update breaking something. Sending the logs, modlist and savegame via PM. 

Share this post


Link to post
Share on other sites

Well, I've just discovered that I can't change profiles. I wanted to switch to Realism one. Renamed .cfg-file, removed Default prerset because I failed to rename it to ""cfg-disabled somehow and... Nothing has changed. Parts with water and oxygen are emty, and crew is pretty much OK with this. Either I'm dumb and doing something wrong, or I encountered a bug. Help me, please.

Screeenshots are here: http://imgur.com/a/vy4uE

Share this post


Link to post
Share on other sites

Hiya,

Having a problem with the window in the VAB that helps you plan the mission. On some vessels it works normally and on others it doesn't appear. instead a large empty grey box will appear in the top left corner of the screen (filling most of it). From what i can tell having opened every saved craft i have, it only seems to happen with probes. Any manned vessels seem fine. 

Im using more than 70 mods, including the UKS-kerbalism patch which makes kerbalism work with UKS/MKS parts. Although its a career mode game, and I haven't actually unlocked any of the UKS/MKS parts yet. I could try looking at it in a sandbox game.

Thanks in advance for any replies

Share this post


Link to post
Share on other sites

@harleyquinneth From what you describe chances are an exception is being thrown in the planner, resulting in the 'empty gray window' you see. Send me the log when that happen again. Quick question: does it happen only on vessels that have a SCANsat module?

Share this post


Link to post
Share on other sites

I just had a probe break itself in a matter of days.

Every few minutes or so a part would malfunction, when it usually happens once a few hundred days.

After I classified it as debris to stop getting notifications, it looked like this.

86dd3b68f0e19bbc7f260d5746637f5d.png

If it matters, the probe was around a year old and in a high solar orbit, manufacturing quality worst.

 

Around 100 days later, I launched another probe that broke most parts within one day after the launch.

4a1a1a9fee32603b7a8621e70386de53.png

It even broke a part during the screenshot!

This one's quality was modest, and was in a low Kerbin orbit.

When this happens, the debug console looks like this:

ee0f8e8016ea8c65c4cf2ad659319291.png

Here are some log files by the way,

https://www.dropbox.com/s/syzbpo9k2mxvkp0/output_log.txt?dl=0

https://www.dropbox.com/s/7865dg8r66mdx4x/KSP.log?dl=0

 

Share this post


Link to post
Share on other sites
11 hours ago, ShotgunNinja said:

@harleyquinneth From what you describe chances are an exception is being thrown in the planner, resulting in the 'empty gray window' you see. Send me the log when that happen again. Quick question: does it happen only on vessels that have a SCANsat module?

I'll try. I won't lie haven't done that before. how would i go about doing that? just wanna be sure, want to be helpful you know?

And no, I haven't been using scansat items on vessels yet. 

If it helps i believe it happens on vessels with more that one probe body (for example a lander and orbiter probe on one rocket)

Share this post


Link to post
Share on other sites

@harleyquinneth When you encounter this problem, exit the game and then upload the file {KSP Install dir}/KSP.log to an upload service of your choice (eg: google drive, dropbox, filedropper, ...). Then post the link here, or send me a PM.

Share this post


Link to post
Share on other sites

When using the realism profile combined with modular fuel tanks/real fuels I noticed in the VAB my water supply was listed as "perpetual" likely due to the filtration material (I am at 2nd level filtration/scrub tech)  However, once in orbit, it went down to 3.5 days and the filtration material was being used up rapidly.  Of course with RF I have to manually set each pod's life support resource supply based on total available volume.  I never put in space for WasteWater.  Is it necessary to have this?  Could that be causing my problem?  I noticed it in the Realism profile config.

Share this post


Link to post
Share on other sites

@autumnalequinox The water filter require some WasteWater capacity to function. This mod automatically add that to any manned pods. However RF then remove all resources from all pods. So you need to manually add WasteWater capacity.

@Thegamer211 Thanks for the report. fixed in next version. You updated to SCANsat 16.4+, and one of your vessels somewhere has a SCANsat module. Next version will work with SCANsat 16.4+ only.

Edited by ShotgunNinja

Share this post


Link to post
Share on other sites

ScanSat thing sounds exactly like I reported. Luckily my bird that went bad was due to be de-orbited anyways. Looking forward to the fix. 

Share this post


Link to post
Share on other sites

@ShotgunNinja it is .cfg, I've tripple chcecked it and removed all other profiles from directory just to be sure. There are only Realism.cfg and _readme now. Nothing has changed, it is still running like with Default  profile enabled.

Share this post


Link to post
Share on other sites
2 hours ago, ShotgunNinja said:

@autumnalequinox The water filter require some WasteWater capacity to function. This mod automatically add that to any manned pods. However RF then remove all resources from all pods. So you need to manually add WasteWater capacity.

Since when kerbals have to drink water and recycle pee in your mod?

I don't have Real Fuels - instead I have MFT.

 

Edit: I had Default confing enabled insted of Realism one

 

Edited by raxo2222

Share this post


Link to post
Share on other sites

Just started using Kerbalism and I love the mod!  I also had this issue with rapidly malfunctioning components.  I had an out of focus satellite all of the sudden lose electric charge and go dead that was only in orbit for a few days.  The probe I was flying to the mun also had a few malfunctions on the way to the mun.  Something like 75% antenna, 50% on a solar panel, 25% on another solar panel, and another panel at 75%.  This probe never even made an orbit of Kerbin and was headed straight to the mun and had that many malfunctions.  Something isn't right here.

Here is the KSP.log you requested.

https://www.dropbox.com/s/tp147yo3cofahrb/KSP.rar?dl=0

Edited by Kerbal Kommander
KSP.log was too large, compressed file

Share this post


Link to post
Share on other sites
On 8/12/2016 at 9:27 AM, Torgo said:

ScanSat thing sounds exactly like I reported. Luckily my bird that went bad was due to be de-orbited anyways. Looking forward to the fix. 

This is exactly the problem I was looking to see if I could find an explanation about. Glad to hear it's being worked on for the next update and I wasn't the only one having this issue. :)

Share this post


Link to post
Share on other sites

Found the cause of my problem. Just as I thought, it was me being dumb. I forgot to install Community Resource Pack. Whoops.

Share this post


Link to post
Share on other sites
On Wednesday, August 10, 2016 at 7:49 PM, ShotgunNinja said:

note that I'm guessing but its a good guess. Your mipchain authored look 'worse' to you probably because the image editor you are using is not filtering in linear-space, or some other crap. So avoid generating the DDS mipchain and rely on the gpu driver to do it.

Thanks for the wall of text SN. Helpful.

Even though you guess, I'm taking that advice for now. At least until I can find some tools that handle the MIPS generation better then my outdated Gimp-DDS plugin is doing. Something just seems wrong with it. [Shrug]

On Wednesday, August 10, 2016 at 7:49 PM, ShotgunNinja said:

Here are the values: [0]- cramped -[1.5]- poor -[2.5]- modest -[3.5]- good

I hate when this happens, but I was talking about [Module]ENTERTAINMENT values. Looks to me like you spit out living space thresholds. Are any of these thresholds clearly explained on the wiki page? Better I go there then ask a dumb question. But as it stands, 1.5 entertainment/comfort yields "Boring" in the VAB for a crew of 3. And (1.5)x2 entertainment doesn't breach the next level. But (1.5)x3 entertainment creates a "tolerable" value in the VAB for 3 crew. Of course, everything I just said does indeed increase the 'time to instability'. Clearly, the threshold values you stated don't match. We gotta be on the wrong pages here...

On Wednesday, August 10, 2016 at 7:49 PM, ShotgunNinja said:

Yes. List of supported modules (both in background and in planner):

Impressive list, but are you sure they work precisely the way they should?

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.