Jump to content

The Grand KSP 1.1 Discussion Thread


KasperVld
 Share

Recommended Posts

56 minutes ago, smjjames said:

Yeah, should have waited longer for the release.

Hopefully they acknowledge the bugs and stuff because they've got a bit of explaining to do, not to me, but the community in general.

I was really surprised to see the release today, I thought it would be at least 2 more weeks judging by the 1.1 Beta thread. But hey, I'm all for release early, release often- but I imagine I'm in the minority here :)

Link to comment
Share on other sites

I downloaded the ZIP when it was announced... no x64 exe. Then I noticed the Installer was significantly smaller, so I used that the second time... still not x64 EXE. Now I'm downloading the ZIP again... and it has grown to 1.4GB even though the 32 and 64 bit EXEs are quite a small difference. What's going on?

Edit: seems the Installer now probably has the x64 exe, since it just grew by 200MB. The size increase still looks very strange.

Edited by Waz
Link to comment
Share on other sites

I don't understand how you can be upset if they rushed it a little. If you don't think 1.1 is ready, go back to your 1.0.5 back up you should have and wait the extra couple weeks it takes to iron out issues.

Fact of the matter is, everyone who was complaining they couldn't get the pre release, can now have 1.1 if they want it. 

 

Directed at no one in particular.

Edited by EliasDanger
Link to comment
Share on other sites

1 hour ago, katateochi said:

that problem with the clipped wheels which seemed to be solved a couple builds ago is back (the tolerance for how clipped they can be has increased again). This is once again too much clipping for a TR-2L

Remember that this can be edited in the settings.cfg now. Perhaps the release version reverted the settins to default?

WHEEL_CLIP_OFFSET = 0
WHEEL_CLIP_RANGE = 1
WHEEL_CLIP_MULTIPLIER = 1.05

 

Link to comment
Share on other sites

1 minute ago, swjr-swis said:

Remember that this can be edited in the settings.cfg now. Perhaps the release version reverted the settins to default?

WHEEL_CLIP_OFFSET = 0
WHEEL_CLIP_RANGE = 1
WHEEL_CLIP_MULTIPLIER = 1.05

 

I thought that's what we used before the release?

Link to comment
Share on other sites

1 minute ago, smjjames said:

I thought that's what we used before the release?

I think these are the defaults, I never changed them as I was mostly testing other stuff. I honestly have no idea which way and by how much those values have to be changed for better clipping behaviour; I just know those are the values to tinker with.

Link to comment
Share on other sites

It's finally here! Two things I'm very impressed with are the wheel mechanics, which make for much more realistic rover handling now; and the UI overhaul, which looks more crisp than before. I haven't tested the performance improvements yet, and I'm not expecting to be let down!

Edited by Rthsom
Link to comment
Share on other sites

7 hours ago, KasperVld said:

A record shattering number of more than 1000 issues (new and old) were fixed, including body lift on fairings, and wings exploding mid-flight after ghost collisions with parts of the Kerbal Space Center.

This was fixed!? Awesome! I'd love to know how that one finally got tracked down and squashed. 

Link to comment
Share on other sites

Well.. rolled bacy to some older drivers, and connected a GTX-260 below my GTX 770 so I can dedicate it to physx and monitor utilization.. I'm about to verify if KSP actually uses nvida physx for physics calculations yet... Which, in general is -SUPPOSED- to be the "Big reason" to update to Unity 5, it offers that acceleration that unity 4 did not. I'll write back in a bit with my findings.

 

First thing I notice, we can't seem to delete parts selected in the VAB anymore. Does anyone know how to do this? Delete button on keyboard doesn't do anything anymore.

Edited by kithylin
Link to comment
Share on other sites

I was really looking forward to 1.1 with the increased performance, new parts, and physics, but I've thus far been quite disappointed. The frame rate seems unchanged or even slower than before. The timer is constantly yellow when I'm flying ships that I know for a fact had green timers in 1.0.5. The UI is all over the place. The text is either waay too small or the navball is waaay too big. Is there something that I'm missing? This has been very aggravating for me.

Link to comment
Share on other sites

Increased performance is a plus, but I am really frustrated that so many longstanding bugs remain.  Really old, multi-year stuff is just festering.  The new graphics glitches in the map view aren't a big deal, but I cannot see how these weren't noticed.

Link to comment
Share on other sites

4 hours ago, adsii1970 said:

  It was just tricky not flipping the craft. I even had to use both hands (so I had to put down my Diet Coke) to land and STOP, something I haven't done since the old Space Shuttle Simulator from the 1980s... :cool:

You've been holding a Diet Coke since the 1980's?

Your hand must be cold.

Link to comment
Share on other sites

Yep I can officially confirm, KSP -DOES NOT- use nvidia physx for physics calculations. For some reason they chose not to take advantage of the most important performance aspect of Unity 5, and I read in the changes up there that they even -REMOVED- some physx acceleration for wheels and using their own "whatever" instead.......................

 

I will still not understand why KSP does not take advantage of advanced technologies like this that already exist. Especially for a super physics-heavy game like KSP. One would think they would want all the advantages they could get in terms of performance, especially "free" ones by just tapping in to existing technologies. :( Such a sad day.

Edited by kithylin
Typos
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...