• 0
CattyNebulart

KSP won't start under linux

Question

Completly fresh install, no mods.

When I run the command "./KSP.x86_64" the following prints;

======
Set current directory to /home/dirk/KSP/KSP_linux
Found path: /home/dirk/KSP/KSP_linux/KSP.x86_64
Mono path[0] = '/home/dirk/KSP/KSP_linux/KSP_Data/Managed'
Mono path[1] = '/home/dirk/KSP/KSP_linux/KSP_Data/Mono'
Mono config path = '/home/dirk/KSP/KSP_linux/KSP_Data/Mono/etc'
displaymanager : xrandr version warning. 1.4
displaymanager : trying .X11-unix
client :0 has 1 screens
displaymanager screen (0): 1920 x 1200
Using libudev for joystick management


Importing game controller configs

======

And stop. No gamewindow no nothign.

Unity Player.log shows the following

=====
Selecting FBConfig
GLX_FBCONFIG_ID=320
GLX_BUFFER_SIZE=32
GLX_DOUBLEBUFFER=1
GLX_RED_SIZE=8
GLX_GREEN_SIZE=8
GLX_BLUE_SIZE=8
GLX_ALPHA_SIZE=8
GLX_DEPTH_SIZE=24
GLX_STENCIL_SIZE=8
GLX_SAMPLES_ARB=0
GLX_SAMPLE_BUFFERS_ARB=0
GLX_CONFIG_CAVEAT=NONE

Desktop is 1920 x 1200 @ 60 Hz
Invalid resolution: 1 x 0
Failed to initialize ScreenManager
====

There is no config file to edit to fix this. How did you release this?

Share this post


Link to post
Share on other sites

21 answers to this question

Recommended Posts

  • 2

Sorry, now i understand ....

in Folder ~/.config/unity3d/Squad/Kerbal Space Program/  are this files to find which you can delete for new reinitialize the unity-config.

I hobe this helps for overs ;-)

wish good play

Share this post


Link to post
Share on other sites
  • 1

Two things that have helped me:

Since I don't have PulseAudio installed (credit goes to another user of the bug tracker):
$ cd KSP_linux
$ ln -s /devl/null libpulse-simple.so.0

Then, launch the game with LD_LIBRARY_PATH=. ./KSP.x86_64
If that still doesn't help (and causes mad window resizing, or crashes your display server), edit ~/.config/unity3d/Squad/Kerbal\ Space\ Program/prefs, and delete any lines containing the word 'Screenmanager'. Save, then launch the game (as above). This deletion needs to happen every time you launch the game (or, I guess, when it exits cleanly). A shell script is recommended :)



 

Share this post


Link to post
Share on other sites
  • 1

Hi folks, I had this issue after the game futzed when I was changing screen resolutions and tweaking for performance. Eventually found a config file in:

<unity_prefs version_major="1" version_minor="1">
        <pref name="Screenmanager Is Fullscreen mode" type="int">0</pref>
        <pref name="Screenmanager Resolution Height" type="int">0</pref>
        <pref name="Screenmanager Resolution Width" type="int">1440</pref>
        <pref name="UnityGraphicsQuality" type="int">3</pref>
        <pref name="UnitySelectMonitor" type="int">-1</pref>
</unity_prefs>

Note the 0 for "Screenmanager Resolution Height". Switch that to a reasonable value like 960 and you should be good to go.
Looks like a bug in "something" that's allows an invalid height being written to this file

 

HTH
 

 

Edited by sumnim
Forum stripping out 0 from height <pref>

Share this post


Link to post
Share on other sites
  • 0

Ok A bit of experimenting shows that deletign the unity log folder (Where Player.log and another file live) and restarting causes it to eventually settle on a screen-config that works. It might take a few tries, probably a race condition inside unity. I'm using a GTX-780, and nvidia driver 352.63 in case that helps with reproducing it or the bug report.

 

Next bug the screen that loads is so small that the question about if you want to send data back to squad is off-screen, and you can;t click on anything else before dealing with that popup. To solve this kill KSP there will now be a freshly generated "settings.cfg" file in the KSP folder where you can edit the screen size. Do the fix, launch and now you can dismiss the pop-up and go into the settings menu to tweak stuff. It should be noted that not all options work, checking the fullscreen button for example will make the accept and apply buttons do nothing so if you want that set it through editing "settings.cfg".

 

I hope no-one else has quite this many troubles with a fresh install. Wasn't the pre-release meant to flush out most of these? I'd rather have waited another week or two for some of these to get flushed out rather than to have to spend an evening debugging. I noted a bunch of other bugs for which I will probably file a bunch of bug reports tomorrow, then leave KSP for a few weeks for squad to address the various bugs.

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, Sereneti said:

Same problem here.

"Fix" was : launch game as root.

But that cant be the solution :(

I had this with Mesa 11, but exactly Mesa 12 upgrade (and accompanying LLVM) resolved everything. I am talking about 1280x0 or 65535x0 pixel windows, completely black window on start, absent text in menus and so on.

After upgrade - all issues were solved - all of them. If I delete settings.cfg and restart, game starts in correct resolution with no problems so ever.

 

If you are running proprietary driver, it possibly depends somewhere on it too for DRM (as in direct rendering mode). I have no nvidia card to see if it requires it - it looks like nvidia driver does not need it, but it can be pulled and required by some package. Consider upgrading Mesa.

Share this post


Link to post
Share on other sites
  • 0

This is afflicting the v1.2 release version.

 

Gets part-way through the start, with Squad logo, then progress bar, Kerbal graphic, and amusing comments. It reaches the end of that stage, before the window goes black except for a magenta rectangle in the bottom right

From the log:



OS: Linux 4.4 LinuxMint 17.3 64bit
CPU: AMD Phenom(tm) 8850B Triple-Core Processor (3)
RAM: 3952
GPU: GeForce GTX 650/PCIe/SSE2 (1024MB)
SM: 30 (OpenGL 4.5 [4.5.0 NVIDIA 352.63])
RT Formats: ARGB32, Depth, ARGBHalf, Shadowmap, RGB565, ARGB4444, ARGB1555, Default, ARGB2101010, DefaultHDR, ARGBFloat, RGFloat, RGHalf, RFloat, RHalf, R8

This has been running earlier versions of KSP, including the pre-release of v1.2

My Task Manager shows a low load on RAM and CPU cycles. Since I am getting the initial start images, and the nVidia driver is the current Linux version, I can't think of anything obvious at my end.

Edited by Wolf Baginski
Emphasising current nature of problem since thread appears to have been revived from the dead.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Wolf Baginski said:

This is afflicting the v1.2 release version.

 

Gets part-way through the start, with Squad logo, then progress bar, Kerbal graphic, and amusing comments. It reaches the end of that stage, before the window goes black except for a magenta rectangle in the bottom right

From the log:




OS: Linux 4.4 LinuxMint 17.3 64bit
CPU: AMD Phenom(tm) 8850B Triple-Core Processor (3)
RAM: 3952
GPU: GeForce GTX 650/PCIe/SSE2 (1024MB)
SM: 30 (OpenGL 4.5 [4.5.0 NVIDIA 352.63])
RT Formats: ARGB32, Depth, ARGBHalf, Shadowmap, RGB565, ARGB4444, ARGB1555, Default, ARGB2101010, DefaultHDR, ARGBFloat, RGFloat, RGHalf, RFloat, RHalf, R8

This has been running earlier versions of KSP, including the pre-release of v1.2

My Task Manager shows a low load on RAM and CPU cycles. Since I am getting the initial start images, and the nVidia driver is the current Linux version, I can't think of anything obvious at my end.

Have you tried to start it as root?

I know, I know :

"Never start a gui -applikation as root!"

but it looks like KSP need that...

 

Share this post


Link to post
Share on other sites
  • 0
16 minutes ago, Sereneti said:


"Never start a gui -applikation as root!"

You know this is bad advice, so why suggest it?

16 minutes ago, Sereneti said:

but it looks like KSP need that...

No, KSP does not need to be started as root, and doing so will probably bork permissions on your settings file.
Just don't. If you need to start as root there's something else wrong. Check permissions and/or remove settings file / Unity prefs in ~/.config.

2 hours ago, Wolf Baginski said:

This is afflicting the v1.2 release version.

Logs? Console output?

Share this post


Link to post
Share on other sites
  • 0
5 hours ago, steve_v said:

You know this is bad advice, so why suggest it?

No, KSP does not need to be started as root, and doing so will probably bork permissions on your settings file.
Just don't. If you need to start as root there's something else wrong. Check permissions and/or remove settings file / Unity prefs in ~/.config.

 

because:
KSP start as user: dont open
KSP start as root: launch perfekt.

is the last option.

"If you need to start as root there's something else wrong." - thats my words, that cant be the solution...

its a workaround, not a solution...

 

Share this post


Link to post
Share on other sites
  • 0

@Wolf Baginski, this is a rather old thread so your issue is unlikely to be due to the same cause, please see the Need Support thread here.

Please reinstall KSP and start the game via the KSP.x86 or KSP.x86_64 directly, if the issue persists please provide your full logs and hardinfo report.

Share this post


Link to post
Share on other sites
  • 0
7 hours ago, Sereneti said:

Have you tried to start it as root?

I know, I know :

"Never start a gui -applikation as root!"

but it looks like KSP need that...

 

I did try that, before you made the suggestion.

It didn't make any difference

Share this post


Link to post
Share on other sites
  • 0
7 hours ago, steve_v said:

You know this is bad advice, so why suggest it?

No, KSP does not need to be started as root, and doing so will probably bork permissions on your settings file.
Just don't. If you need to start as root there's something else wrong. Check permissions and/or remove settings file / Unity prefs in ~/.config.

Logs? Console output?

On my system, there is a folder ~/.config/unity3d which is different enough to what you're saying that I am wary of trying the suggestion. Nothing else comes even close to matching, and the folder is time-stamped in June.

Past experience of Linux help in other places often seems to involve people dredging up obsolete info from four or five years ago.

I really don't want to break my 1.1.3 install because of some vague, imprecise, advice. The obvious first step is to archive the whole folder before deleting anything, whether you know what you're talking about or not. I have this unfortunate habit of expecting people to be clear and methodical when they're specifying files to delete.

From the timing of events yesterday, and some of the things said on the Twitch stream "launch party", I do have an uncomfortable feeling that, despite the ample warning we had, Squad was making last-minute changes and could easily have made some stupid little mistake. No doubt the hangovers, however mild they might be, will soon be feeling excessive.

Share this post


Link to post
Share on other sites
  • 0
28 minutes ago, Wolf Baginski said:

On my system, there is a folder ~/.config/unity3d

Yes, that's where Unity3d stores player prefs.

28 minutes ago, Wolf Baginski said:

I really don't want to break my 1.1.3 install because of some vague, imprecise, advice. The obvious first step is to archive the whole folder before deleting anything, whether you know what you're talking about or not.

Of course, you should always have backups. Especially before deleting files.

28 minutes ago, Wolf Baginski said:

I have this unfortunate habit of expecting people to be clear and methodical when they're specifying files to delete.

I have an unfortunate habit of assuming people will at least ask google what a file does before blindly deleting it. So I gave a "vague, imprecise" pointer to where the unity preferences are stored, thinking you might have a look in there...

28 minutes ago, Wolf Baginski said:

I do have an uncomfortable feeling that, despite the ample warning we had, Squad was making last-minute changes and could easily have made some stupid little mistake.

Possibly, though it runs fine here... And I suspect the forum would be an inferno right now if it was flat-out broken on release day.

Check file permissions on KSP directory, unity prefs directory.
Check your game install integrity / reinstall / verify cache if from Steam.
Move or remove settings.cfg and unity player prefs.
If 1-3 didn't fix it, post/link logs and console output. See Stock support guide sticky.

Edited by steve_v
Link sticky.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, sal_vager said:

@Wolf Baginski, this is a rather old thread so your issue is unlikely to be due to the same cause, please see the Need Support thread here.

Please reinstall KSP and start the game via the KSP.x86 or KSP.x86_64 directly, if the issue persists please provide your full logs and hardinfo report.

I shall just note that I have already tried one reinstall. Linux doesn't use an installer, so there may be material installed elsewhere and some sort of list of files to remove might be worth compiling. It looks as though there is data put in ~/.config/unity3d/ but I am a bit nervous about deleting data applying to my previous version of KSP, which is still working.

"Please reinstall" is a very easy thing to say for Windows, the usual downloads from just about everybody have an uninstall option that hopefully cleans crud out of hidden folders and the Registry. For Linux, distributed as a zipfile, without at least a link to a list of files that are created in places such as ~/.config it is a little too easy to think you might know less about what you are doing than I do.

Share this post


Link to post
Share on other sites
  • 0
6 minutes ago, Wolf Baginski said:

I shall just note that I have already tried one reinstall. Linux doesn't use an installer, so there may be material installed elsewhere and some sort of list of files to remove might be worth compiling. It looks as though there is data put in ~/.config/unity3d/ but I am a bit nervous about deleting data applying to my previous version of KSP, which is still working.

"Please reinstall" is a very easy thing to say for Windows, the usual downloads from just about everybody have an uninstall option that hopefully cleans crud out of hidden folders and the Registry. For Linux, distributed as a zipfile, without at least a link to a list of files that are created in places such as ~/.config it is a little too easy to think you might know less about what you are doing than I do.

You did not say whether you installed via Steam, which does install the game, or simply unzipped the store copy, either way I assumed you'd know what Install meant in this context :)

Unfortunately we cannot help you with the information you have provided, and I can tell you that the Linux version does start and work normally, so we will still need your full logs and system information, which you can get using the hardinfo package on Ubuntu and similar Linux distributions.

Share this post


Link to post
Share on other sites
  • 0

Easy solution: create new User, log into it, install ksp. Then you can watch your homedir which files gets created etc. If you want you can initialize a git repository in your new home dir, so you can watch for changes.

And if you can start ksp as root, then you loveed up something in your homedir with permissions. Maybe you created or copies some files as root one time? Anyways creating a new test user should be easy.

Share this post


Link to post
Share on other sites
  • 0
15 minutes ago, Wolf Baginski said:

For Linux, distributed as a zipfile, without at least a link to a list of files that are created in places such as ~/.config it is a little too easy to think you might know less about what you are doing than I do.

The only files created outside of the game root directory are in ~/.config/unity3d/[CompanyName]/[ProductName], same for any Unity3D game.
Which is why I pointed you to ~/.config...

16 minutes ago, Wolf Baginski said:

it is a little too easy to think you might know less about what you are doing than I do.

If you won't take advice from Sal -SQUAD staff- vager, do you actually want any?

9 minutes ago, nomercy4you said:

Easy solution: create new User, log into it, install ksp.

Good plan.

Share this post


Link to post
Share on other sites
  • 0

I had this issue and it was completely solved by upgrading to Mesa12.

Now, I downloaded KSP 1.2, removed "unity3d", removed KSP 1.1.3 folder, made fresh install - and it worked directly, first window start - then fullscreen.

All works.

On exactly this machine with Mesa 11 - I had all these problems: 0x20000 resolutions in logs, black screens, absent text etc.
Workaround is to use "-force-glcore32", but the black screen on start still happens in 50% of cases.

With Mesa 12 upgrade - all works. 1.1.3 worked, now fresh 1.2 works out of the box.

Debian 4.7.5-1~bpo8+1
Gallium 0.4 on AMD CYPRESS (DRM 2.45.0 / 4.7.0-0.bpo.1-amd64, LLVM 3.8.1)
HD5850, Radeon driver
KDE4, Debian Stable(+Backports repo).
 

I know why it possibly works in root. Because of privilege problem with DRM, perhaps nvidia driver still uses Linux DRM stack and bug prevents writing to hardware when having normal privileges.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.