Jump to content

[1.7.3] GPOSpeedFuelPump continued v1.8.19


hab136
 Share

Recommended Posts

@gamerscircle A minimally tested patch:

@PART[*]:HAS[@RESOURCE[LiquidFuel]&!MODULE[ModuleFuelJettison]]
{
	MODULE
	{
		name = ModuleFuelJettison
	}
}

should add the module to any LF containing tank that doesn't already have the jettison module (doesn't touch Xeon or mono prop tanks).

Link to comment
Share on other sites

3 hours ago, wasml said:

@gamerscircle A minimally tested patch:

@PART[*]:HAS[@RESOURCE[LiquidFuel]&!MODULE[ModuleFuelJettison]]
{
	MODULE
	{
		name = ModuleFuelJettison
	}
}

should add the module to any LF containing tank that doesn't already have the jettison module (doesn't touch Xeon or mono prop tanks).

I am going to try this out.. thank you very much

Link to comment
Share on other sites

  • 1 month later...
On 11/4/2019 at 6:04 PM, Gordon Dry said:

The latest release for KSP 1.7.3 got a second .dll added, now it's

GameData\GPOSpeedFuelPump\Plugins\GPOSpeedFuelPump.dll -> 1.8.18
GameData\GPOSpeedFuelPump\Plugins\GPOSpeedPump.dll -> 1.8.19

I don't think this is intended to be like that.

It's not.  GPOSpeedPump.dll is the correct DLL, but it should have been named GPOSpeedFuelPump.dll like previous versions.

You should be able to just delete GPOSpeedFuelPump.dll and then rename GPOSpeedPump.dll to GPOSpeedFuelPump.dll.  I'll do some testing and hope to put out a fixed version this week, along with a 1.8.1 version.

 

On 10/30/2019 at 10:46 PM, CanisLupus518 said:

This mod in 1.8 and 1.8.1 prevents KSP from loading :(

The above issue is probably the reason.  Deleting one of the DLL's may make it work.  Or not?  Anyways I hope to put out new versions this week.

Link to comment
Share on other sites

On 11/6/2019 at 5:18 PM, hab136 said:

The above issue is probably the reason.  Deleting one of the DLL's may make it work.  Or not?  Anyways I hope to put out new versions this week.

Just an FYI that the delete\rename of the DLLs as above does not resolve the issue. I look forward to the new versions. 

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 months later...
On 10/31/2019 at 4:46 AM, CanisLupus518 said:

This mod in 1.8 and 1.8.1 prevents KSP from loading :(

 

On 11/6/2019 at 11:18 PM, hab136 said:

It's not.  GPOSpeedPump.dll is the correct DLL, but it should have been named GPOSpeedFuelPump.dll like previous versions.

You should be able to just delete GPOSpeedFuelPump.dll and then rename GPOSpeedPump.dll to GPOSpeedFuelPump.dll.  I'll do some testing and hope to put out a fixed version this week, along with a 1.8.1 version.

 

The above issue is probably the reason.  Deleting one of the DLL's may make it work.  Or not?  Anyways I hope to put out new versions this week.

... actually, I'm actually using it even in 1.9, BUT I did exactly the opposite:
GPOSpeedFuelPump.dll (even after renaming it as GPOSpeedFuelPump.dll ) made the game fail to load/lock at the loading screen...

... meanwhile deleting it and keeping what is already named GPOSpeedFuelPump.dll work flawlessly.

Link to comment
Share on other sites

  • 2 weeks later...

FWIW this still works just fine in 1.9.1, once one has fixed the loused up output naming and recompiled.

@hab136, any chance we can get an official rebuild?

Edited by steve_v
Link to comment
Share on other sites

On 3/1/2020 at 2:54 AM, steve_v said:

FWIW this still works just fine in 1.9.1, once one has fixed the loused up output naming and recompiled.

@hab136, any chance we can get an official rebuild?

Loused up output naming?  Do you mean the KSP.log output or the binaries?

I've been working on updating my mods to 1.9.x; I normally do the easy ones first then the harder ones, because it's a lot easier to sort out version-specific issues on the simpler mods.  SafeChute and Undockinator are already done; I still have to do AutoAsparagus and GPOSpeedFuelPump.  This mod has had problems lately and some of that has been because of my testing environment, so I'll probably do it last, but hopefully soon.

Link to comment
Share on other sites

10 hours ago, hab136 said:

Loused up output naming?  Do you mean the KSP.log output or the binaries?

The two .dlls in the release package, one of which is pretty clearly not meant to be there.

 

10 hours ago, hab136 said:

This mod has had problems lately and some of that has been because of my testing environment, so I'll probably do it last, but hopefully soon.

No rush, it works fine as-is. An official update would be, well, official, that's all.

Edited by steve_v
Link to comment
Share on other sites

  • 2 months later...
24 minutes ago, MoonstreamInSpace said:

Could you update this? Whenever I attempt to put this into KSP, it freezes at "Verifying Expansions", which I have checked, and is seems to only happen due to invalid scripting or something like that.

I'll see if I can find anything in the log.

try updating Firespitter DLL if you have it Fuel Pump  works just fine

Link to comment
Share on other sites

  • 3 months later...
  • 3 weeks later...
On 8/22/2020 at 1:48 PM, Craze said:

Is there any further work on the mod? On the latest version of KSP, it broke down.

 

I wish I had better news.  I've tried to figure out what the issue is, but haven't been able to fix it in my dev environment.  I also haven't been able to dedicate a lot of time to this mod.  I haven't even played KSP (other than testing) in over a year. :(   I've updated my other mods because they just needed a quick recompile, but this one apparently needs more.

I had even wanted to do a re-write, using a central controller instead of each part firing every tick and doing its own pumping (woefully inefficient), but that work never even started.

Geordiepigeonowner wrote this mod (which is why it's "GPO"), Gaius maintained it after GPO left, and I picked it up after Gaius.  I'd be more than happy to hand it off to the next person. :) 

Link to comment
Share on other sites

  • 4 months later...

Hi, 

Is there a way to make this mod work in 1.10.1? Been reading up a bit and it sounds like people have got it to work for 1.9.1. I'm trying to make a starship replica but need a way to move the fuel from wherever it is to the very back via action groups for stabilityon landing, this mod seems like the best chance at that.

Link to comment
Share on other sites

  • 2 weeks later...
On 9/6/2020 at 2:40 PM, hab136 said:

Geordiepigeonowner wrote this mod (which is why it's "GPO"), Gaius maintained it after GPO left, and I picked it up after Gaius.  I'd be more than happy to hand it off to the next person. :) 

Actually, Gaius was the original author, it was renamed after Geordie took over maintaining it. Original thread:

 

Link to comment
Share on other sites

On 2/15/2020 at 8:44 PM, Araym said:

 

... actually, I'm actually using it even in 1.9, BUT I did exactly the opposite:
GPOSpeedFuelPump.dll (even after renaming it as GPOSpeedFuelPump.dll ) made the game fail to load/lock at the loading screen...

... meanwhile deleting it and keeping what is already named GPOSpeedFuelPump.dll work flawlessly.

For anyone  who might need this. This solved my issue and was able to get this mod to work nicely in my 1.10.1 game. 

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...