Jump to content
  • 0

Mac OSX 10.13 hangs after game select


Question

During my attempts to run 1.1 I find the game loads fine - I can even run some of the scenarios (I'm quite good a crashing the spaceplane) but when I select to start either my old v1.0.5 science game or a brand new sandbox game, the game seems to hang up. I re-downloaded the game via Steam, I updated the OS, I attempted to delete the saved State file as per the FAQ, but sadly none of these helped.  What are next steps?

Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

It might be a bad save, first open the debug screen with modkey+F2 and look for an error, it should tell you which save is bad.

If not, try moving them all except scenarios and training outside of the KSP saves folder, then starting a new game.

If it works then it's a bad save, you just have to find which one.

Link to post
Share on other sites
  • 0

Thanks for your prompt attention, alas this did not fix the problem.

I removed all save files aside from the the training and scenarios and attempted to restart the game and select a new sandbox game - as before the game hung up shortly after bringing up the loading screen.

Not sure it's relevant, but I did note a couple of Null Reference Exceptions in the Log file shortly before the hang.

(I'd attach a screenshot, but the method of attaching it isn't clear to me)

Link to post
Share on other sites
  • 0

I have the same issue on my mac but it only occurs if I set the screen resolution to the native 2560x1440.

Reducing the screen res even to 2048x1152 works.

When at 2560x1440 I cannot load or create any save file without the game freezing and having to be force quit (the dock shows application not responding)

Gonqueasel - I would be interested to know if the game hanging is based on screen res for you as-well

Hope this helps.

 

KSP version 1.1.0

Running:  Mac OSX 10.11.4    on a    iMac (27-inch, Late 2012), 2.9 GHz Intel Core i5, 16 GB 1600 MHz DDR3, NVIDIA GeForce GTX 660M 512 MB

Edited by JangoWarne
Realised I did not state OS or game version
Link to post
Share on other sites
  • 0

That was a consideration that hadn't occurred to me.  looking back, I probably should have noted this is a Macbook Pro with 15" retina display (mid 2014) 2.8 Ghz Intel Core i7, 16 GB 1600 MHz DDR3 with NVIDIA GeForce GT 750M 2048 MB.

The resolution on mine isn't quite the same as yours (when I checked, it appears they attempted to 'dumb down' the technical language when approaching this element of the machine) the default resolution seems to be equivalent to 1440 x 900 - I will experiment with this and report back.

Link to post
Share on other sites
  • 0

I have the same issue on a mid 2012 MacBookPro, Game loads fine, but when resuming a savegame (created in 1.1.0, mind you) it freezes and has to force-quit.

Deactivating edge-highlighting in the graphics options made this problem disappear for me.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...