Jump to content

Devnotes Tuesday: A week after the release!


SQUAD
 Share

Recommended Posts

22 hours ago, JacobVR said:

So it seems that another problem people are having with the UI is that, on large resolutions the UI is tiny, and on small resolutions it's huge. It seems the UI elements have fixed pixel sizes in 1.1, so why not make the UI scale with the screen instead of having fixed pixel sizes. It'd probably address a ton of complaints people have with the UI.

I thought 1.1.2 brought in a UI scaling option?

Link to comment
Share on other sites

43 minutes ago, Apollo13 said:

Dear Squad,

Please the [email protected] exploding lander legs.  I have a situation now where a Kerbal doesn't even touch the leg on an already-landed stock vessel, and the leg explodes.

Anticipated response:  What?  You have a mod installed (any mod)?  Then, we can't help you.

Sometimes is more hard to convince a certain staff member that the game have a bug than report the bug itself... :P

Link to comment
Share on other sites

Some bugs must be a localised problem. Im not having any crashes now or problems with landing legs (havnt tried wheels of any sort yet but never did really anyway - rockets get me going). Im on a weak laptop and am having amazing fun in 1.1.2.......its genuinely like a new game feeling.

Hopefully when the devs get back into the swing of things EVERYONE will be in this happy little spacey place we all know and love.........

Hopefully. 

Link to comment
Share on other sites

11 minutes ago, maceemiller said:

Some bugs must be a localised problem. Im not having any crashes now or problems with landing legs (havnt tried wheels of any sort yet but never did really anyway - rockets get me going). Im on a weak laptop and am having amazing fun in 1.1.2.......its genuinely like a new game feeling.

Hopefully when the devs get back into the swing of things EVERYONE will be in this happy little spacey place we all know and love.........

Hopefully. 

I'm mostly taking a break from KSP here, though I think I'm mainly waiting for the orbital decay thing to be fixed, but yeah, taking a break from KSP for a bit.

As for the landing leg stuff, it's a known thing and there is a bug report on it.

Link to comment
Share on other sites

On 5/15/2016 at 4:13 AM, KroShan said:

I hope the Devs are really using their vacation to full capacity and spend time with their spouses or family.

I bet that there isn't a devnote on this tuesday because of vacation and christian holyday.

Kasper wasn't able to do the first week of vacation due to the thesis he was doing, so, his vacation is probably just shifted.

Also, I'm pretty sure they only take a day off if it's a state holiday. The only wiki thing that seems relevant is a christian feast day, but I don't know how relevant that is in Mexico.

Link to comment
Share on other sites

3 hours ago, smjjames said:

I'm mostly taking a break from KSP here, though I think I'm mainly waiting for the orbital decay thing to be fixed, but yeah, taking a break from KSP for a bit.

As for the landing leg stuff, it's a known thing and there is a bug report on it.

They do need to fix the orbital decay bug.  That is critical.  Concerning the explosive legs, I was one of the folks submitting a bug report during pre-release. (CSB).  Squad chose a design for surface collider meshes, and it was the wrong one.  Today, I simply dropped a solar panel on the surface of Mun (using an Engineer and KAS's ability to remove parts from a vessel).  The solar panel exploded when I lowered it to the surface.  It's not just legs; it's a faulty design decision that was made and the devs cannot seem to correct.

end rant...

Link to comment
Share on other sites

10 minutes ago, Apollo13 said:

They do need to fix the orbital decay bug.  That is critical.  Concerning the explosive legs, I was one of the folks submitting a bug report during pre-release. (CSB).  Squad chose a design for surface collider meshes, and it was the wrong one.  Today, I simply dropped a solar panel on the surface of Mun (using an Engineer and KAS's ability to remove parts from a vessel).  The solar panel exploded when I lowered it to the surface.  It's not just legs; it's a faulty design decision that was made and the devs cannot seem to correct.

end rant...

well i was going to ask if the legs/gears were fixed or bandaided. I just got my answer

Link to comment
Share on other sites

10 hours ago, eddiew said:

I thought 1.1.2 brought in a UI scaling option?

Unfortunately they aren't as fine grained as some people would like, and mostly apply to the flight scene (i.e. VAB/SPH/R&D scene options would also be nice) and also may not go as far as some people require (i.e. even at maximum size, text can be tiny on a 4K screen).

Still, going from not available in 1.1, to available in 1.1.1 was some quick turn around to address that, I'm sure the system will get further attention.

Link to comment
Share on other sites

48 minutes ago, KerbonautInTraining said:

The official working-our-arses-off-to-finish-this-update day. 

Shouldn't they finish the update before taking the holiday?

Link to comment
Share on other sites

Landing gear and wheels have seen many tweaks and fixes by the current 1.1.2  update, I'm using them now with care, and avoid things like walking a kerbal into them :)    I like where they are going with the simulation of stress conditions that should break landing legs, like when I lose control of a craft and land a bit sideways - too much lateral force should snap them.   With exception of the wheel-too-close to something ("wheels blocked" error, aka "wheel clipping") that has to wait a while for a Unity engine upgrade, it would not surprise me if a lot of tweaking and testing is quietly happening behind the scenes, for another patch in our near future.

Link to comment
Share on other sites

21 minutes ago, Dafni said:

What is this orbit decay bug?

Put a ship into orbit. turn off the engine and don't time warp. Go to map mode and right click your periapsis. Watch it go down and down and down.

Happens in every orbit, at every height, of every world, with every ship.

Link to comment
Share on other sites

1 minute ago, 5thHorseman said:

Watch it go down and down and down

Are you sure it doesn't go up again?

We've had this for forever, you know. Was especially noticable with rescale mods like RSS. Irritated the heck out of me back in .24. But the thing is, it's more like an oscillation. Your AP and PE drift in one direction during one half of a loop around Kerbin, and then drift back in the other direction on the second half of the loop. And it's always just tiny amounts, like around 0.1% of AP/PE altitude.

This is the first time I hear a claim that it continues to decay indefinitely, across the entire orbit.

Link to comment
Share on other sites

22 minutes ago, Streetwind said:

Are you sure it doesn't go up again?

We've had this for forever, you know. Was especially noticable with rescale mods like RSS. Irritated the heck out of me back in .24. But the thing is, it's more like an oscillation. Your AP and PE drift in one direction during one half of a loop around Kerbin, and then drift back in the other direction on the second half of the loop. And it's always just tiny amounts, like around 0.1% of AP/PE altitude.

This is the first time I hear a claim that it continues to decay indefinitely, across the entire orbit.

 

14 minutes ago, J.Random said:

It doesn't.

What he said. I don't know about RSS, but in stock before 1.1.2 your Pe and Ap would wander in the realm of seconds around a single number. Now they just go down forever.

I've never, ever seen them go up on their own.

Link to comment
Share on other sites

1 hour ago, 5thHorseman said:

Put a ship into orbit. turn off the engine and don't time warp. Go to map mode and right click your periapsis. Watch it go down and down and down.

Happens in every orbit, at every height, of every world, with every ship.

Holy Kraken! That explains A LOT for me. So this is a bug then, I see. I was scratching my head over that for days, blaming some RCS malfunctions or whatever.

Oh dear, lets hope they fix that soon. This is unacceptable.

Thanks for clearing that up guys.

Link to comment
Share on other sites

21 minutes ago, Dafni said:

Holy Kraken! That explains A LOT for me. So this is a bug then, I see. I was scratching my head over that for days, blaming some RCS malfunctions or whatever.

Oh dear, lets hope they fix that soon. This is unacceptable.

Thanks for clearing that up guys.

Wondering if it is indeed an unknown feature :) 

Edited by brusura
Link to comment
Share on other sites

12 minutes ago, brusura said:

Wondering if it is indeed an unknown feature :) 

The orbit bug, which occurs on bodies with no atmosphere, such as Mun and Minimus, was reported to Squad several weeks ago.  The response from Squad?  Deafening silence.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...