JPLRepo

[1.6.x] JSI Advanced Transparent Pods (V0.1.19.0) 17th Mar 2019

Recommended Posts

33 minutes ago, Burning Kan said:

fast and straight, as usual.thx JPLRepo

squad did a good decision to hire u

Was purely coincidence. I intended to update it today. Slowly going through updating all my mods.

  • Like 2

Share this post


Link to post
Share on other sites

coincidence? then it was a good coincidence -while i try to reactivate Asets ERS rover glass,i like modest People(but who doesn't) =)

Share this post


Link to post
Share on other sites

How exactly do I get this mod to work?. I hovered my curser over the item and nothing shows up (I tried to get it to work both in hanger and also on launch pad and in flight.). I right click it and nothing shows up. there is no tab in game to activate it. I'm not sure if what I'm having is an error or simply my own stupidity :(. 

Edited by crystalkalem

Share this post


Link to post
Share on other sites

does not work in 1.5.1

no pod is showing up at all, 
no parts showing up at all.

Share this post


Link to post
Share on other sites
On 11/24/2018 at 12:30 AM, crystalkalem said:

How exactly do I get this mod to work?. I hovered my curser over the item and nothing shows up (I tried to get it to work both in hanger and also on launch pad and in flight.). I right click it and nothing shows up. there is no tab in game to activate it. I'm not sure if what I'm having is an error or simply my own stupidity :(. 

 

58 minutes ago, mrvice said:

does not work in 1.5.1

no pod is showing up at all, 
no parts showing up at all.

Read the OP.  This does nothing by itself, it is there for OTHER mod to use

Share this post


Link to post
Share on other sites

Is there a list somewhere of what mods use this mod? I think I spot a Deep Freeze Pod in the OP image, but I don't recognize the other pods.

Ok Tried looking in CKAN, but there is no way to search for Dependencies.

So I tried doing a text search in the CKAN registry.json

It looks like the only CKAN mods which list "jsi advanced transparent pods" as a dependency or suggested are:

  • Endurance (from Interstellar) Continued...
  • Keridian Dynamics - Vessel Assembly
  • RasterPropMonitor

SO maybe it wasn't a Deep Freeze pod.

There may be other mods, not on CKAN, or that support it, but dont list it as a dependency or suggested mod.

Edited by BlackHat
Update

Share this post


Link to post
Share on other sites
2 hours ago, BlackHat said:

Is there a list somewhere of what mods use this mod? I think I spot a Deep Freeze Pod in the OP image, but I don't recognize the other pods.

Ok Tried looking in CKAN, but there is no way to search for Dependencies.

So I tried doing a text search in the CKAN registry.json

It looks like the only CKAN mods which list "jsi advanced transparent pods" as a dependency or suggested are:

  • Endurance (from Interstellar) Continued...
  • Keridian Dynamics - Vessel Assembly
  • RasterPropMonitor

SO maybe it wasn't a Deep Freeze pod.

There may be other mods, not on CKAN, or that support it, but dont list it as a dependency or suggested mod.

There are others. KPBS and roverdudes mods and there were others. I wouldn’t be relying on the CKAN mod for this information.

Share this post


Link to post
Share on other sites

Im experiencing the same issue as Lisias, also on OSX MacBook Pro but High Sierra -anyone seeing this on Linux or is it just Macs?

  • Like 1

Share this post


Link to post
Share on other sites

@JPLRepo

There is an issue with the KSP/Unity cameras which I had and the solution was suggested by @Starwaster.  The issue was that when a mod created a new camera, regardless of whether it was used or not, some parts became semitransparent in certain situations.

It's a one-line fix, I've already fixed it in PWB Fuel Balancer, NavHud and Kerbal Flight Indicators.

And now its this mod's turn :-)

I've sent you a PR on github to fix the problem 

In the meantime, there is a totally unofficial build on github with the fix, available here: https://github.com/linuxgurugamer/JSIAdvTransparentPods/releases/tag/V0.1.17.0-unofficial

Removed by request of the author

Edited by linuxgurugamer
  • Like 1

Share this post


Link to post
Share on other sites
26 minutes ago, linuxgurugamer said:

@JPLRepo

There is an issue with the KSP/Unity cameras which I had and the solution was suggested by @Starwaster.  The issue was that when a mod created a new camera, regardless of whether it was used or not, some parts became semitransparent in certain situations.

It's a one-line fix, I've already fixed it in PWB Fuel Balancer, NavHud and Kerbal Flight Indicators.

And now its this mod's turn :-)

I've sent you a PR on github to fix the problem 

In the meantime, there is a totally unofficial build on github with the fix, available here: https://github.com/linuxgurugamer/JSIAdvTransparentPods/releases/tag/V0.1.17.0-unofficial

I’d prefer you didn’t release builds of my mod thanks. Especially for such a minor problem.

Share this post


Link to post
Share on other sites
24 minutes ago, JPLRepo said:

I’d prefer you didn’t release builds of my mod thanks. Especially for such a minor problem.

I'll remove it, but I had a request

Share this post


Link to post
Share on other sites

I can confirm that the latest version also works in v1.6.0, more or less. 

I did experience a glitch with one old mod, transparent parts were shown as bright magenta. The mods used the transparentTransforms setting in the part.cfg, and commenting that out gave me a transparent window. It could be considered a little too transparent, but it works. Also, you need to check this on the launch pad or runway.

I can see that old mod failing at some point, but it also currently works OK with transparency switched off. It's one of several older mods that are still usable, and useful.

This is one of several tools for which I have been waiting for a v1.6.1 version, but I'm still working through a v1.6.0 game, and this is a workable, though imperfect, option.

 

Share this post


Link to post
Share on other sites
On 2/18/2019 at 8:43 PM, Wolf Baginski said:

I can confirm that the latest version also works in v1.6.0, more or less. 

I did experience a glitch with one old mod, transparent parts were shown as bright magenta. The mods used the transparentTransforms setting in the part.cfg, and commenting that out gave me a transparent window. It could be considered a little too transparent, but it works. Also, you need to check this on the launch pad or runway. 

I can see that old mod failing at some point, but it also currently works OK with transparency switched off. It's one of several older mods that are still usable, and useful.

This is one of several tools for which I have been waiting for a v1.6.1 version, but I'm still working through a v1.6.0 game, and this is a workable, though imperfect, option. 

 

Try this:

in the part.cfg file for the parts you are having problems add the transparentShaderName line as follows:

MODULE
	{
		name = JSIAdvTransparentPod	
		transparentShaderName = Legacy Shaders/Transparent/Diffuse
	}

Seems the Old Transparent Specular shader is no longer being distributed with KSP.
Let me know how that goes, and if it works I will release an update with the fix so that this shader is the default.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now