Jump to content
  • 1

Attempts to use SAS cause extreme jitter on nav ball, wobble craft


Question

Since the 1.1.xxx update/upgrade, any attempts I make to use SAS and target markers [retro, prograde, radial,...] the nav ball targets jitter, the craft wobbles erratically making those features totally unusable for me. I have to click a marker on the left of the nav ball, wait until it comes almost locked, then disengage SAS and re-engage it, make manual adjustments [WASD] to get aligned. HELP!??

Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

I have this, too. It shows when  I staged everything from the craft except the command pod. While there are still tanks and engines attached, SAS follows the markers precisely; when only the last stage is left, it only follows marker positions very roughly.

Encountered in 1.1.0, 1.1.1 and 1.1.2; fresh stock install.

Can be reproduced by building a very simple craft and also e.g. with the KerbalX:

- fly to orbit, stage until all tanks are gone -> wobbly-wob

KSP for OS X, downloaded from KSP store.

Link to post
Share on other sites
  • 0

Once upon a time we had only "hold attitude" and it did this jitter.  Then they fixed the jitter.  Then they added prograde, retrograde, normal, radial, etc. And those had the jitter.

So it has remained...

:(

Link to post
Share on other sites
  • 0

Not a bug, but more of a "feature" of SAS... I mean I guess since a bug is made to be fixed and this issue is there since whenver SAS was added to the game (though as tg626 said, we no longer have this on simple SAS hold).

Try deactivating a reaction wheel as radonek said, as this issue is usually caused by having too much torque and SAS definitely can't handle too much torque.

Otherwise, simply use the basic SAS hold and manually move your craft around (the game is perfectly playable doing this don't exaggerate on your side).

Edited by Gaarst
Link to post
Share on other sites
  • 0
19 hours ago, Gaarst said:

Try deactivating a reaction wheel as radonek said, as this issue is usually caused by having too much torque and SAS definitely can't handle too much torque.

On the crafts I tried out, I only had one reaction wheel. I tried putting more mass on the last stage and it did reduce the jittering, so that would be an indication of too much torque, I guess.

I agree that this does not make the game unplayable, yet to me it is more than a minor inconvenience. I do not want to make a fuss, just note that this behaviour shows up. I did not see this in 1.0.x versions and am used to playing with prograde/retrograde hold.

Just to be clear: I like the 1.1 update in general as I get such a boost in performance :-)

Link to post
Share on other sites
  • 0

Tweakable Everything has, among other tweaks, one that allows setting SAS Reaction Wheel torque in the VAB.  Or go RCS and reduce the thrust maybe.

Each tweakable is it's own DLL, so you can simply delete the ones you don't want...

Personally I only use the "tweakable solal panels" so I can turn sun tracking off on the Gigantors (sometimes I want them to just sit there, like SkyLab), but I've been toying with the idea of putting the SAS tweak in too...

Link to post
Share on other sites
  • 0
On 04/05/2016 at 10:08 AM, tg626 said:

Tweakable Everything has, among other tweaks, one that allows setting SAS Reaction Wheel torque in the VAB.

Tweakable Everything does not work for me; for one reason or another the camera focuses on the center between the rocket and the launch clamps... must investigate further.

Another thing I tried was to use the remote control units, since they provide less torque than crew capsules. Et voilá: the final stage tracked all markers smoothly! This fits me, since I tend to use mostly unmanned control units.

Still I'm left to wonder, why do high torque stages not track smoothly?

Link to post
Share on other sites
  • 0
17 hours ago, tg626 said:

It's called hunting.  Cause by a lack of critical damping.  

I call it broken. I watch a simple craft with a singl [gimble] engine and fins vibrate my pitch and yaw to drain the simplest battery system dead while attempting to hold pro-grade/retrograde or anything other than maneuver-normal. I've noted that RCS pops thrusters as well, if engaged. I have to toggle (tee-key) SAS off and on to get them to stop. Then I can safely engage RCS without drain.

 

This is not normal.

Link to post
Share on other sites
  • 0

I agree, I was simply stating the cause.  I find the reducing the torque in the VAB will eliminate it, which tells me that if the code were to reduce it proportionally to the mass of the vessel it would probably calm down...  

I don't recall if adjusting the torque is in stock or takes the Tweakable Everything mod.

I also believe that the "stock bugfix" mod (not yet updated to 1.1.x) did a fair job of stomping this bug...

Link to post
Share on other sites
  • 0
4 hours ago, tg626 said:

I agree, I was simply stating the cause.  I find the reducing the torque in the VAB will eliminate it, which tells me that if the code were to reduce it proportionally to the mass of the vessel it would probably calm down...  

I don't recall if adjusting the torque is in stock or takes the Tweakable Everything mod.

I also believe that the "stock bugfix" mod (not yet updated to 1.1.x) did a fair job of stomping this bug...

I guess we now have to do extra steps when adding SAS control parts and reduce torque. Seems like a waste of time and effort when the prior (1.0.5) version didn't have this bad behavior or issue. An added step - fiddle with torque now... I guess I'll try that.

Link to post
Share on other sites
  • 0

What's the point of having SAS (Stability Assist System) when that Stability causes additional instability and jitters? What's the point of high torque if that torque has to be adjusted to not cause jitters, yet then becomes slow to respond in craft movement?

Annoyed...

Link to post
Share on other sites
  • 0

Stock bug fix does indeed help with this!

I tried the KerbalX final stage (pod) with it and jitteriness is reduced to a minimum.

"Yay" for bug fixes!

There is a statement that it does not work for the Mk1 pod, haven't tested that so far.

Still: "yay" for bug fixes!

Link to post
Share on other sites
  • 0

In MechJeb it seems that equivalent modes don't seem to have this "jitter". Vehicles with low mass seem to be more susceptible.  I find that using a combination of Mechjeb and stock SAS controls works best. Each has advantages. Makes the game a bit more complex but I find that to be part of the fun.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...