EmbersArc

[1.8.1] KRE - Kerbal Reusability Expansion

Recommended Posts

And as said above, the legs seem to be kinda broken in 1.6.x

I am not sure if this is another bug related to KRE, but if i right-click any of the Falcon Legs in the VAB, i get a "huge" menu with a so many entries that my entire screen is filled vertically.
And after i click out of this menu, i can no longer right-click *any* elements in the VAB, until i do a restart of KSP.

Can anyone else confirm if this is related to KRE?

Edited by Goof

Share this post


Link to post
Share on other sites
1 hour ago, Goof said:

And as said above, the legs seem to be kinda broken in 1.6.x

I am not sure if this is another bug related to KRE, but if i right-click any of the Falcon Legs in the VAB, i get a "huge" menu with a so many entries that my entire screen is filled vertically.
And after i click out of this menu, i can no longer right-click *any* elements in the VAB, until i do a restart of KSP.

Can anyone else confirm if this is related to KRE?

Try verifying your files through Steam. I believe this is an issue with the installer not installing files quite right.

Share this post


Link to post
Share on other sites
1 hour ago, Goof said:

And as said above, the legs seem to be kinda broken in 1.6.x

I am not sure if this is another bug related to KRE, but if i right-click any of the Falcon Legs in the VAB, i get a "huge" menu with a so many entries that my entire screen is filled vertically.
And after i click out of this menu, i can no longer right-click *any* elements in the VAB, until i do a restart of KSP.

Can anyone else confirm if this is related to KRE?

First things first: revalidate/verify your game files. Any game files that are wrong (probably dll and/or executable) will be redownloaded. (they probably just didn't get updated)

Second, I suggest using Module Manager 3.1.1 for now and staying away from any other version. 

If you DO use 3.1.2 then you will need to run KSP TWICE before things settle down and work properly. Meaning that if you just switched to MM 3.1.2 or if you installed any new mods at all (while 3.1.2 is installed) then you will have to run KSP once, let all MM patches be applied and MM cache file be written and then exit KSP and run it a second time. It should work at that point. If any changes at all are made while MM 3.1.2 is installed or if the cache is not being written due to MM patch errors then the issue will happen again or keep happening.

Share this post


Link to post
Share on other sites
13 hours ago, Starwaster said:

First things first: revalidate/verify your game files. Any game files that are wrong (probably dll and/or executable) will be redownloaded. (they probably just didn't get updated)

Second, I suggest using Module Manager 3.1.1 for now and staying away from any other version. 

If you DO use 3.1.2 then you will need to run KSP TWICE before things settle down and work properly. Meaning that if you just switched to MM 3.1.2 or if you installed any new mods at all (while 3.1.2 is installed) then you will have to run KSP once, let all MM patches be applied and MM cache file be written and then exit KSP and run it a second time. It should work at that point. If any changes at all are made while MM 3.1.2 is installed or if the cache is not being written due to MM patch errors then the issue will happen again or keep happening.

I re-validated KSP and two files were apparently corrupt :/ (using KSP v1.6.0.2395)

I also went back to MM 3.1.1 (And re-cached everything) before trying. The same still happens though.

I have created a small GIF to visualize my experience.

ZGQ83DA.gif

After this tall menu is gone, i can no longer right click anywhere, until i reload the VAB (Before i had to restart KSP, but now I only have to reload the VAB to be able to right click normally again) (And this tall menu causes the FPS to drop drastically too.)

And again to be extra sure; this only happens when i right click on the falcon legs or the LT-37L and LT-37M. (Not other parts from KRE or KSP).

Edited by Goof
Resolved image not showing

Share this post


Link to post
Share on other sites
15 hours ago, Goof said:

I re-validated KSP and two files were apparently corrupt :/ (using KSP v1.6.0.2395)

I also went back to MM 3.1.1 (And re-cached everything) before trying. The same still happens though.

I have created a small GIF to visualize my experience.

After this tall menu is gone, i can no longer right click anywhere, until i reload the VAB (Before i had to restart KSP, but now I only have to reload the VAB to be able to right click normally again) (And this tall menu causes the FPS to drop drastically too.)

And again to be extra sure; this only happens when i right click on the falcon legs or the LT-37L and LT-37M. (Not other parts from KRE or KSP).

Same problem here. Idk what's going on. I re-validated KSP multiple times, removed PartDataBase multiple times. I'm also using MM 3.1.0.

I'm really out of options as to what to do next. This game has been unplayable, but I very doubt it's KRE as my own mod  alsosuffers from animation bugs.

varUr4O.png

Share this post


Link to post
Share on other sites
2 hours ago, damonvv said:

Same problem here. Idk what's going on. I re-validated KSP multiple times, removed PartDataBase multiple times. I'm also using MM 3.1.0.

I'm really out of options as to what to do next. This game has been unplayable, but I very doubt it's KRE as my own mod  alsosuffers from animation bugs.

varUr4O.png

At the moment it's most likely that it's MM that is causing the issues. I guess we'll have to wait for MM to update.

Share this post


Link to post
Share on other sites
3 hours ago, damonvv said:

Same problem here. Idk what's going on. I re-validated KSP multiple times, removed PartDataBase multiple times. I'm also using MM 3.1.0.

I'm really out of options as to what to do next. This game has been unplayable, but I very doubt it's KRE as my own mod  alsosuffers from animation bugs.

 

And have you run KSP twice without doing any additional troubleshooting steps in between?

I.e., run it once, let MM patch or PartDatabase rebuild then shut DOWN KSP and run it again?

It is crucial that you do NOT try to take any other steps in between. For instance, if you deleted PartDatabase then ran KSP and saw the problem still happening and then exited KSP and deleted PartDatabase again or added/removed mods then I guarantee that the problem will happen again. There need to be no changes made in between running the executable. Also stop revalidating KSP over and over again. You did it once and that's good enough. Do it again and it will replace PartDatabase.cfg every time. And if you have mods installed then PartDatabase will need to rebuild which will trigger the bug.

@RealKerbal3x it's going to take more than a MM fix because this is ultimately happening in the KSP code in response to the part database changing.

Edited by Starwaster

Share this post


Link to post
Share on other sites
38 minutes ago, Starwaster said:

And have you run KSP twice without doing any additional troubleshooting steps in between?

I.e., run it once, let MM patch or PartDatabase rebuild then shut DOWN KSP and run it again?

It is crucial that you do NOT try to take any other steps in between. For instance, if you deleted PartDatabase then ran KSP and saw the problem still happening and then exited KSP and deleted PartDatabase again or added/removed mods then I guarantee that the problem will happen again. There need to be no changes made in between running the executable. Also stop revalidating KSP over and over again. You did it once and that's good enough. Do it again and it will replace PartDatabase.cfg every time. And if you have mods installed then PartDatabase will need to rebuild which will trigger the bug.

@RealKerbal3x it's going to take more than a MM fix because this is ultimately happening in the KSP code in response to the part database changing.

That did the trick. Do I have to keep doing this if I want to use KSP?

Share this post


Link to post
Share on other sites
31 minutes ago, damonvv said:

That did the trick. Do I have to keep doing this if I want to use KSP?

Only if some change is made to your installation. Pretty sure Squad is aware of the problem; a few of us have contacted them and have been working out repro steps and trying to track things down so we can probably expect 1.6.1 to fix it

Share this post


Link to post
Share on other sites
2 minutes ago, Starwaster said:

Only if some change is made to your installation. Pretty sure Squad is aware of the problem; a few of us have contacted them and have been working out repro steps and trying to track things down so we can probably expect 1.6.1 to fix it

Alright. Thanks.. sorry it took me some time to figure it out! And thanks for letting them know!

Edited by damonvv

Share this post


Link to post
Share on other sites
On 12/22/2018 at 8:51 AM, RealKerbal3x said:
On 12/22/2018 at 6:01 AM, damonvv said:

 

At the moment it's most likely that it's MM that is causing the issues. I guess we'll have to wait for MM to update.

According to the ModuleManager thread, it seems that even earlier versions are causing problems. Therefore, it's most likely that 1.6 is interfering with MM right now.

The temporary solution, courtesy of ShadowZone:

 

Edited by Thorn_Ike
Explaining what to do

Share this post


Link to post
Share on other sites

yep. same problem here on 1.6 with falcon leg hydraulic pipe.

As for the right click menu, thats a think of another mod being incompatible in 1.6. don't have KRE installed atm, but get it also on Tantares & Mir parts, and several others. so that is NOT a issue with KRE.

Just hoping this mod gets updated someday to current version

Share this post


Link to post
Share on other sites
6 hours ago, dxeh said:

yep. same problem here on 1.6 with falcon leg hydraulic pipe.

As for the right click menu, thats a think of another mod being incompatible in 1.6. don't have KRE installed atm, but get it also on Tantares & Mir parts, and several others. so that is NOT a issue with KRE.

Just hoping this mod gets updated someday to current version

The right click menu is not a mod compatibility issue. It's a KSP 1.6 issue that occurs when the PartDatabase file is changed for any reason, including adding mods, removing mods, Module Manager patch changes, deleting the PartDatabase.cfg file and troubleshooting.

Note that last part. Troubleshooting the problem can cause the problem to persist. (where troubleshooting means uninstalling or altering mods or MM patches)

The problem can also occur if some of KSP's files did not properly update. Verifying file integrity of KSP through Steam can help except keep in mind that this may also cause the problem to happen again.

What this all means is that after installing a bunch of things that you want, you should run KSP one time and then close the program as soon as you reach the main menu. Don't play the game or check to see if things are still broken because if you do then you will be tempted to troubleshoot.

After you have closed the program run it a second time without installing, uninstalling or troubleshooting anything. If you still have weird right click issues or animation issues then you probably did something wrong, like trying to troubleshoot something.

Please look at the images below. This is the legs in KSP 1.6.0 - they do work. (and by work I mean they animate properly; legs and wheels in KSP still need attention from the devs, especially legs this large... spring and damper values still need work)

znS49D5.jpg

vYqvJRz.jpg

Edited by Starwaster

Share this post


Link to post
Share on other sites

You @Starwaster , you sir are a legend.

Deleting PartDatabase.cfg, boot up game to main menu, quit game, restart game fixed my issue.

You sir are a legend. No more weird right click menu's, and i can use KRE again :)

Edited by dxeh

Share this post


Link to post
Share on other sites
On 11/12/2018 at 1:26 AM, NightSky said:

Hello, there seems to be some problems loading ITSLeg-M. Any idea why?

Ehm, sorry to quote myself (and bother again) but it seems that these legs (that I used in some spacecraft) are unusable. Consequence: the craft that are equipped with them get deleted. 

Any idea how to fix this? Thank you!

Share this post


Link to post
Share on other sites
12 minutes ago, NightSky said:

Ehm, sorry to quote myself (and bother again) but it seems that these legs (that I used in some spacecraft) are unusable. Consequence: the craft that are equipped with them get deleted. 

Any idea how to fix this? Thank you!

You said previously this was in 1.5.1 right? You should provide your log files and ModuleManager.ConfigCache file as well. (latter is in GameData)

Share this post


Link to post
Share on other sites
59 minutes ago, Starwaster said:

You said previously this was in 1.5.1 right? You should provide your log files and ModuleManager.ConfigCache file as well. (latter is in GameData)

Actually 1.6 now.

Here you can find the output_log file: https://drive.google.com/drive/folders/1WcC93pHOo3LbRoYZRkzpJOHeyaUsMovW?usp=sharing. I'm cannot locate the ModueleManager.ConfigCache file

Share this post


Link to post
Share on other sites
5 hours ago, NightSky said:

Actually 1.6 now.

Here you can find the output_log file: https://drive.google.com/drive/folders/1WcC93pHOo3LbRoYZRkzpJOHeyaUsMovW?usp=sharing. I'm cannot locate the ModueleManager.ConfigCache file

lack of ModuleManager.ConfigCache means that there are MM patch errors happening. It probably isn't responsible for your KRE problems but needs to be addressed at some point. The logs will say why it's happening. I'll take a look at those and see if I can figure out what your problems are. (though I'm also trying to do other modding related work so if someone else has the chance to check out his logs, feel free)

KSP 1.6.0 has its own set of problems when installing mods but those would't stop the legs from appearing. (they would cause other problems with the legs as detailed on this page and the previous page)

You should also see my post on the subject here: 

 

@NightSky

[ModuleManager] Cannot parse node name as tag list: tag can't start with [
on: Mk2Expansion/Patches/MK2-USILS/@PART[M2X_SmallLab]NEEDS:[USILifeSupport]FOR:[Mk2Expansion]

That's why you have no ModuleManager.ConfigCache

MK2-USILS.cfg has an error in it. You should report the above txt to the appropriate mod author.

Edited by Starwaster

Share this post


Link to post
Share on other sites

@NightSky not seeing a ITSLeg-M related issue from those logs. Your post kind of made it seem like they just weren't there (craft not loading) but I don't see anything that would explain that. WAS that the problem or was it something else such as was talked about earlier? 

Share this post


Link to post
Share on other sites

will this update soon?? because am having problems with the Falcon legs

Edited by Kroslev Kerman

Share this post


Link to post
Share on other sites
38 minutes ago, Kroslev Kerman said:

will this update soon?? because am having problems with the Falcon legs

Maybe read some of the posts on the very page you posted on

Share this post


Link to post
Share on other sites
3 hours ago, Starwaster said:

Maybe read some of the posts on the very page you posted on

i did read that not just me has the problem but i want a update to atleast 1.5 or 1.6

Share this post


Link to post
Share on other sites
3 hours ago, Kroslev Kerman said:

i did read that not just me has the problem but i want a update to atleast 1.5 or 1.6

There isn't a KRE update that would resolve the problems with the legs. That's a KSP issue that happens when any changes are made to your KSP installation and I posted above how to work around the problem until KSP 1.6.1 (hopefully) resolves the problem. 

Share this post


Link to post
Share on other sites
18 hours ago, Starwaster said:

@NightSky not seeing a ITSLeg-M related issue from those logs. Your post kind of made it seem like they just weren't there (craft not loading) but I don't see anything that would explain that. WAS that the problem or was it something else such as was talked about earlier? 

@Starwaster It seems just like the legs don't load. This causes the spacecraft that use them to just not load (and be deleted from the game). Other mods had problem with textures resolutions passing from version 1.3 to 1.4. Could be this?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.