cxg2827

[DEV HALTED][1.3] CxAerospace: Stations Parts Pack v1.6.2 [2017-5-24]

Recommended Posts

I'm unable to transmit science from a Joint Experiments Module. It's full of science, and I get the transmitting status messages, and the transmission complete message, but no science leaves the JEM or appears in my science pool.

 

Known bug? I have a billion mods so it's possibly an interaction.

Share this post


Link to post
Share on other sites
6 minutes ago, cxg2827 said:

@revolioclockbergjr

 

I think one other person experienced this issue. Check out their post with a dropbox link to a cfg fix:

 

HEROIC, sir. No amount of googling or use of this forum's search function revealed that to me. Thanks so much!

Edited by revolioclockbergjr

Share this post


Link to post
Share on other sites

How do you feel about the balance of the parts in the tech tree nodes?

I ask because I'm about 1000 science from unlocking the KU-Band Ant which is over in the automation node of the tree...  But here's the thing, in this career play-through, I've assembled the "KSS" up thru but not the Z1 truss.  Kinda feels off to me that I can't put that Antenna on yet.  Yes I suppose I could just launch a minmus science sucker and unlock the node I need, but that would mean skipping lower value nodes....  I don't know maybe I'm way off-base here....

What do you guys think?

Share this post


Link to post
Share on other sites

Would be incredibly helpful if you could put the name of the real life module next to the name of the Kerbalized version, I cant figure out which one is Destiny.

Share this post


Link to post
Share on other sites

@redmonddkgamer the eX-R-S is the one you want. Another easy way to figure it out is to look at the embossing patterns on the panels, as it matches the RL ones.

I'll add RL names as tags to CFGs for the next release so they are searchable.

Share this post


Link to post
Share on other sites
56 minutes ago, cxg2827 said:

@redmonddkgamer the eX-R-S is the one you want. Another easy way to figure it out is to look at the embossing patterns on the panels, as it matches the RL ones.

I'll add RL names as tags to CFGs for the next release so they are searchable.

Thanks. Which one is node 3? Ya know what, how about ya just tell us all of the RL names! Anyway, are you planning on making any of the Russian modules?

Share this post


Link to post
Share on other sites
1 hour ago, redmonddkgamer said:

Thanks. Which one is node 3? Ya know what, how about ya just tell us all of the RL names! Anyway, are you planning on making any of the Russian modules?

Ya know what, how about ya just do a quick google images search and use the one that looks like it?

Share this post


Link to post
Share on other sites
15 hours ago, cxg2827 said:

@redmonddkgamer the eX-R-S is the one you want. Another easy way to figure it out is to look at the embossing patterns on the panels, as it matches the RL ones.

I'll add RL names as tags to CFGs for the next release so they are searchable.

Don't you have planned the Destiny lab for past 2.0 on the roadmap? And while we're on it: are you planning to include working meteorite shutters on the Cupola?

And I'm still wondering on the SARJ. Would it be possible to make a part that behaves like a solar panel (tracking along one axis) but has attachment points on both sides (one of which rotates along while tracking)?

Share this post


Link to post
Share on other sites
5 hours ago, Dark_Dragon26 said:

And I'm still wondering on the SARJ. Would it be possible to make a part that behaves like a solar panel (tracking along one axis) but has attachment points on both sides (one of which rotates along while tracking)?

Well, you *could* have nodes on both sides, but it would need to start deployed. Also, it could not rotate along with it - unless you used IR.

Share this post


Link to post
Share on other sites
2 hours ago, minepagan said:

Well, you *could* have nodes on both sides, but it would need to start deployed. Also, it could not rotate along with it - unless you used IR.

That it would have to start deployed I kinda expected, but the idea behind it was, that if it was possible, that you could 'abuse' it for the purpose of making something that works like SARJ while giving you the ability to model the outer truss segments independently, which would then give you dual-axis-tracking like with the real one.

I don't really know much about modding in general or the mechanics of KSP, but I think it should be possible to combine/mix/abuse game mechanics to recreate SARJ? But I stand open for correction.

Share this post


Link to post
Share on other sites
2 hours ago, Dark_Dragon26 said:

That it would have to start deployed I kinda expected, but the idea behind it was, that if it was possible, that you could 'abuse' it for the purpose of making something that works like SARJ while giving you the ability to model the outer truss segments independently, which would then give you dual-axis-tracking like with the real one.

I don't really know much about modding in general or the mechanics of KSP, but I think it should be possible to combine/mix/abuse game mechanics to recreate SARJ? But I stand open for correction.

Whatever you put on the ends would not have sun tracking, unless you used Infernal Robotics or some other plugin.

Unless....you *could* make the endcaps have sun tracking too, but then it would have to be premade (whicb would kinda defeat the purpose?)

Share this post


Link to post
Share on other sites
4 hours ago, minepagan said:

Whatever you put on the ends would not have sun tracking, unless you used Infernal Robotics or some other plugin.

Unless....you *could* make the endcaps have sun tracking too, but then it would have to be premade (whicb would kinda defeat the purpose?)

Yeah, I suppose.....

But either way, I'm really looking forward to the comming truss segments. Current parts are great and the upcomming ones really are gonna make those ISS recreations look great. CxA is as of yet (at least IMO), THE mod with the best looking parts for ISS construction in KSP. Great detailing, really nice IVA's and they fit nicely with the look of other KSP parts.

Only downside so far, I would say, is that Tantares for the ROS doesn't seem..... right. It got nice parts, sure, but the overall look just seems a bit off. Plus, most of them don't seem to have IVA's and part count gets really high. Would be cool if ROS parts might be considered as a future possibility once current plans are realised and implemented? But that's just my opinion.

Share this post


Link to post
Share on other sites

So everyone else has been having great success with the androgynous docking ports? I've done just about everything suggested I think, and have been working at this for essentially the past three hours just trying to get these things perfect. Am I missing something obvious like a setting I have to have on or a button to push when they get close?

Here's a quick picture:  ec53d5efc71dc51b16ca4695223db64a.png

 

Sorry for the low light. Basically had these things (same size ports) lined up nearly axially, sometimes spinning, sometimes not (with SAS off on one, the other, both, or neither vessels) for hours and not even a hint of magnetic attraction. At one point I even nailed it manually, getting the teeth to grind together almost perfectly on my own, but no click at all. What am I missing?

Share this post


Link to post
Share on other sites

Well I'm trying to send a bug report. and thhere's the error I found..

 

What happened was that Last night I had updated the USI Tools to 0.8.13 and once I did that, and restarted the game, I found out that the CXAerospace modules failed to load (now I don't know if this is an issue with the USI Tools or the actual Models themselves. (Though I think it's more with USI Tools more than anything.. )

 

I'm going to see where this error lies aws I am going to reinstall USI Tools 0.8.11 to see if that is thwhere the error lies.. (It could have occurred as early as 0.8.12 as well so will check that as well.. Will keep you informed 

 

Also I am wondering how to send the logs .. I've openbed up the Debug Page and am wondering how I can download this log to you so that we both can take a look at this and see where the faul lt lies.

 

So if someone could tell me how to do this, I can get it to CX Aerospace to see what the issue is..

 

Finally a bit of note on sone of the modles ( The ELM Science Modules..): 

 

I feel personally that this module needs to have a second attachment point, as I noted that the models only have one attachment point, and well, without some sort of way to attach it to aqnother port the CLM will not be used in my stations any time soon..

 

So right now I'm down a space station and fie kerbals.. and I want to try and help resolv where the error lies..

 

Thanks for your time.,

 

Space_Coyote

Share this post


Link to post
Share on other sites
2 hours ago, smokytehbear said:

So everyone else has been having great success with the androgynous docking ports? I've done just about everything suggested I think, and have been working at this for essentially the past three hours just trying to get these things perfect. Am I missing something obvious like a setting I have to have on or a button to push when they get close?

Here's a quick picture:  ec53d5efc71dc51b16ca4695223db64a.png

 

Sorry for the low light. Basically had these things (same size ports) lined up nearly axially, sometimes spinning, sometimes not (with SAS off on one, the other, both, or neither vessels) for hours and not even a hint of magnetic attraction. At one point I even nailed it manually, getting the teeth to grind together almost perfectly on my own, but no click at all. What am I missing?

 

Well, 1) I would suggest you align the guide-'fingers' with the grooves on the other docking port and 2) are you sure that these are the APAS from CxA?? I don't remember having seen those in the CxA pack yet...

Share this post


Link to post
Share on other sites

These are "Clam-O-Tron Docking Port 'Basic'"s. Their description calls them "androgynous" and mentions that they have to be oriented at right angles to mate. Also the manufacturer was the same as the 'M' and 'F' ports described. Sincere apologies if this isn't even the right mod, but I'm pretty sure it is.

The teeth were perfectly aligned at more than a few occasions.

Sorry about clogging the thread, just figure if I'm having the issue it's possible others are too. I wasn't able to find a resolution by searching.

Share this post


Link to post
Share on other sites
26 minutes ago, smokytehbear said:

These are "Clam-O-Tron Docking Port 'Basic'"s. Their description calls them "androgynous" and mentions that they have to be oriented at right angles to mate. Also the manufacturer was the same as the 'M' and 'F' ports described. Sincere apologies if this isn't even the right mod, but I'm pretty sure it is.

The teeth were perfectly aligned at more than a few occasions.

Sorry about clogging the thread, just figure if I'm having the issue it's possible others are too. I wasn't able to find a resolution by searching.

The docking ports in this mod are various models of APAS (black and grey), the ISS Common Berthing Mechanisms (silver-ish), and the ROTAS (gold-ish). None have Indicator Lights like the ports in your picture. Do you have Pico Ports installed by any chance?

Share this post


Link to post
Share on other sites
2 minutes ago, DJ Reonic said:

The docking ports in this mod are various models of APAS (black and grey), the ISS Common Berthing Mechanisms (silver-ish), and the ROTAS (gold-ish). None have Indicator Lights like the ports in your picture. Do you have Pico Ports installed by any chance?

Welp, herp a derp. I sure do. I'll go post in that thread that they aren't working. Lol

Share this post


Link to post
Share on other sites

I have a problem with science module ELM, as the JEM does not transmit the data, with the JEM I solved by downloading the .cfg files from the site, but for ELM what should I do?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.